]> git.pld-linux.org Git - packages/bugzilla.git/blob - bugzilla.spec
e7e7ffc5c1e4faa177292be5c0cd185cb6f85b69
[packages/bugzilla.git] / bugzilla.spec
1 # TODO
2 # - Split DB packages for mysql/pgsql
3 # - fill brr and add autodeps bcond
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Bug tracking system
6 Summary(pl.UTF-8):      System śledzenia błędów
7 Name:           bugzilla
8 Version:        2.22.2
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/WWW
12 Source0:        http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
13 # Source0-md5:  fb7fdcaacf5efad6f3bd5a1a810c467f
14 Source1:        %{name}.conf
15 Source2:        %{name}-localconfig.pl
16 Source3:        %{name}.cron
17 Patch0:         %{name}-pld.patch
18 URL:            http://www.bugzilla.org/
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 BuildRequires:  sed >= 4.0
22 Requires:       perl-DBD-mysql
23 Requires:       perl-DBI >= 1.36
24 Requires:       perl-MailTools >= 1.67
25 Requires:       smtpdaemon
26 Requires:       webapps
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _webapps        /etc/webapps
31 %define         _webapp         %{name}
32 %define         _sysconfdir     %{_webapps}/%{_webapp}
33 %define         _appdir         %{_datadir}/%{_webapp}
34 # Don't enforce DBD driver and exclude optional packages according to release notes
35 %define         _noautoreq              'perl(DBD::*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
36
37 %description
38 Bugzilla is the Bug-Tracking System from the Mozilla project.
39
40 %description -l pl.UTF-8
41 System śledzenia błędów.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 sed -i -e '
48 s,use lib ".",use lib "%{_appdir}",
49 s,use lib qw(.),use lib "%{_appdir}",
50 ' *.cgi
51
52 find -name CVS -type d | xargs rm -rf
53 find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
54
55 # won't package tests
56 rm -f runtests.pl
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
61         $RPM_BUILD_ROOT%{perl_vendorlib}
62
63 install *.pl $RPM_BUILD_ROOT%{_appdir}
64 cp -a template $RPM_BUILD_ROOT%{_appdir}
65 cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
66
67 install *.{cgi,js,txt,dtd,xul} $RPM_BUILD_ROOT%{_appdir}/htdocs
68 cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
69
70 ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
71
72 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
73 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
74 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
75 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 if [ "$1" = 1 ]; then
82 # shamelessly stolen from gentoo
83 %banner -e %{name} <<'EOF'
84 0. Bugzilla has been installed into %{_appdir}
85
86 1. To finish the installation, please read
87    http://www.bugzilla.org/docs/%{version}/html/installation.html
88    You will need to run %{_appdir}/checksetup.pl
89
90    IMPORTANT: If you have customized the values in your
91    Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
92    IT. Please see the Release Notes for more details.
93
94 2. Please read the Release Notes, especially if you are upgrading:
95    http://www.bugzilla.org/releases/%{version}/release-notes.html
96 EOF
97 fi
98
99 %triggerin -- apache1 < 1.3.37-3, apache1-base
100 %webapp_register apache %{_webapp}
101
102 %triggerun -- apache1 < 1.3.37-3, apache1-base
103 %webapp_unregister apache %{_webapp}
104
105 %triggerin -- apache < 2.2.0, apache-base
106 %webapp_register httpd %{_webapp}
107
108 %triggerun -- apache < 2.2.0, apache-base
109 %webapp_unregister httpd %{_webapp}
110
111 %files
112 %defattr(644,root,root,755)
113 %doc QUICKSTART README UPGRADING* docs/rel_notes.txt docs/txt/Bugzilla-Guide.txt
114 %doc contrib docs/html
115 %dir %attr(750,root,http) %{_sysconfdir}
116 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
117 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
118 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
119
120 %attr(755,root,root) /etc/cron.daily/bugzilla
121
122 %{perl_vendorlib}/Bugzilla
123 %{perl_vendorlib}/Bugzilla.pm
124
125 %dir %{_appdir}
126 %{_appdir}/template
127 %attr(755,root,root) %{_appdir}/*.pl
128
129 %dir %{_appdir}/htdocs
130 %{_appdir}/htdocs/*.dtd
131 %{_appdir}/htdocs/*.js
132 %{_appdir}/htdocs/*.txt
133 %{_appdir}/htdocs/*.xul
134 %{_appdir}/htdocs/graphs
135 %{_appdir}/htdocs/images
136 %{_appdir}/htdocs/js
137 %{_appdir}/htdocs/skins
138 %attr(755,root,root) %{_appdir}/htdocs/*.cgi
139
140 %dir /var/lib/%{name}
141 %attr(770,root,http) /var/lib/%{name}/data
142 %attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.082613 seconds and 3 git commands to generate.