]> git.pld-linux.org Git - packages/bugzilla.git/blob - bugzilla.spec
- default localconfig
[packages/bugzilla.git] / bugzilla.spec
1 # TODO
2 # - Split DB packages for mysql/pgsql
3 # - fill brr and add autodeps bcond
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Bug tracking system
6 Summary(pl):    System ¶ledzenia b³êdów
7 Name:           bugzilla
8 Version:        2.22
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/WWW
12 Source0:        http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
13 # Source0-md5:  bbf2f1ec5607978d39855df104231973
14 Source1:        %{name}.conf
15 Patch0:         %{name}-httpd_user.patch
16 Patch1:         %{name}-chdir.patch
17 URL:            http://www.bugzilla.org/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       perl-DBD-mysql
20 Requires:       perl-DBI >= 1.36
21 Requires:       smtpdaemon
22 Requires:       webapps
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _webapps        /etc/webapps
27 %define         _webapp         %{name}
28 %define         _sysconfdir     %{_webapps}/%{_webapp}
29 %define         _appdir         %{_datadir}/%{_webapp}
30 # Don't enforce DBD driver and exclude optional packages according to release notes
31 %define         _noautoreq              'perl(DBD::*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
32
33 %description
34 Bugzilla is the Bug-Tracking System from the Mozilla project.
35
36 %description -l pl
37 System ¶ledzenia b³êdów.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42 %patch1 -p1
43
44 find -name CVS -type d | xargs rm -rf
45 find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/Bugzilla,/var/lib/%{name}/{data,graphs}}
50
51 install *.{cgi,js,pl,pm,txt,dtd,xul} $RPM_BUILD_ROOT%{_appdir}
52 cp -a Bugzilla $RPM_BUILD_ROOT%{_appdir}
53 cp -a images js skins template $RPM_BUILD_ROOT%{_appdir}
54
55 ln -s /var/lib/%{name}/data $RPM_BUILD_ROOT%{_appdir}
56 ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}
57 mv $RPM_BUILD_ROOT%{_appdir}/globals.pl $RPM_BUILD_ROOT%{_sysconfdir}
58 ln -s %{_sysconfdir}/globals.pl $RPM_BUILD_ROOT%{_appdir}/globals.pl
59
60 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
61 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %triggerin -- apache1
67 %webapp_register apache %{_webapp}
68
69 %triggerun -- apache1
70 %webapp_unregister apache %{_webapp}
71
72 %triggerin -- apache < 2.2.0, apache-base
73 %webapp_register httpd %{_webapp}
74
75 %triggerun -- apache < 2.2.0, apache-base
76 %webapp_unregister httpd %{_webapp}
77
78 %files
79 %defattr(644,root,root,755)
80 %doc QUICKSTART README UPGRADING* docs/rel_notes.txt docs/txt/Bugzilla-Guide.txt
81 %doc contrib docs/html
82 %dir %attr(750,root,http) %{_sysconfdir}
83 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
84 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
85 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
86
87 %dir %{_appdir}
88 %{_appdir}/Bugzilla
89 %{_appdir}/data
90 %{_appdir}/graphs
91 %{_appdir}/images
92 %{_appdir}/js
93 %{_appdir}/skins
94 %{_appdir}/template
95 %{_appdir}/*.pl
96 %{_appdir}/*.dtd
97 %{_appdir}/*.js
98 %{_appdir}/*.pm
99 %{_appdir}/*.txt
100 %{_appdir}/*.xul
101 %attr(755,root,root) %{_appdir}/*.cgi
102 %dir /var/lib/%{name}
103 %attr(770,root,http) /var/lib/%{name}/data
104 %attr(775,root,http) /var/lib/%{name}/graphs
This page took 0.105844 seconds and 3 git commands to generate.