]> git.pld-linux.org Git - projects/template-specs.git/blob - browser-plugin.spec
- template for plugins, work in progress
[projects/template-specs.git] / browser-plugin.spec
1 #
2 # NOTE: using symlinks will not have rpm file conflicts verification,
3 # but that's okay since most of the plugins are cross browser, so you
4 # won't be having any regular files in browser specific plugin dir.
5 #
6 Summary:        Template for browser plugins
7 Name:           template-browser-plugin
8 Version:        0.1
9 Release:        0.1
10 License:        GPL
11 Group:          Development
12 # TODO
13 BuildRequires:  rpmbuild(macros) >= 1.223
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # directory where you store the plugin
18 %define         _plugindir      %{_libdir}/browser-plugins
19
20 %description
21 This spec is for demonstrating triggers used for linking package
22 plugins to all browsers plugins dir capable for NSAPI plugins
23
24 See also browser-plugins.spec
25
26 %prep
27 %setup -q -c -T
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT%{_plugindir}
32
33 cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.so <<EOF
34 # dummy plugin
35 EOF
36 cat >> $RPM_BUILD_ROOT%{_plugindir}/%{name}.xpi <<EOF
37 # Second plugin file.
38 EOF
39
40 %triggerin -- mozilla-firefox
41 %ns_plugin_install -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
42
43 %triggerun -- mozilla-firefox
44 %ns_plugin_uninstall -d %{_libdir}/mozilla-firefox/plugins %{name}.so %{name}.xpi
45
46 %triggerin -- mozilla
47 %ns_plugin_install -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
48
49 %triggerun -- mozilla
50 %ns_plugin_uninstall -d %{_libdir}/mozilla/plugins %{name}.so %{name}.xpi
51
52 %triggerin -- opera
53 %ns_plugin_install -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
54
55 %triggerun -- opera
56 %ns_plugin_uninstall -d %{_libdir}/opera/plugins %{name}.so %{name}.xpi
57
58 %triggerin -- konqueror
59 %ns_plugin_install -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
60
61 %triggerun -- konqueror
62 %ns_plugin_uninstall -d %{_libdir}/kde3/plugins/konqueror %{name}.so %{name}.xpi
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %attr(755,root,root) %{_plugindir}/*.so
70 %{_plugindir}/*.xpi
This page took 0.060044 seconds and 4 git commands to generate.