]> git.pld-linux.org Git - packages/brltty.git/blob - brltty.spec
f9121dbbba590a922727627975aaf11c1affa1ed
[packages/brltty.git] / brltty.spec
1 # TODO:
2 #       - what is that huge %post script?
3 #
4 # Conditional build:
5 %bcond_without  apidocs                 # documentation generated with doxygen
6 %bcond_without  java                    # Java bindings
7 %bcond_without  ocaml                   # OCaml bindings
8 %bcond_without  python                  # Python bindings
9 %bcond_without  tcl                     # Tcl bindings
10 %bcond_without  x                       # X11-based utilities
11 %bcond_without  gpm                     # mouse tracking via GPM
12 %bcond_without  libbraille              # libbraille Braille driver
13 %bcond_without  espeak                  # eSpeak synthesizer driver
14 %bcond_without  flite                   # Flite synthesizer driver
15 %bcond_with     mikropuhe               # Mikropuhe synthesizer driver [commercial, Finnish]
16 %bcond_without  speech_dispatcher       # Speech Dispatcher synthesizer driver
17 %bcond_with     swift                   # Swift synthesizer driver [commercial, from Cepstral]
18 %bcond_with     theta                   # Theta synthesizer driver [commercial, from Cepstral]
19 %bcond_with     viavoice                # IBM ViaVoice synthesizer driver [commercial]
20 %bcond_without  at_spi                  # AtSpi screen driver
21 %bcond_without  at_spi2                 # AtSpi2 screen driver
22 #
23 %define         brlapi_ver      0.6.0
24 #
25 %include        /usr/lib/rpm/macros.java
26 Summary:        Braille display driver for Linux/Unix
27 Summary(pl.UTF-8):      Sterownik do wyświetlaczy Braille'a
28 Name:           brltty
29 Version:        4.5
30 Release:        3
31 Group:          Daemons
32 License:        GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
33 Source0:        http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
34 # Source0-md5:  7b52fa7746fed41ed344a1f75ce55951
35 Patch0:         %{name}-stat.patch
36 Patch1:         %{name}-java.patch
37 Patch2:         %{name}-speech-dispatcher.patch
38 Patch3:         %{name}-python.patch
39 URL:            http://mielke.cc/brltty/
40 BuildRequires:  alsa-lib-devel
41 %{?with_at_spi:BuildRequires:   at-spi-devel}
42 BuildRequires:  autoconf >= 2.62
43 BuildRequires:  automake
44 BuildRequires:  bison
45 # just headers
46 BuildRequires:  bluez-libs-devel
47 %{?with_at_spi2:BuildRequires:  dbus-devel >= 1.0}
48 %{?with_apidocs:BuildRequires:  doxygen}
49 %{?with_espeak:BuildRequires:   espeak-devel}
50 %{?with_flite:BuildRequires:    flite-devel}
51 %{?with_gpm:BuildRequires:      gpm-devel}
52 %{?with_java:BuildRequires:     jdk}
53 %{?with_java:BuildRequires:     jpackage-utils}
54 %{?with_libbraille:BuildRequires:       libbraille-devel}
55 BuildRequires:  libicu-devel
56 BuildRequires:  ncurses-devel
57 %{?with_ocaml:BuildRequires:    ocaml}
58 BuildRequires:  pkgconfig
59 %{?with_python:BuildRequires:   python-Pyrex}
60 %{?with_java:BuildRequires:     rpm-javaprov}
61 %{?with_python:BuildRequires:   rpm-pythonprov}
62 %{?with_speech_dispatcher:BuildRequires:        speech-dispatcher-devel >= 0.8}
63 %{?with_tcl:BuildRequires:      tcl-devel}
64 %if %{with x}
65 BuildRequires:  xorg-lib-libX11-devel
66 BuildRequires:  xorg-lib-libXaw-devel
67 BuildRequires:  xorg-lib-libXext-devel
68 BuildRequires:  xorg-lib-libXt-devel
69 BuildRequires:  xorg-lib-libXtst-devel
70 %endif
71 #%{?with_mikropuhe:BuildRequires:       Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
72 #%{?with_swift:BuildRequires:   Swift-devel (-lswift <swift.h>)}
73 #%{?with_theta:BuildRequires:   Theta-devel (-ltheta <theta.h>)}
74 #%{?with_viavoice:BuildRequires:        ViaVoice-devel (-libmeci50 <eci.h>)}
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 BRLTTY is a background process (daemon) which provides access to the
79 Linux/Unix console (when in text mode) for a blind person using a
80 refreshable Braille display. It drives the Braille display, and
81 provides complete screen review functionality. Some speech capability
82 has also been incorporated.
83
84 %description -l pl.UTF-8
85 BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
86 trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
87 odświeżaniem (refreshable Braille display). BRLTTY steruje
88 wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
89 przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
90 mowy.
91
92 %package -n brlapi
93 Summary:        Application Programming Interface for BRLTTY
94 Summary(pl.UTF-8):      API do BRLTTY
95 License:        LGPL v2.1+
96 Group:          Libraries
97
98 %description -n brlapi
99 This package provides the run-time support for the Application
100 Programming Interface to BRLTTY.
101
102 Install this package if you have an application which directly
103 accesses a refreshable Braille display.
104
105 %description -n brlapi -l pl.UTF-8
106 Ten pakiet zawiera środowisko uruchomieniowe dla programów
107 korzystających z API BRLTTY.
108
109 Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
110 wyświetlacza Braille'a z odświeżaniem.
111
112 %package -n brlapi-devel
113 Summary:        Headers and documentation for BrlAPI
114 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do BrlAPI
115 License:        LGPL v2.1+
116 Group:          Development/Libraries
117 Requires:       brlapi = %{version}-%{release}
118
119 %description -n brlapi-devel
120 This package provides the header files, shared object linker
121 reference, and reference documentation for BrlAPI (the Application
122 Programming Interface to BRLTTY). It enables the implementation of
123 applications which take direct advantage of a refreshable Braille
124 display in order to present information in ways which are more
125 appropriate for blind users and/or to provide user interfaces which
126 are more specifically atuned to their needs.
127
128 Install this package if you're developing or maintaining an
129 application which directly accesses a refreshable Braille display.
130
131 %description -n brlapi-devel -l pl.UTF-8
132 Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
133 do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
134 korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
135 bardziej przystosowany dla osób niewidomych.
136
137 Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
138 korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
139
140 %package -n brlapi-static
141 Summary:        Static BrlAPI library
142 Summary(pl.UTF-8):      Statyczna biblioteka BrlAPI
143 License:        LGPL v2.1+
144 Group:          Development/Libraries
145 Requires:       brlapi-devel = %{version}-%{release}
146
147 %description -n brlapi-static
148 This is package with static BrlAPI library.
149
150 %description -n brlapi-static -l pl.UTF-8
151 Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
152
153 %package -n brlapi-apidocs
154 Summary:        BrlAPI documentation
155 Summary(pl.UTF-8):      Documentacja BrlAPI
156 Group:          Documentation
157
158 %description -n brlapi-apidocs
159 Documentation for BrlAPI in HTML format generated from brltty
160 sources by doxygen.
161
162 %description -n brlapi-apidocs -l pl.UTF-8
163 Dokumentacja BrlAPI w formacie HTML generowane ze
164 źrodeł brltty przez doxygen.
165
166 %package -n java-brlapi
167 Summary:        BrlAPI library for Java
168 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Javy
169 License:        LGPL v2.1+
170 Group:          Libraries
171 Requires:       brlapi = %{version}-%{release}
172
173 %description -n java-brlapi
174 BrlAPI library for Java.
175
176 %description -n java-brlapi -l pl.UTF-8
177 Biblioteka BrlAPI dla Javy.
178
179 %package -n ocaml-brlapi
180 Summary:        OCaml binding for BrlAPI
181 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI
182 License:        LGPL v2.1+
183 Group:          Libraries
184 Requires:       brlapi = %{version}-%{release}
185 %requires_eq    ocaml-runtime
186
187 %description -n ocaml-brlapi
188 OCaml binding for BrlAPI.
189
190 %description -n ocaml-brlapi -l pl.UTF-8
191 Wiązania OCamla do BrlAPI.
192
193 %package -n ocaml-brlapi-devel
194 Summary:        OCaml binding for BrlAPI - development files
195 Summary(pl.UTF-8):      Wiązania OCamla do BrlAPI - pliki programistyczne
196 License:        LGPL v2.1+
197 Group:          Libraries
198 Requires:       ocaml-brlapi = %{version}-%{release}
199 %requires_eq    ocaml
200
201 %description -n ocaml-brlapi-devel
202 OCaml binding for BrlAPI - development files.
203
204 %description -n ocaml-brlapi-devel -l pl.UTF-8
205 Wiązania OCamla do BrlAPI - pliki programistyczne.
206
207 %package -n python-brlapi
208 Summary:        Python interface to BrlAPI
209 Summary(pl.UTF-8):      Pythonowy interfejs do BrlAPI
210 License:        LGPL v2.1+
211 Group:          Libraries
212 Requires:       brlapi = %{version}-%{release}
213
214 %description -n python-brlapi
215 Python interface to BrlAPI.
216
217 %description -n python-brlapi -l pl.UTF-8
218 Pythonowy interfejs do BrlAPI.
219
220 %package -n brlapi-tcl
221 Summary:        BrlAPI library for Tcl
222 Summary(pl.UTF-8):      Biblioteka BrlAPI dla Tcl
223 License:        LGPL v2.1+
224 Group:          Libraries
225 Requires:       brlapi = %{version}-%{release}
226
227 %description -n brlapi-tcl
228 BrlAPI library for Tcl.
229
230 %description -n brlapi-tcl -l pl.UTF-8
231 Biblioteka BrlAPI dla Tcl.
232
233 %prep
234 %setup -q
235 %patch0 -p1
236 %patch1 -p1
237 %patch2 -p1
238 %patch3 -p1
239
240 %build
241 %{__autoconf}
242 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
243 %configure \
244         %{?with_java:JAVA_HOME=%{java_home}} \
245         --with-install-root="$RPM_BUILD_ROOT" \
246         %{!?with_libbraille:--without-libbraille} \
247         %{!?with_espeak:--without-espeak} \
248         %{!?with_flite:--without-flite} \
249         %{!?with_speech_dispatcher:--without-speechd} \
250         %{!?with_ocaml:--disable-caml-bindings} \
251         %{!?with_gpm:--disable-gpm} \
252         %{!?with_java:--disable-java-bindings} \
253         %{!?with_python:--disable-python-bindings} \
254         %{!?with_tcl:--disable-tcl-bindings} \
255         %{!?with_x:--disable-x} \
256         --enable-api
257
258 %{__make} -j1
259
260 directory="doc"
261 mkdir -p "$directory"
262 for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
263 do
264         mkdir -p "$directory/${file%/*}"
265         cp -rp "$file" "$directory/$file"
266 done
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270
271 %{__make} -j1 install \
272         OCAML_INSTALL_TARGET=install-without-findlib
273
274 %if %{_lib} != "lib"
275         # Fix java plugin install path on 64-bit archs
276         install -d $RPM_BUILD_ROOT%{_libdir}/java
277         %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
278 %endif
279
280 install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
281
282 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
283 cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
284 d /var/run/brltty 0755 root root -
285 EOF
286
287 %clean
288 rm -rf $RPM_BUILD_ROOT
289
290 %pre
291 # The pre-install scriptlet.
292
293 # If a configuration file already exists then rpm installs the new one as
294 # <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
295 # already exists.
296
297 # There's no explicit way to tell if a configuration file has been installed
298 # as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
299 # erasing the .rpmnew file now so that we can see if it gets created later.
300 rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
301
302 %post
303 # The post-install scriptlet.
304
305 # If BRLTTY's boot parameter has been specified then update the just installed
306 # configuration file template to reflect the options supplied thereby.
307
308 # First, we need to determine which file to update. If there's a .rpmnew file
309 # then update it since a previous configuration file must already have existed.
310 file="%{_sysconfdir}/brltty.conf"
311 new="${file}.rpmnew"
312 [ -f "${new}" ] && file="${new}"
313
314 # Update the configuration file template via the Bootdisks/bp2cf script.
315 # Include it right within this scriptlet so that it needn't be installed.
316 # Imbed it within a subshell to ensure that it won't impact this scriptlet.
317 (
318         # First, set bp2cf's command line arguments.
319         set -- -u -f "${file}"
320
321 #!/bin/sh
322 ###############################################################################
323 # BRLTTY - A background process providing access to the Linux console (when in
324 #          text mode) for a blind person using a refreshable Braille display.
325 #
326 # Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
327 #
328 # BRLTTY comes with ABSOLUTELY NO WARRANTY.
329 #
330 # This is free software, placed under the terms of the
331 # GNU General Public License, as published by the Free Software
332 # Foundation.  Please see the file COPYING for details.
333 #
334 # Web Page: http://mielke.cc/brltty/
335 #
336 # This software is maintained by Dave Mielke <dave@mielke.cc>.
337 ###############################################################################
338
339 # Convert the boot parameter to configuration file directives.
340 # If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
341 # If /proc is not mounted then use the brltty environment variable.
342 # Invoke with -h for usage information.
343
344 programName="${0##*/}"
345 programMessage()
346 {
347         echo 2>&1 "${programName}: ${1}"
348 }
349 syntaxError()
350 {
351         programMessage "${1}"
352         exit 2
353 }
354 internalError()
355 {
356         programMessage "${1}"
357         exit 3
358 }
359
360 configurationFile=""
361 requestedAction=create
362 deviceTranslation=none
363 requestedParameter=""
364 OPTIND=1
365 while getopts ":f:cundop:h" option
366 do
367         case "${option}" in
368             f) configurationFile="${OPTARG}";;
369             c) requestedAction=create;;
370             u) requestedAction=update;;
371             n) deviceTranslation=none;;
372             d) deviceTranslation=devfs;;
373             o) deviceTranslation=old;;
374             p) requestedParameter="${OPTARG}";;
375             h)
376                 cat <<EOF
377 Usage: ${programName} [option ...]
378 -f file  The configuration file to create/update.
379 -c       Create the configuration file (write to stdout if no -f).
380 -u       Update the configuration file (copying from stdin to stdout if no -f).
381 -n       Do not translate device paths.
382 -d       Do old-style to devfs device path translation.
383 -o       Do devfs to old-style device path translation.
384 -p [driver][,[device][,[table]]]
385          Explicitly specify the boot parameter.
386 -h       Display this usage summary.
387 EOF
388                 exit 0
389                 ;;
390             \?) syntaxError "unknown option: -${OPTARG}";;
391             :) syntaxError "missing value: -${OPTARG}";;
392             *) internalError "unimplemented option: -${option}";;
393         esac
394 done
395 shift "`expr $OPTIND - 1`"
396 [ "${#}" -eq 0 ] || syntaxError "too many parameters."
397
398 case "${requestedAction}" in
399     create)
400         putConfigurationLine()
401         {
402                 echo "${1}" || exit 4
403         }
404         startConfigurationFile()
405         {
406                 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
407                 putConfigurationLine "`makeHeaderLine Created`"
408                 putConfigurationLine "`makeParameterLine`"
409                 putConfigurationLine ""
410         }
411         putConfigurationDirective()
412         {
413                 putConfigurationLine "${1} ${2}"
414         }
415         finalizeConfigurationFile()
416         {
417                 :
418         }
419         ;;
420     update)
421         putSedCommand()
422         {
423                 sedScript="${sedScript}
424 ${1}"
425         }
426         startConfigurationFile()
427         {
428                 if [ -n "${configurationFile}" ]; then
429                         [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
430                         [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
431                         [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
432                         [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
433                         outputFile="${configurationFile}.new"
434                         exec <"${configurationFile}" >"${outputFile}"
435                 fi
436                 sedScript=""
437                 putSedCommand "1i\\
438 `makeHeaderLine Updated`\\
439 `makeParameterLine`\\
440 "
441         }
442         putConfigurationDirective()
443         {
444                 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
445                 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
446                 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
447         }
448         finalizeConfigurationFile()
449         {
450                 sed -e "${sedScript}"
451                 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
452         }
453         ;;
454     *) internalError "unimplemented action: ${requestedAction}";;
455 esac
456
457 translateDevice_none()
458 {
459         :
460 }
461 translateDevice_devfs()
462 {
463         minor="${device#ttyS}"
464         if [ "${minor}" != "${device}" ]; then
465                 device="tts/${minor}"
466                 return 0
467         fi
468         minor="${device#lp}"
469         if [ "${minor}" != "${device}" ]; then
470                 device="printers/${minor}"
471                 return 0
472         fi
473         programMessage "unsupported old-style device: ${device}"
474 }
475 translateDevice_old()
476 {
477         major="${device%%/*}"
478         if [ "${major}" != "${device}" ]; then
479                 minor="${device#*/}"
480                 case "${major}" in
481                     tts) devfs="ttyS${minor}";;
482                     printers) devfs="lp${minor}";;
483                 esac
484         fi
485         if [ -n "${devfs}" ]; then
486                 device="${devfs}"
487         else
488                 programMessage "unsupported devfs device: ${device}"
489         fi
490 }
491
492 makeHeaderLine()
493 {
494         echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
495 }
496 makeParameterLine()
497 {
498         echo "# Boot Parameter:${bootParameter}"
499 }
500 putConfigurationFile()
501 {
502         startConfigurationFile
503         [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
504         [ -n "${brailleDevice}" ] && {
505         device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
506         if [ "${device#/}" = "${device}" ]; then
507                 translateDevice_${deviceTranslation}
508         fi
509         putConfigurationDirective "braille-device" "${device}"
510         }
511         [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
512         finalizeConfigurationFile
513 }
514 parseBootParameter()
515 {
516         bootParameter="${bootParameter} ${1}"
517         number=1
518         while [ "${number}" -le 3 ]; do
519                 cut="cut -d, -f${number}"
520                 [ "${number}" -gt 1 ] && cut="${cut} -s"
521                 operand="`echo ${1} | ${cut}`"
522                 if [ -n "${operand}" ]; then
523                         case "${number}" in
524                             1) brailleDriver="${operand}";;
525                             2) brailleDevice="${operand}";;
526                             3) textTable="${operand}";;
527                         esac
528                 fi
529                 number="`expr ${number} + 1`"
530         done
531 }
532 putBootParameter()
533 {
534         parseBootParameter "${1}"
535         putConfigurationFile
536 }
537 parseBootCommand()
538 {
539         found=false
540         while [ "${#}" -gt 0 ]; do
541                 case "${1}" in
542                     "brltty="*)
543                         found=true
544                         parseBootParameter "${1#*=}"
545                         ;;
546                 esac
547                 shift
548         done
549         "${found}" && putConfigurationFile
550 }
551
552 brailleDriver=""
553 brailleDevice=""
554 textTable=""
555 bootCommandFile="/proc/cmdline"
556 if [ -n "${requestedParameter}" ]; then
557         putBootParameter "${requestedParameter}"
558 elif [ -f "${bootCommandFile}" ]; then
559         parseBootCommand `cat "${bootCommandFile}"`
560 elif [ -n "${brltty}" ]; then
561         putBootParameter "${brltty}"
562 fi
563 exit 0
564 )
565
566 %post   -n brlapi -p /sbin/ldconfig
567 %postun -n brlapi -p /sbin/ldconfig
568
569 %files
570 %defattr(644,root,root,755)
571 %doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
572 %doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README,nsistrings.txt}
573 %attr(755,root,root) %{_bindir}/brltty
574 %attr(755,root,root) %{_bindir}/brltty-config
575 %attr(755,root,root) %{_bindir}/brltty-ctb
576 %attr(755,root,root) %{_bindir}/brltty-install
577 %attr(755,root,root) %{_bindir}/brltty-trtxt
578 %attr(755,root,root) %{_bindir}/brltty-ttb
579 %attr(755,root,root) %{_bindir}/vstp
580 %{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
581 %dir %{_libdir}/brltty
582 # Braille drivers
583 %attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
584 %attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
585 %attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
586 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
587 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
588 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
589 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
590 %attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
591 %attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
592 %attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
593 %attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
594 %attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
595 %attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
596 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
597 %attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
598 %attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
599 %attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
600 %{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
601 %attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
602 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
603 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
604 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
605 %attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
606 %attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
607 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
608 %attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
609 %attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
610 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
611 %attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
612 %attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
613 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
614 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
615 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
616 %attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
617 %{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
618 # speech synthesizer drivers
619 %attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
620 %attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
621 %attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
622 %{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
623 %{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
624 %attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
625 %attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
626 %{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
627 %{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
628 %{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
629 %{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
630 %{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
631 %attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
632 # screen drivers
633 %{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
634 %{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
635 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
636 %attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
637 %{_sysconfdir}/brltty
638 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
639 /usr/lib/tmpfiles.d/brltty.conf
640 %dir /var/lib/BrlAPI
641 %dir /var/run/brltty
642 %{_mandir}/man1/brltty.1*
643 %{_mandir}/man1/vstp.1*
644 %{?with_x:%{_mandir}/man1/xbrlapi.1*}
645
646 %files -n brlapi
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
650
651 %files -n brlapi-devel
652 %defattr(644,root,root,755)
653 %doc Documents/Manual-BrlAPI/English/BrlAPI*
654 %attr(755,root,root) %{_libdir}/libbrlapi.so
655 %{_includedir}/brltty
656 %{_includedir}/brlapi*.h
657 %{_mandir}/man3/brlapi_*.3*
658
659 %files -n brlapi-static
660 %defattr(644,root,root,755)
661 %{_libdir}/libbrlapi.a
662
663 %if %{with apidocs}
664 %files -n brlapi-apidocs
665 %defattr(644,root,root,755)
666 %doc Documents/BrlAPIref/html/*
667 %endif
668
669 %if %{with java}
670 %files -n java-brlapi
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
673 %{_javadir}/brlapi.jar
674 %endif
675
676 %if %{with ocaml}
677 %files -n ocaml-brlapi
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
680 %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
681
682 %files -n ocaml-brlapi-devel
683 %defattr(644,root,root,755)
684 %dir %{_libdir}/ocaml/brlapi
685 %{_libdir}/ocaml/brlapi/META
686 %{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
687 %{_libdir}/ocaml/brlapi/brlapi.mli
688 %{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
689 %endif
690
691 %if %{with python}
692 %files -n python-brlapi
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{py_sitedir}/brlapi.so
695 %{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
696 %endif
697
698 %if %{with tcl}
699 %files -n brlapi-tcl
700 %defattr(644,root,root,755)
701 %dir %{_libdir}/brlapi-%{brlapi_ver}
702 %attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
703 %{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
704 %endif
This page took 0.128352 seconds and 3 git commands to generate.