]> git.pld-linux.org Git - packages/brlcad.git/blob - brlcad.spec
- updated BR for TH
[packages/brlcad.git] / brlcad.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        BRL CAD
7 Summary(pl):    BRL CAD
8 Name:           brlcad
9 Version:        7.8.0
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/CAD
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  bb4c5fd83ae1dd1b5dd84384f7894fc8
15 #Source1:       -
16 # Source1-md5:  -
17 #Patch0:                %{name}-DESTDIR.patch
18 URL:            htp://brlcad.sourceforge.net/
19 #BuildRequires: -
20 #for TH
21 BuildRequires:  xorg-lib-libICE-devel
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xorg-lib-libXext-devel
24 BuildRequires:  xorg-lib-libXi-devel
25 BuildRequires:  xorg-lib-libXmu-devel
26 BuildRequires:  xorg-lib-libXt-devel
27 BuildRequires:  xorg-lib-libSM-devel
28 #
29 BuildRequires:  tcl-devel
30 BuildRequires:  tk-devel
31 Buildrequires:  itcl-devel
32 BuildRequires:  itk-devel
33 Buildrequires:  python
34 BuildRequires:  SDL-devel
35 BuildRequires:  tk-Img-devel
36 #Requires(postun):      -
37 #Requires(pre,post):    -
38 #Requires(preun):       -
39 #Requires:      -
40 #Provides:      -
41 #Provides:      group(foo)
42 #Provides:      user(foo)
43 #Obsoletes:     -
44 #Conflicts:     -
45 #BuildArch:     noarch
46 #ExclusiveArch: %{ix86}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 The BRL-CAD package is a powerful Constructive Solid Geometry (CSG) solid modeling system with over 20 years development and production use by the U.S. military. BRL-CAD includes an interactive geometry editor, parallel ray-tracing support for rendering and geometric analysis, path-tracing for realistic image synthesis, network distributed framebuffer support, image-processing and signal-processing tools. The entire package is distributed in source code form.
51
52 %description -l pl
53
54 %package subpackage
55 Summary:        -
56 Summary(pl):    -
57 Group:          -
58
59 %description subpackage
60
61 %description subpackage -l pl
62
63 %package libs
64 Summary:        -
65 Summary(pl):    -
66 Group:          Libraries
67
68 %description libs
69
70 %description libs -l pl
71
72
73 %package devel
74 Summary:        Header files for ... library
75 Summary(pl):    Pliki nag³ówkowe biblioteki ...
76 Group:          Development/Libraries
77 #Requires:      %{name} = %{version}-%{release}
78
79 %description devel
80 This is the package containing the header files for ... library.
81
82 %description devel -l pl
83 Ten pakiet zawiera pliki nag³ówkowe biblioteki ....
84
85 %package static
86 Summary:        Static ... library
87 Summary(pl):    Statyczna biblioteka ...
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static ... library.
93
94 %description static -l pl
95 Statyczna biblioteka ....
96
97 %prep
98 %setup -q
99 #%setup -q -c -T
100 #%setup -q -n %{name}
101 #%%setup -q -n %{name}-%{version}.orig -a 1
102 #%patch0 -p1
103
104 # undos the source
105 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 sed -i -e 's,\r$,,'
106
107 # remove CVS control files
108 #find -name CVS -print0 | xargs -0 rm -rf
109
110 %build
111 #/autogen.sh
112 %configure \
113     --disable-zlib-build \
114     --disable-png-build \
115     --disable-tcl-build \
116     --disable-itcl-build \
117     --disable-itk-build \
118     --disable-tkimg-build
119 #{__make}
120
121 #%{__make} \
122 #       CFLAGS="%{rpmcflags}" \
123 #       LDFLAGS="%{rpmldflags}"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 # create directories if necessary
128 #install -d $RPM_BUILD_ROOT
129 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %pre
138
139 %post
140
141 %preun
142
143 %postun
144
145 %if %{with ldconfig}
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148 %endif
149
150 %if %{with initscript}
151 %post init
152 /sbin/chkconfig --add %{name}
153 %service %{name} restart
154
155 %preun init
156 if [ "$1" = "0" ]; then
157         %service -q %{name} stop
158         /sbin/chkconfig --del %{name}
159 fi
160 %endif
161
162 %files
163 %defattr(644,root,root,755)
164 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
165
166 %if 0
167 # if _sysconfdir != /etc:
168 #%%dir %{_sysconfdir}
169 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
170 %attr(755,root,root) %{_bindir}/*
171 %{_datadir}/%{name}
172 %endif
173
174 # initscript and its config
175 %if %{with initscript}
176 %attr(754,root,root) /etc/rc.d/init.d/%{name}
177 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
178 %endif
179
180 #%{_examplesdir}/%{name}-%{version}
181
182 %if %{with subpackage}
183 %files subpackage
184 %defattr(644,root,root,755)
185 #%doc extras/*.gz
186 #%{_datadir}/%{name}-ext
187 %endif
This page took 0.081278 seconds and 4 git commands to generate.