]> git.pld-linux.org Git - packages/bopm.git/blob - bopm.spec
- sort BR
[packages/bopm.git] / bopm.spec
1 Summary:        Open proxy monitor and blocker, designed for use with ircds
2 Name:           bopm
3 Version:        3.1.2
4 Release:        0.10
5 Epoch:          0
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  ab1b7494c4242eef957b5fca61c92b18
10 Source1:        %{name}.init
11 Source2:        %{name}.conf
12 Patch0:         %{name}-DESTDIR.patch
13 URL:            http://www.blitzed.org/bopm/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  findutils
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.202
19 Requires:       rc-scripts >= 0.4.0.17
20 Requires(post): /sbin/chkconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Blitzed Open Proxy Monitor is designed to connect to an IRC server
25 and become an IRC operator. It then watches connect notices in order
26 to scan all connecting clients for open (insecure) proxies. Such
27 insecure proxies are commonly used for spamming, floods and other
28 abusive activities.
29
30 BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
31 routers with default passwords. BOPM also has support for checking
32 against a DNS-Based Blacklist (similar to MAPS RBL) and can be
33 configured to report new proxies back to the Blitzed Open Proxy
34 Monitoring project.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 find -name CVS | xargs -r rm -rf
41 rm -f contrib/bopm.spec
42
43 %build
44 %{__libtoolize}
45 %{__aclocal}
46 %{__autoconf}
47 %{__autoheader}
48 %{__automake}
49 %configure \
50         --localstatedir=/var/log/%{name} \
51         --bindir=%{_sbindir}
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/{run,log}/%{name}}
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
63 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
64 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
65 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %pre
71 %groupadd -g 151 %{name}
72 %useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
73
74 %post
75 /sbin/chkconfig --add %{name}
76 if [ -f /var/lock/subsys/%{name} ]; then
77         /etc/rc.d/init.d/%{name} restart 1>&2
78 else
79         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start BOPM daemon."
80 fi
81
82 %preun
83 if [ "$1" = "0" ]; then
84         if [ -f /var/lock/subsys/%{name} ]; then
85                 /etc/rc.d/init.d/%{name} stop 1>&2
86         fi
87         /sbin/chkconfig --del %{name}
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc ChangeLog INSTALL README bopm.conf.sample
93 %doc contrib/ network-bopm/
94 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
95 %attr(754,root,root) /etc/rc.d/init.d/%{name}
96 %attr(755,root,root) %{_sbindir}/%{name}
97
98 %attr(770,root,bopm) %dir /var/run/%{name}
99 %attr(770,root,bopm) %dir /var/log/%{name}
100 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
101 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
This page took 0.089345 seconds and 4 git commands to generate.