]> git.pld-linux.org Git - packages/bopm.git/blob - bopm.spec
- sorted preamble, use %service
[packages/bopm.git] / bopm.spec
1 Summary:        Open proxy monitor and blocker, designed for use with ircds
2 Summary(pl):    Monitorowanie i blokowanie otwartych proxy do u¿ywania z ircd
3 Name:           bopm
4 Version:        3.1.2
5 Release:        0.12
6 License:        GPL
7 Group:          Applications/Communications
8 Source0:        http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  ab1b7494c4242eef957b5fca61c92b18
10 Source1:        %{name}.init
11 Source2:        %{name}.conf
12 Patch0:         %{name}-DESTDIR.patch
13 URL:            http://www.blitzed.org/bopm/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(postun):       /usr/sbin/groupdel
20 Requires(postun):       /usr/sbin/userdel
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires:       rc-scripts >= 0.4.0.17
26 Provides:       group(%{name})
27 Provides:       user(%{name})
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Blitzed Open Proxy Monitor is designed to connect to an IRC server
32 and become an IRC operator. It then watches connect notices in order
33 to scan all connecting clients for open (insecure) proxies. Such
34 insecure proxies are commonly used for spamming, floods and other
35 abusive activities.
36
37 BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
38 routers with default passwords. BOPM also has support for checking
39 against a DNS-Based Blacklist (similar to MAPS RBL) and can be
40 configured to report new proxies back to the Blitzed Open Proxy
41 Monitoring project.
42
43 %description -l pl
44 Blitzed Open Proxy Monitor jest zaprojektowany tak, ¿e ³±czy siê z
45 serwerem IRC i staje operatorem. Nastêpnie ogl±da informacje o
46 po³±czeniach w celu skanowania wszystkich klientów pod k±tem otwartych
47 (niebezpiecznych) proxy. Takie niebezpieczne proxy zwykle s± u¿ywane
48 do spamowania, floodowania i innych nadu¿yæ.
49
50 BOPM jest w stanie wykryæ WinGates, proxy HTTP, proxy SOCKS 4/5 oraz
51 routery Cisco z domy¶lnymi has³ami. BOPM obs³uguje tak¿e sprawdzanie
52 czarnych list opartych na DNS (takich jak MAPS RBL) i mo¿e byæ
53 skonfigurowany do zg³aszania nowych proxy z powrotem do projektu
54 Blitzed Open Proxy Monitoring.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 find -name CVS | xargs -r rm -rf
61 rm -f contrib/bopm.spec
62
63 %build
64 %{__libtoolize}
65 %{__aclocal}
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 %configure \
70         --localstatedir=/var/log/%{name} \
71         --bindir=%{_sbindir}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/{run,log}/%{name}}
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
83 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
84 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
85 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %pre
91 %groupadd -g 151 %{name}
92 %useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
93
94 %post
95 /sbin/chkconfig --add %{name}
96 %service %{name} restart "BOPM daemon"
97
98 %preun
99 if [ "$1" = "0" ]; then
100         %service %{name} stop
101         /sbin/chkconfig --del %{name}
102 fi
103
104 %postun
105 if [ "$1" = "0" ]; then
106         %userremove %{name}
107         %groupremove %{name}
108 fi
109
110 %files
111 %defattr(644,root,root,755)
112 %doc ChangeLog INSTALL README bopm.conf.sample
113 %doc contrib/ network-bopm/
114 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
115 %attr(754,root,root) /etc/rc.d/init.d/%{name}
116 %attr(755,root,root) %{_sbindir}/%{name}
117
118 %attr(770,root,bopm) %dir /var/run/%{name}
119 %attr(770,root,bopm) %dir /var/log/%{name}
120 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
121 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
This page took 0.082926 seconds and 4 git commands to generate.