]> git.pld-linux.org Git - packages/bopm.git/blob - bopm.spec
- BR(findutils) for xargs and find
[packages/bopm.git] / bopm.spec
1 Summary:        Open proxy monitor and blocker, designed for use with ircds
2 Summary(pl):    Monitorowanie i blokowanie otwartych proxy do u¿ywania z ircd
3 Name:           bopm
4 Version:        3.1.2
5 Release:        0.11
6 Epoch:          0
7 License:        GPL
8 Group:          Applications/Communications
9 Source0:        http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  ab1b7494c4242eef957b5fca61c92b18
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 Patch0:         %{name}-DESTDIR.patch
14 URL:            http://www.blitzed.org/bopm/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  findutils
18 BuildRequires:  libtool
19 BuildRequires:  rpmbuild(macros) >= 1.202
20 PreReq:         rc-scripts >= 0.4.0.17
21 Requires(pre):  /usr/bin/getgid
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires(postun):       /usr/sbin/userdel
26 Requires(postun):       /usr/sbin/groupdel
27 Requires(post,preun):   /sbin/chkconfig
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Blitzed Open Proxy Monitor is designed to connect to an IRC server
32 and become an IRC operator. It then watches connect notices in order
33 to scan all connecting clients for open (insecure) proxies. Such
34 insecure proxies are commonly used for spamming, floods and other
35 abusive activities.
36
37 BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
38 routers with default passwords. BOPM also has support for checking
39 against a DNS-Based Blacklist (similar to MAPS RBL) and can be
40 configured to report new proxies back to the Blitzed Open Proxy
41 Monitoring project.
42
43 %description -l pl
44 Blitzed Open Proxy Monitor jest zaprojektowany tak, ¿e ³±czy siê z
45 serwerem IRC i staje operatorem. Nastêpnie ogl±da informacje o
46 po³±czeniach w celu skanowania wszystkich klientów pod k±tem otwartych
47 (niebezpiecznych) proxy. Takie niebezpieczne proxy zwykle s± u¿ywane
48 do spamowania, floodowania i innych nadu¿yæ.
49
50 BOPM jest w stanie wykryæ WinGates, proxy HTTP, proxy SOCKS 4/5 oraz
51 routery Cisco z domy¶lnymi has³ami. BOPM obs³uguje tak¿e sprawdzanie
52 czarnych list opartych na DNS (takich jak MAPS RBL) i mo¿e byæ
53 skonfigurowany do zg³aszania nowych proxy z powrotem do projektu
54 Blitzed Open Proxy Monitoring. 
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 find -name CVS | xargs -r rm -rf
61 rm -f contrib/bopm.spec
62
63 %build
64 %{__libtoolize}
65 %{__aclocal}
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 %configure \
70         --localstatedir=/var/log/%{name} \
71         --bindir=%{_sbindir}
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/{run,log}/%{name}}
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
83 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
84 > $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
85 > $RPM_BUILD_ROOT/var/log/%{name}/scan.log
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %pre
91 %groupadd -g 151 %{name}
92 %useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
93
94 %post
95 /sbin/chkconfig --add %{name}
96 if [ -f /var/lock/subsys/%{name} ]; then
97         /etc/rc.d/init.d/%{name} restart 1>&2
98 else
99         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start BOPM daemon."
100 fi
101
102 %preun
103 if [ "$1" = "0" ]; then
104         if [ -f /var/lock/subsys/%{name} ]; then
105                 /etc/rc.d/init.d/%{name} stop 1>&2
106         fi
107         /sbin/chkconfig --del %{name}
108 fi
109
110 %postun
111 if [ "$1" = "0" ]; then
112         %userremove %{name}
113         %groupremove %{name}
114 fi
115
116 %files
117 %defattr(644,root,root,755)
118 %doc ChangeLog INSTALL README bopm.conf.sample
119 %doc contrib/ network-bopm/
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
121 %attr(754,root,root) /etc/rc.d/init.d/%{name}
122 %attr(755,root,root) %{_sbindir}/%{name}
123
124 %attr(770,root,bopm) %dir /var/run/%{name}
125 %attr(770,root,bopm) %dir /var/log/%{name}
126 %attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
127 %attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
This page took 0.047344 seconds and 4 git commands to generate.