]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
1742f98e26205046d9eebc18d72b45b2a567572e
[packages/boost.git] / boost.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # without boost-python support
4 #
5 %define _ver    1.31.0
6 %define _fver   %(echo %{_ver} | tr . _)
7
8 Summary:        The Boost C++ Libraries
9 Summary(pl):    Biblioteki C++ "Boost"
10 Name:           boost
11 Version:        %{_ver}
12 Release:        0.1
13 License:        Boost Software License and others
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
16 # Source0-md5:  8cc183538eaa5cfc53d88d0e94bd2fd4
17 Patch0:         %{name}-python.patch
18 URL:            http://www.boost.org/
19 BuildRequires:  boost-jam >= 3.1.3
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  perl-base
22 %{?with_python:BuildRequires:   python-devel >= 2.2}
23 BuildConflicts: gcc = 5:3.3.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Boost web site provides free peer-reviewed portable C++ source
28 libraries. The emphasis is on libraries which work well with the C++
29 Standard Library. One goal is to establish "existing practice" and
30 provide reference implementations so that the Boost libraries are
31 suitable for eventual standardization. Some of the libraries have
32 already been proposed for inclusion in the C++ Standards Committee's
33 upcoming C++ Standard Library Technical Report.
34
35 %description -l pl
36 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
37 kodem ¼ród³owym. Nacisk po³o¿ono na biblioteki, które dobrze
38 wspó³pracuj± ze standardow± bibliotek± C++. Celem jest ustanowienie
39 "isniej±cej praktyki" i dostarczenie implementacji, tak ¿e biblioteki
40 "Boost" nadaj± siê do ewentualnej standaryzacji. Niektóre z bibliotek
41 ju¿ zosta³y zg³oszone do komitetu standaryzacyjnego C++ w nadchodz±cym
42 Raporcie Technicznym Biblioteki Standardowej C++
43
44 %package devel
45 Summary:        Boost C++ development libraries and headers
46 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++
47 Group:          Development/Libraries
48 # req'd by <boost/iterator_adaptors.hpp> (also included by <boost/signal.h>)
49 Requires:       %{name}-compressed_pair-devel = %{version}-%{release}
50 Requires:       %{name}-concept_check-devel = %{version}-%{release}
51 Requires:       libstdc++-devel
52
53 %description devel
54 Headers and static libraries for the Boost C++ libraries.
55
56 %description devel -l pl
57 Pliki nag³ówkowe i biblioteki statyczne bibliotek Boost C++.
58
59 %package python
60 Summary:        Boost.Python library
61 Summary(pl):    biblioteka Boost.Python
62 Group:          Libraries
63 %pyrequires_eq  python
64
65 %description python
66 Use the Boost Python Library to quickly and easily export a C++
67 library to Python such that the Python interface is very similar to
68 the C++ interface. It is designed to be minimally intrusive on your
69 C++ design. In most cases, you should not have to alter your C++
70 classes in any way in order to use them with Boost.Python. The system
71 should simply ``reflect'' your C++ classes and functions into Python.
72
73 %description python -l pl
74 Biblioteka Boost Python s³u¿y do szybkiego i prostego eksportu
75 biblioteki C++ do Pythona, tak ¿e interfejs Pythona jest bardzo
76 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, ¿eby
77 narzucaæ jak najmniej wymagañ dotycz±cych konstrukcjii C++. W
78 wiêkszo¶ci przypadków nie trzeba w ogóle zmieniaæ w³asnych klas C++,
79 ¿eby u¿ywaæ ich z Boost.Python. System powinien po prostu ,,odbiæ''
80 klasy C++ i funkcje do Pythona.
81
82 %package python-devel
83 Summary:        Boost.Python development headers
84 Summary(pl):    Pliki nag³ówkowe dla Boost.Python
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       %{name}-python = %{version}-%{release}
88
89 %description python-devel
90 Headers for the Boost.Python library.
91
92 %description python-devel -l pl
93 Pliki nag³ówkowe dla biblioteki Boost.Python.
94
95 %package python-static
96 Summary:        Static version of Boost.Python library
97 Summary(pl):    Statyczna wersja biblioteki Boost.Python
98 Group:          Development/Libraries
99 Requires:       %{name}-python-devel = %{version}-%{release}
100
101 %description python-static
102 Static version of Boost.Python library.
103
104 %description python-static -l pl
105 Statyczna wersja biblioteki Boost.Python.
106
107 %package regex
108 Summary:        Boost C++ regular expressions library
109 Summary(pl):    Biblioteka wyra¿eñ regularnych Boost C++
110 Group:          Libraries
111
112 %description regex
113 Shared library for Boost C++ regular expressions.
114
115 %description regex -l pl
116 Biblioteka wyra¿eñ regularnych dla C++, biblioteki dzielone.
117
118 %package regex-devel
119 Summary:        Boost C++ Regex library headers
120 Summary(pl):    Pliki nag³ówkowe Boost C++ Regex
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123 Requires:       %{name}-regex = %{version}-%{release}
124
125 %description regex-devel
126 Boost C++ Regex headers.
127
128 %description regex-devel -l pl
129 Pliki nag³ówkowe dla Boost C++ Regex.
130
131 %package regex-static
132 Summary:        Boost C++ Regex static libraries
133 Summary(pl):    Biblioteki statyczne Boost C++ Regex
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136 Requires:       %{name}-regex = %{version}-%{release}
137
138 %description regex-static
139 Boost C++ Regex static libraries.
140
141 %description regex-static -l pl
142 Biblioteki statyczne dla Boost C++ Regex.
143
144 %package any-devel
145 Summary:        Header for Boost C++ "Any" Library
146 Summary(pl):    Plik nag³ówkowy dla biblioteki Boost C++ "Any"
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149
150 %description any-devel
151 The boost::any class, is a variant value type, which supports copying
152 of any value type and safe checked extraction of that value strictly
153 against that type.
154
155 I.e. 5 is held strictly as an int and is not implicitly convertible
156 either to "5" or to 5.0.
157
158 %description any-devel -l pl
159 Klasa boost::any jest typem, który umo¿liwia kopiowanie ze zmiennej
160 dowolnego typu i bezpieczne, sprawdzone wydobycie jej warto¶ci
161 dok³adnie tego samego typu.
162
163 Np. 5 jest trzymane jako int i nie jest niejawnie konwertowalne ani do
164 "5" ani do 5.0.
165
166 %package array-devel
167 Summary:        STL compliant container wrapper for arrays of constant size
168 Summary(pl):    Wrapper na STLowe kontenery dla tablic o sta³ym rozmiarze
169 Group:          Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171
172 %description array-devel
173 As replacement for ordinary arrays, the STL provides class vector<>.
174 However, vector<> provides the semantics of dynamic arrays. Thus, it
175 manages data to be able to change the number of elements. This results
176 in some overhead in case only arrays with static size are needed. This
177 library provides support for such static size arrays.
178
179 %description array-devel -l pl
180 STL dostarcza klasê vector<> jako zamiennik zwyk³ej tablicy. Jednak
181 vector<> dostarcza semantykê dynamicznych tablic. Zatem zarz±dza
182 danymi tak, by by³a mo¿liwa zmiana ilo¶ci elementów. To skutkuje
183 pewnym nadmiarem w przypadku kiedy tylko tablice o sta³ym rozmiarze s±
184 potrzebne. Ta biblioteka dostarcza wsparcie dla takich w³a¶nie tablic
185 o sta³ym rozmiarze.
186
187 %package bind-devel
188 Summary:        Generalized binders for function/object/pointers
189 Summary(pl):    Uogólnione bindery dla funkcji/obiektów/wska¼ników
190 Group:          Development/Libraries
191 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
192 Requires:       %{name}-ref-devel = %{version}-%{release}
193
194 %description bind-devel
195 boost::bind is a generalization of the standard functions std::bind1st
196 and std::bind2nd.
197
198 %description bind-devel -l pl
199 boost::bind jest uogólnieniem standardowych funkcji std::bind1st i
200 std::bind2nd.
201
202 %package call_traits-devel
203 Summary:        Defines types for passing parameters
204 Summary(pl):    Definiowanie typów dla przekazywania parametrów
205 Group:          Development/Libraries
206 Requires:       %{name}-devel = %{version}-%{release}
207 Requires:       %{name}-type_traits-devel = %{version}-%{release}
208
209 %description call_traits-devel
210 boost::call_traits<T> encapsulates the "best" method to pass a
211 parameter of some type T to or from a function. The purpose of
212 call_traits is to ensure that problems like "references to references"
213 never occur, and that parameters are passed in the most efficient
214 manner possible.
215
216 %description call_traits-devel -l pl
217 boost::call_traits<T> zawiera "najlepsz±" metodê przekazywania
218 parametrów jakiego¶ typu T do lub z funkcji. Celem call_traits jest
219 zapewnienie ¿e problemy takie jak "referencja referencji" nigdy nie
220 wyst±pi± i ¿e parametry s± przekazywane w mo¿liwie najbardziej
221 efektywny sposób.
222
223 %package compatibility-devel
224 Summary:        Help for non-conforming standard libraries
225 Summary(pl):    Pomoc dla nie trzymaj±cych standardu bibliotek
226 Group:          Development/Libraries
227 Requires:       %{name}-devel = %{version}-%{release}
228
229 %description compatibility-devel
230 This library provides workarounds which allow the other Boost
231 libraries to be used on otherwise non-conforming platforms.
232
233 %description compatibility-devel -l pl
234 Biblioteka dostarcza obej¶cie problemu platform nie trzymaj±cych
235 standardu C++, pozwalaj±ce na u¿ywanie bibliotek Boost na tych
236 platformach.
237
238 %package compose-devel
239 Summary:        Functional composition adapters for the STL
240 Summary(pl):    Funkcjonalne adaptery kompozycji dla STL
241 Group:          Development/Libraries
242 Requires:       %{name}-devel = %{version}-%{release}
243
244 %description compose-devel
245 The boost::compose provides compose function object adapter extensions
246 for use with the Standard Template Library (STL) portion of the C++
247 Standard Library. If you aren't currently using the STL, this library
248 won't be of any interest, but hard-core STL users will appreciate its
249 usefulness.
250
251 %description compose-devel -l pl
252 boost::compose dostarcza rozszerzenie adaptera obiektu funkcji compose
253 do u¿ytku z STL-ow± czê¶ci± Standardu C++. Je¿eli nie u¿ywasz STL,
254 biblioteka bêdzie poza twoim zainteresowaniem, lecz hardkorowi
255 u¿ytkownicy STL-a doceni± jej u¿yteczno¶æ.
256
257 %package compressed_pair-devel
258 Summary:        Empty member optimization
259 Summary(pl):    Optymalizacja pustego elementu
260 Group:          Development/Libraries
261 Requires:       %{name}-call_traits-devel = %{version}-%{release}
262 Requires:       %{name}-devel = %{version}-%{release}
263
264 %description compressed_pair-devel
265 The class boost::compressed_pair is very similar to std::pair, but if
266 either of the template arguments are empty classes, then the "empty
267 base-class optimisation" is applied to compress the size of the pair.
268
269 %description compressed_pair-devel -l pl
270 Klasa boost::compressed_pair jest bardzo podobna do std::pair, ale
271 je¿eli który¶ z argumentów wzorca jest pust± klas±, wtedy stosowana
272 jest "optymalizacja pustej klasy bazowej" do kompresji pary.
273
274 %package concept_check-devel
275 Summary:        Tools for generic programming
276 Summary(pl):    Narzêdzia dla programowania generycznego
277 Group:          Development/Libraries
278 Requires:       %{name}-static_assert-devel = %{version}-%{release}
279 Requires:       %{name}-type_traits-devel = %{version}-%{release}
280
281 %description concept_check-devel
282 The boost::concept_check library provides various tools for generic
283 programming.
284
285 %description concept_check-devel -l pl
286 Biblioteka boost::concept_check dostarcza ró¿ne narzêdzia dla
287 programowania generycznego.
288
289 %package conversion-devel
290 Summary:        Numeric, polymorphic, and lexical casts
291 Summary(pl):    Numeryczne, polimorficzne i leksykalne rzutowania
292 Group:          Development/Libraries
293 Requires:       %{name}-type_traits-devel = %{version}-%{release}
294
295 %description conversion-devel
296 The boost::conversion library improves program safety and clarity by
297 performing otherwise messy conversions. It includes cast-style
298 function templates designed to complement the C++ Standard's built-in
299 casts.
300
301 %description conversion-devel -l pl
302 Biblioteka boost::conversion zwiêksza bezpieczeñstwo i klarowno¶æ
303 programu dokonuj±c konwersji które s± w innych przypadkach niechlujne.
304 Biblioteka zawiera "rzutopodobne" wzorce funkcji uzupe³niaj±ce
305 wbudowane w Standard C++ rzutowania.
306
307 %package crc-devel
308 Summary:        CRC computing library
309 Summary(pl):    Biblioteka obliczaj±ca CRC
310 Group:          Development/Libraries
311 Requires:       %{name}-devel = %{version}-%{release}
312
313 %description crc-devel
314 The boost::crc library provides two implementations of CRC computation
315 objects and functions. The implementations are template-based.
316
317 %description crc-devel -l pl
318 Bibliteka boost::crc dostarcza dwie implementacje obiektów i funkcji
319 obliczaj±cych CRC. Implementacje s± oparte na wzorcach.
320
321 %package date_time
322 Summary:        Date-Time library
323 Summary(pl):    Biblioteka daty-czasu
324 Group:          Libraries
325
326 %description date_time
327 A set of date-time libraries.
328
329 %description date_time -l pl
330 Zbiór bibliotek daty-czasu.
331
332 %package date_time-devel
333 Summary:        Header files for boost::date_time library
334 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::date_time
335 Group:          Development/Libraries
336 Requires:       %{name}-date_time = %{version}-%{release}
337 #TODO: make decision if do separate packages include it to main devel package
338 #Requires:      %{name}-operators-devel = %{version}-%{release}
339 #Requires:      %{name}-integer-devel = %{version}-%{release}
340 #Requires:      %{name}-tokenizer-devel = %{version}-%{release}
341 Requires:       %{name}-conversion-devel = %{version}-%{release}
342
343 %description date_time-devel
344 Header files for boost::date_time library.
345
346 %description date_time-devel -l pl
347 Pliki nag³ówkowe dla biblioteki boost::date_time
348
349 %package date_time-static
350 Summary:        Static boost::date_time library
351 Summary(pl):    Statyczna biblioteka boost::date_time
352 Group:          Development/Libraries
353 Requires:       %{name}-date_time-devel = %{version}-%{release}
354
355 %description date_time-static
356 Static boost::date_time library.
357
358 %description date_time-devel -l pl
359 Statyczna biblioteka boost::date_time.
360
361 %package filesystem
362 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
363 Summary(pl):    Przeno¶ne ¶cie¿ki, iteracje katalogów i inne u¿yteczne operacje na systemie plików
364 Group:          Libraries
365
366 %description filesystem
367 The boost::filesystem library provides portable facilities to query
368 and manipulate paths, files, and directories.
369
370 %description filesystem -l pl
371 Przeno¶na biblioteka boost::filesystem dostarcza u³atwienia w
372 operacjach na ¶cie¿kach, plikach i katalogach.
373
374 %package filesystem-devel
375 Summary:        Header files for boost::filesystem
376 Summary(pl):    Pliki nag³ówkowe dla boost::filesystem
377 Group:          Development/Libraries
378 Requires:       %{name}-devel = %{version}-%{release}
379 Requires:       %{name}-filesystem = %{version}-%{release}
380 #TODO:
381 #Requires:      %{name}-smart_ptr = %{version}-%{release}
382
383 %description filesystem-devel
384 Header files for boost::filesystem library.
385
386 %description filesystem-devel -l pl
387 Pliki nag³ówkowe dla biblioteki boost::filesystem.
388
389 %package filesystem-static
390 Summary:        Static boost::filesystem library
391 Summary(pl):    Biblioteka statyczna boost::filesystem
392 Group:          Development/Libraries
393 Requires:       %{name}-filesystem-devel = %{version}-%{release}
394
395 %description filesystem-static
396 Static boost::filesystem library.
397
398 %description filesystem-static -l pl
399 Biblioteka statyczna boost::filesystem.
400
401 %package mem_fn-devel
402 Summary:        Generalized binders for member functions
403 Summary(pl):    Uogólnione bindery dla metod
404 Group:          Development/Libraries
405 Requires:       %{name}-bind-devel = %{version}-%{release}
406
407 %description mem_fn-devel
408 boost::mem_fn is a generalization of the standard functions
409 std::mem_fun and std::mem_fun_ref.
410
411 %description mem_fn-devel -l pl
412 boost::mem_fn jest uogólnieniem standardowych funkcji std::mem_fun i
413 std::mem_fun_ref.
414
415 %package mpl-devel
416 Summary:        Compile-time algorithms, sequences and metafunction classes
417 Summary(pl):    Algorytmy czasu kompilacji, sekwencji i klas metafunkcji
418 Group:          Development/Libraries
419 Requires:       %{name}-devel = %{version}-%{release}
420 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
421 Requires:       %{name}-type_traits-devel = %{version}-%{release}
422 Requires:       %{name}-utility-devel = %{version}-%{release}
423
424 %description mpl-devel
425 The boost-mpl library is a C++ template metaprogramming framework of
426 compile-time algorithms, sequences and metafunction classes.
427
428 %description mpl-devel -l pl
429 Biblioteka boost-mpl jest szkieletem wzorców C++ dla algorytmów czasu
430 kompilacji, sekwencji i klas metafunkcji.
431
432 %package preprocessor-devel
433 Summary:        Preprocessor metaprogramming tools including repetition and recursion
434 Summary(pl):    Narzêdzia metaprogramowania preprocesora razem z repetycj± i rekursj±
435 Group:          Development/Libraries
436 Requires:       %{name}-devel = %{version}-%{release}
437
438 %description preprocessor-devel
439 This library provides preprocessor metaprogramming tools, including
440 repetition and recursion.
441
442 %description preprocessor-devel -l pl
443 Biblioteka udostêpnia narzêdzia metaprogramowania preprocesora,
444 w³±czaj±c w to repetycje i rekursjê.
445
446 %package ref-devel
447 Summary:        Small library useful for passing references to function templates
448 Summary(pl):    Ma³a biblioteka u¿yteczna przy przekazywaniu referencji do wzorców funkcji
449 Group:          Development/Libraries
450 Requires:       %{name}-devel = %{version}-%{release}
451 Requires:       %{name}-mpl-devel = %{version}-%{release}
452 Requires:       %{name}-utility-devel = %{version}-%{release}
453
454 %description ref-devel
455 boost::ref library is a small library that is useful for passing
456 references to function templates (algorithms) that would usually take
457 copies of their arguments.
458
459 %description ref-devel -l pl
460 Biblioteka boost::ref jest ma³± bibliotek± która jest u¿yteczna w
461 przypadku przekazywania referencji do wzorców funkcji (algorytmów)
462 które zazwyczaj bior± kopiê swoich argumentów.
463
464 %package signals
465 Summary:        signals & slots callback implementation
466 Summary(pl):    implementacja sygna³ów i slotów
467 Group:          Libraries
468
469 %description signals
470 The boost::signals library is an implementation of a signals and slots
471 system.
472
473 %description signals -l pl
474 Biblioteka boost::signals jest implementacj± systemu sygna³ów i
475 slotów.
476
477 %package signals-devel
478 Summary:        Header files for boost::signals library
479 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::signals
480 Group:          Development/Libraries
481 Requires:       %{name}-any-devel = %{version}-%{release}
482 #TODO: separate smart_ptr or include to the main devel package
483 #Requires:      %{name}-iterator_adaptors-devel = %{version}-%{release}
484 #Requires:      %{name}-operators-devel = %{version}-%{release}
485 #Requires:      %{name}-smart_ptr-devel = %{version}-%{release}
486 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
487 Requires:       %{name}-ref-devel = %{version}-%{release}
488 Requires:       %{name}-type_traits-devel = %{version}-%{release}
489 Requires:       %{name}-utility-devel = %{version}-%{release}
490
491 %description signals-devel
492 Header files for boost::signals library.
493
494 %description signals-devel -l pl
495 Pliki nag³ówkowe dla biblioteki boost::signals.
496
497 %package signals-static
498 Summary:        Static library for boost::signals
499 Summary(pl):    Biblioteka statyczna dla boost::signals
500 Group:          Development/Libraries
501 Requires:       %{name}-signals-devel = %{version}-%{release}
502
503 %description signals-static
504 Static library for boost::signals.
505
506 %description signals-static -l pl
507 Biblioteka statyczna dla boost::signals.
508
509 %package static_assert-devel
510 Summary:        Static assertions (compile time assertions)
511 Summary(pl):    Statyczne asercje (asercje kompilacyjne)
512 Group:          Development/Libraries
513 Requires:       %{name}-devel = %{version}
514
515 %description static_assert-devel
516 The header <boost/static_assert.hpp> supplies a single macro
517 BOOST_STATIC_ASSERT(x), which generates a compile time error message
518 if the integral-constant-expression x is not true. In other words it
519 is the compile time equivalent of the assert macro; this is sometimes
520 known as a "compile-time-assertion"
521
522 One of the aims of BOOST_STATIC_ASSERT is to generate readable error
523 messages. These immediately tell the user that a library is being used
524 in a manner that is not supported.
525
526 %description static_assert-devel -l pl
527 Plik nag³ówkowy <boost/static_assert.hpp> dostarcza pojedyncze makro
528 BOOST_STATIC_ASSERT(x), które generuje komunikat b³êdu kompilacji
529 je¿eli sta³e wyra¿enie x nie jest prawdziwe. Innymi s³owy jest to
530 kompilacyjny ekwiwalent makra 'assert'; czasami znane jest jako
531 "asercja czasu kompilacji"
532
533 Jednym z celów BOOST_STATIC_ASSERT jest generowanie czytelnych
534 komunikatów o b³êdach. One b³yskawicznie powiedz± u¿ytkownikowi ¿e
535 biblioteka zosta³a u¿yta w sposób który nie jest zalecany.
536
537 %package test
538 Summary:        Support for program testing and  execution monitoring
539 Summary(pl):    Wsparcie dla testowania i monitorowania programu
540 Group:          Libraries
541
542 %description test
543 Support for simple program testing, full unit testing, and for program
544 execution monitoring.
545
546 %description test -l pl
547 Wsparcie dla prostego testowania programu, pe³nego testowania i
548 monitorowania wykonania programu.
549
550 %package test-devel
551 Summary:        Header files for boost::test
552 Summary(pl):    Pliki nag³ówkowe dla boost::test
553 Group:          Development/Libraries
554 Requires:       %{name}-devel = %{version}-%{release}
555 Requires:       %{name}-mpl-devel = %{version}-%{release}
556 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
557 Requires:       %{name}-test = %{version}-%{release}
558 #TODO:
559 #Requires:      %{name}-smart_ptr = %{version}-%{release}
560 #?Requires?:    %{name}-function-devel = %{version}-%{release}
561
562 %description test-devel
563 Header files for boost::test.
564
565 %description test-devel -l pl
566 Pliki nag³ówkowe dla boost::test
567
568 %package test-static
569 Summary:        Static libraries for boost::test
570 Summary(pl):    Biblioteki statyczne dla boost::test
571 Group:          Development/Libraries
572 Requires:       %{name}-test-devel = %{version}-%{release}
573
574 %description test-static
575 Static libraries for boost::test.
576
577 %description test-static -l pl
578 Biblioteki statyczne dla boost::test.
579
580 %package thread
581 Summary:        Portable C++ threads library
582 Summary(pl):    Przeno¶na biblioteka w±tków C++
583 Group:          Libraries
584
585 %description thread
586 Portable C++ threads library - shared library.
587
588 %description thread -l pl
589 Przeno¶na biblioteka w±tków dla C++ - biblioteka dzielona.
590
591 %package thread-devel
592 Summary:        Header files for boost::thread library
593 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::thread
594 Group:          Development/Libraries
595 Requires:       %{name}-thread = %{version}-%{release}
596 Requires:       %{name}-utility-devel = %{version}-%{release}
597 #TODO:requires boost::function or boost::function to boost-devel
598
599 %description thread-devel
600 Header files for boost::thread library.
601
602 %description thread-devel -l pl
603 Pliki nag³ówkowe dla biblioteki boost::thread.
604
605 %package type_traits-devel
606 Summary:        Templates for fundamental properties of types
607 Summary(pl):    Wzorce dla fundamentalnych w³a¶ciwo¶ci typów
608 Group:          Development/Libraries
609 Requires:       %{name}-devel = %{version}-%{release}
610 Requires:       %{name}-mpl-devel = %{version}-%{release}
611 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
612 Requires:       %{name}-static_assert-devel = %{version}-%{release}
613 Requires:       %{name}-utility-devel = %{version}-%{release}
614
615 %description type_traits-devel
616 The boost-type_traits library defines three kinds of type trait:
617  1. The properties of a specific type.
618  2. The relationship between two types.
619  3. A transformation from one type to another.
620
621 %description type_traits-devel -l pl
622 Biblioteka boost-type_traits definiuje trzy rodzaje cech typów:
623  1. w³a¶ciwo¶ci konkretnego typu.
624  2. powi±zania miêdzy dwoma typami.
625  3. transformacjê z jednego typu do drugiego.
626
627 %package utility-devel
628 Summary:        Useful utilities: classes and function templates
629 Summary(pl):    U¿yteczne narzêdzia: klasy i wzorce funkcji
630 Group:          Development/Libraries
631 Requires:       %{name}-type_traits-devel = %{version}
632
633 %description utility-devel
634 Class noncopyable plus checked_delete(), checked_array_delete(),
635 next(), prior() function templates, plus base-from-member idiom.
636
637 %description utility-devel -l pl
638 Klasy noncopyable i checked_delete, funkcje checked_array_delete(),
639 next(), prior() oraz idiom base-from-member.
640
641 %package doc
642 Summary:        Boost C++ Library documentation
643 Summary(pl):    Dokumentacja dla biblioteki Boost C++
644 Group:          Documentation
645 Requires:       %{name}-devel = %{version}-%{release}
646
647 %description doc
648 Documentation for the Boost C++ Library.
649
650 %description doc -l pl
651 Dokumentacja dla biblioteki Boost C++.
652
653 %prep
654 %setup -q -n %{name}_%{_fver}
655 %patch0 -p1
656
657 # don't know how to pass it through (b)jam -s (no way?)
658 # due to oversophisticated build flags system
659 %{__perl} -pi -e 's/ -O3 / %{rpmcflags} /' tools/build/v1/gcc-tools.jam
660
661 %build
662 %if %{with python}
663 PYTHON_VERSION=`python -V 2>&1 | sed 's,.* \([0-9]\.[0-9]\)\(\.[0-9]\)\?.*,\1,'`
664 PYTHON_ROOT=%{_prefix}
665 %else
666 PYTHON_ROOT=
667 PYTHON_VERSION=
668 %endif
669 bjam \
670         -d2 \
671         -sBUILD=release \
672         -sPYTHON_ROOT=$PYTHON_ROOT \
673         -sPYTHON_VERSION=$PYTHON_VERSION
674
675 %install
676 rm -rf $RPM_BUILD_ROOT
677 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
678
679 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
680
681 install bin/boost/libs/*/build/*.a/*/release/lib*.a $RPM_BUILD_ROOT%{_libdir}
682 install bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
683 # use cp -d, install follows symlinks instead of preserving them!
684 cp -df bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so $RPM_BUILD_ROOT%{_libdir}
685
686 # documentation
687 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
688 install README $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
689
690 # as the documentation doesn't completely reside in a directory of its
691 # own, we need to find out ourselves... this looks for HTML files and
692 # then collects everything linked from those.  this is certainly quite
693 # unoptimized wrt mkdir calls, but does it really matter?
694 for i in `find -type f -name '*.htm*'`; do
695         # bjam docu is included in the boost-jam RPM
696         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
697                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $i`
698                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
699                         sub rewrite_link
700                         {
701                                 my $link = shift;
702                                 # rewrite links from boost/* to %{_includedir}/boost/* and
703                                 # ignore external links as well as document-internal ones.
704                                 # HTML files are also ignored as they get installed anyway.
705                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
706                                 {
707                                         (my $file = $link) =~ s/\#.*//;
708                                         print "$file\n";
709                                 }
710                                 $link;
711                         }
712                         open IN, @ARGV[0];
713                         open OUT, ">@ARGV[1]";
714                         my $in_link;
715                         while (<IN>)
716                         {
717                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
718                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
719                                 print OUT;
720                                 $in_link = /href|src=\s*$/;
721                         }
722 EOT`; do
723                         TARGET=`dirname $i`/$LINKED
724                         # ignore non-existant linked files
725                         if test -f $TARGET; then
726                                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $TARGET`
727                                 install -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
728                         fi
729                 done
730         fi
731 done
732
733 %clean
734 rm -rf $RPM_BUILD_ROOT
735
736 %post   -p /sbin/ldconfig
737 %postun -p /sbin/ldconfig
738
739 %post   date_time -p /sbin/ldconfig
740 %postun date_time -p /sbin/ldconfig
741
742 %post   filesystem -p /sbin/ldconfig
743 %postun filesystem -p /sbin/ldconfig
744
745 %post   python  -p /sbin/ldconfig
746 %postun python  -p /sbin/ldconfig
747
748 %post   regex   -p /sbin/ldconfig
749 %postun regex   -p /sbin/ldconfig
750
751 %post   signals -p /sbin/ldconfig
752 %postun signals -p /sbin/ldconfig
753
754 %post   test    -p /sbin/ldconfig
755 %postun test    -p /sbin/ldconfig
756
757 %post   thread  -p /sbin/ldconfig
758 %postun thread  -p /sbin/ldconfig
759
760 %files devel
761 %defattr(644,root,root,755)
762 %dir %{_includedir}/boost
763 %{_includedir}/boost/assert.hpp
764 %{_includedir}/boost/blank_fwd.hpp
765 %{_includedir}/boost/config
766 %{_includedir}/boost/config.hpp
767 %{_includedir}/boost/cstd*.hpp
768 %{_includedir}/boost/current_function.hpp
769 %dir %{_includedir}/boost/detail
770 %{_includedir}/boost/detail/algorithm.hpp
771 %{_includedir}/boost/detail/allocator.hpp
772 %{_includedir}/boost/detail/atomic_count*.hpp
773 %{_includedir}/boost/detail/binary_search.hpp
774 %{_includedir}/boost/detail/catch_exceptions.hpp
775 %{_includedir}/boost/detail/dynamic_bitset.hpp
776 %{_includedir}/boost/detail/is_incrementable.hpp
777 %{_includedir}/boost/detail/iterator.hpp
778 %{_includedir}/boost/detail/lightweight_*.hpp
779 %{_includedir}/boost/detail/limits.hpp
780 %{_includedir}/boost/detail/lwm_*.hpp
781 %{_includedir}/boost/detail/named_template_params.hpp
782 %{_includedir}/boost/detail/numeric_traits.hpp
783 %{_includedir}/boost/detail/reference_content.hpp
784 %{_includedir}/boost/detail/quick_allocator.hpp
785 %{_includedir}/boost/detail/select_type.hpp
786 %{_includedir}/boost/detail/shared_*.hpp
787 %{_includedir}/boost/detail/workaround.hpp
788 %{_includedir}/boost/dynamic_bitset*.hpp
789 %{_includedir}/boost/enable_shared_from_this.hpp
790 %{_includedir}/boost/format
791 %{_includedir}/boost/format.hpp
792 %{_includedir}/boost/function
793 %{_includedir}/boost/function.hpp
794 %{_includedir}/boost/function_output_iterator.hpp
795 %{_includedir}/boost/functional.hpp
796 %{_includedir}/boost/generator_iterator.hpp
797 %{_includedir}/boost/graph
798 %{_includedir}/boost/half_open_range.hpp
799 %{_includedir}/boost/indirect_reference.hpp
800 %{_includedir}/boost/integer
801 %{_includedir}/boost/integer*.hpp
802 %{_includedir}/boost/intrusive_ptr.hpp
803 %{_includedir}/boost/io
804 %{_includedir}/boost/io_fwd.hpp
805 %{_includedir}/boost/iterator*.hpp
806 %{_includedir}/boost/iterator
807 %{_includedir}/boost/lambda
808 %{_includedir}/boost/limits.hpp
809 %{_includedir}/boost/math
810 %{_includedir}/boost/math_fwd.hpp
811 %{_includedir}/boost/multi_array
812 %{_includedir}/boost/multi_array.hpp
813 %{_includedir}/boost/nondet_random.hpp
814 %{_includedir}/boost/non_type.hpp
815 %{_includedir}/boost/numeric
816 %{_includedir}/boost/operators.hpp
817 %{_includedir}/boost/optional.hpp
818 %{_includedir}/boost/pending
819 %{_includedir}/boost/pool
820 %{_includedir}/boost/pointee.hpp
821 %{_includedir}/boost/progress.hpp
822 %{_includedir}/boost/property_map*.hpp
823 %{_includedir}/boost/random
824 %{_includedir}/boost/random.hpp
825 %{_includedir}/boost/rational.hpp
826 %{_includedir}/boost/scoped_*.hpp
827 %{_includedir}/boost/shared_*.hpp
828 %{_includedir}/boost/smart_ptr.hpp
829 %{_includedir}/boost/spirit
830 %{_includedir}/boost/spirit.hpp
831 %{_includedir}/boost/throw_exception.hpp
832 %{_includedir}/boost/timer.hpp
833 %{_includedir}/boost/token*.hpp
834 %{_includedir}/boost/tuple
835 %{_includedir}/boost/type.hpp
836 %{_includedir}/boost/utility
837 %{_includedir}/boost/version.hpp
838 %{_includedir}/boost/vector_property_map.hpp
839 %{_includedir}/boost/weak_ptr.hpp
840 #boost::variant
841 %{_includedir}/boost/variant.hpp
842 %{_includedir}/boost/variant
843 %{_includedir}/boost/blank.hpp
844 %{_includedir}/boost/detail/templated_streams.hpp
845 #boost::optional
846 %{_includedir}/boost/aligned_storage.hpp
847 %{_includedir}/boost/detail/in_place_factory*.hpp
848 %{_includedir}/boost/detail/none.hpp
849 %{_includedir}/boost/detail/none_t.hpp
850 %{_includedir}/boost/detail/typed_in_place_factory.hpp
851
852 %if %{with python}
853 %files python
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so.*.*.*
856
857 %files python-devel
858 %defattr(644,root,root,755)
859 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so
860 %{_includedir}/boost/python
861 %{_includedir}/boost/python.hpp
862
863 %files python-static
864 %defattr(644,root,root,755)
865 %{_libdir}/libboost_python-gcc-1_31.a
866 %endif
867
868 %files regex
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so.*.*.*
871
872 %files regex-devel
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so
875 %{_includedir}/boost/cregex.hpp
876 %{_includedir}/boost/regex.h
877 %{_includedir}/boost/regex*.hpp
878 %{_includedir}/boost/regex
879
880 %files regex-static
881 %defattr(644,root,root,755)
882 %{_libdir}/libboost_regex-gcc-1_31.a
883
884 %files any-devel
885 %defattr(644,root,root,755)
886 %{_includedir}/boost/any.hpp
887
888 %files array-devel
889 %defattr(644,root,root,755)
890 %{_includedir}/boost/array.hpp
891
892 %files bind-devel
893 %defattr(644,root,root,755)
894 %{_includedir}/boost/bind
895 %{_includedir}/boost/bind.hpp
896
897 %files call_traits-devel
898 %defattr(644,root,root,755)
899 %{_includedir}/boost/call_traits.hpp
900 %{_includedir}/boost/detail/call_traits.hpp
901 %{_includedir}/boost/detail/ob_call_traits.hpp
902
903 %files compatibility-devel
904 %defattr(644,root,root,755)
905 %{_includedir}/boost/compatibility
906
907 %files compose-devel
908 %defattr(644,root,root,755)
909 %{_includedir}/boost/compose.hpp
910
911 %files compressed_pair-devel
912 %defattr(644,root,root,755)
913 %{_includedir}/boost/compressed_pair.hpp
914 %{_includedir}/boost/detail/compressed_pair.hpp
915 %{_includedir}/boost/detail/ob_compressed_pair.hpp
916
917 %files concept_check-devel
918 %defattr(644,root,root,755)
919 %{_includedir}/boost/concept_archetype.hpp
920 %{_includedir}/boost/concept_check.hpp
921
922 %files conversion-devel
923 %defattr(644,root,root,755)
924 %{_includedir}/boost/cast.hpp
925 %{_includedir}/boost/implicit_cast.hpp
926 %{_includedir}/boost/lexical_cast.hpp
927
928 %files crc-devel
929 %defattr(644,root,root,755)
930 %{_includedir}/boost/crc.hpp
931
932 %files date_time
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so.*.*.*
935
936 %files date_time-devel
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so
939 %{_includedir}/boost/date_time
940
941 %files date_time-static
942 %defattr(644,root,root,755)
943 %{_libdir}/libboost_date_time-gcc-1_31.a
944
945 %files filesystem
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so.*.*.*
948
949 %files filesystem-devel
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so
952 %{_includedir}/boost/filesystem
953
954 %files filesystem-static
955 %defattr(644,root,root,755)
956 %{_libdir}/libboost_filesystem-gcc-1_31.a
957
958 %files mem_fn-devel
959 %defattr(644,root,root,755)
960 %{_includedir}/boost/get_pointer.hpp
961 %{_includedir}/boost/mem_fn.hpp
962
963 %files mpl-devel
964 %defattr(644,root,root,755)
965 %{_includedir}/boost/mpl
966
967 %files preprocessor-devel
968 %defattr(644,root,root,755)
969 %{_includedir}/boost/preprocessor
970 %{_includedir}/boost/preprocessor.hpp
971
972 %files ref-devel
973 %defattr(644,root,root,755)
974 %{_includedir}/boost/ref.hpp
975
976 %files signals
977 %defattr(644,root,root,755)
978 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so.*.*.*
979
980 %files signals-devel
981 %defattr(644,root,root,755)
982 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so
983 %{_includedir}/boost/signal*.hpp
984 %{_includedir}/boost/signals
985 %{_includedir}/boost/last_value.hpp
986 %{_includedir}/boost/visit_each.hpp
987
988 %files signals-static
989 %defattr(644,root,root,755)
990 %{_libdir}/libboost_signals-gcc-1_31.a
991
992 %files static_assert-devel
993 %defattr(644,root,root,755)
994 %{_includedir}/boost/static_assert.hpp
995
996 %files test
997 %defattr(644,root,root,755)
998 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so.*.*.*
999 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so.*.*.*
1000 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so.*.*.*
1001
1002 %files test-devel
1003 %defattr(644,root,root,755)
1004 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so
1005 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so
1006 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so
1007 %{_includedir}/boost/test
1008
1009 %files test-static
1010 %defattr(644,root,root,755)
1011 %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.a
1012 %{_libdir}/libboost_test_exec_monitor-gcc-1_31.a
1013 %{_libdir}/libboost_unit_test_framework-gcc-1_31.a
1014
1015 %files thread
1016 %defattr(644,root,root,755)
1017 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so.*.*.*
1018
1019 %files thread-devel
1020 %defattr(644,root,root,755)
1021 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so
1022 %{_includedir}/boost/thread
1023 %{_includedir}/boost/thread.hpp
1024
1025 %files type_traits-devel
1026 %defattr(644,root,root,755)
1027 %{_includedir}/boost/type_traits.hpp
1028 %{_includedir}/boost/type_traits
1029
1030 %files utility-devel
1031 %defattr(644,root,root,755)
1032 %{_includedir}/boost/checked_delete.hpp
1033 %{_includedir}/boost/next_prior.hpp
1034 %{_includedir}/boost/noncopyable.hpp
1035 %{_includedir}/boost/utility*.hpp
1036 %{_includedir}/boost/utility
1037
1038 %files doc
1039 %defattr(644,root,root,755)
1040 %{_docdir}/boost-%{version}
This page took 0.186228 seconds and 3 git commands to generate.