]> git.pld-linux.org Git - packages/bogofilter.git/blob - bogofilter.spec
- use docdir macro
[packages/bogofilter.git] / bogofilter.spec
1 Summary:        Bayesian Spam Filter
2 Summary(pl):    Bayesowski Filtr Antyspamowy
3 Name:           bogofilter
4 Version:        1.0.0
5 Release:        2
6 License:        GPL v2
7 Vendor:         Eric S. Raymond <esr@thyrsus.com>
8 Group:          Applications/Mail
9 Source0:        http://dl.sourceforge.net/bogofilter/%{name}-%{version}.tar.gz
10 # Source0-md5:  1f3bff28f7d9cb7b0c3a28184c101b53
11 Patch0:         %{name}-home_etc.patch
12 Patch1:         %{name}-dummy.patch
13 URL:            http://bogofilter.sourceforge.net/
14 BuildRequires:  autoconf >= 2.53
15 BuildRequires:  automake
16 BuildRequires:  db-devel
17 BuildRequires:  flex
18 BuildRequires:  gsl-devel
19 BuildRequires:  judy-devel
20 Requires:       gsl >= 1.4
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         specflags_ia32  -fomit-frame-pointer
24
25 %description
26 Bogofilter is a Bayesian spam filter. In its normal mode of operation,
27 it takes an email message or other text on standard input, does a
28 statistical check against lists of "good" and "bad" words, and returns
29 a status code indicating whether or not the message is spam.
30 Bogofilter is designed with fast algorithms (including Berkeley DB
31 system), coded directly in C, and tuned for speed, so it can be used
32 for production by sites that process a lot of mail.
33
34 %description -l pl
35 Bogofilter jest bayesowski filtrem antyspamowym. W podstawowym trybie
36 dzia³ania na emailu lub innym tek¶cie odczytanym na wej¶ciu wykonuje
37 statystyczne testy na wystêpowanie "dobrych" i "z³ych" s³ów i zwraca
38 kod powrotu wskazuj±cy czy wiadomo¶æ jest spamem, czy te¿ nie.
39 Bogofilter jest zaprojektowany z u¿yciem szybkich algorytmów
40 (w³±czaj±c w to Berkeley DB), napisany w czystym C i "podkrêcony" pod
41 k±tem szybko¶ci, a wiêc mo¿e byæ u¿ywany na systemach "produkcyjnych",
42 które przetwarzaj± du¿e ilo¶ci poczty.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 %{__aclocal}
51 %{__autoconf}
52 %{__autoheader}
53 %{__automake}
54 %configure
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf.example $RPM_BUILD_ROOT%{_sysconfdir}/bogofilter.cf
64
65 rm -f $RPM_BUILD_ROOT%{_bindir}/lexertest
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %banner %{name} -e <<'EOF'
72
73 WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING
74 ------------------------------------------------------------------------
75 POTENTIAL FOR DATA CORRUPTION DURING UPDATES
76
77 If you plan to upgrade your database library, if only as a side effect
78 of an operating system upgrade, DO HEED the relevant documentation, for
79 instance, the %{_docdir}/%{name}-%{version}/README.db file.
80 You may need to prepare the upgrade with the old version of the software.
81
82 Otherwise, you may cause irrecoverable damage to your databases.
83
84 DO backup your databases before making the upgrade.
85 ------------------------------------------------------------------------
86 WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING
87
88 EOF
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS GETTING.STARTED RELEASE* NEWS README doc/README.db TODO
93 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/bogofilter.cf
94 %attr(755,root,root) %{_bindir}/*
95 %attr(644,root,root) %{_mandir}/man1/*
This page took 0.041966 seconds and 4 git commands to generate.