]> git.pld-linux.org Git - packages/bogl.git/blob - bogl.spec
993c323c1d196a3abd2faeb231b629d3ab0a8390
[packages/bogl.git] / bogl.spec
1 # TODO
2 # - optflags
3 Summary:        A terminal program for displaying Unicode on the console
4 Summary(pl.UTF-8):      Program terminalowy do wyświetlania Unikodu na konsoli
5 Name:           bogl
6 Version:        0.1.18
7 Release:        7
8 Epoch:          0
9 License:        GPL
10 Group:          Libraries
11 Source0:        %{name}_%{version}-1.tar.gz
12 # Source0-md5:  9658700ed196eb1789c12aca0a095cb5
13 Source1:        wlite-0.8.1.tar.gz
14 # Source1-md5:  03a2faa33978e88ea2b9ff4679b8f2df
15 Source2:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz
16 # Source2-md5:  cca6a3cb6cfbde5f3ebb24278a9022a4
17 Source3:        http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts-asian.tar.gz
18 # Source3-md5:  d3184f182c6eebfcf156d08a65696496
19 Source4:        14x14cjk.bdf.gz
20 # Source4-md5:  c08ab351a43a91632127f509aadc6797
21 Patch0:         %{name}-0.1.18-rh.patch
22 Patch1:         %{name}-0.1.9-fpic.patch
23 Patch3:         %{name}-0.1.9-2.6fbdev.patch
24 Patch4:         %{name}-0.1.18-gcc.patch
25 Patch5:         %{name}-0.1.18-noexecstack.patch
26 Patch6:         %{name}-page_mask.patch
27 URL:            http://www.stanford.edu/~blp/projects.html
28 BuildRequires:  gd-devel
29 BuildRequires:  libpng-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 BOGL stands for Ben's Own Graphics Library. It is a small graphics
34 library for Linux kernel framebuffers. It supports only very simple
35 graphics.
36
37 %description -l pl.UTF-8
38 BOGL oznacza Ben's Own Graphics Library (bibliotekę graficzną Bena).
39 Jest to mała biblioteka dla framebufferów jądra Linuksa. Obsługuje
40 tylko bardzo prostą grafikę.
41
42 %package devel
43 Summary:        Development files required to build BOGL applications
44 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania aplikacji BOGL
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47
48 %description devel
49 The bogl-devel package contains the header files for writing BOGL
50 applications.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera pliki nagłówkowe do pisania aplikacji BOGL.
54
55 %package static
56 Summary:        Static BOGL libraries
57 Summary(pl.UTF-8):      Statyczne biblioteki BOGL
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
60
61 %description static
62 Static BOGL libraries.
63
64 %description static -l pl.UTF-8
65 Statyczne biblioteki BOGL.
66
67 %package bterm
68 Summary:        A Unicode capable terminal program for the Linux framebuffer
69 Summary(pl.UTF-8):      Obsługujący Unikod program terminalowy dla linuksowego framebuffera
70 Group:          Applications/System
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72
73 %description bterm
74 The bterm application is a terminal emulator that displays to a Linux
75 framebuffer. It is able to display Unicode text on the console.
76
77 %description bterm -l pl.UTF-8
78 Aplikacja bterm to emulator terminala wyświetlający obraz na
79 linuksowym framebufferze. Potrafi wyświetlać tekst unikodowy na
80 konsoli.
81
82 %prep
83 %setup -q -n %{name} -a 1
84 %patch0 -p1
85 %patch1 -p1
86 %patch3 -p1
87 %patch4 -p1
88 %patch5 -p1
89 %patch6 -p1
90
91 mkdir -p fonts
92 cd fonts
93 tar zxf %{SOURCE2}
94 tar zxf %{SOURCE3}
95
96 %build
97 %{__make} -j1 \
98         CFLAGS="%{rpmcflags}"
99 #./mergebdf fonts/9x18.bdf fonts/18x18ja.bdf > font.bdf
100 gunzip -c %{SOURCE4} > font.bdf
101 ./bdftobogl -b font.bdf > font.bgf
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         libdir=%{_libdir}
109
110 %{__make} -C wlite install \
111         prefix=$RPM_BUILD_ROOT%{_prefix} \
112         libdir=$RPM_BUILD_ROOT%{_libdir}
113
114 if [ -f wlite/libwlitediet.a ]; then
115         install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT%{_libdir}
116 fi
117 install -d $RPM_BUILD_ROOT%{_libdir}/bogl
118 install font.bgf $RPM_BUILD_ROOT%{_libdir}/bogl
119 install font.bdf $RPM_BUILD_ROOT%{_libdir}/bogl
120 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bdf
121 gzip -9n $RPM_BUILD_ROOT%{_libdir}/bogl/font.bgf
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc README
132 %attr(755,root,root) %{_libdir}/libbogl.so.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/bdftobogl
137 %attr(755,root,root) %{_bindir}/mergebdf
138 %attr(755,root,root) %{_bindir}/pngtobogl
139 %attr(755,root,root) %{_bindir}/reduce-font
140 %attr(755,root,root) %{_libdir}/libbogl.so
141 %{_libdir}/libbterm.a
142 %{_libdir}/libwlite.a
143 %{_includedir}/bogl
144 %{_includedir}/wlite*.h
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libbogl.a
149
150 %files bterm
151 %defattr(644,root,root,755)
152 %doc README.BOGL-bterm
153 %attr(755,root,root) %{_bindir}/bterm
154 # XXX: dir duplicated with terminfo package
155 %dir %{_datadir}/terminfo/b
156 %{_datadir}/terminfo/b/bterm
157 %{_libdir}/bogl
This page took 0.102395 seconds and 3 git commands to generate.