]> git.pld-linux.org Git - packages/bmon.git/blob - bmon.spec
- fix syntax errors (-gcc4.patch)
[packages/bmon.git] / bmon.spec
1
2 %define _pre    pre1
3 %define _sysconfdir     /etc/%{name}
4 Summary:        Console interface bandwidth usage monitor
5 Summary(pl.UTF-8):      Konsolowy monitor użycia interfejsu sieciowego
6 Name:           bmon
7 Version:        2.2.0
8 Release:        0.%{_pre}.5
9 License:        Artistic
10 Group:          Applications/Networking
11 Source0:        http://people.suug.ch/~tgr/bmon/files/%{name}-%{version}-%{_pre}.tar.gz
12 # Source0-md5:  f4ec66927751027f855886f3dc45c218
13 Patch0:         %{name}-gcc4.patch
14 Patch1:         %{name}-no-libnl.patch
15 URL:            http://people.suug.ch/~tgr/bmon/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gettext-devel
19 BuildRequires:  libdbi-devel
20 BuildRequires:  ncurses-devel
21 BuildRequires:  postgresql-devel
22 BuildRequires:  rrdtool-devel >= 1.2.10
23 Conflicts:      nstats
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 bmon is an interface bandwidth monitor.
28
29 It is able to generate and draw three types of diagrams:
30 - The overview diagram which is a list of all interfaces and their
31   send/receive rates.
32 - A very MRTG like graphical diagram in ASCII showing the rate over a
33   specific time period in a bar diagram.
34 - The details diagram which contains all counters of an interface such
35   as total bytes sent/received, errors, compressed packets, ...
36
37 %description -l pl.UTF-8
38 bmon jest monitorem ruchu na interfejsach sieciowych.
39
40 Pozwala on na generowanie i rysowanie trzech typów diagramów:
41 - Diagram ogólny który wyświetla wszystkie interfejsy sieciowe i
42   informacje o aktualnym zużyciu przepustowości
43 - Diagram ASCII podobny do generowanego przez MRTG, pokazujący
44   informacje o przesyle danych w postaci wykresu paskowego
45 - Diagram szczegółowy który zawiera wszystkie liczniki danego
46   interfejsu, takie jak całkowita liczba bajtów odebranych/wysłanych,
47   błędy, skompresowane pakiety...
48
49 %package devel
50 Summary:        Header files for bmon
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla bmon
52 Group:          Development/Libraries
53
54 %description devel
55 Header files neccesary to develop bmon applications.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe niezbędne do tworzenia aplikacji korzystających z
59 bmon.
60
61 %prep
62 %setup -q -n %{name}-%{version}-%{_pre}
63 %patch0 -p1
64 %patch1 -p1
65
66 %build
67 cp -f /usr/share/automake/config.sub .
68 %{__gettextize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %configure
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_sysconfdir}
78 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}
79 cp -r etc/* $RPM_BUILD_ROOT%{_sysconfdir}
80 install include/%{name}/* $RPM_BUILD_ROOT%{_includedir}/%{name}/
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc ChangeLog
91 %attr(755,root,root) %{_bindir}/*
92 %dir %{_sysconfdir}
93 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
94 %{_mandir}/man1/*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_includedir}/*
This page took 0.058469 seconds and 3 git commands to generate.