]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
a87bf3116e274b165988835bb16c8f7ed0ef19e8
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 # - DRACO (requires WITH_PYTHON_INSTALL?)
5 # - OSL, Cycles
6 # - Alembic
7 # - USD
8 # - OpenImageDenoise
9 # - OpenSubdiv
10 # - XR_OpenXR_SDK
11 # - OptiX >= 7.3.0
12 #
13 # Conditional build:
14 %bcond_with     openvdb # OpenVDB support (3.1.x is not ready for openvdb 10)
15
16 Summary:        3D modeling, rendering, animation and game creation package
17 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
18 Name:           blender
19 Version:        3.2.2
20 Release:        1
21 License:        GPL v2+
22 Group:          X11/Applications/Graphics
23 Source0:        https://download.blender.org/source/%{name}-%{version}.tar.xz
24 # Source0-md5:  245de23f60dddc2b7be09142bcd3fbbf
25 Patch0:         %{name}-2.76-droid.patch
26 Patch1:         format-security.patch
27 Patch2:         boost1.81.patch
28 Patch3:         gcc13.patch
29 URL:            https://www.blender.org/
30 BuildRequires:  OpenAL-devel
31 BuildRequires:  OpenCOLLADA-devel
32 BuildRequires:  OpenColorIO-devel >= 2.0.0
33 BuildRequires:  OpenEXR-devel
34 BuildRequires:  OpenGL-devel
35 BuildRequires:  OpenGL-GLU-devel
36 BuildRequires:  OpenImageIO-devel
37 BuildRequires:  SDL2-devel
38 BuildRequires:  boost-devel
39 BuildRequires:  cmake >= 3.10
40 BuildRequires:  embree-devel >= 3.8.0
41 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
42 BuildRequires:  fftw3-devel >= 3
43 BuildRequires:  freealut-devel
44 BuildRequires:  freetype-devel >= 2
45 BuildRequires:  ftgl-devel
46 BuildRequires:  gcc >= 5:3.4.0
47 BuildRequires:  gettext-tools
48 BuildRequires:  glew-devel
49 BuildRequires:  gmp-devel
50 BuildRequires:  jack-audio-connection-kit-devel
51 BuildRequires:  jemalloc-devel
52 BuildRequires:  libgomp-devel
53 BuildRequires:  libharu-devel
54 BuildRequires:  libjpeg-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libsndfile-devel
57 BuildRequires:  libspnav-devel
58 BuildRequires:  libstdc++-devel
59 BuildRequires:  libtiff-devel
60 BuildRequires:  libvorbis-devel
61 BuildRequires:  libwebp-devel
62 BuildRequires:  libxml2-devel >= 2.0
63 BuildRequires:  openjpeg2-devel
64 %{?with_openvdb:BuildRequires:  openvdb-devel}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 BuildRequires:  pcre-devel
67 BuildRequires:  potrace-devel
68 BuildRequires:  pugixml-devel
69 BuildRequires:  pulseaudio-devel
70 BuildRequires:  python3 >= 1:3.10
71 BuildRequires:  python3-devel >= 1:3.10
72 BuildRequires:  python3-numpy-devel
73 BuildRequires:  rpm-pythonprov
74 BuildRequires:  rpmbuild(macros) >= 1.605
75 BuildRequires:  sed >= 4.0
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  tbb-devel
78 BuildRequires:  xorg-lib-libX11-devel
79 BuildRequires:  xorg-lib-libXi-devel
80 BuildRequires:  xz
81 BuildRequires:  zlib-devel
82 BuildRequires:  zstd-devel
83 Requires(post,postun):  desktop-file-utils
84 Requires:       OpenGL
85 Requires:       freetype
86 Requires:       python3-modules >= 1:3.10
87 ExclusiveArch:  %{x8664}
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
91
92 %description
93 Blender is a free and fully functional 3D modeling, rendering,
94 animation and game creation package for Unix, Windows and BeOS
95 systems.
96
97 %description -l pl.UTF-8
98 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
99 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107
108 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
109       release/scripts/addons/io_curve_svg/svg_util_test.py \
110       release/scripts/addons/io_scene_fbx/fbx2json.py \
111       release/scripts/addons/io_scene_fbx/json2fbx.py \
112       release/scripts/addons/sun_position/geo.py \
113       release/scripts/modules/bl_i18n_utils/merge_po.py \
114       release/scripts/modules/bl_i18n_utils/utils_rtl.py \
115       release/scripts/modules/blend_render_info.py
116
117 %build
118 install -d build
119 cd build
120 %cmake \
121         -DBOOST_ROOT=%{_prefix} \
122         -DBUILD_SHARED_LIBS:BOOL=OFF \
123         -DCMAKE_SKIP_RPATH:BOOL=ON \
124         -DPYTHON_VERSION:STRING=%{py3_ver} \
125         -DWITH_CODEC_FFMPEG:BOOL=ON \
126         -DWITH_CODEC_SNDFILE:BOOL=ON \
127         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
128         -DWITH_CYCLES:BOOL=ON \
129         -DWITH_FFTW3:BOOL=ON \
130         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
131         -DWITH_INPUT_NDOF:BOOL=ON \
132         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
133         -DWITH_JACK:BOOL=ON \
134         -DWITH_JACK_DYNLOAD:BOOL=ON \
135         -DWITH_MEM_JEMALLOC:BOOL=ON \
136         -DWITH_MOD_OCEANSIM:BOOL=ON \
137         -DWITH_OPENCOLLADA:BOOL=ON \
138         -DWITH_OPENCOLORIO:BOOL=ON \
139         %{!?with_openvdb:-DWITH_OPENVDB:BOOL=OFF} \
140         -DWITH_PYTHON:BOOL=ON \
141         -DWITH_PYTHON_INSTALL:BOOL=OFF \
142         -DWITH_PYTHON_SAFETY:BOOL=ON \
143         -DWITH_SDL:BOOL=ON \
144         -DWITH_SDL_DYNLOAD:BOOL=ON \
145         -DWITH_SYSTEM_GLEW:BOOL=ON \
146         ..
147
148 %{__make} V=1
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
153
154 %{__make} -C build install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 ./doc/manpage/blender.1.py \
158         --blender $RPM_BUILD_ROOT%{_bindir}/blender \
159         --output $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
160
161 #%find_lang %{name}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 %update_desktop_database_post
168
169 %postun
170 %update_desktop_database_postun
171
172 %files
173 %defattr(644,root,root,755)
174 # -f %{name}.lang
175 %doc doc/license/bf-members.txt doc/guides/*.txt
176 %attr(755,root,root) %{_bindir}/blender
177 %attr(755,root,root) %{_bindir}/blender-thumbnailer
178 %attr(755,root,root) %{_datadir}/%{name}
179 %{_desktopdir}/*.desktop
180 %{_iconsdir}/hicolor/scalable/apps/blender.svg
181 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
182 %{_mandir}/man1/*
This page took 0.07123 seconds and 2 git commands to generate.