]> git.pld-linux.org Git - packages/bitlbee.git/blob - bitlbee.spec
81f8ca6ce30f70fd22c90df12edef75d0ee96d6f
[packages/bitlbee.git] / bitlbee.spec
1 # TODO
2 # - sync pl
3 #
4 # Conditional build:
5 %bcond_without  otr             # build without OTR
6 %bcond_with             purple  # build with libpurple (not recommended for public servers). http://wiki.bitlbee.org/HowtoPurple
7
8 Summary:        An IRC to other chat networks gateway
9 Summary(pl.UTF-8):      Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
10 Name:           bitlbee
11 Version:        3.0.5
12 Release:        2
13 License:        GPL v2+ and MIT
14 Group:          Daemons
15 Source0:        http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  9ff97260a2a7f3a7d102db158a8d9887
17 URL:            http://www.bitlbee.org/
18 Patch0:         config.patch
19 Patch1:         systemd.patch
20 Patch2:         skyped-FD_CLOEXEC.patch
21 Patch3:         skype-no-groups.patch
22 BuildRequires:  asciidoc
23 BuildRequires:  gnutls-devel
24 %{?with_otr:BuildRequires:      libotr-devel >= 3.2.0}
25 %{?with_purple:BuildRequires:   libpurple-devel}
26 BuildRequires:  rpmbuild(macros) >= 1.461
27 BuildRequires:  systemd-units
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(postun):       /usr/sbin/userdel
30 Requires(pre):  /bin/id
31 Requires(pre):  /usr/bin/getgid
32 Requires(pre):  /usr/sbin/groupadd
33 Requires(pre):  /usr/sbin/useradd
34 Requires(post,preun,postun):    systemd-units >= 38
35 Requires:       systemd-units >= 38
36 Provides:       group(bitlbee)
37 Provides:       user(bitlbee)
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
42 as an IRC server which forwards everything you say to people on other
43 chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
44 Yahoo or Twitter!
45
46 %description -l pl.UTF-8
47 Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
48 może być używany jako serwer IRC przekazujący wszystko co się mówi do
49 ludzi korzystających z innych sieci komunikacyjnych, takich jak
50 MSN/ICQ/Jabber.
51
52 %package devel
53 Summary:        Development files for bitlbee
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description devel
58 The bitlbee-devel package includes header files necessary for building
59 and developing programs and plugins which use bitlbee.
60
61 %package otr
62 Summary:        OTR plugin for bitlbee
63 Group:          Daemons
64 Requires:       %{name} = %{version}-%{release}
65
66 %description otr
67 The bitlbee-otr package includes OTR plugin for bitlbee. Not
68 completely stable and not 100% foolproof so use at your own risk.
69
70 %package protocol-skype
71 Summary:        Skype protocol support for bitlbee
72 Group:          Daemons
73 Requires:       %{name} = %{version}-%{release}
74 Suggests:       skyped
75
76 %description protocol-skype
77 Skype protocol support for bitlbee.
78
79 %package -n skyped
80 Summary:        Remote control of the Skype GUI client
81 Group:          Daemons
82 Requires:       python-skype
83
84 %description -n skyped
85 Skype supports remote control of the GUI client only via X11 or DBus
86 messages. This is hard in care you want remote control. This daemon
87 listens on a TCP port and runs on the same machine where the GUI
88 client runs. It passes all the input it gets to Skype directly, except
89 for a few commands which is related to authentication. The whole
90 communication is done via SSL.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 # fix wrong assumption with $DESTDIR
100 %{__sed} -i -e 's,$(shell id -u),0,' Makefile
101
102 # fix #!%{_bindir}/env python -> #!%{__python}:
103 %{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
104
105 # fix config path
106 %{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
107
108 %build
109 CFLAGS="%{rpmcflags}" \
110 ./configure \
111         --prefix=%{_prefix} \
112         --bindir=%{_sbindir} \
113         --etcdir=%{_sysconfdir}/%{name} \
114         --mandir=%{_mandir} \
115         --datadir=%{_datadir}/%{name} \
116         --config=%{_localstatedir}/lib/%{name} \
117         --pcdir=%{_pkgconfigdir} \
118         --plugindir=%{_libdir}/%{name} \
119         --strip=0 \
120         --plugins=1 \
121         --ssl=gnutls \
122 %if %{with purple}
123         --purple=1 \
124 %endif
125 %if %{with otr}
126         --otr=plugin \
127 %endif
128         --skype=plugin \
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
135 %{__make} install install-dev install-etc install-systemd \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %pre
142 %groupadd -g 280 bitlbee
143 %useradd -u 280 -d /var/lib/bitlbee -g bitlbee -c "Bitlbee User" bitlbee
144 %systemd_post bitlbee.service
145
146 %preun
147 %systemd_preun bitlbee.service
148
149 %postun
150 if [ "$1" = "0" ]; then
151         %userremove bitlbee
152         %groupremove bitlbee
153 fi
154 %systemd_reload
155
156 %files
157 %defattr(644,root,root,755)
158 %doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README} utils
159 %dir %attr(750,root,bitlbee) %{_sysconfdir}/%{name}
160 %attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
161 %attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
162 %attr(755,root,root) %{_sbindir}/bitlbee
163 %{_mandir}/man5/bitlbee.conf.5*
164 %{_mandir}/man8/bitlbee.8*
165 %{_datadir}/bitlbee
166 %dir %{_libdir}/%{name}
167 %attr(770,root,bitlbee) %{_localstatedir}/lib/bitlbee
168 %{systemdunitdir}/bitlbee.service
169 %{systemdunitdir}/bitlbee.socket
170 %{systemdunitdir}/bitlbee@.service
171
172 %files devel
173 %defattr(644,root,root,755)
174 %doc doc/example_plugin.c
175 %{_includedir}/%{name}
176 %{_pkgconfigdir}/%{name}.pc
177
178 %if %{with otr}
179 %files otr
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/%{name}/otr.so
182 %endif
183
184 %files protocol-skype
185 %defattr(644,root,root,755)
186 %doc protocols/skype/{HACKING,NEWS,README}
187 %attr(755,root,root) %{_libdir}/%{name}/skype.so
188
189 %files -n skyped
190 %defattr(644,root,root,755)
191 %doc protocols/skype/{skyped.txt,client.sh}
192 %dir %{_sysconfdir}/skyped
193 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
194 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
195 %attr(755,root,root) %{_sbindir}/skyped
196 %{_mandir}/man1/skyped.1*
This page took 0.061147 seconds and 3 git commands to generate.