]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- added libdir patch (suffix-aware bfd-plugins dir; at the cost of relative plugins...
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 %bcond_without  gold            # don't build gold (no C++ dependencies)
8 %bcond_without  default_bfd     # default ld.bfd instead of gold
9 %bcond_without  gasp            # gasp
10 %bcond_with     tests
11
12 %ifnarch %{ix86} %{x8664} x32
13 %undefine       with_gold
14 %endif
15
16 Summary:        GNU Binary Utility Development Utilities
17 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
18 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
19 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
20 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
21 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
22 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
23 Summary(tr.UTF-8):      GNU geliştirme araçları
24 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
25 Name:           binutils
26 Version:        2.25.51.0.1
27 Release:        1
28 Epoch:          3
29 License:        GPL v3+
30 Group:          Development/Tools
31 # Source0:      https://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.xz
32
33 # release with no tarball - https://sourceware.org/git/?p=binutils-gdb.git;a=summary
34 Source0:        %{name}-%{version}.tar.xz
35 # Source0-md5:  4d3bd9694a1c9c318e7afe6db4a23b69
36
37 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
38 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
39 Patch0:         %{name}-gasp.patch
40 Patch1:         %{name}-info.patch
41 Patch2:         %{name}-libtool-relink.patch
42 Patch3:         %{name}-pt_pax_flags.patch
43 Patch4:         %{name}-libdir.patch
44 Patch5:         %{name}-discarded.patch
45 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
46 Patch7:         %{name}-libtool-m.patch
47 Patch8:         %{name}-build-id.patch
48 Patch9:         %{name}-tooldir.patch
49 Patch10:        %{name}-sanity-check.patch
50 Patch11:        %{name}-am.patch
51 URL:            http://sources.redhat.com/binutils/
52 BuildRequires:  autoconf >= 2.64
53 BuildRequires:  automake >= 1:1.11
54 BuildRequires:  bison
55 BuildRequires:  flex
56 BuildRequires:  gettext-tools
57 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
58 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
59 BuildRequires:  perl-tools-pod
60 %ifarch sparc sparc32
61 BuildRequires:  sparc32
62 %endif
63 BuildRequires:  tar >= 1:1.22
64 BuildRequires:  texinfo >= 4.2
65 BuildRequires:  xz
66 BuildRequires:  zlib-devel
67 %{?with_tests:BuildRequires:    zlib-static}
68 Conflicts:      gcc-c++ < 5:3.3
69 Conflicts:      modutils < 2.4.17
70 Conflicts:      rpmbuild(macros) < 1.660
71 Obsoletes:      binutils-gold
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Binutils is a collection of binary utilities, including:
76 - ar - create, modify and extract from archives,
77 - nm - lists symbols from object files,
78 - objcopy - copy and translate object files,
79 - objdump - display information from object files,
80 - ranlib - generate an index for the contents of an archive,
81 - size - list the section sizes of an object or archive file,
82 - strings - list printable strings from files,
83 - strip - discard symbols,
84 - addr2line - convert addresses to file and line,
85 - nlmconv - convert object code into an NLM.
86
87 %description -l es.UTF-8
88 Binutils es una colección de utilitarios necesarios para compilar
89 programas. Incluye assembler y linker, así como varios otros programas
90 para trabajar con formatos que se puedan ejecutar.
91
92 %description -l pl.UTF-8
93 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
94 programów. Znajdują się tutaj między innymi assembler, konsolidator
95 (linker), a także inne narzędzia do manipulowania binarnymi plikami
96 programów i bibliotek.
97
98 %description -l pt_BR.UTF-8
99 binutils é uma coletânea de utilitários necessários para compilar
100 programas. Inclui assembler e linker, assim como vários outros
101 programas para trabalhar com formatos executáveis.
102
103 %description -l ru.UTF-8
104 binutils - это набор инструментов, необходимых для компилляции
105 программ. Включает ассемблер, компоновщик и набор других программ для
106 работы с исполняемыми файлами разнообразных форматов.
107
108 %description -l uk.UTF-8
109 binutils - це набір інструментів, необхідних для компіляції програм.
110 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
111 виконуваними файлами різних форматів.
112
113 %package libs
114 Summary:        GNU binutils shared libraries
115 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
116 Group:          Libraries
117 Conflicts:      binutils < 3:2.17.50.0.8-3
118
119 %description libs
120 GNU binutils shared libraries (libbfd, libopcodes).
121
122 %description libs -l pl.UTF-8
123 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
124
125 %package devel
126 Summary:        Development files for GNU binutils libraries
127 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
128 Group:          Development/Libraries
129 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
130
131 %description devel
132 Development files for GNU binutils libraries (libbfd, libopcodes) and
133 static libiberty library.
134
135 %description devel -l pl.UTF-8
136 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
137 statyczna biblioteka libiberty.
138
139 %package static
140 Summary:        GNU binutils static libraries
141 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
142 Group:          Development/Libraries
143 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
144 #Requires:      zlib-static
145
146 %description static
147 Static GNU binutils libraries (libbfd, libopcodes).
148
149 %description static -l pl.UTF-8
150 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
151
152 %package gasp
153 Summary:        GASP - old preprocessor for assembly programs
154 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
155 Group:          Development/Tools
156 Requires:       %{name} = %{epoch}:%{version}-%{release}
157
158 %description gasp
159 GASP - old preprocessor for assembly programs. It's officially
160 obsoleted, but it's still needed to build some packages.
161
162 %description gasp -l pl.UTF-8
163 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
164 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
165 niektórych pakietów.
166
167 %prep
168 %setup -q
169 %{?with_gasp:%patch0 -p1}
170 %patch1 -p1
171 %patch2 -p1
172 %{?with_pax:%patch3 -p1}
173 %patch4 -p1
174 %patch5 -p1
175 %patch6 -p1
176 %patch7 -p1
177 %patch8 -p1
178 %patch9 -p1
179 %patch10 -p1
180 %patch11 -p1
181
182 # file contains hacks for ac 2.59 only
183 %{__rm} config/override.m4
184
185 %build
186 %{__aclocal}
187 %{__autoconf}
188
189 # non-standard regeneration (needed because of gasp patch)
190 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
191 for dir in gas bfd; do
192         cd $dir || exit 1
193         %{__aclocal} -I .. -I ../config -I ../bfd
194         %{__automake} Makefile
195         %{__automake} doc/Makefile
196         %{__autoconf}
197         cd ..
198 done
199
200 # More targets
201 TARGETS=
202 %ifarch ia64
203 TARGETS=i686-linux
204 %endif
205 # uhm?
206 %ifarch %{ix86}
207 TARGETS=x86_64-linux
208 %endif
209 %ifarch sparc
210 TARGETS=sparc64-linux
211 %endif
212 %ifarch %{x8664}
213 TARGETS="x86_64-pep"
214 %endif
215 %ifarch x32
216 TARGETS="x86_64-linux,x86_64-pep"
217 %endif
218 %{?addtargets:TARGETS="%{addtargets}"}
219
220 cp -f /usr/share/automake/config.* .
221 CFLAGS="%{rpmcflags}"; export CFLAGS
222 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
223 CC="%{__cc}"; export CC
224 CXX="%{__cxx}"; export CXX
225 %ifarch sparc
226 sparc32 \
227 %endif
228 ./configure %{_target_platform} \
229         --disable-debug \
230         --disable-werror \
231         --enable-build-warnings=,-Wno-missing-prototypes \
232         --enable-shared \
233         --enable-lto \
234         --enable-plugins \
235         --with-zlib=yes \
236         --prefix=%{_prefix} \
237         --libdir=%{_libdir} \
238         --infodir=%{_infodir} \
239         --mandir=%{_mandir} \
240         --with-tooldir=%{_prefix} \
241         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
242 %ifarch sparc
243         --enable-64-bit-bfd \
244 %else
245         %{?with_allarchs:--enable-64-bit-bfd} \
246 %endif
247         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
248 %if %{with gold}
249         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
250 %endif
251
252 %{__make} -j1
253
254 %{?with_tests:%{__make} -j1 check}
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258 install -d $RPM_BUILD_ROOT%{_libdir}/bfd-plugins
259
260 %{__make} install \
261         DESTDIR=$RPM_BUILD_ROOT
262
263 # remove these man pages unless we cross-build for win*/netware platforms.
264 # however, this should be done in Makefiles.
265 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windmc,windres}.1
266
267 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
268
269 cp -p include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
270 cp -p libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
271
272 # remove evil -L pointing inside builder's home
273 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
274
275 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
276
277 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
278
279 %find_lang bfd
280 %find_lang binutils
281 %find_lang gas
282 %find_lang gprof
283 touch ld.lang gold.lang
284 %find_lang ld
285 %if %{with gold}
286 %find_lang gold
287 %endif
288 %find_lang opcodes
289 cat bfd.lang opcodes.lang > %{name}-libs.lang
290 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post   -p /sbin/postshell
296 -/usr/sbin/fix-info-dir -c %{_infodir}
297
298 %postun -p /sbin/postshell
299 -/usr/sbin/fix-info-dir -c %{_infodir}
300
301 %post   libs -p /sbin/ldconfig
302 %postun libs -p /sbin/ldconfig
303
304 %post   devel -p /sbin/postshell
305 -/usr/sbin/fix-info-dir -c %{_infodir}
306
307 %postun devel -p /sbin/postshell
308 -/usr/sbin/fix-info-dir -c %{_infodir}
309
310 %post   gasp -p /sbin/postshell
311 -/usr/sbin/fix-info-dir -c %{_infodir}
312
313 %postun gasp -p /sbin/postshell
314 -/usr/sbin/fix-info-dir -c %{_infodir}
315
316 %files -f %{name}.lang
317 %defattr(644,root,root,755)
318 %doc README
319 %{?with_gold:%doc gold/{ChangeLog,README,TODO}}
320 %attr(755,root,root) %{_bindir}/addr2line
321 %attr(755,root,root) %{_bindir}/ar
322 %attr(755,root,root) %{_bindir}/as
323 %attr(755,root,root) %{_bindir}/c++filt
324 %attr(755,root,root) %{_bindir}/elfedit
325 %attr(755,root,root) %{_bindir}/gprof
326 %attr(755,root,root) %{_bindir}/ld
327 %attr(755,root,root) %{_bindir}/ld.bfd
328 %if %{with gold}
329 %attr(755,root,root) %{_bindir}/ld.gold
330 %attr(755,root,root) %{_bindir}/dwp
331 %endif
332 %attr(755,root,root) %{_bindir}/nm
333 %attr(755,root,root) %{_bindir}/objcopy
334 %attr(755,root,root) %{_bindir}/objdump
335 %attr(755,root,root) %{_bindir}/ranlib
336 %attr(755,root,root) %{_bindir}/readelf
337 %attr(755,root,root) %{_bindir}/size
338 %attr(755,root,root) %{_bindir}/strings
339 %attr(755,root,root) %{_bindir}/strip
340 %{_prefix}/lib/ldscripts
341 %{_infodir}/as.info*
342 %{_infodir}/binutils.info*
343 %{_infodir}/gprof.info*
344 %{_infodir}/ld.info*
345 %{_mandir}/man1/addr2line.1*
346 %{_mandir}/man1/ar.1*
347 %{_mandir}/man1/as.1*
348 %{_mandir}/man1/c++filt.1*
349 %{_mandir}/man1/elfedit.1*
350 %{_mandir}/man1/gprof.1*
351 %{_mandir}/man1/ld.1*
352 %{_mandir}/man1/nm.1*
353 %{_mandir}/man1/objcopy.1*
354 %{_mandir}/man1/objdump.1*
355 %{_mandir}/man1/ranlib.1*
356 %{_mandir}/man1/readelf.1*
357 %{_mandir}/man1/size.1*
358 %{_mandir}/man1/strings.1*
359 %{_mandir}/man1/strip.1*
360 %lang(cs) %{_mandir}/cs/man1/*
361 %lang(de) %{_mandir}/de/man1/*
362 %lang(es) %{_mandir}/es/man1/*
363 %lang(fi) %{_mandir}/fi/man1/*
364 %lang(fr) %{_mandir}/fr/man1/*
365 %lang(hu) %{_mandir}/hu/man1/*
366 %lang(ja) %{_mandir}/ja/man1/*
367 %lang(pl) %{_mandir}/pl/man1/*
368
369 %files libs -f %{name}-libs.lang
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_libdir}/libbfd-*.so
372 %attr(755,root,root) %{_libdir}/libopcodes-*.so
373 %dir %{_libdir}/bfd-plugins
374
375 %files devel
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libbfd.so
378 %attr(755,root,root) %{_libdir}/libopcodes.so
379 %{_libdir}/libbfd.la
380 %{_libdir}/libopcodes.la
381 %{_libdir}/libiberty.a
382 %{_includedir}/ansidecl.h
383 %{_includedir}/bfd.h
384 %{_includedir}/bfdlink.h
385 %{_includedir}/dis-asm.h
386 %{_includedir}/libiberty.h
387 %{_includedir}/plugin-api.h
388 %{_includedir}/symcat.h
389 %{_infodir}/bfd.info*
390
391 %files static
392 %defattr(644,root,root,755)
393 %{_libdir}/libbfd.a
394 %{_libdir}/libopcodes.a
395
396 %if %{with gasp}
397 %files gasp
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_bindir}/gasp
400 %{_infodir}/gasp.info*
401 %endif
This page took 0.053227 seconds and 4 git commands to generate.