]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- gold bcond
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5 %bcond_with     gold            # disable gold (gnu ld successor) on supported archs (x86/sparc)
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 #
8 %ifnarch %ix86 %x8664 sparc
9 %define         with_gold       0
10 %endif
11 #
12 Summary:        GNU Binary Utility Development Utilities
13 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
14 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
15 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
16 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
17 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
18 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
19 Summary(tr.UTF-8):      GNU geliştirme araçları
20 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
21 Name:           binutils
22 Version:        2.18.50.0.7
23 Release:        2
24 Epoch:          3
25 License:        GPL v3+
26 Group:          Development/Tools
27 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
28 # Source0-md5:  d5bce238060d631be60a3f1f1009a7ba
29 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
31 Patch0:         %{name}-gasp.patch
32 Patch1:         %{name}-info.patch
33 Patch2:         %{name}-libtool-relink.patch
34 Patch3:         %{name}-pt_pax_flags.patch
35 Patch4:         %{name}-mips-relocs.patch
36 Patch5:         %{name}-flex.patch
37 Patch6:         %{name}-discarded.patch
38 Patch7:         %{name}-absolute-gnu_debuglink-path.patch
39 Patch8:         %{name}-libtool-m.patch
40 URL:            http://sources.redhat.com/binutils/
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake >= 1:1.8.2
43 BuildRequires:  bison
44 BuildRequires:  flex
45 BuildRequires:  gettext-devel
46 BuildRequires:  perl-tools-pod
47 %ifarch sparc sparc32
48 BuildRequires:  sparc32
49 %endif
50 BuildRequires:  texinfo >= 4.2
51 Requires:       %{name} = %{epoch}:%{version}-%{release}
52 Conflicts:      gcc-c++ < 5:3.3
53 Conflicts:      modutils < 2.4.17
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Binutils is a collection of binary utilities, including:
58 - ar - create, modify and extract from archives,
59 - nm - lists symbols from object files,
60 - objcopy - copy and translate object files,
61 - objdump - display information from object files,
62 - ranlib - generate an index for the contents of an archive,
63 - size - list the section sizes of an object or archive file,
64 - strings - list printable strings from files,
65 - strip - discard symbols,
66 - addr2line - convert addresses to file and line,
67 - nlmconv - convert object code into an NLM.
68
69 %description -l es.UTF-8
70 Binutils es una colección de utilitarios necesarios para compilar
71 programas. Incluye assembler y linker, así como varios otros programas
72 para trabajar con formatos que se puedan ejecutar.
73
74 %description -l pl.UTF-8
75 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
76 programów. Znajdują się tutaj między innymi assembler, konsolidator
77 (linker), a także inne narzędzia do manipulowania binarnymi plikami
78 programów i bibliotek.
79
80 %description -l pt_BR.UTF-8
81 binutils é uma coletânea de utilitários necessários para compilar
82 programas. Inclui assembler e linker, assim como vários outros
83 programas para trabalhar com formatos executáveis.
84
85 %description -l ru.UTF-8
86 binutils - это набор инструментов, необходимых для компилляции
87 программ. Включает ассемблер, компоновщик и набор других программ для
88 работы с исполняемыми файлами разнообразных форматов.
89
90 %description -l uk.UTF-8
91 binutils - це набір інструментів, необхідних для компіляції програм.
92 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
93 виконуваними файлами різних форматів.
94
95 %package libs
96 Summary:        GNU binutils shared libraries
97 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
98 Group:          Libraries
99 Conflicts:      binutils < 3:2.17.50.0.8-3
100
101 %description libs
102 GNU binutils shared libraries (libbfd, libopcodes).
103
104 %description libs -l pl.UTF-8
105 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
106
107 %package devel
108 Summary:        Development files for GNU binutils libraries
109 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
110 Group:          Development/Libraries
111 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
112
113 %description devel
114 Development files for GNU binutils libraries (libbfd, libopcodes) and
115 static libiberty library.
116
117 %description devel -l pl.UTF-8
118 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
119 statyczna biblioteka libiberty.
120
121 %package static
122 Summary:        GNU binutils static libraries
123 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
124 Group:          Development/Libraries
125 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
126
127 %description static
128 Static GNU binutils libraries (libbfd, libopcodes).
129
130 %description static -l pl.UTF-8
131 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
132
133 %package gasp
134 Summary:        GASP - old preprocessor for assembly programs
135 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
136 Group:          Development/Tools
137 Requires:       %{name} = %{epoch}:%{version}-%{release}
138
139 %description gasp
140 GASP - old preprocessor for assembly programs. It's officially
141 obsoleted, but it's still needed to build some packages.
142
143 %description gasp -l pl.UTF-8
144 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
145 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
146 niektórych pakietów.
147
148 %prep
149 %setup -q
150 %patch0 -p1
151 %patch1 -p1
152 %patch2 -p1
153 %{?with_pax:%patch3 -p1}
154 %patch4 -p0
155 %patch5 -p1
156 %patch6 -p1
157 %patch7 -p1
158 %patch8 -p1
159
160 %build
161 # non-standard regeneration (needed because of gasp patch)
162 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
163 for dir in gas bfd; do
164         cd $dir || exit 1
165         aclocal -I ../bfd -I ../config -I ..
166         automake --cygnus Makefile
167         automake --cygnus doc/Makefile
168         autoconf
169         cd ..
170 done
171
172 # More targets
173 TARGETS=
174 %ifarch ia64
175 TARGETS=i686-linux
176 %endif
177 # uhm?
178 %ifarch %{ix86}
179 TARGETS=x86_64-linux
180 %endif
181 %ifarch sparc
182 TARGETS=sparc64-linux
183 %endif
184 %{?addtargets:TARGETS="%{addtargets}"}
185
186 cp -f /usr/share/automake/config.* .
187 CFLAGS="%{rpmcflags} -fno-strict-aliasing"; export CFLAGS
188 CC="%{__cc}"; export CC
189 %ifarch sparc
190 sparc32 \
191 %endif
192 ./configure %{_target_platform} \
193         --disable-debug \
194         --disable-werror \
195         --enable-build-warnings=,-Wno-missing-prototypes \
196         --enable-shared \
197         --prefix=%{_prefix} \
198         --libdir=%{_libdir} \
199         --infodir=%{_infodir} \
200         --mandir=%{_mandir} \
201         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
202 %ifarch sparc
203         --enable-64-bit-bfd \
204 %else
205         %{?with_allarchs:--enable-64-bit-bfd} \
206 %endif
207         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout} \
208         %{?with_gold:--enable-gold}
209
210 %{__make} -j1 configure-bfd
211 %{__make} -j1 headers -C bfd
212 %{__make} -j1 all info \
213         tooldir=%{_prefix}
214
215 %install
216 rm -rf $RPM_BUILD_ROOT
217
218 %{__make} -j1 install \
219         prefix=$RPM_BUILD_ROOT%{_prefix} \
220         tooldir=$RPM_BUILD_ROOT%{_prefix} \
221         mandir=$RPM_BUILD_ROOT%{_mandir} \
222         infodir=$RPM_BUILD_ROOT%{_infodir} \
223         includedir=$RPM_BUILD_ROOT%{_includedir} \
224         libdir=$RPM_BUILD_ROOT%{_libdir}
225
226 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
227
228 # remove these man pages unless we cross-build for win*/netware platforms.
229 # however, this should be done in Makefiles.
230 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
231
232 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
233
234 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
235 install libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
236
237 # remove evil -L pointing inside builder's home
238 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
239
240 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
241
242 %find_lang bfd
243 %find_lang binutils
244 %find_lang gas
245 %find_lang gprof
246 touch ld.lang
247 %if %{without gold}
248 %find_lang ld
249 %endif
250 %find_lang opcodes
251 cat bfd.lang opcodes.lang > %{name}-libs.lang
252 cat gas.lang gprof.lang ld.lang >> %{name}.lang
253
254 %clean
255 rm -rf $RPM_BUILD_ROOT
256
257 %post   -p      /sbin/postshell
258 -/usr/sbin/fix-info-dir -c %{_infodir}
259
260 %postun -p      /sbin/postshell
261 -/usr/sbin/fix-info-dir -c %{_infodir}
262
263 %post   libs -p /sbin/ldconfig
264 %postun libs -p /sbin/ldconfig
265
266 %post devel     -p      /sbin/postshell
267 -/usr/sbin/fix-info-dir -c %{_infodir}
268
269 %postun devel   -p      /sbin/postshell
270 -/usr/sbin/fix-info-dir -c %{_infodir}
271
272 %files -f %{name}.lang
273 %defattr(644,root,root,755)
274 %doc README
275 %attr(755,root,root) %{_bindir}/[!g]*
276 %attr(755,root,root) %{_bindir}/g[!a]*
277 %{_infodir}/as.info*
278 %{_infodir}/binutils.info*
279 %{_infodir}/configure.info*
280 %{_infodir}/gprof.info*
281 %if %{without gold}
282 %{_infodir}/ld.info*
283 %{_prefix}/lib/ldscripts
284 %endif
285 %{_mandir}/man1/*
286 %lang(cs) %{_mandir}/cs/man1/*
287 %lang(de) %{_mandir}/de/man1/*
288 %lang(es) %{_mandir}/es/man1/*
289 %lang(fi) %{_mandir}/fi/man1/*
290 %lang(fr) %{_mandir}/fr/man1/*
291 %lang(hu) %{_mandir}/hu/man1/*
292 %lang(ja) %{_mandir}/ja/man1/*
293 %lang(pl) %{_mandir}/pl/man1/*
294
295 %files libs -f %{name}-libs.lang
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/libbfd-*.so
298 %attr(755,root,root) %{_libdir}/libopcodes-*.so
299
300 %files devel
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/libbfd.so
303 %attr(755,root,root) %{_libdir}/libopcodes.so
304 %{_libdir}/libbfd.la
305 %{_libdir}/libopcodes.la
306 %{_libdir}/libiberty.a
307 %{_includedir}/*.h
308 %{_infodir}/bfd.info*
309
310 %files static
311 %defattr(644,root,root,755)
312 %{_libdir}/libbfd.a
313 %{_libdir}/libopcodes.a
314
315 %files gasp
316 %defattr(644,root,root,755)
317 %attr(755,root,root) %{_bindir}/gasp
318 %{_infodir}/gasp.info*
This page took 0.096838 seconds and 4 git commands to generate.