]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- add support for x32
[packages/binutils.git] / binutils.spec
1 #
2 # Conditional build:
3 %bcond_with     allarchs        # enable all targets
4 # define addtargets x,y,z       # build with additional targets x,y,z (e.g. x86_64-linux)
5                                 # http://sourceware.org/ml/binutils/2008-03/msg00162.html
6 %bcond_without  pax             # without PaX flags (for upstream bugreports)
7 %bcond_without  gold            # don't build gold (no C++ dependencies)
8 %bcond_without  default_bfd     # default ld.bfd instead of gold
9 %bcond_without  gasp            # gasp
10 %bcond_without  tests
11
12 %ifnarch %{ix86} %{x8664} x32
13 %undefine       with_gold
14 %endif
15
16 Summary:        GNU Binary Utility Development Utilities
17 Summary(de.UTF-8):      GNU Binary Utility Development Utilities
18 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU
19 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU
20 Summary(pl.UTF-8):      Narzędzia GNU dla programistów
21 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU
22 Summary(ru.UTF-8):      Набор инструментов GNU для построения исполняемых программ
23 Summary(tr.UTF-8):      GNU geliştirme araçları
24 Summary(uk.UTF-8):      Набір інструментів GNU для побудови виконуваних програм
25 Name:           binutils
26 Version:        2.24.51.0.4
27 Release:        1
28 Epoch:          3
29 License:        GPL v3+
30 Group:          Development/Tools
31 # Source0:      https://www.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.xz
32
33 # release with no tarball - https://sourceware.org/git/?p=binutils-gdb.git;a=summary
34 Source0:        %{name}-%{version}.tar.bz2
35 # Source0-md5:  a44a86209c84e2072824183c4b0a11f4
36
37 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
38 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
39 Patch0:         %{name}-gasp.patch
40 Patch1:         %{name}-info.patch
41 Patch2:         %{name}-libtool-relink.patch
42 Patch3:         %{name}-pt_pax_flags.patch
43 Patch5:         %{name}-discarded.patch
44 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
45 Patch7:         %{name}-libtool-m.patch
46 Patch8:         %{name}-build-id.patch
47 Patch9:         %{name}-tooldir.patch
48 Patch10:        %{name}-sanity-check.patch
49 Patch11:        %{name}-am.patch
50 URL:            http://sources.redhat.com/binutils/
51 BuildRequires:  autoconf >= 2.64
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  bison
54 BuildRequires:  flex
55 BuildRequires:  gettext-tools
56 %{?with_gold:BuildRequires:     libstdc++-devel >= 6:4.0-1}
57 %{?with_tests:BuildRequires:    libstdc++-static >= 6:4.0}
58 BuildRequires:  perl-tools-pod
59 %ifarch sparc sparc32
60 BuildRequires:  sparc32
61 %endif
62 BuildRequires:  tar >= 1:1.22
63 BuildRequires:  texinfo >= 4.2
64 BuildRequires:  xz
65 BuildRequires:  zlib-devel
66 %{?with_tests:BuildRequires:    zlib-static}
67 Conflicts:      gcc-c++ < 5:3.3
68 Conflicts:      modutils < 2.4.17
69 Conflicts:      rpmbuild(macros) < 1.660
70 Obsoletes:      binutils-gold
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 Binutils is a collection of binary utilities, including:
75 - ar - create, modify and extract from archives,
76 - nm - lists symbols from object files,
77 - objcopy - copy and translate object files,
78 - objdump - display information from object files,
79 - ranlib - generate an index for the contents of an archive,
80 - size - list the section sizes of an object or archive file,
81 - strings - list printable strings from files,
82 - strip - discard symbols,
83 - addr2line - convert addresses to file and line,
84 - nlmconv - convert object code into an NLM.
85
86 %description -l es.UTF-8
87 Binutils es una colección de utilitarios necesarios para compilar
88 programas. Incluye assembler y linker, así como varios otros programas
89 para trabajar con formatos que se puedan ejecutar.
90
91 %description -l pl.UTF-8
92 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
93 programów. Znajdują się tutaj między innymi assembler, konsolidator
94 (linker), a także inne narzędzia do manipulowania binarnymi plikami
95 programów i bibliotek.
96
97 %description -l pt_BR.UTF-8
98 binutils é uma coletânea de utilitários necessários para compilar
99 programas. Inclui assembler e linker, assim como vários outros
100 programas para trabalhar com formatos executáveis.
101
102 %description -l ru.UTF-8
103 binutils - это набор инструментов, необходимых для компилляции
104 программ. Включает ассемблер, компоновщик и набор других программ для
105 работы с исполняемыми файлами разнообразных форматов.
106
107 %description -l uk.UTF-8
108 binutils - це набір інструментів, необхідних для компіляції програм.
109 Містить асемблер, компоновщик та інші програми, необхідні для роботи з
110 виконуваними файлами різних форматів.
111
112 %package libs
113 Summary:        GNU binutils shared libraries
114 Summary(pl.UTF-8):      Biblioteki współdzielone GNU binutils
115 Group:          Libraries
116 Conflicts:      binutils < 3:2.17.50.0.8-3
117
118 %description libs
119 GNU binutils shared libraries (libbfd, libopcodes).
120
121 %description libs -l pl.UTF-8
122 Biblioteki współdzielone GNU binutils (libbfd, libopcodes).
123
124 %package devel
125 Summary:        Development files for GNU binutils libraries
126 Summary(pl.UTF-8):      Pliki programistyczne bibliotek GNU binutils
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
129
130 %description devel
131 Development files for GNU binutils libraries (libbfd, libopcodes) and
132 static libiberty library.
133
134 %description devel -l pl.UTF-8
135 Pliki programistyczne bibliotek GNU binutils (libbfd, libopcodes) oraz
136 statyczna biblioteka libiberty.
137
138 %package static
139 Summary:        GNU binutils static libraries
140 Summary(pl.UTF-8):      Biblioteki statyczne do GNU binutils
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
143 #Requires:      zlib-static
144
145 %description static
146 Static GNU binutils libraries (libbfd, libopcodes).
147
148 %description static -l pl.UTF-8
149 Biblioteki statyczne GNU binutils (libbfd, libopcodes).
150
151 %package gasp
152 Summary:        GASP - old preprocessor for assembly programs
153 Summary(pl.UTF-8):      GASP - stary preprocesor dla programów w asemblerze
154 Group:          Development/Tools
155 Requires:       %{name} = %{epoch}:%{version}-%{release}
156
157 %description gasp
158 GASP - old preprocessor for assembly programs. It's officially
159 obsoleted, but it's still needed to build some packages.
160
161 %description gasp -l pl.UTF-8
162 GASP - stary preprocesor dla programów w asemblerze. Jest oficjalnie
163 uznany za przestarzały, ale jest nadal potrzebny do zbudowania
164 niektórych pakietów.
165
166 %prep
167 %setup -q
168 %{?with_gasp:%patch0 -p1}
169 %patch1 -p1
170 %patch2 -p1
171 %{?with_pax:%patch3 -p1}
172 %patch5 -p1
173 %patch6 -p1
174 %patch7 -p1
175 %patch8 -p1
176 %patch9 -p1
177 %patch10 -p1
178 %patch11 -p1
179
180 # file contains hacks for ac 2.59 only
181 %{__rm} config/override.m4
182
183 %build
184 %{__aclocal}
185 %{__autoconf}
186
187 # non-standard regeneration (needed because of gasp patch)
188 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
189 for dir in gas bfd; do
190         cd $dir || exit 1
191         %{__aclocal} -I .. -I ../config -I ../bfd
192         %{__automake} Makefile
193         %{__automake} doc/Makefile
194         %{__autoconf}
195         cd ..
196 done
197
198 # More targets
199 TARGETS=
200 %ifarch ia64
201 TARGETS=i686-linux
202 %endif
203 # uhm?
204 %ifarch %{ix86}
205 TARGETS=x86_64-linux
206 %endif
207 %ifarch sparc
208 TARGETS=sparc64-linux
209 %endif
210 %ifarch %{x8664}
211 TARGETS="x86_64-pep"
212 %endif
213 %ifarch x32
214 TARGETS="x86_64-linux,x86_64-pep"
215 %endif
216 %{?addtargets:TARGETS="%{addtargets}"}
217
218 cp -f /usr/share/automake/config.* .
219 CFLAGS="%{rpmcflags}"; export CFLAGS
220 CXXFLAGS="%{rpmcxxflags}"; export CXXFLAGS
221 CC="%{__cc}"; export CC
222 CXX="%{__cxx}"; export CXX
223 %ifarch sparc
224 sparc32 \
225 %endif
226 ./configure %{_target_platform} \
227         --disable-debug \
228         --disable-werror \
229         --enable-build-warnings=,-Wno-missing-prototypes \
230         --enable-shared \
231         --enable-lto \
232         --enable-plugins \
233         --with-zlib=yes \
234         --prefix=%{_prefix} \
235         --libdir=%{_libdir} \
236         --infodir=%{_infodir} \
237         --mandir=%{_mandir} \
238         --with-tooldir=%{_prefix} \
239         %{!?with_allarchs:`[ -n "${TARGETS}" ] && echo "--enable-targets=${TARGETS}"`} \
240 %ifarch sparc
241         --enable-64-bit-bfd \
242 %else
243         %{?with_allarchs:--enable-64-bit-bfd} \
244 %endif
245         %{?with_allarchs:--enable-targets=alpha-linux,arm-linux,cris-linux,hppa-linux,i386-linux,ia64-linux,x86_64-linux,x86_64-linux-gnux32,m68k-linux,mips-linux,mips64-linux,mips64el-linux,mipsel-linux,ppc-linux,s390-linux,s390x-linux,sh-linux,sparc-linux,sparc64-linux,i386-linuxaout,x86_64-pep} \
246 %if %{with gold}
247         --enable-gold%{!?with_default_bfd:=default} --enable-ld%{?with_default_bfd:=default} \
248 %endif
249
250 %{__make} -j1
251
252 %{?with_tests:%{__make} -j1 check}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256
257 %{__make} install \
258         DESTDIR=$RPM_BUILD_ROOT
259
260 # remove these man pages unless we cross-build for win*/netware platforms.
261 # however, this should be done in Makefiles.
262 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
263
264 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
265
266 cp -p include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
267 cp -p libiberty/pic/libiberty.a $RPM_BUILD_ROOT%{_libdir}
268
269 # remove evil -L pointing inside builder's home
270 perl -pi -e 's@-L[^ ]*/pic @@g' $RPM_BUILD_ROOT%{_libdir}/libbfd.la
271
272 [ -x $RPM_BUILD_ROOT%{_bindir}/ld.bfd ] || ln $RPM_BUILD_ROOT%{_bindir}/ld{,.bfd}
273
274 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
275
276 %find_lang bfd
277 %find_lang binutils
278 %find_lang gas
279 %find_lang gprof
280 touch ld.lang gold.lang
281 %find_lang ld
282 %if %{with gold}
283 %find_lang gold
284 %endif
285 %find_lang opcodes
286 cat bfd.lang opcodes.lang > %{name}-libs.lang
287 cat gas.lang gprof.lang ld.lang gold.lang >> %{name}.lang
288
289 %clean
290 rm -rf $RPM_BUILD_ROOT
291
292 %post   -p /sbin/postshell
293 -/usr/sbin/fix-info-dir -c %{_infodir}
294
295 %postun -p /sbin/postshell
296 -/usr/sbin/fix-info-dir -c %{_infodir}
297
298 %post   libs -p /sbin/ldconfig
299 %postun libs -p /sbin/ldconfig
300
301 %post   devel -p /sbin/postshell
302 -/usr/sbin/fix-info-dir -c %{_infodir}
303
304 %postun devel -p /sbin/postshell
305 -/usr/sbin/fix-info-dir -c %{_infodir}
306
307 %post   gasp -p /sbin/postshell
308 -/usr/sbin/fix-info-dir -c %{_infodir}
309
310 %postun gasp -p /sbin/postshell
311 -/usr/sbin/fix-info-dir -c %{_infodir}
312
313 %files -f %{name}.lang
314 %defattr(644,root,root,755)
315 %doc README
316 %{?with_gold:%doc gold/{ChangeLog,README,TODO}}
317 %attr(755,root,root) %{_bindir}/addr2line
318 %attr(755,root,root) %{_bindir}/ar
319 %attr(755,root,root) %{_bindir}/as
320 %attr(755,root,root) %{_bindir}/c++filt
321 %attr(755,root,root) %{_bindir}/elfedit
322 %attr(755,root,root) %{_bindir}/gprof
323 %attr(755,root,root) %{_bindir}/ld
324 %attr(755,root,root) %{_bindir}/ld.bfd
325 %if %{with gold}
326 %attr(755,root,root) %{_bindir}/ld.gold
327 %attr(755,root,root) %{_bindir}/dwp
328 %endif
329 %attr(755,root,root) %{_bindir}/nm
330 %attr(755,root,root) %{_bindir}/objcopy
331 %attr(755,root,root) %{_bindir}/objdump
332 %attr(755,root,root) %{_bindir}/ranlib
333 %attr(755,root,root) %{_bindir}/readelf
334 %attr(755,root,root) %{_bindir}/size
335 %attr(755,root,root) %{_bindir}/strings
336 %attr(755,root,root) %{_bindir}/strip
337 %{_infodir}/as.info*
338 %{_infodir}/binutils.info*
339 %{_infodir}/gprof.info*
340 %{_infodir}/ld.info*
341 %{_prefix}/lib/ldscripts
342 %{_mandir}/man1/*
343 %lang(cs) %{_mandir}/cs/man1/*
344 %lang(de) %{_mandir}/de/man1/*
345 %lang(es) %{_mandir}/es/man1/*
346 %lang(fi) %{_mandir}/fi/man1/*
347 %lang(fr) %{_mandir}/fr/man1/*
348 %lang(hu) %{_mandir}/hu/man1/*
349 %lang(ja) %{_mandir}/ja/man1/*
350 %lang(pl) %{_mandir}/pl/man1/*
351
352 %files libs -f %{name}-libs.lang
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/libbfd-*.so
355 %attr(755,root,root) %{_libdir}/libopcodes-*.so
356
357 %files devel
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/libbfd.so
360 %attr(755,root,root) %{_libdir}/libopcodes.so
361 %{_libdir}/libbfd.la
362 %{_libdir}/libopcodes.la
363 %{_libdir}/libiberty.a
364 %{_includedir}/ansidecl.h
365 %{_includedir}/bfd.h
366 %{_includedir}/bfdlink.h
367 %{_includedir}/dis-asm.h
368 %{_includedir}/libiberty.h
369 %{_includedir}/plugin-api.h
370 %{_includedir}/symcat.h
371 %{_infodir}/bfd.info*
372
373 %files static
374 %defattr(644,root,root,755)
375 %{_libdir}/libbfd.a
376 %{_libdir}/libopcodes.a
377
378 %if %{with gasp}
379 %files gasp
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_bindir}/gasp
382 %{_infodir}/gasp.info*
383 %endif
This page took 0.058217 seconds and 4 git commands to generate.