]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- translated kloczkish into english
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(fr):    Utilitaires de développement binaire de GNU
4 Summary(pl):    Narzêdzia GNU dla programistów
5 Summary(tr):    GNU geliþtirme araçlarý
6 Name:           binutils
7 Version:        2.9.5.0.29
8 Release:        1
9 Copyright:      GPL
10 Group:          Development/Tools
11 Group(pl):      Programowanie/Narzêdzia
12 Source:         ftp://ftp.varesearch.com/pub/support/hjl/binutils/%{name}-%{version}.tar.gz
13 Patch0:         binutils-info.patch
14 Prereq:         /usr/sbin/fix-info-dir
15 Prereq:         /sbin/ldconfig
16 BuildRoot:      /tmp/%{name}-%{version}-root
17
18 %description
19 Binutils is a collection of binary utilities, including:
20 - ar - create, modify and extract from archives,
21 - nm - lists symbols from object files,
22 - objcopy - copy and translate object files,
23 - objdump - display information from object files,
24 - ranlib - generate an index for the contents of an archive,
25 - size - list the section sizes of an object or archive file,
26 - strings - list printable strings from files,
27 - strip - discard symbols,
28 - c++filt - a filter for demangling encoded C++ symbols,
29 - addr2line - convert addresses to file and line,
30 - nlmconv - convert object code into an NLM.
31
32 %description -l pl
33 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê programów. 
34 Znajduj± siê tutaj miêdzy innymi assembler, konsolidator (linker), a tak¿e 
35 inne narzêdzia do manipulowania binarnymi plikami programów i bibliotek.
36
37 %package static
38 Summary:        GNU Binutils static libraries
39 Summary(pl):    Biblioteki statyczne do GNU Binutils
40 Group:          Development/Libraries
41 Group(pl):      Programowanie/Biblioteki
42 Requires:       %{name} = %{version}
43
44 %description static
45 Static libraries for GNU Binutils.
46
47 %description -l pl static
48 Biblioteki statyczne GNU Binutils.
49
50 %prep
51 %setup -q 
52 %patch0 -p1
53
54 %build
55 LDFLAGS="-s"; export LDFLAGS
56 %ifarch sparc sparc64
57 sparc32 \
58 %endif
59 ./configure %{_target_platform} \
60         --enable-shared \
61         --disable-debug \
62         --prefix=%{_prefix} \
63         --infodir=%{_infodir} \
64         --mandir=%{_mandir}
65
66 make tooldir=%{_prefix} all info
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 install -d $RPM_BUILD_ROOT%{_prefix}
72
73 make install install-info \
74         prefix=$RPM_BUILD_ROOT%{_prefix} \
75         tooldir=$RPM_BUILD_ROOT%{_prefix} \
76         mandir=$RPM_BUILD_ROOT%{_mandir} \
77         infodir=$RPM_BUILD_ROOT%{_infodir} \
78         includedir=$RPM_BUILD_ROOT%{_includedir} \
79         libdir=$RPM_BUILD_ROOT%{_libdir}
80
81 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt 
82
83 strip $RPM_BUILD_ROOT%{_bindir}/*
84 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so
85
86 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
87
88 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*.inf*,%{_mandir}/man1/*} \
89         README
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 /sbin/ldconfig
96 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
97
98 %postun
99 /sbin/ldconfig
100 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
101
102 %files
103 %defattr(644,root,root,755)
104 %doc *.gz
105 %attr(755,root,root) %{_bindir}/*
106 %attr(755,root,root) %{_libdir}/*.so
107
108 %{_libdir}/ldscripts
109 %{_includedir}/*.h
110
111 %{_infodir}/*.gz
112 %{_mandir}/man1/*
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
This page took 0.065381 seconds and 3 git commands to generate.