]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.16.0
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  geoip           # GeoIP support
6 %bcond_without  kerberos5       # GSS-API support
7 %bcond_without  ssl             # OpenSSL support
8 %bcond_with     ldap            # LDAP DLZ support
9 %bcond_with     odbc            # ODBC DLZ support
10 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
11 %bcond_without  lmdb            # LMDB storage support for addzone zones
12 %bcond_without  static_libs     # static libraries
13 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
14 %bcond_with     tests           # unit tests
15 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
16 %bcond_with     hip             # HIP RR support
17
18 %if "%{pld_release}" == "ac"
19 %bcond_with     epoll           # enable epoll support
20 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
21 %ifarch %{x8664}
22 %define         with_epoll      1
23 %endif
24 %else
25 %bcond_without  epoll           # disable epoll support
26 %endif
27
28 %define         ver     9.16.0
29 %if 0
30 %define         pverdot .P0
31 %define         pverdir -P0
32 %else
33 %define         pverdot %{nil}
34 %define         pverdir %{nil}
35 %endif
36 Summary:        BIND - DNS name server
37 Summary(de.UTF-8):      BIND - DNS-Namenserver
38 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
39 Summary(fr.UTF-8):      BIND - serveur de noms DNS
40 Summary(pl.UTF-8):      BIND - serwer nazw DNS
41 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
42 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
43 Summary(tr.UTF-8):      DNS alan adı sunucusu
44 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
45 Summary(zh_CN.UTF-8):   Internet 域名服务器
46 Name:           bind
47 Version:        %{ver}%{pverdot}
48 Release:        1
49 Epoch:          7
50 License:        MPL 2.0
51 Group:          Networking/Daemons
52 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
53 # Source0-md5:  f973848bf32797c5f546de7d92a6fd07
54 Source1:        named.init
55 Source2:        named.sysconfig
56 Source3:        named.logrotate
57 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
58 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
59 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
60 # Source5-md5:  026f3ddad50e5a8832bce39bb49bed2f
61 Source6:        %{name}-hip.tar.gz
62 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
63 Source7:        https://www.internic.net/domain/named.root
64 # Source7-md5:  7cee6519fca7a4a6e771633560e55d53
65 Source8:        %{name}-127.0.0.zone
66 Source9:        %{name}-localhost.zone
67 Source10:       %{name}-named.conf
68 Source11:       %{name}.tmpfiles
69 Source12:       named.service
70 Patch0:         %{name}-time.patch
71 Patch1:         %{name}-link.patch
72 Patch2:         %{name}-pmake.patch
73 Patch3:         %{name}-sdb-ldap.patch
74 Patch4:         %{name}-ac-libs.patch
75 Patch5:         %{name}-edns-client-subnet.patch
76 Patch6:         nsupdate_segfault.patch
77 URL:            https://www.isc.org/software/bind
78 BuildRequires:  autoconf >= 2.59
79 BuildRequires:  automake
80 BuildRequires:  bison
81 BuildRequires:  flex
82 %{?with_kerberos5:BuildRequires:        heimdal-devel}
83 BuildRequires:  json-c-devel
84 BuildRequires:  libidn2-devel
85 # note, there is no kyua in PLD yet (work in progress)
86 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
87 BuildRequires:  libtool
88 BuildRequires:  libuv-devel >= 1.0.0
89 %{?with_hip:BuildRequires:      libxml2-devel}
90 %{?with_lmdb:BuildRequires:     lmdb-devel}
91 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
92 %{?with_sql:BuildRequires:      mysql-devel}
93 %{?with_ldap:BuildRequires:     openldap-devel}
94 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
95 %{?with_sql:BuildRequires:      postgresql-devel}
96 BuildRequires:  python3-devel
97 BuildRequires:  python3-ply
98 BuildRequires:  readline-devel
99 BuildRequires:  rpm >= 4.4.9-56
100 BuildRequires:  rpmbuild(macros) >= 1.647
101 %{?with_odbc:BuildRequires:     unixODBC-devel}
102 BuildRequires:  zlib-devel
103 Requires(post,preun):   /sbin/chkconfig
104 Requires(postun):       /usr/sbin/groupdel
105 Requires(postun):       /usr/sbin/userdel
106 Requires(pre):  /bin/id
107 Requires(pre):  /usr/bin/getgid
108 Requires(pre):  /usr/sbin/groupadd
109 Requires(pre):  /usr/sbin/useradd
110 Requires(pre):  fileutils
111 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
112 # for dnssec-{checkds,coverage,keymgr}
113 Requires:       python3-isc = %{epoch}:%{version}-%{release}
114 Requires:       psmisc >= 20.1
115 Requires:       rc-scripts >= 0.2.0
116 Requires:       systemd-units >= 38
117 Requires:       uname(release) >= 2.2.18
118 Provides:       group(named)
119 Provides:       nameserver
120 Provides:       user(named)
121 Obsoletes:      caching-nameserver
122 Conflicts:      %{name}-chroot
123 Conflicts:      logrotate < 3.8.0
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         schemadir       /usr/share/openldap/schema
127
128 %description
129 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
130 (Domain Name System) protocols. BIND includes a DNS server (named),
131 which resolves host names to IP addresses, and a resolver library
132 (routines for applications to use when interfacing with DNS). A DNS
133 server allows clients to name resources or objects and share the
134 information with other network machines. The named DNS server can be
135 used on workstations as a caching name server, but is generally only
136 needed on one machine for an entire network. Note that the
137 configuration files for making BIND act as a simple caching nameserver
138 are included in the caching-nameserver package.
139
140 Install the bind package if you need a DNS server for your network. If
141 you want bind to act a caching name server, you will also need to
142 install the caching-nameserver package.
143
144 %description -l de.UTF-8
145 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
146 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
147 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
148 Recher des Netzwerks erforderlich.
149
150 %description -l es.UTF-8
151 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
152 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
153 un servidor de nombres caché, pero generalmente sólo hace falta en una
154 máquina para toda la red.
155
156 %description -l fr.UTF-8
157 Contient le serveur de noms named, utilisé pour définir les
158 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
159 utilisé sur les stations de travail comme serveur de nom en cache mais
160 n'est souvent nécessaire que sur une machine pour un réseau entier.
161
162 %description -l pl.UTF-8
163 Pakiet ten zawiera demona named, który służy do zmieniania nazw
164 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
165 roboczych jako bufor odwołań do serwisu nazw (caching name server),
166 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
167 program na fragment sieci.
168
169 %description -l pt_BR.UTF-8
170 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
171 IP (e vice-versa). Pode ser usado em estações de trabalho como um
172 servidor de nomes cache, mas geralmente só é necessário em uma máquina
173 para toda a rede.
174
175 %description -l ru.UTF-8
176 BIND (Berkeley Internet Name Domain) является реализацией протоколов
177 DNS (Domain Name System). BIND включает DNS сервер (named) и
178 библиотеку "резолвера" (подпрограммы для приложений, через которые
179 происходят обращения к DNS). DNS сервер named может быть использован
180 на рабочих станциях как кеширующий сервер, но обычно запускается на
181 одной машине в локальной сети и используется остальными машинами (этим
182 достигается намного более эффективное кеширование).
183
184 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
185 кеширующего сервера, включены в пакет caching-nameserver.
186
187 %description -l tr.UTF-8
188 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
189 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
190 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
191 için sadece bir makina üzerinde kurulur.
192
193 %description -l uk.UTF-8
194 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
195 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
196 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
197 сервер named може бути використаний на робочих станціях як кешируючий
198 сервер, але звичайно запускається на одній машині в локальній мережі і
199 використовується іншими (цим досягається більша ефективність
200 використання кешу).
201
202 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
203 кешируючого серверу, включені в пакет caching-nameserver.
204
205 %package utils
206 Summary:        DNS utils - host, dig, dnsquery, nslookup
207 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
208 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
209 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
210 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
211 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
212 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
213 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
214 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
215 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
216 Group:          Networking/Utilities
217 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
218 Requires:       iconv
219
220 %description utils
221 Bind-utils contains a collection of utilities for querying DNS (Domain
222 Name Service) name servers to find out information about Internet
223 hosts. These tools will provide you with the IP addresses for given
224 host names, as well as other information about registered domains and
225 network addresses.
226
227 You should install bind-utils if you need to get information from DNS
228 name servers.
229
230 %description utils -l de.UTF-8
231 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
232 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
233 Informationen über registrierte Domains und Netzwerk-Adressen.
234
235 %description utils -l es.UTF-8
236 Conjunto de utilitarios para consulta a servidores de nombres. Estas
237 herramientas permiten la determinación de direcciones IP para nombres
238 de máquinas informados y busca información sobre dominios registrados
239 y direcciones de red.
240
241 %description utils -l fr.UTF-8
242 Ensemble d'utilitaires pour interroger les serveurs de noms et
243 rechercher des hôtes. Ces outils vous permettent de déterminer les
244 adresses IP pour des noms d'hôtes donnés, et trouver des informations
245 sur les noms de domaine déclarés et les adresses réseau.
246
247 %description utils -l pl.UTF-8
248 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
249 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
250 i ich adresach IP.
251
252 %description utils -l pt_BR.UTF-8
253 Conjunto de utilitários para consulta a servidores DNS. Estas
254 ferramentas permitem a determinação de endereços IP para nomes de
255 máquinas informados e busca informações sobre domínios registrados e
256 endereços de rede. Você deveria instalar este pacote se necessitar
257 obter informações de servidores DNS.
258
259 %description utils -l ru.UTF-8
260 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
261 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
262 доменному имени (и наоборот) и другую информацию о зарегистрированных
263 доменах и сетевых адресах.
264
265 %description utils -l tr.UTF-8
266 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
267 için kullanılan araçlar bulunmaktadır.
268
269 %description utils -l uk.UTF-8
270 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
271 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
272 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
273 домени та адреси.
274
275 %package libs
276 Summary:        DNS libraries
277 Summary(pl.UTF-8):      Biblioteki DNS
278 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
279 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
280 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
281 Group:          Libraries
282
283 %description libs
284 The bind-libs package contains all libraries required for running BIND
285 and bind utils.
286
287 %description libs -l pl.UTF-8
288 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
289 lub programów z pakietu bind-utils.
290
291 %description libs -l ru.UTF-8
292 Библиотеки, необходимые для работы bind.
293
294 %description libs -l uk.UTF-8
295 Бібліотеки, необхідні для роботи bind.
296
297 %package devel
298 Summary:        DNS development includes
299 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
300 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
301 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
302 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
303 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
304 Group:          Development/Libraries
305 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
306
307 %description devel
308 The bind-devel package contains all the include files and symlinks
309 required for DNS (Domain Name Service) development for BIND.
310
311 You should install bind-devel if you want to develop bind DNS
312 applications. If you install bind-devel, you'll also need to install
313 bind-libs.
314
315 %description devel -l es.UTF-8
316 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
317 para el bind.
318
319 %description devel -l pl.UTF-8
320 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
321 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
322 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
323 pakiet.
324
325 %description devel -l pt_BR.UTF-8
326 Todos os arquivos de cabeçalho e bibliotecas necessários para o
327 desenvolvimento com o bind.
328
329 %description devel -l ru.UTF-8
330 Все хедеры и библиотеки, необходимые для написания программ с
331 использованием BIND 9.x.x.
332
333 %description devel -l uk.UTF-8
334 Всі хедери та бібліотеки, необхідні для розробки програм з
335 використанням BIND 9.x.x.
336
337 %package static
338 Summary:        DNS static libs
339 Summary(pl.UTF-8):      Biblioteki statyczne DNS
340 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
341 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
342 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
343 Group:          Development/Libraries
344 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
345
346 %description static
347 Static bind libraries.
348
349 %description static -l pl.UTF-8
350 Statyczne biblioteki binda.
351
352 %description static -l pt_BR.UTF-8
353 Bibliotecas estáticas para desenvolvimento DNS.
354
355 %description static -l ru.UTF-8
356 Статические библиотеки, необходимые для написания программ с
357 использованием BIND.
358
359 %description static -l uk.UTF-8
360 Статичні бібліотеки, необхідні для розробки програм з використанням
361 BIND.
362
363 %package -n openldap-schema-bind
364 Summary:        BIND schema for openldap
365 Summary(pl.UTF-8):      Schemat BIND dla openldap
366 Group:          Development/Libraries
367 Requires(post,postun):  sed >= 4.0
368 Requires:       openldap-servers
369 Requires:       sed >= 4.0
370 %if "%{_rpmversion}" >= "5"
371 BuildArch:      noarch
372 %endif
373
374 %description -n openldap-schema-bind
375 BIND schema for openldap.
376
377 %description -n openldap-schema-bind -l pl.UTF-8
378 Schemat BIND dla openldap.
379
380 %package -n python3-isc
381 Summary:        Python 3 ISC module - functions to support BIND utilities
382 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
383 Group:          Libraries/Python
384 Requires:       python3-modules
385
386 %description -n python3-isc
387 Python 3 ISC module containing functions to support BIND utilities.
388
389 %description -n python3-isc -l pl.UTF-8
390 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
391 BIND-a.
392
393 %prep
394 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
395 %patch0 -p1
396 %patch1 -p1
397 %patch2 -p1
398 %{?with_ldap:%patch3 -p1}
399 %patch4 -p1
400 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
401 %{?with_edns_cli:%patch5 -p0}
402 %patch6 -p0
403
404 %build
405 %{__libtoolize}
406 %{__aclocal}
407 %{__autoconf}
408 cp -f /usr/share/automake/config.* .
409 %configure \
410         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
411         %{!?with_epoll:--disable-epoll --disable-devpoll} \
412         --enable-full-report \
413         --enable-largefile \
414         %{!?with_static_libs:--disable-static} \
415         %{?with_kerberos5:--with-gssapi} \
416         --with-libidn2 \
417         --with-libtool \
418         %{?with_ssl:--with-openssl} \
419         %{?with_sql:--with-dlz-postgres} \
420         %{?with_sql:--with-dlz-mysql} \
421         --without-dlz-bdb \
422         --with-dlz-filesystem \
423         %{?with_ldap:--with-dlz-ldap} \
424         --with-dlz-odbc%{!?with_odbc:=no} \
425         --with-dlz-stub \
426         %{?with_geoip:--with-maxminddb} \
427         --with-lmdb%{!?with_lmdb:=no} \
428         --with-python=%{__python3}
429
430 %{__make}
431
432 %{?with_hip:%{__make} -C bind-hip}
433
434 %if %{with tests}
435 %if %{with system_tests}
436 %{__make} test-force
437 %else
438 sh unit/unittest.sh
439 %endif
440 %endif
441
442 %install
443 rm -rf $RPM_BUILD_ROOT
444 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
445         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
446         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
447         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
448
449 %{__make} install \
450         DESTDIR=$RPM_BUILD_ROOT
451
452 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
453 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
454 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
455 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
456
457 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
458 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
459 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
460 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
461 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
462 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
463 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
464 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
465 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
466
467 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
468 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
469 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
470 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
471
472 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
473
474 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
475 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
476
477 %if %{with ldap}
478 install -d $RPM_BUILD_ROOT%{schemadir}
479 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
480 %endif
481
482 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
483
484 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
485 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
486
487 # let rpm generate deps (workaround -m644 used for libs installation)
488 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
489
490 # we don't want Makefiles in documentation...
491 rm -rf _doc
492 cp -a doc _doc
493 %{__rm} _doc/misc/Makefile*
494
495 %clean
496 rm -rf $RPM_BUILD_ROOT
497
498 %pre
499 if [ -f %{_sysconfdir}/named.boot ]; then
500         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
501         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
502         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
503 fi
504 %groupadd -g 58 named
505 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
506
507 %post
508 /sbin/chkconfig --add named
509 %service named restart
510 %systemd_post named.service
511
512 %preun
513 if [ "$1" = "0" ]; then
514         %service named stop
515         /sbin/chkconfig --del named
516 fi
517 %systemd_preun named.service
518
519 %postun
520 if [ "$1" = "0" ]; then
521         %userremove named
522         %groupremove named
523 fi
524 %systemd_reload
525
526 %post   libs -p /sbin/ldconfig
527 %postun libs -p /sbin/ldconfig
528
529 %post -n openldap-schema-bind
530 %openldap_schema_register %{schemadir}/dnszone.schema
531 %service -q ldap restart
532
533 %postun -n openldap-schema-bind
534 if [ "$1" = "0" ]; then
535         %openldap_schema_unregister %{schemadir}/dnszone.schema
536         %service -q ldap restart
537 fi
538
539 %triggerpostun -- %{name} < 7:9.4.2-2
540 /sbin/chkconfig named reset
541 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
542 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
543 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
544
545 %triggerpostun -- %{name} < 7:9.9.2.P2-2
546 %systemd_trigger named.service
547
548 %files
549 %defattr(644,root,root,755)
550 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
551 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
552
553 %{systemdunitdir}/named.service
554 %attr(754,root,root) /etc/rc.d/init.d/named
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
556 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
557 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
559
560 %attr(755,root,root) %{_sbindir}/ddns-confgen
561 %attr(755,root,root) %{_sbindir}/dnssec-*
562 %attr(755,root,root) %{_sbindir}/named
563 %attr(755,root,root) %{_sbindir}/named-*
564 %attr(755,root,root) %{_sbindir}/nsec3hash
565 %attr(755,root,root) %{_sbindir}/rndc
566 %attr(755,root,root) %{_sbindir}/rndc-confgen
567 %attr(755,root,root) %{_sbindir}/tsig-keygen
568
569 %{_mandir}/man5/named.conf.5*
570 %{_mandir}/man5/rndc.conf.5*
571 %{_mandir}/man8/ddns-confgen.8*
572 %{_mandir}/man8/dnssec-*.8*
573 %{_mandir}/man8/named.8*
574 %{_mandir}/man8/named-*.8*
575 %{_mandir}/man8/nsec3hash.8*
576 %{_mandir}/man8/rndc.8*
577 %{_mandir}/man8/rndc-confgen.8*
578 %{_mandir}/man8/tsig-keygen.8*
579 %lang(ja) %{_mandir}/ja/man8/named*
580
581 %{systemdtmpfilesdir}/%{name}.conf
582
583 %attr(770,root,named) %dir %{_var}/lib/named
584 %attr(770,root,named) %dir %{_var}/lib/named/D
585 %attr(770,root,named) %dir %{_var}/lib/named/M
586 %attr(770,root,named) %dir %{_var}/lib/named/S
587 %attr(770,root,named) %dir %{_var}/lib/named/dev
588 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
589 %attr(750,root,named) %dir %{_var}/lib/named/etc
590 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
591 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
592 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
593 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
594 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
595 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
596
597 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
598 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
599
600 %attr(770,root,named) %dir %{_var}/run/named
601
602 %dir %{_libdir}/named
603 %attr(755,root,root) %{_libdir}/named/filter-aaaa.so
604 %{_mandir}/man8/filter-aaaa.8*
605
606 %files utils
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/arpaname
609 %attr(755,root,root) %{_bindir}/delv
610 %attr(755,root,root) %{_bindir}/dig
611 %attr(755,root,root) %{_bindir}/host
612 %attr(755,root,root) %{_bindir}/named-rrchecker
613 %attr(755,root,root) %{_bindir}/mdig
614 %attr(755,root,root) %{_bindir}/nslookup
615 %attr(755,root,root) %{_bindir}/nsupdate
616 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
617 %{_mandir}/man1/arpaname.1*
618 %{_mandir}/man1/delv.1*
619 %{_mandir}/man1/dig.1*
620 %{_mandir}/man1/host.1*
621 %{_mandir}/man1/mdig.1*
622 %{_mandir}/man1/named-rrchecker.1*
623 %{_mandir}/man1/nslookup.1*
624 %{_mandir}/man1/nsupdate.1*
625
626 %lang(fi) %{_mandir}/fi/man1/host.1*
627
628 %lang(fr) %{_mandir}/fr/man1/host.1*
629
630 %lang(hu) %{_mandir}/hu/man1/host.1*
631
632 %lang(ja) %{_mandir}/ja/man1/dig.1*
633 %lang(ja) %{_mandir}/ja/man1/host.1*
634 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
635 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
636
637 %lang(pl) %{_mandir}/pl/man1/host.1*
638
639 %files libs
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
642 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1600
643 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
644 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1600
645 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
646 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1600
647 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
648 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1600
649 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1600
651 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1600
653 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libns.so.1600
655
656 %files devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libbind9.so
659 %attr(755,root,root) %{_libdir}/libdns.so
660 %attr(755,root,root) %{_libdir}/libirs.so
661 %attr(755,root,root) %{_libdir}/libisc.so
662 %attr(755,root,root) %{_libdir}/libisccc.so
663 %attr(755,root,root) %{_libdir}/libisccfg.so
664 %attr(755,root,root) %{_libdir}/libns.so
665 %{_libdir}/libbind9.la
666 %{_libdir}/libdns.la
667 %{_libdir}/libirs.la
668 %{_libdir}/libisc.la
669 %{_libdir}/libisccc.la
670 %{_libdir}/libisccfg.la
671 %{_libdir}/libns.la
672 %{_includedir}/bind9
673 %{_includedir}/dns
674 %{_includedir}/dst
675 %{_includedir}/irs
676 %{_includedir}/isc
677 %{_includedir}/isccc
678 %{_includedir}/isccfg
679 %{_includedir}/ns
680 %{_includedir}/pk11
681 %{_includedir}/pkcs11
682
683 %if %{with static_libs}
684 %files static
685 %defattr(644,root,root,755)
686 %{_libdir}/libbind9.a
687 %{_libdir}/libdns.a
688 %{_libdir}/libirs.a
689 %{_libdir}/libisc.a
690 %{_libdir}/libisccc.a
691 %{_libdir}/libisccfg.a
692 %{_libdir}/libns.a
693 %endif
694
695 %if %{with ldap}
696 %files -n openldap-schema-bind
697 %defattr(644,root,root,755)
698 %{_datadir}/openldap/schema/dnszone.schema
699 %endif
700
701 %files -n python3-isc
702 %defattr(644,root,root,755)
703 %{py3_sitedir}/isc
704 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.12723 seconds and 4 git commands to generate.