]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- TODO: geodns support
[packages/bind.git] / bind.spec
1 # TODO
2 # - schema regstering in openldap-schema-bind
3 # - apply http://www.caraytech.com/geodns/
4 #
5 # Conditional build:
6 %bcond_without  ssl             # build without OpenSSL support
7 %bcond_without  ipv6            # build without IPv6 support
8 %bcond_without  ldap            # build without LDAP support
9 %bcond_without  kerberos5       # build without kerneros5 support
10 %bcond_without  sql             # build without SQL support
11 %bcond_without  static_libs     # build without static libraries
12 %bcond_without  tests           # perform tests
13 %bcond_with     hip             # build with HIP RR support
14 #
15 Summary:        BIND - DNS name server
16 Summary(de.UTF-8):      BIND - DNS-Namenserver
17 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
18 Summary(fr.UTF-8):      BIND - serveur de noms DNS
19 Summary(pl.UTF-8):      BIND - serwer nazw DNS
20 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
21 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
22 Summary(tr.UTF-8):      DNS alan adı sunucusu
23 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
24 Summary(zh_CN.UTF-8):   Internet 域名服务器
25 %define ver     9.5.0
26 %define plevel  P2
27 Name:           bind
28 Version:        %{ver}.%{plevel}
29 Release:        3
30 Epoch:          7
31 License:        BSD-like
32 Group:          Networking/Daemons
33 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}-%{plevel}/%{name}-%{ver}-%{plevel}.tar.gz
34 # Source0-md5:  16c893f73a394c8cc36d7900cb9bb801
35 Source1:        named.init
36 Source2:        named.sysconfig
37 Source3:        named.logrotate
38 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
40 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
41 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
42 Source6:        %{name}-hip.tar.gz
43 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
44 Source7:        ftp://rs.internic.net/domain/named.root
45 # Source7-md5:  a94e29ac677846f3d4d618c50b7d34f1
46 Source8:        %{name}-127.0.0.zone
47 Source9:        %{name}-localhost.zone
48 Source10:       %{name}-named.conf
49 Patch0:         %{name}-time.patch
50 Patch1:         %{name}-autoconf.patch
51 Patch2:         %{name}-includedir-libbind.patch
52 Patch3:         %{name}-link.patch
53 Patch4:         %{name}-pmake.patch
54 Patch5:         %{name}-sdb-ldap.patch
55 Patch6:         %{name}-noinet6.patch
56 Patch7:         %{name}-chroot-numcpus.patch
57 URL:            http://www.isc.org/sw/bind/
58 BuildRequires:  autoconf
59 BuildRequires:  automake
60 BuildRequires:  bison
61 BuildRequires:  flex
62 BuildRequires:  idnkit-devel
63 %{?with_kerberos5:BuildRequires:        krb5-devel}
64 %{?with_hip:BuildRequires:      libxml2-devel}
65 BuildRequires:  libtool
66 %{?with_ldap:BuildRequires:     openldap-devel}
67 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
68 %{?with_sql:BuildRequires:      mysql-devel}
69 %{?with_sql:BuildRequires:      postgresql-devel}
70 %{?with_sql:BuildRequires:      unixODBC-devel}
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 Requires(post,preun):   /sbin/chkconfig
73 Requires(postun):       /usr/sbin/groupdel
74 Requires(postun):       /usr/sbin/userdel
75 Requires(pre):  /bin/id
76 Requires(pre):  /usr/bin/getgid
77 Requires(pre):  /usr/sbin/groupadd
78 Requires(pre):  /usr/sbin/useradd
79 Requires(pre):  fileutils
80 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
81 Requires:       psmisc >= 20.1
82 Requires:       rc-scripts >= 0.2.0
83 Provides:       group(named)
84 Provides:       nameserver
85 Provides:       user(named)
86 Obsoletes:      caching-nameserver
87 Conflicts:      %{name}-chroot
88 Conflicts:      kernel < 2.2.18
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
93 (Domain Name System) protocols. BIND includes a DNS server (named),
94 which resolves host names to IP addresses, and a resolver library
95 (routines for applications to use when interfacing with DNS). A DNS
96 server allows clients to name resources or objects and share the
97 information with other network machines. The named DNS server can be
98 used on workstations as a caching name server, but is generally only
99 needed on one machine for an entire network. Note that the
100 configuration files for making BIND act as a simple caching nameserver
101 are included in the caching-nameserver package.
102
103 Install the bind package if you need a DNS server for your network. If
104 you want bind to act a caching name server, you will also need to
105 install the caching-nameserver package.
106
107 %description -l de.UTF-8
108 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
109 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
110 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
111 Recher des Netzwerks erforderlich.
112
113 %description -l es.UTF-8
114 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
115 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
116 un servidor de nombres caché, pero generalmente sólo hace falta en una
117 máquina para toda la red.
118
119 %description -l fr.UTF-8
120 Contient le serveur de noms named, utilisé pour définir les
121 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
122 utilisé sur les stations de travail comme serveur de nom en cache mais
123 n'est souvent nécessaire que sur une machine pour un réseau entier.
124
125 %description -l pl.UTF-8
126 Pakiet ten zawiera demona named, który służy do zmieniania nazw
127 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
128 roboczych jako bufor odwołań do serwisu nazw (caching name server),
129 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
130 program na fragment sieci.
131
132 %description -l pt_BR.UTF-8
133 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
134 IP (e vice-versa). Pode ser usado em estações de trabalho como um
135 servidor de nomes cache, mas geralmente só é necessário em uma máquina
136 para toda a rede.
137
138 %description -l ru.UTF-8
139 BIND (Berkeley Internet Name Domain) является реализацией протоколов
140 DNS (Domain Name System). BIND включает DNS сервер (named) и
141 библиотеку "резолвера" (подпрограммы для приложений, через которые
142 происходят обращения к DNS). DNS сервер named может быть использован
143 на рабочих станциях как кеширующий сервер, но обычно запускается на
144 одной машине в локальной сети и используется остальными машинами (этим
145 достигается намного более эффективное кеширование).
146
147 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
148 кеширующего сервера, включены в пакет caching-nameserver.
149
150 %description -l tr.UTF-8
151 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
152 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
153 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
154 için sadece bir makina üzerinde kurulur.
155
156 %description -l uk.UTF-8
157 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
158 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
159 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
160 сервер named може бути використаний на робочих станціях як кешируючий
161 сервер, але звичайно запускається на одній машині в локальній мережі і
162 використовується іншими (цим досягається більша ефективність
163 використання кешу).
164
165 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
166 кешируючого серверу, включені в пакет caching-nameserver.
167
168 %package utils
169 Summary:        DNS utils - host, dig, dnsquery, nslookup
170 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
171 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
172 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
173 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
174 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
175 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
176 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
177 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
178 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
179 Group:          Networking/Utilities
180 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
181 Requires:       iconv
182
183 %description utils
184 Bind-utils contains a collection of utilities for querying DNS (Domain
185 Name Service) name servers to find out information about Internet
186 hosts. These tools will provide you with the IP addresses for given
187 host names, as well as other information about registered domains and
188 network addresses.
189
190 You should install bind-utils if you need to get information from DNS
191 name servers.
192
193 %description utils -l de.UTF-8
194 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
195 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
196 Informationen über registrierte Domains und Netzwerk-Adressen.
197
198 %description utils -l es.UTF-8
199 Conjunto de utilitarios para consulta a servidores de nombres. Estas
200 herramientas permiten la determinación de direcciones IP para nombres
201 de máquinas informados y busca información sobre dominios registrados
202 y direcciones de red.
203
204 %description utils -l fr.UTF-8
205 Ensemble d'utilitaires pour interroger les serveurs de noms et
206 rechercher des hôtes. Ces outils vous permettent de déterminer les
207 adresses IP pour des noms d'hôtes donnés, et trouver des informations
208 sur les noms de domaine déclarés et les adresses réseau.
209
210 %description utils -l pl.UTF-8
211 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
212 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
213 i ich adresach IP.
214
215 %description utils -l pt_BR.UTF-8
216 Conjunto de utilitários para consulta a servidores DNS. Estas
217 ferramentas permitem a determinação de endereços IP para nomes de
218 máquinas informados e busca informações sobre domínios registrados e
219 endereços de rede. Você deveria instalar este pacote se necessitar
220 obter informações de servidores DNS.
221
222 %description utils -l ru.UTF-8
223 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
224 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
225 доменному имени (и наоборот) и другую информацию о зарегистрированных
226 доменах и сетевых адресах.
227
228 %description utils -l tr.UTF-8
229 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
230 için kullanılan araçlar bulunmaktadır.
231
232 %description utils -l uk.UTF-8
233 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
234 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
235 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
236 домени та адреси.
237
238 %package libs
239 Summary:        DNS libraries
240 Summary(pl.UTF-8):      Biblioteki DNS
241 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
242 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
243 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
244 Group:          Libraries
245
246 %description libs
247 The bind-libs package contains all libraries required for running BIND
248 and bind utils.
249
250 %description libs -l pl.UTF-8
251 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
252 lub programów z pakietu bind-utils.
253
254 %description libs -l ru.UTF-8
255 Библиотеки, необходимые для работы bind.
256
257 %description libs -l uk.UTF-8
258 Бібліотеки, необхідні для роботи bind.
259
260 %package devel
261 Summary:        DNS development includes
262 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
263 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
264 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
265 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
266 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
267 Group:          Development/Libraries
268 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
269
270 %description devel
271 The bind-devel package contains all the include files and symlinks
272 required for DNS (Domain Name Service) development for BIND.
273
274 You should install bind-devel if you want to develop bind DNS
275 applications. If you install bind-devel, you'll also need to install
276 bind-libs.
277
278 %description devel -l es.UTF-8
279 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
280 para el bind.
281
282 %description devel -l pl.UTF-8
283 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
284 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
285 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
286 pakiet.
287
288 %description devel -l pt_BR.UTF-8
289 Todos os arquivos de cabeçalho e bibliotecas necessários para o
290 desenvolvimento com o bind.
291
292 %description devel -l ru.UTF-8
293 Все хедеры и библиотеки, необходимые для написания программ с
294 использованием BIND 9.x.x.
295
296 %description devel -l uk.UTF-8
297 Всі хедери та бібліотеки, необхідні для розробки програм з
298 використанням BIND 9.x.x.
299
300 %package static
301 Summary:        DNS static libs
302 Summary(pl.UTF-8):      Biblioteki statyczne DNS
303 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
304 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
305 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
306 Group:          Development/Libraries
307 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
308
309 %description static
310 Static bind libraries.
311
312 %description static -l pl.UTF-8
313 Statyczne biblioteki binda.
314
315 %description static -l pt_BR.UTF-8
316 Bibliotecas estáticas para desenvolvimento DNS.
317
318 %description static -l ru.UTF-8
319 Статические библиотеки, необходимые для написания программ с
320 использованием BIND.
321
322 %description static -l uk.UTF-8
323 Статичні бібліотеки, необхідні для розробки програм з використанням
324 BIND.
325
326 %package -n openldap-schema-bind
327 Summary:        BIND schema for openldap
328 Summary(pl.UTF-8):      Schemat BIND dla openldap
329 Group:          Development/Libraries
330 Requires:       %{name} = %{epoch}:%{version}-%{release}
331 Requires:       openldap-servers
332
333 %description -n openldap-schema-bind
334 BIND schema for openldap.
335
336 %description -n openldap-schema-bind -l pl.UTF-8
337 Schemat BIND dla openldap.
338
339 %prep
340 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}-%{plevel}
341 %patch0 -p1
342 %patch1 -p1
343 %patch2 -p1
344 %patch3 -p1
345 %patch4 -p1
346 %{?with_ldap:%patch5 -p1}
347 %patch6 -p1
348 %patch7 -p1
349 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
350
351
352 %build
353 %{__libtoolize}
354 %{__aclocal}
355 %{__autoconf}
356 cp -f /usr/share/automake/config.* .
357 cd lib/bind
358 %{__libtoolize}
359 %{__aclocal}
360 %{__autoconf}
361 cp -f /usr/share/automake/config.* .
362 cd ../..
363 %configure \
364         CFLAGS="-D_GNU_SOURCE=1" \
365         --with-idn \
366         --with-libtool \
367         %{?with_ssl:--with-openssl=%{_prefix}} \
368         %{?with_ipv6:--enable-ipv6} \
369         %{?with_kerberos5:--with-gssapi} \
370         --enable-libbind \
371         %{?with_sql:--with-dlz-postgres=yes} \
372         %{?with_sql:--with-dlz-mysql=yes} \
373         --with-dlz-bdb=no \
374         --with-dlz-filesystem=yes \
375         %{?with_ldap:--with-dlz-ldap=yes} \
376         --with-dlz-odbc=no \
377         --with-dlz-stub=yes \
378         --enable-largefile \
379         %{!?with_static_libs:--enable-static=no} \
380         --enable-threads \
381         --enable-getifaddrs=glibc
382
383 %{__make}
384 %{?with_hip:cd bind-hip/; %{__make}}
385
386 %{?with_tests:%{__make} test}
387
388 %install
389 rm -rf $RPM_BUILD_ROOT
390 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
391         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
392         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run,log}}
393
394 %{__make} install \
395         DESTDIR=$RPM_BUILD_ROOT
396
397 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
398 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
399 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
400
401 install bin/tests/named.conf            EXAMPLE-CONFIG-named
402 install bin/tests/ndc.conf              EXAMPLE-CONFIG-ndc
403 install %{SOURCE1}                      $RPM_BUILD_ROOT/etc/rc.d/init.d/named
404 install %{SOURCE2}                      $RPM_BUILD_ROOT/etc/sysconfig/named
405 install %{SOURCE3}                      $RPM_BUILD_ROOT/etc/logrotate.d/named
406 install %{SOURCE7}                      $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
407 install %{SOURCE8}                      $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
408 install %{SOURCE9}                      $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
409 install %{SOURCE10}                     $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
410
411 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
412 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
413 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
414
415 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
416
417 %{?with_ldap:install -d $RPM_BUILD_ROOT%{_datadir}/openldap/schema}
418 %{?with_ldap:install %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/openldap/schema/dnszone.schema}
419 %{?with_hip:install bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
420
421 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
422 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
423
424 # let rpm generate deps (workaround -m644 used for libs installation)
425 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
426
427 # we don't want Makefiles in documentation...
428 rm -rf _doc
429 cp -a doc _doc
430 rm -f _doc/rfc/rfc*
431 rm -f _doc/misc/Makefile*
432
433 %clean
434 rm -rf $RPM_BUILD_ROOT
435
436 %pre
437 if [ -f %{_sysconfdir}/named.boot ]; then
438         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
439         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
440         echo "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave." 1>&2
441 fi
442 %groupadd -g 58 named
443 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
444
445 %post
446 /sbin/chkconfig --add named
447 %service named restart
448
449 %preun
450 if [ "$1" = "0" ]; then
451         %service named stop
452         /sbin/chkconfig --del named
453 fi
454
455 %postun
456 if [ "$1" = "0" ]; then
457         %userremove named
458         %groupremove named
459 fi
460
461 %post   libs -p /sbin/ldconfig
462 %postun libs -p /sbin/ldconfig
463
464 %triggerpostun -- %{name} < 7:9.4.2-2
465 /sbin/chkconfig named reset
466 #triggerpostun -- %{name} < 6:9.4.1
467 sed -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
468 sed -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
469 sed -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
470
471 %files
472 %defattr(644,root,root,755)
473 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
474 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
475
476 %attr(754,root,root) /etc/rc.d/init.d/named
477 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
478 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
479 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
480
481 %attr(755,root,root) %{_sbindir}/*
482
483 %{_mandir}/man8/dns*
484 %{_mandir}/man8/lwres*
485 %{_mandir}/man8/named*
486 %{_mandir}/man8/rndc*
487 %{_mandir}/man5/rndc*
488 %{_mandir}/man5/named.conf*
489 %lang(ja) %{_mandir}/ja/man8/named*
490
491 %attr(770,root,named) %dir %{_var}/lib/named
492 %attr(770,root,named) %dir %{_var}/lib/named/D
493 %attr(750,root,named) %dir %{_var}/lib/named/M
494 %attr(770,root,named) %dir %{_var}/lib/named/S
495 %attr(750,root,named) %dir %{_var}/lib/named%{_sysconfdir}
496
497 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*
498 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.*
499 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named%{_sysconfdir}/*
500 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named*
501 %attr(660,named,named) %ghost  %{_var}/lib/named/named.log
502 %attr(660,named,named) %ghost  %{_var}/lib/named/named.stats
503
504 %files utils
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/dig
507 %attr(755,root,root) %{_bindir}/host
508 %attr(755,root,root) %{_bindir}/nslookup
509 %attr(755,root,root) %{_bindir}/nsupdate
510 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
511 %{_mandir}/man1/dig.1*
512 %{_mandir}/man1/host.1*
513 %{_mandir}/man1/nslookup.1*
514 %{_mandir}/man8/nsupdate.8*
515
516 %lang(fi) %{_mandir}/fi/man1/host.1*
517
518 %lang(fr) %{_mandir}/fr/man1/host.1*
519
520 %lang(hu) %{_mandir}/hu/man1/host.1*
521
522 %lang(ja) %{_mandir}/ja/man1/dig.1*
523 %lang(ja) %{_mandir}/ja/man1/host.1*
524 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
525 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
526
527 %lang(pl) %{_mandir}/pl/man1/host.1*
528
529 %files libs
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/libbind.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libbind.so.[0-9]
533 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
535 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
537 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
539 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
541 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
543 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
545
546 %files devel
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_bindir}/isc-config.sh
549 %attr(755,root,root) %{_libdir}/libbind.so
550 %attr(755,root,root) %{_libdir}/libbind9.so
551 %attr(755,root,root) %{_libdir}/libdns.so
552 %attr(755,root,root) %{_libdir}/libisc.so
553 %attr(755,root,root) %{_libdir}/libisccc.so
554 %attr(755,root,root) %{_libdir}/libisccfg.so
555 %attr(755,root,root) %{_libdir}/liblwres.so
556 %{_libdir}/libbind.la
557 %{_libdir}/libbind9.la
558 %{_libdir}/libdns.la
559 %{_libdir}/libisc.la
560 %{_libdir}/libisccc.la
561 %{_libdir}/libisccfg.la
562 %{_libdir}/liblwres.la
563 %{_includedir}/bind
564 %{_includedir}/bind9
565 %{_includedir}/dns
566 %{_includedir}/dst
567 %{_includedir}/isc
568 %{_includedir}/isccc
569 %{_includedir}/isccfg
570 %{_includedir}/lwres
571 %{_mandir}/man3/lwres*.3*
572
573 %if %{with static_libs}
574 %files static
575 %defattr(644,root,root,755)
576 %{_libdir}/libbind.a
577 %{_libdir}/libbind9.a
578 %{_libdir}/libdns.a
579 %{_libdir}/libisc.a
580 %{_libdir}/libisccc.a
581 %{_libdir}/libisccfg.a
582 %{_libdir}/liblwres.a
583 %endif
584
585 %if %{with ldap}
586 %files -n openldap-schema-bind
587 %defattr(644,root,root,755)
588 %{_datadir}/openldap/schema/dnszone.schema
589 %endif
This page took 0.084949 seconds and 4 git commands to generate.