]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
BR libatomic-devel (most likely needed only on some arch; needed on x86)
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_with     ldap            # LDAP DLZ support
10 %bcond_with     odbc            # ODBC DLZ support
11 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
12 %bcond_without  lmdb            # LMDB storage support for addzone zones
13 %bcond_without  static_libs     # static libraries
14 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
15 %bcond_with     tests           # unit tests
16 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
17 %bcond_with     hip             # HIP RR support
18
19 %if "%{pld_release}" == "ac"
20 %bcond_with     epoll           # enable epoll support
21 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
22 %ifarch %{x8664}
23 %define         with_epoll      1
24 %endif
25 %else
26 %bcond_without  epoll           # disable epoll support
27 %endif
28
29 %define         ver     9.16.22
30 %if 0
31 %define         pverdot .P0
32 %define         pverdir -P0
33 %else
34 %define         pverdot %{nil}
35 %define         pverdir %{nil}
36 %endif
37 Summary:        BIND - DNS name server
38 Summary(de.UTF-8):      BIND - DNS-Namenserver
39 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
40 Summary(fr.UTF-8):      BIND - serveur de noms DNS
41 Summary(pl.UTF-8):      BIND - serwer nazw DNS
42 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
43 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
44 Summary(tr.UTF-8):      DNS alan adı sunucusu
45 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
46 Summary(zh_CN.UTF-8):   Internet 域名服务器
47 Name:           bind
48 Version:        %{ver}%{pverdot}
49 Release:        2
50 Epoch:          7
51 License:        MPL 2.0
52 Group:          Networking/Daemons
53 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
54 # Source0-md5:  6a45478b33c04c830d4263635d8cd137
55 Source1:        named.init
56 Source2:        named.sysconfig
57 Source3:        named.logrotate
58 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
59 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
60 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
61 Source5:        dnszone-schema.txt
62 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
63 Source6:        %{name}-hip.tar.gz
64 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
65 Source7:        https://www.internic.net/domain/named.root
66 # Source7-md5:  3f5bdad0960fa1db701747c8e1169503
67 Source8:        %{name}-127.0.0.zone
68 Source9:        %{name}-localhost.zone
69 Source10:       %{name}-named.conf
70 Source11:       %{name}.tmpfiles
71 Source12:       named.service
72
73 Patch1:         %{name}-link.patch
74 Patch2:         %{name}-pmake.patch
75 Patch3:         %{name}-sdb-ldap.patch
76 Patch4:         %{name}-ac-libs.patch
77 Patch5:         %{name}-edns-client-subnet.patch
78 URL:            https://www.isc.org/software/bind
79 BuildRequires:  autoconf >= 2.60
80 BuildRequires:  automake
81 BuildRequires:  bison
82 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
83 BuildRequires:  flex
84 %{?with_kerberos5:BuildRequires:        heimdal-devel}
85 BuildRequires:  json-c-devel >= 0.11
86 BuildRequires:  libatomic-devel
87 BuildRequires:  libcap-devel
88 BuildRequires:  libidn2-devel
89 # note, there is no kyua in PLD yet (work in progress)
90 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
91 BuildRequires:  libtool
92 BuildRequires:  libuv-devel >= 1.37.0
93 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
94 BuildRequires:  libxml2-devel >= 1:2.6.0
95 %{?with_lmdb:BuildRequires:     lmdb-devel}
96 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
97 %{?with_sql:BuildRequires:      mysql-devel}
98 %{?with_ldap:BuildRequires:     openldap-devel}
99 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
100 BuildRequires:  pkgconfig
101 %{?with_sql:BuildRequires:      postgresql-devel}
102 BuildRequires:  python3-devel >= 1:3.2
103 BuildRequires:  python3-ply
104 BuildRequires:  python3-sphinx_rtd_theme
105 BuildRequires:  readline-devel
106 BuildRequires:  rpm >= 4.4.9-56
107 BuildRequires:  rpmbuild(macros) >= 1.647
108 BuildRequires:  sphinx-pdg
109 %{?with_odbc:BuildRequires:     unixODBC-devel}
110 BuildRequires:  zlib-devel
111 %if %{with dnstap}
112 BuildRequires:  fstrm-devel
113 BuildRequires:  protobuf-c-devel
114 %endif
115 Requires(post,preun):   /sbin/chkconfig
116 Requires(postun):       /usr/sbin/groupdel
117 Requires(postun):       /usr/sbin/userdel
118 Requires(pre):  /bin/id
119 Requires(pre):  /usr/bin/getgid
120 Requires(pre):  /usr/sbin/groupadd
121 Requires(pre):  /usr/sbin/useradd
122 Requires(pre):  fileutils
123 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
124 # for dnssec-{checkds,coverage,keymgr}
125 Requires:       python3-isc = %{epoch}:%{version}-%{release}
126 Requires:       psmisc >= 20.1
127 Requires:       rc-scripts >= 0.2.0
128 Requires:       systemd-units >= 38
129 Requires:       uname(release) >= 2.2.18
130 Provides:       group(named)
131 Provides:       nameserver
132 Provides:       user(named)
133 Obsoletes:      caching-nameserver
134 Conflicts:      %{name}-chroot
135 Conflicts:      logrotate < 3.8.0
136 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
137
138 %define         schemadir       /usr/share/openldap/schema
139
140 %description
141 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
142 (Domain Name System) protocols. BIND includes a DNS server (named),
143 which resolves host names to IP addresses, and a resolver library
144 (routines for applications to use when interfacing with DNS). A DNS
145 server allows clients to name resources or objects and share the
146 information with other network machines. The named DNS server can be
147 used on workstations as a caching name server, but is generally only
148 needed on one machine for an entire network. Note that the
149 configuration files for making BIND act as a simple caching nameserver
150 are included in the caching-nameserver package.
151
152 Install the bind package if you need a DNS server for your network. If
153 you want bind to act a caching name server, you will also need to
154 install the caching-nameserver package.
155
156 %description -l de.UTF-8
157 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
158 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
159 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
160 Recher des Netzwerks erforderlich.
161
162 %description -l es.UTF-8
163 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
164 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
165 un servidor de nombres caché, pero generalmente sólo hace falta en una
166 máquina para toda la red.
167
168 %description -l fr.UTF-8
169 Contient le serveur de noms named, utilisé pour définir les
170 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
171 utilisé sur les stations de travail comme serveur de nom en cache mais
172 n'est souvent nécessaire que sur une machine pour un réseau entier.
173
174 %description -l pl.UTF-8
175 Pakiet ten zawiera demona named, który służy do zmieniania nazw
176 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
177 roboczych jako bufor odwołań do serwisu nazw (caching name server),
178 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
179 program na fragment sieci.
180
181 %description -l pt_BR.UTF-8
182 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
183 IP (e vice-versa). Pode ser usado em estações de trabalho como um
184 servidor de nomes cache, mas geralmente só é necessário em uma máquina
185 para toda a rede.
186
187 %description -l ru.UTF-8
188 BIND (Berkeley Internet Name Domain) является реализацией протоколов
189 DNS (Domain Name System). BIND включает DNS сервер (named) и
190 библиотеку "резолвера" (подпрограммы для приложений, через которые
191 происходят обращения к DNS). DNS сервер named может быть использован
192 на рабочих станциях как кеширующий сервер, но обычно запускается на
193 одной машине в локальной сети и используется остальными машинами (этим
194 достигается намного более эффективное кеширование).
195
196 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
197 кеширующего сервера, включены в пакет caching-nameserver.
198
199 %description -l tr.UTF-8
200 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
201 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
202 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
203 için sadece bir makina üzerinde kurulur.
204
205 %description -l uk.UTF-8
206 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
207 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
208 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
209 сервер named може бути використаний на робочих станціях як кешируючий
210 сервер, але звичайно запускається на одній машині в локальній мережі і
211 використовується іншими (цим досягається більша ефективність
212 використання кешу).
213
214 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
215 кешируючого серверу, включені в пакет caching-nameserver.
216
217 %package utils
218 Summary:        DNS utils - host, dig, dnsquery, nslookup
219 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
220 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
221 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
222 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
223 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
224 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
225 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
226 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
227 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
228 Group:          Networking/Utilities
229 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
230 Requires:       iconv
231
232 %description utils
233 Bind-utils contains a collection of utilities for querying DNS (Domain
234 Name Service) name servers to find out information about Internet
235 hosts. These tools will provide you with the IP addresses for given
236 host names, as well as other information about registered domains and
237 network addresses.
238
239 You should install bind-utils if you need to get information from DNS
240 name servers.
241
242 %description utils -l de.UTF-8
243 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
244 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
245 Informationen über registrierte Domains und Netzwerk-Adressen.
246
247 %description utils -l es.UTF-8
248 Conjunto de utilitarios para consulta a servidores de nombres. Estas
249 herramientas permiten la determinación de direcciones IP para nombres
250 de máquinas informados y busca información sobre dominios registrados
251 y direcciones de red.
252
253 %description utils -l fr.UTF-8
254 Ensemble d'utilitaires pour interroger les serveurs de noms et
255 rechercher des hôtes. Ces outils vous permettent de déterminer les
256 adresses IP pour des noms d'hôtes donnés, et trouver des informations
257 sur les noms de domaine déclarés et les adresses réseau.
258
259 %description utils -l pl.UTF-8
260 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
261 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
262 i ich adresach IP.
263
264 %description utils -l pt_BR.UTF-8
265 Conjunto de utilitários para consulta a servidores DNS. Estas
266 ferramentas permitem a determinação de endereços IP para nomes de
267 máquinas informados e busca informações sobre domínios registrados e
268 endereços de rede. Você deveria instalar este pacote se necessitar
269 obter informações de servidores DNS.
270
271 %description utils -l ru.UTF-8
272 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
273 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
274 доменному имени (и наоборот) и другую информацию о зарегистрированных
275 доменах и сетевых адресах.
276
277 %description utils -l tr.UTF-8
278 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
279 için kullanılan araçlar bulunmaktadır.
280
281 %description utils -l uk.UTF-8
282 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
283 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
284 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
285 домени та адреси.
286
287 %package libs
288 Summary:        DNS libraries
289 Summary(pl.UTF-8):      Biblioteki DNS
290 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
291 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
292 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
293 Group:          Libraries
294 Requires:       json-c >= 0.11
295 Requires:       libuv >= 1.37.0
296 Requires:       libxml2 >= 1:2.6.0
297
298 %description libs
299 The bind-libs package contains all libraries required for running BIND
300 and bind utils.
301
302 %description libs -l pl.UTF-8
303 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
304 lub programów z pakietu bind-utils.
305
306 %description libs -l ru.UTF-8
307 Библиотеки, необходимые для работы bind.
308
309 %description libs -l uk.UTF-8
310 Бібліотеки, необхідні для роботи bind.
311
312 %package devel
313 Summary:        DNS development includes
314 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
315 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
316 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
317 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
318 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
319 Group:          Development/Libraries
320 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
321
322 %description devel
323 The bind-devel package contains all the include files and symlinks
324 required for DNS (Domain Name Service) development for BIND.
325
326 You should install bind-devel if you want to develop bind DNS
327 applications. If you install bind-devel, you'll also need to install
328 bind-libs.
329
330 %description devel -l es.UTF-8
331 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
332 para el bind.
333
334 %description devel -l pl.UTF-8
335 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
336 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
337 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
338 pakiet.
339
340 %description devel -l pt_BR.UTF-8
341 Todos os arquivos de cabeçalho e bibliotecas necessários para o
342 desenvolvimento com o bind.
343
344 %description devel -l ru.UTF-8
345 Все хедеры и библиотеки, необходимые для написания программ с
346 использованием BIND 9.x.x.
347
348 %description devel -l uk.UTF-8
349 Всі хедери та бібліотеки, необхідні для розробки програм з
350 використанням BIND 9.x.x.
351
352 %package static
353 Summary:        DNS static libs
354 Summary(pl.UTF-8):      Biblioteki statyczne DNS
355 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
356 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
357 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
358 Group:          Development/Libraries
359 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
360
361 %description static
362 Static bind libraries.
363
364 %description static -l pl.UTF-8
365 Statyczne biblioteki binda.
366
367 %description static -l pt_BR.UTF-8
368 Bibliotecas estáticas para desenvolvimento DNS.
369
370 %description static -l ru.UTF-8
371 Статические библиотеки, необходимые для написания программ с
372 использованием BIND.
373
374 %description static -l uk.UTF-8
375 Статичні бібліотеки, необхідні для розробки програм з використанням
376 BIND.
377
378 %package -n openldap-schema-bind
379 Summary:        BIND schema for openldap
380 Summary(pl.UTF-8):      Schemat BIND dla openldap
381 Group:          Development/Libraries
382 Requires(post,postun):  sed >= 4.0
383 Requires:       openldap-servers
384 Requires:       sed >= 4.0
385 BuildArch:      noarch
386
387 %description -n openldap-schema-bind
388 BIND schema for openldap.
389
390 %description -n openldap-schema-bind -l pl.UTF-8
391 Schemat BIND dla openldap.
392
393 %package -n python3-isc
394 Summary:        Python 3 ISC module - functions to support BIND utilities
395 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
396 Group:          Libraries/Python
397 Requires:       python3-modules
398
399 %description -n python3-isc
400 Python 3 ISC module containing functions to support BIND utilities.
401
402 %description -n python3-isc -l pl.UTF-8
403 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
404 BIND-a.
405
406 %prep
407 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
408
409 %patch1 -p1
410 %patch2 -p1
411 %{?with_ldap:%patch3 -p1}
412 %patch4 -p1
413 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
414 %{?with_edns_cli:%patch5 -p0}
415
416 %build
417 %{__libtoolize}
418 %{__aclocal}
419 %{__autoconf}
420 cp -f /usr/share/automake/config.* .
421 %configure \
422         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
423         LDFLAGS="%{rpmldflags}" \
424         %{?with_dnstap:--enable-dnstap} \
425         %{!?with_epoll:--disable-epoll --disable-devpoll} \
426         --enable-full-report \
427         --enable-largefile \
428         %{!?with_static_libs:--disable-static} \
429         %{?with_kerberos5:--with-gssapi} \
430         --with-libidn2 \
431         --with-libtool \
432         --with-libxml2 \
433         %{?with_ssl:--with-openssl} \
434         %{?with_sql:--with-dlz-postgres} \
435         %{?with_sql:--with-dlz-mysql} \
436         --without-dlz-bdb \
437         --with-dlz-filesystem \
438         %{?with_ldap:--with-dlz-ldap} \
439         --with-dlz-odbc%{!?with_odbc:=no} \
440         --with-dlz-stub \
441         %{?with_geoip:--with-maxminddb} \
442         --with-lmdb%{!?with_lmdb:=no} \
443         --with-python=%{__python3} \
444         --with-tuning
445
446 %{__make}
447 %{__make} -C doc/arm html
448
449 %{?with_hip:%{__make} -C bind-hip}
450
451 %if %{with tests}
452 %if %{with system_tests}
453 %{__make} test-force
454 %else
455 sh unit/unittest.sh
456 %endif
457 %endif
458
459 %install
460 rm -rf $RPM_BUILD_ROOT
461 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
462         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
463         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
464         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
465
466 %{__make} install \
467         DESTDIR=$RPM_BUILD_ROOT
468
469 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
470 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
471 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
472 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
473
474 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
475 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
476 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
477 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
478 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
479 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
480 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
481 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
482 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
483
484 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
485 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
486 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
487 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
488
489 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
490
491 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
492 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
493
494 %if %{with ldap}
495 install -d $RPM_BUILD_ROOT%{schemadir}
496 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
497 %endif
498
499 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
500
501 # we don't want Makefiles in documentation...
502 rm -rf _doc
503 cp -a doc _doc
504 %{__rm} _doc/misc/Makefile*
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %pre
510 if [ -f %{_sysconfdir}/named.boot ]; then
511         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
512         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
513         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
514 fi
515 %groupadd -g 58 named
516 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
517
518 %post
519 /sbin/chkconfig --add named
520 %service named restart
521 %systemd_post named.service
522
523 %preun
524 if [ "$1" = "0" ]; then
525         %service named stop
526         /sbin/chkconfig --del named
527 fi
528 %systemd_preun named.service
529
530 %postun
531 if [ "$1" = "0" ]; then
532         %userremove named
533         %groupremove named
534 fi
535 %systemd_reload
536
537 %post   libs -p /sbin/ldconfig
538 %postun libs -p /sbin/ldconfig
539
540 %post -n openldap-schema-bind
541 %openldap_schema_register %{schemadir}/dnszone.schema
542 %service -q ldap restart
543
544 %postun -n openldap-schema-bind
545 if [ "$1" = "0" ]; then
546         %openldap_schema_unregister %{schemadir}/dnszone.schema
547         %service -q ldap restart
548 fi
549
550 %triggerpostun -- %{name} < 7:9.9.2.P2-2
551 %systemd_trigger named.service
552
553 %files
554 %defattr(644,root,root,755)
555 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
556 %doc _doc/misc/* _doc/arm/_build/html/*.html %{?with_ldap:_doc/*.sdb-ldap}
557
558 %{systemdunitdir}/named.service
559 %attr(754,root,root) /etc/rc.d/init.d/named
560 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
562 %{_sysconfdir}/named.conf
563 %{_sysconfdir}/bind.keys
564
565 %attr(755,root,root) %{_sbindir}/ddns-confgen
566 %attr(755,root,root) %{_sbindir}/dnssec-*
567 %attr(755,root,root) %{_sbindir}/named
568 %attr(755,root,root) %{_sbindir}/named-*
569 %attr(755,root,root) %{_sbindir}/nsec3hash
570 %attr(755,root,root) %{_sbindir}/rndc
571 %attr(755,root,root) %{_sbindir}/rndc-confgen
572 %attr(755,root,root) %{_sbindir}/tsig-keygen
573
574 %{_mandir}/man5/named.conf.5*
575 %{_mandir}/man5/rndc.conf.5*
576 %{_mandir}/man8/ddns-confgen.8*
577 %{_mandir}/man8/dnssec-*.8*
578 %{_mandir}/man8/named.8*
579 %{_mandir}/man8/named-*.8*
580 %{_mandir}/man8/nsec3hash.8*
581 %{_mandir}/man8/rndc.8*
582 %{_mandir}/man8/rndc-confgen.8*
583 %{_mandir}/man8/tsig-keygen.8*
584 %lang(ja) %{_mandir}/ja/man8/named*
585
586 %{systemdtmpfilesdir}/%{name}.conf
587
588 %attr(770,root,named) %dir %{_var}/lib/named
589 %attr(770,root,named) %dir %{_var}/lib/named/D
590 %attr(770,root,named) %dir %{_var}/lib/named/M
591 %attr(770,root,named) %dir %{_var}/lib/named/S
592 %attr(770,root,named) %dir %{_var}/lib/named/dev
593 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
594 %attr(750,root,named) %dir %{_var}/lib/named/etc
595 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
596 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
597 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
598 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
599 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
600 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
601
602 %config(noreplace,missingok) %{_var}/log/named
603 %config(noreplace,missingok) %{_var}/log/named.stats
604
605 %attr(770,root,named) %dir %{_var}/run/named
606
607 %dir %{_libdir}/named
608 %attr(755,root,root) %{_libdir}/named/filter-aaaa.so
609 %{_mandir}/man8/filter-aaaa.8*
610
611 %files utils
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/arpaname
614 %attr(755,root,root) %{_bindir}/delv
615 %attr(755,root,root) %{_bindir}/dig
616 %attr(755,root,root) %{_bindir}/host
617 %attr(755,root,root) %{_bindir}/named-rrchecker
618 %attr(755,root,root) %{_bindir}/mdig
619 %attr(755,root,root) %{_bindir}/nslookup
620 %attr(755,root,root) %{_bindir}/nsupdate
621 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
622 %{_mandir}/man1/arpaname.1*
623 %{_mandir}/man1/delv.1*
624 %{_mandir}/man1/dig.1*
625 %{_mandir}/man1/host.1*
626 %{_mandir}/man1/mdig.1*
627 %{_mandir}/man1/named-rrchecker.1*
628 %{_mandir}/man1/nslookup.1*
629 %{_mandir}/man1/nsupdate.1*
630
631 %lang(fi) %{_mandir}/fi/man1/host.1*
632
633 %lang(fr) %{_mandir}/fr/man1/host.1*
634
635 %lang(hu) %{_mandir}/hu/man1/host.1*
636
637 %lang(ja) %{_mandir}/ja/man1/dig.1*
638 %lang(ja) %{_mandir}/ja/man1/host.1*
639 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
640 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
641
642 %lang(pl) %{_mandir}/pl/man1/host.1*
643
644 %files libs
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
647 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
648 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
649 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
650 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
651 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
652 %attr(755,root,root) %{_libdir}/libns-%{version}.so
653
654 %files devel
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/libbind9.so
657 %attr(755,root,root) %{_libdir}/libdns.so
658 %attr(755,root,root) %{_libdir}/libirs.so
659 %attr(755,root,root) %{_libdir}/libisc.so
660 %attr(755,root,root) %{_libdir}/libisccc.so
661 %attr(755,root,root) %{_libdir}/libisccfg.so
662 %attr(755,root,root) %{_libdir}/libns.so
663 %{_libdir}/libbind9.la
664 %{_libdir}/libdns.la
665 %{_libdir}/libirs.la
666 %{_libdir}/libisc.la
667 %{_libdir}/libisccc.la
668 %{_libdir}/libisccfg.la
669 %{_libdir}/libns.la
670 %{_includedir}/bind9
671 %{_includedir}/dns
672 %{_includedir}/dst
673 %{_includedir}/irs
674 %{_includedir}/isc
675 %{_includedir}/isccc
676 %{_includedir}/isccfg
677 %{_includedir}/ns
678 %{_includedir}/pk11
679 %{_includedir}/pkcs11
680
681 %if %{with static_libs}
682 %files static
683 %defattr(644,root,root,755)
684 %{_libdir}/libbind9.a
685 %{_libdir}/libdns.a
686 %{_libdir}/libirs.a
687 %{_libdir}/libisc.a
688 %{_libdir}/libisccc.a
689 %{_libdir}/libisccfg.a
690 %{_libdir}/libns.a
691 %endif
692
693 %if %{with ldap}
694 %files -n openldap-schema-bind
695 %defattr(644,root,root,755)
696 %{_datadir}/openldap/schema/dnszone.schema
697 %endif
698
699 %files -n python3-isc
700 %defattr(644,root,root,755)
701 %{py3_sitedir}/isc
702 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.117931 seconds and 4 git commands to generate.