]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- dnszone-schema.txt no longer available at original URL
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  geoip           # GeoIP support
6 %bcond_without  kerberos5       # GSS-API support
7 %bcond_without  ssl             # OpenSSL support
8 %bcond_with     ldap            # LDAP DLZ support
9 %bcond_with     odbc            # ODBC DLZ support
10 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
11 %bcond_without  lmdb            # LMDB storage support for addzone zones
12 %bcond_without  static_libs     # static libraries
13 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
14 %bcond_with     tests           # unit tests
15 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
16 %bcond_with     hip             # HIP RR support
17
18 %if "%{pld_release}" == "ac"
19 %bcond_with     epoll           # enable epoll support
20 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
21 %ifarch %{x8664}
22 %define         with_epoll      1
23 %endif
24 %else
25 %bcond_without  epoll           # disable epoll support
26 %endif
27
28 %define         ver     9.16.0
29 %if 0
30 %define         pverdot .P0
31 %define         pverdir -P0
32 %else
33 %define         pverdot %{nil}
34 %define         pverdir %{nil}
35 %endif
36 Summary:        BIND - DNS name server
37 Summary(de.UTF-8):      BIND - DNS-Namenserver
38 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
39 Summary(fr.UTF-8):      BIND - serveur de noms DNS
40 Summary(pl.UTF-8):      BIND - serwer nazw DNS
41 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
42 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
43 Summary(tr.UTF-8):      DNS alan adı sunucusu
44 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
45 Summary(zh_CN.UTF-8):   Internet 域名服务器
46 Name:           bind
47 Version:        %{ver}%{pverdot}
48 Release:        1
49 Epoch:          7
50 License:        MPL 2.0
51 Group:          Networking/Daemons
52 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
53 # Source0-md5:  f973848bf32797c5f546de7d92a6fd07
54 Source1:        named.init
55 Source2:        named.sysconfig
56 Source3:        named.logrotate
57 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
58 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
59 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
60 Source5:        dnszone-schema.txt
61 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
62 Source6:        %{name}-hip.tar.gz
63 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
64 Source7:        https://www.internic.net/domain/named.root
65 # Source7-md5:  7cee6519fca7a4a6e771633560e55d53
66 Source8:        %{name}-127.0.0.zone
67 Source9:        %{name}-localhost.zone
68 Source10:       %{name}-named.conf
69 Source11:       %{name}.tmpfiles
70 Source12:       named.service
71 Patch0:         %{name}-time.patch
72 Patch1:         %{name}-link.patch
73 Patch2:         %{name}-pmake.patch
74 Patch3:         %{name}-sdb-ldap.patch
75 Patch4:         %{name}-ac-libs.patch
76 Patch5:         %{name}-edns-client-subnet.patch
77 Patch6:         nsupdate_segfault.patch
78 URL:            https://www.isc.org/software/bind
79 BuildRequires:  autoconf >= 2.59
80 BuildRequires:  automake
81 BuildRequires:  bison
82 BuildRequires:  flex
83 %{?with_kerberos5:BuildRequires:        heimdal-devel}
84 BuildRequires:  json-c-devel
85 BuildRequires:  libidn2-devel
86 # note, there is no kyua in PLD yet (work in progress)
87 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
88 BuildRequires:  libtool
89 BuildRequires:  libuv-devel >= 1.0.0
90 %{?with_hip:BuildRequires:      libxml2-devel}
91 %{?with_lmdb:BuildRequires:     lmdb-devel}
92 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
93 %{?with_sql:BuildRequires:      mysql-devel}
94 %{?with_ldap:BuildRequires:     openldap-devel}
95 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
96 %{?with_sql:BuildRequires:      postgresql-devel}
97 BuildRequires:  python3-devel
98 BuildRequires:  python3-ply
99 BuildRequires:  readline-devel
100 BuildRequires:  rpm >= 4.4.9-56
101 BuildRequires:  rpmbuild(macros) >= 1.647
102 %{?with_odbc:BuildRequires:     unixODBC-devel}
103 BuildRequires:  zlib-devel
104 Requires(post,preun):   /sbin/chkconfig
105 Requires(postun):       /usr/sbin/groupdel
106 Requires(postun):       /usr/sbin/userdel
107 Requires(pre):  /bin/id
108 Requires(pre):  /usr/bin/getgid
109 Requires(pre):  /usr/sbin/groupadd
110 Requires(pre):  /usr/sbin/useradd
111 Requires(pre):  fileutils
112 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
113 # for dnssec-{checkds,coverage,keymgr}
114 Requires:       python3-isc = %{epoch}:%{version}-%{release}
115 Requires:       psmisc >= 20.1
116 Requires:       rc-scripts >= 0.2.0
117 Requires:       systemd-units >= 38
118 Requires:       uname(release) >= 2.2.18
119 Provides:       group(named)
120 Provides:       nameserver
121 Provides:       user(named)
122 Obsoletes:      caching-nameserver
123 Conflicts:      %{name}-chroot
124 Conflicts:      logrotate < 3.8.0
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         schemadir       /usr/share/openldap/schema
128
129 %description
130 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
131 (Domain Name System) protocols. BIND includes a DNS server (named),
132 which resolves host names to IP addresses, and a resolver library
133 (routines for applications to use when interfacing with DNS). A DNS
134 server allows clients to name resources or objects and share the
135 information with other network machines. The named DNS server can be
136 used on workstations as a caching name server, but is generally only
137 needed on one machine for an entire network. Note that the
138 configuration files for making BIND act as a simple caching nameserver
139 are included in the caching-nameserver package.
140
141 Install the bind package if you need a DNS server for your network. If
142 you want bind to act a caching name server, you will also need to
143 install the caching-nameserver package.
144
145 %description -l de.UTF-8
146 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
147 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
148 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
149 Recher des Netzwerks erforderlich.
150
151 %description -l es.UTF-8
152 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
153 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
154 un servidor de nombres caché, pero generalmente sólo hace falta en una
155 máquina para toda la red.
156
157 %description -l fr.UTF-8
158 Contient le serveur de noms named, utilisé pour définir les
159 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
160 utilisé sur les stations de travail comme serveur de nom en cache mais
161 n'est souvent nécessaire que sur une machine pour un réseau entier.
162
163 %description -l pl.UTF-8
164 Pakiet ten zawiera demona named, który służy do zmieniania nazw
165 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
166 roboczych jako bufor odwołań do serwisu nazw (caching name server),
167 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
168 program na fragment sieci.
169
170 %description -l pt_BR.UTF-8
171 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
172 IP (e vice-versa). Pode ser usado em estações de trabalho como um
173 servidor de nomes cache, mas geralmente só é necessário em uma máquina
174 para toda a rede.
175
176 %description -l ru.UTF-8
177 BIND (Berkeley Internet Name Domain) является реализацией протоколов
178 DNS (Domain Name System). BIND включает DNS сервер (named) и
179 библиотеку "резолвера" (подпрограммы для приложений, через которые
180 происходят обращения к DNS). DNS сервер named может быть использован
181 на рабочих станциях как кеширующий сервер, но обычно запускается на
182 одной машине в локальной сети и используется остальными машинами (этим
183 достигается намного более эффективное кеширование).
184
185 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
186 кеширующего сервера, включены в пакет caching-nameserver.
187
188 %description -l tr.UTF-8
189 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
190 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
191 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
192 için sadece bir makina üzerinde kurulur.
193
194 %description -l uk.UTF-8
195 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
196 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
197 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
198 сервер named може бути використаний на робочих станціях як кешируючий
199 сервер, але звичайно запускається на одній машині в локальній мережі і
200 використовується іншими (цим досягається більша ефективність
201 використання кешу).
202
203 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
204 кешируючого серверу, включені в пакет caching-nameserver.
205
206 %package utils
207 Summary:        DNS utils - host, dig, dnsquery, nslookup
208 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
209 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
210 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
211 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
212 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
213 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
214 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
215 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
216 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
217 Group:          Networking/Utilities
218 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
219 Requires:       iconv
220
221 %description utils
222 Bind-utils contains a collection of utilities for querying DNS (Domain
223 Name Service) name servers to find out information about Internet
224 hosts. These tools will provide you with the IP addresses for given
225 host names, as well as other information about registered domains and
226 network addresses.
227
228 You should install bind-utils if you need to get information from DNS
229 name servers.
230
231 %description utils -l de.UTF-8
232 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
233 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
234 Informationen über registrierte Domains und Netzwerk-Adressen.
235
236 %description utils -l es.UTF-8
237 Conjunto de utilitarios para consulta a servidores de nombres. Estas
238 herramientas permiten la determinación de direcciones IP para nombres
239 de máquinas informados y busca información sobre dominios registrados
240 y direcciones de red.
241
242 %description utils -l fr.UTF-8
243 Ensemble d'utilitaires pour interroger les serveurs de noms et
244 rechercher des hôtes. Ces outils vous permettent de déterminer les
245 adresses IP pour des noms d'hôtes donnés, et trouver des informations
246 sur les noms de domaine déclarés et les adresses réseau.
247
248 %description utils -l pl.UTF-8
249 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
250 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
251 i ich adresach IP.
252
253 %description utils -l pt_BR.UTF-8
254 Conjunto de utilitários para consulta a servidores DNS. Estas
255 ferramentas permitem a determinação de endereços IP para nomes de
256 máquinas informados e busca informações sobre domínios registrados e
257 endereços de rede. Você deveria instalar este pacote se necessitar
258 obter informações de servidores DNS.
259
260 %description utils -l ru.UTF-8
261 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
262 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
263 доменному имени (и наоборот) и другую информацию о зарегистрированных
264 доменах и сетевых адресах.
265
266 %description utils -l tr.UTF-8
267 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
268 için kullanılan araçlar bulunmaktadır.
269
270 %description utils -l uk.UTF-8
271 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
272 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
273 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
274 домени та адреси.
275
276 %package libs
277 Summary:        DNS libraries
278 Summary(pl.UTF-8):      Biblioteki DNS
279 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
280 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
281 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
282 Group:          Libraries
283
284 %description libs
285 The bind-libs package contains all libraries required for running BIND
286 and bind utils.
287
288 %description libs -l pl.UTF-8
289 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
290 lub programów z pakietu bind-utils.
291
292 %description libs -l ru.UTF-8
293 Библиотеки, необходимые для работы bind.
294
295 %description libs -l uk.UTF-8
296 Бібліотеки, необхідні для роботи bind.
297
298 %package devel
299 Summary:        DNS development includes
300 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
301 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
302 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
303 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
304 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
305 Group:          Development/Libraries
306 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
307
308 %description devel
309 The bind-devel package contains all the include files and symlinks
310 required for DNS (Domain Name Service) development for BIND.
311
312 You should install bind-devel if you want to develop bind DNS
313 applications. If you install bind-devel, you'll also need to install
314 bind-libs.
315
316 %description devel -l es.UTF-8
317 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
318 para el bind.
319
320 %description devel -l pl.UTF-8
321 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
322 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
323 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
324 pakiet.
325
326 %description devel -l pt_BR.UTF-8
327 Todos os arquivos de cabeçalho e bibliotecas necessários para o
328 desenvolvimento com o bind.
329
330 %description devel -l ru.UTF-8
331 Все хедеры и библиотеки, необходимые для написания программ с
332 использованием BIND 9.x.x.
333
334 %description devel -l uk.UTF-8
335 Всі хедери та бібліотеки, необхідні для розробки програм з
336 використанням BIND 9.x.x.
337
338 %package static
339 Summary:        DNS static libs
340 Summary(pl.UTF-8):      Biblioteki statyczne DNS
341 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
342 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
343 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
344 Group:          Development/Libraries
345 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
346
347 %description static
348 Static bind libraries.
349
350 %description static -l pl.UTF-8
351 Statyczne biblioteki binda.
352
353 %description static -l pt_BR.UTF-8
354 Bibliotecas estáticas para desenvolvimento DNS.
355
356 %description static -l ru.UTF-8
357 Статические библиотеки, необходимые для написания программ с
358 использованием BIND.
359
360 %description static -l uk.UTF-8
361 Статичні бібліотеки, необхідні для розробки програм з використанням
362 BIND.
363
364 %package -n openldap-schema-bind
365 Summary:        BIND schema for openldap
366 Summary(pl.UTF-8):      Schemat BIND dla openldap
367 Group:          Development/Libraries
368 Requires(post,postun):  sed >= 4.0
369 Requires:       openldap-servers
370 Requires:       sed >= 4.0
371 %if "%{_rpmversion}" >= "5"
372 BuildArch:      noarch
373 %endif
374
375 %description -n openldap-schema-bind
376 BIND schema for openldap.
377
378 %description -n openldap-schema-bind -l pl.UTF-8
379 Schemat BIND dla openldap.
380
381 %package -n python3-isc
382 Summary:        Python 3 ISC module - functions to support BIND utilities
383 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
384 Group:          Libraries/Python
385 Requires:       python3-modules
386
387 %description -n python3-isc
388 Python 3 ISC module containing functions to support BIND utilities.
389
390 %description -n python3-isc -l pl.UTF-8
391 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
392 BIND-a.
393
394 %prep
395 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
396 %patch0 -p1
397 %patch1 -p1
398 %patch2 -p1
399 %{?with_ldap:%patch3 -p1}
400 %patch4 -p1
401 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
402 %{?with_edns_cli:%patch5 -p0}
403 %patch6 -p0
404
405 %build
406 %{__libtoolize}
407 %{__aclocal}
408 %{__autoconf}
409 cp -f /usr/share/automake/config.* .
410 %configure \
411         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
412         %{!?with_epoll:--disable-epoll --disable-devpoll} \
413         --enable-full-report \
414         --enable-largefile \
415         %{!?with_static_libs:--disable-static} \
416         %{?with_kerberos5:--with-gssapi} \
417         --with-libidn2 \
418         --with-libtool \
419         %{?with_ssl:--with-openssl} \
420         %{?with_sql:--with-dlz-postgres} \
421         %{?with_sql:--with-dlz-mysql} \
422         --without-dlz-bdb \
423         --with-dlz-filesystem \
424         %{?with_ldap:--with-dlz-ldap} \
425         --with-dlz-odbc%{!?with_odbc:=no} \
426         --with-dlz-stub \
427         %{?with_geoip:--with-maxminddb} \
428         --with-lmdb%{!?with_lmdb:=no} \
429         --with-python=%{__python3}
430
431 %{__make}
432
433 %{?with_hip:%{__make} -C bind-hip}
434
435 %if %{with tests}
436 %if %{with system_tests}
437 %{__make} test-force
438 %else
439 sh unit/unittest.sh
440 %endif
441 %endif
442
443 %install
444 rm -rf $RPM_BUILD_ROOT
445 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
446         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
447         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
448         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
449
450 %{__make} install \
451         DESTDIR=$RPM_BUILD_ROOT
452
453 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
454 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
455 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
456 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
457
458 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
459 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
460 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
461 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
462 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
463 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
464 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
465 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
466 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
467
468 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
469 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
470 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
471 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
472
473 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
474
475 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
476 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
477
478 %if %{with ldap}
479 install -d $RPM_BUILD_ROOT%{schemadir}
480 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
481 %endif
482
483 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
484
485 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
486 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
487
488 # let rpm generate deps (workaround -m644 used for libs installation)
489 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
490
491 # we don't want Makefiles in documentation...
492 rm -rf _doc
493 cp -a doc _doc
494 %{__rm} _doc/misc/Makefile*
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %pre
500 if [ -f %{_sysconfdir}/named.boot ]; then
501         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
502         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
503         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
504 fi
505 %groupadd -g 58 named
506 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
507
508 %post
509 /sbin/chkconfig --add named
510 %service named restart
511 %systemd_post named.service
512
513 %preun
514 if [ "$1" = "0" ]; then
515         %service named stop
516         /sbin/chkconfig --del named
517 fi
518 %systemd_preun named.service
519
520 %postun
521 if [ "$1" = "0" ]; then
522         %userremove named
523         %groupremove named
524 fi
525 %systemd_reload
526
527 %post   libs -p /sbin/ldconfig
528 %postun libs -p /sbin/ldconfig
529
530 %post -n openldap-schema-bind
531 %openldap_schema_register %{schemadir}/dnszone.schema
532 %service -q ldap restart
533
534 %postun -n openldap-schema-bind
535 if [ "$1" = "0" ]; then
536         %openldap_schema_unregister %{schemadir}/dnszone.schema
537         %service -q ldap restart
538 fi
539
540 %triggerpostun -- %{name} < 7:9.4.2-2
541 /sbin/chkconfig named reset
542 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
543 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
544 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
545
546 %triggerpostun -- %{name} < 7:9.9.2.P2-2
547 %systemd_trigger named.service
548
549 %files
550 %defattr(644,root,root,755)
551 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
552 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
553
554 %{systemdunitdir}/named.service
555 %attr(754,root,root) /etc/rc.d/init.d/named
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
557 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
558 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
559 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
560
561 %attr(755,root,root) %{_sbindir}/ddns-confgen
562 %attr(755,root,root) %{_sbindir}/dnssec-*
563 %attr(755,root,root) %{_sbindir}/named
564 %attr(755,root,root) %{_sbindir}/named-*
565 %attr(755,root,root) %{_sbindir}/nsec3hash
566 %attr(755,root,root) %{_sbindir}/rndc
567 %attr(755,root,root) %{_sbindir}/rndc-confgen
568 %attr(755,root,root) %{_sbindir}/tsig-keygen
569
570 %{_mandir}/man5/named.conf.5*
571 %{_mandir}/man5/rndc.conf.5*
572 %{_mandir}/man8/ddns-confgen.8*
573 %{_mandir}/man8/dnssec-*.8*
574 %{_mandir}/man8/named.8*
575 %{_mandir}/man8/named-*.8*
576 %{_mandir}/man8/nsec3hash.8*
577 %{_mandir}/man8/rndc.8*
578 %{_mandir}/man8/rndc-confgen.8*
579 %{_mandir}/man8/tsig-keygen.8*
580 %lang(ja) %{_mandir}/ja/man8/named*
581
582 %{systemdtmpfilesdir}/%{name}.conf
583
584 %attr(770,root,named) %dir %{_var}/lib/named
585 %attr(770,root,named) %dir %{_var}/lib/named/D
586 %attr(770,root,named) %dir %{_var}/lib/named/M
587 %attr(770,root,named) %dir %{_var}/lib/named/S
588 %attr(770,root,named) %dir %{_var}/lib/named/dev
589 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
590 %attr(750,root,named) %dir %{_var}/lib/named/etc
591 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
592 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
593 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
594 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
595 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
596 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
597
598 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
599 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
600
601 %attr(770,root,named) %dir %{_var}/run/named
602
603 %dir %{_libdir}/named
604 %attr(755,root,root) %{_libdir}/named/filter-aaaa.so
605 %{_mandir}/man8/filter-aaaa.8*
606
607 %files utils
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_bindir}/arpaname
610 %attr(755,root,root) %{_bindir}/delv
611 %attr(755,root,root) %{_bindir}/dig
612 %attr(755,root,root) %{_bindir}/host
613 %attr(755,root,root) %{_bindir}/named-rrchecker
614 %attr(755,root,root) %{_bindir}/mdig
615 %attr(755,root,root) %{_bindir}/nslookup
616 %attr(755,root,root) %{_bindir}/nsupdate
617 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
618 %{_mandir}/man1/arpaname.1*
619 %{_mandir}/man1/delv.1*
620 %{_mandir}/man1/dig.1*
621 %{_mandir}/man1/host.1*
622 %{_mandir}/man1/mdig.1*
623 %{_mandir}/man1/named-rrchecker.1*
624 %{_mandir}/man1/nslookup.1*
625 %{_mandir}/man1/nsupdate.1*
626
627 %lang(fi) %{_mandir}/fi/man1/host.1*
628
629 %lang(fr) %{_mandir}/fr/man1/host.1*
630
631 %lang(hu) %{_mandir}/hu/man1/host.1*
632
633 %lang(ja) %{_mandir}/ja/man1/dig.1*
634 %lang(ja) %{_mandir}/ja/man1/host.1*
635 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
636 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
637
638 %lang(pl) %{_mandir}/pl/man1/host.1*
639
640 %files libs
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1600
644 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1600
646 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1600
648 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1600
650 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1600
652 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1600
654 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libns.so.1600
656
657 %files devel
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libbind9.so
660 %attr(755,root,root) %{_libdir}/libdns.so
661 %attr(755,root,root) %{_libdir}/libirs.so
662 %attr(755,root,root) %{_libdir}/libisc.so
663 %attr(755,root,root) %{_libdir}/libisccc.so
664 %attr(755,root,root) %{_libdir}/libisccfg.so
665 %attr(755,root,root) %{_libdir}/libns.so
666 %{_libdir}/libbind9.la
667 %{_libdir}/libdns.la
668 %{_libdir}/libirs.la
669 %{_libdir}/libisc.la
670 %{_libdir}/libisccc.la
671 %{_libdir}/libisccfg.la
672 %{_libdir}/libns.la
673 %{_includedir}/bind9
674 %{_includedir}/dns
675 %{_includedir}/dst
676 %{_includedir}/irs
677 %{_includedir}/isc
678 %{_includedir}/isccc
679 %{_includedir}/isccfg
680 %{_includedir}/ns
681 %{_includedir}/pk11
682 %{_includedir}/pkcs11
683
684 %if %{with static_libs}
685 %files static
686 %defattr(644,root,root,755)
687 %{_libdir}/libbind9.a
688 %{_libdir}/libdns.a
689 %{_libdir}/libirs.a
690 %{_libdir}/libisc.a
691 %{_libdir}/libisccc.a
692 %{_libdir}/libisccfg.a
693 %{_libdir}/libns.a
694 %endif
695
696 %if %{with ldap}
697 %files -n openldap-schema-bind
698 %defattr(644,root,root,755)
699 %{_datadir}/openldap/schema/dnszone.schema
700 %endif
701
702 %files -n python3-isc
703 %defattr(644,root,root,755)
704 %{py3_sitedir}/isc
705 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.114906 seconds and 4 git commands to generate.