]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
BRs for tar.xz source
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_without  doh             # DNS over HTTPS support
11 %bcond_with     static_libs     # static libraries
12 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
13 %bcond_with     tests           # unit tests
14 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
15 %bcond_with     hip             # HIP RR support
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.18.1
28 %if 0
29 %define         pverdot .P0
30 %define         pverdir -P0
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        1
48 Epoch:          7
49 License:        MPL 2.0
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
52 # Source0-md5:  d7072b2d774077f37bff51580b3a577b
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source6:        %{name}-hip.tar.gz
59 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
60 Source7:        https://www.internic.net/domain/named.root
61 # Source7-md5:  544504d19e2b71c259d2a09d231533aa
62 Source8:        %{name}-127.0.0.zone
63 Source9:        %{name}-localhost.zone
64 Source10:       %{name}-named.conf
65 Source11:       %{name}.tmpfiles
66 Source12:       named.service
67
68 Patch3:         jemalloc.patch
69 Patch4:         %{name}-ac-libs.patch
70 Patch5:         %{name}-edns-client-subnet.patch
71 URL:            https://www.isc.org/software/bind
72 BuildRequires:  autoconf >= 2.60
73 BuildRequires:  automake
74 BuildRequires:  bison
75 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
76 BuildRequires:  flex
77 %{?with_kerberos5:BuildRequires:        heimdal-devel}
78 BuildRequires:  jemalloc-devel
79 BuildRequires:  json-c-devel >= 0.11
80 BuildRequires:  libatomic-devel
81 BuildRequires:  libcap-devel
82 BuildRequires:  libidn2-devel
83 # note, there is no kyua in PLD yet (work in progress)
84 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
85 BuildRequires:  libtool
86 BuildRequires:  libuv-devel >= 1.37.0
87 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
88 BuildRequires:  libxml2-devel >= 1:2.6.0
89 %{?with_lmdb:BuildRequires:     lmdb-devel}
90 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
91 %{?with_doh:BuildRequires:      nghttp2-devel >= 1.6.0}
92 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
93 BuildRequires:  pkgconfig
94 BuildRequires:  python3-devel >= 1:3.2
95 BuildRequires:  python3-sphinx_rtd_theme
96 BuildRequires:  readline-devel
97 BuildRequires:  rpm >= 4.4.9-56
98 BuildRequires:  rpmbuild(macros) >= 1.647
99 BuildRequires:  sphinx-pdg
100 BuildRequires:  tar >= 1:1.22
101 BuildRequires:  xz
102 BuildRequires:  zlib-devel
103 %if %{with dnstap}
104 BuildRequires:  fstrm-devel
105 BuildRequires:  protobuf-c-devel
106 %endif
107 Requires(post,preun):   /sbin/chkconfig
108 Requires(postun):       /usr/sbin/groupdel
109 Requires(postun):       /usr/sbin/userdel
110 Requires(pre):  /bin/id
111 Requires(pre):  /usr/bin/getgid
112 Requires(pre):  /usr/sbin/groupadd
113 Requires(pre):  /usr/sbin/useradd
114 Requires(pre):  fileutils
115 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
116 Requires:       psmisc >= 20.1
117 Requires:       rc-scripts >= 0.2.0
118 Requires:       systemd-units >= 38
119 Requires:       uname(release) >= 2.2.18
120 Provides:       group(named)
121 Provides:       nameserver
122 Provides:       user(named)
123 Obsoletes:      caching-nameserver
124 Conflicts:      %{name}-chroot
125 Conflicts:      logrotate < 3.8.0
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %description
129 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
130 (Domain Name System) protocols. BIND includes a DNS server (named),
131 which resolves host names to IP addresses, and a resolver library
132 (routines for applications to use when interfacing with DNS). A DNS
133 server allows clients to name resources or objects and share the
134 information with other network machines. The named DNS server can be
135 used on workstations as a caching name server, but is generally only
136 needed on one machine for an entire network. Note that the
137 configuration files for making BIND act as a simple caching nameserver
138 are included in the caching-nameserver package.
139
140 Install the bind package if you need a DNS server for your network. If
141 you want bind to act a caching name server, you will also need to
142 install the caching-nameserver package.
143
144 %description -l de.UTF-8
145 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
146 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
147 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
148 Recher des Netzwerks erforderlich.
149
150 %description -l es.UTF-8
151 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
152 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
153 un servidor de nombres caché, pero generalmente sólo hace falta en una
154 máquina para toda la red.
155
156 %description -l fr.UTF-8
157 Contient le serveur de noms named, utilisé pour définir les
158 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
159 utilisé sur les stations de travail comme serveur de nom en cache mais
160 n'est souvent nécessaire que sur une machine pour un réseau entier.
161
162 %description -l pl.UTF-8
163 Pakiet ten zawiera demona named, który służy do zmieniania nazw
164 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
165 roboczych jako bufor odwołań do serwisu nazw (caching name server),
166 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
167 program na fragment sieci.
168
169 %description -l pt_BR.UTF-8
170 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
171 IP (e vice-versa). Pode ser usado em estações de trabalho como um
172 servidor de nomes cache, mas geralmente só é necessário em uma máquina
173 para toda a rede.
174
175 %description -l ru.UTF-8
176 BIND (Berkeley Internet Name Domain) является реализацией протоколов
177 DNS (Domain Name System). BIND включает DNS сервер (named) и
178 библиотеку "резолвера" (подпрограммы для приложений, через которые
179 происходят обращения к DNS). DNS сервер named может быть использован
180 на рабочих станциях как кеширующий сервер, но обычно запускается на
181 одной машине в локальной сети и используется остальными машинами (этим
182 достигается намного более эффективное кеширование).
183
184 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
185 кеширующего сервера, включены в пакет caching-nameserver.
186
187 %description -l tr.UTF-8
188 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
189 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
190 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
191 için sadece bir makina üzerinde kurulur.
192
193 %description -l uk.UTF-8
194 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
195 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
196 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
197 сервер named може бути використаний на робочих станціях як кешируючий
198 сервер, але звичайно запускається на одній машині в локальній мережі і
199 використовується іншими (цим досягається більша ефективність
200 використання кешу).
201
202 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
203 кешируючого серверу, включені в пакет caching-nameserver.
204
205 %package plugins
206 Summary:        Plugins for Bind DNS name server
207 Summary(pl.UTF-8):      Wtyczki dla serwera nazw DNS Bind
208 Group:          Networking/Utilities
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210
211 %description plugins
212 Plugins for extending of query processing functionality of Bind DNS name
213 server.
214
215 %description plugins -l pl.UTF-8
216 Wtyczki rozszerzające funkcjonalność przetwarzania zapytań przez serwer
217 nazw DNS Bind.
218
219 %package utils
220 Summary:        DNS utils - host, dig, dnsquery, nslookup
221 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
222 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
223 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
224 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
225 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
226 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
227 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
228 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
229 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
230 Group:          Networking/Utilities
231 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
232 Requires:       iconv
233
234 %description utils
235 Bind-utils contains a collection of utilities for querying DNS (Domain
236 Name Service) name servers to find out information about Internet
237 hosts. These tools will provide you with the IP addresses for given
238 host names, as well as other information about registered domains and
239 network addresses.
240
241 You should install bind-utils if you need to get information from DNS
242 name servers.
243
244 %description utils -l de.UTF-8
245 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
246 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
247 Informationen über registrierte Domains und Netzwerk-Adressen.
248
249 %description utils -l es.UTF-8
250 Conjunto de utilitarios para consulta a servidores de nombres. Estas
251 herramientas permiten la determinación de direcciones IP para nombres
252 de máquinas informados y busca información sobre dominios registrados
253 y direcciones de red.
254
255 %description utils -l fr.UTF-8
256 Ensemble d'utilitaires pour interroger les serveurs de noms et
257 rechercher des hôtes. Ces outils vous permettent de déterminer les
258 adresses IP pour des noms d'hôtes donnés, et trouver des informations
259 sur les noms de domaine déclarés et les adresses réseau.
260
261 %description utils -l pl.UTF-8
262 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
263 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
264 i ich adresach IP.
265
266 %description utils -l pt_BR.UTF-8
267 Conjunto de utilitários para consulta a servidores DNS. Estas
268 ferramentas permitem a determinação de endereços IP para nomes de
269 máquinas informados e busca informações sobre domínios registrados e
270 endereços de rede. Você deveria instalar este pacote se necessitar
271 obter informações de servidores DNS.
272
273 %description utils -l ru.UTF-8
274 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
275 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
276 доменному имени (и наоборот) и другую информацию о зарегистрированных
277 доменах и сетевых адресах.
278
279 %description utils -l tr.UTF-8
280 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
281 için kullanılan araçlar bulunmaktadır.
282
283 %description utils -l uk.UTF-8
284 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
285 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
286 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
287 домени та адреси.
288
289 %package libs
290 Summary:        DNS libraries
291 Summary(pl.UTF-8):      Biblioteki DNS
292 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
293 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
294 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
295 Group:          Libraries
296 Requires:       json-c >= 0.11
297 Requires:       libuv >= 1.37.0
298 Requires:       libxml2 >= 1:2.6.0
299 %{?with_doh:Requires:   nghttp2-libs >= 1.6.0}
300
301 %description libs
302 The bind-libs package contains all libraries required for running BIND
303 and bind utils.
304
305 %description libs -l pl.UTF-8
306 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
307 lub programów z pakietu bind-utils.
308
309 %description libs -l ru.UTF-8
310 Библиотеки, необходимые для работы bind.
311
312 %description libs -l uk.UTF-8
313 Бібліотеки, необхідні для роботи bind.
314
315 %package devel
316 Summary:        DNS development includes
317 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
318 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
319 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
320 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
321 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
322 Group:          Development/Libraries
323 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
324
325 %description devel
326 The bind-devel package contains all the include files and symlinks
327 required for DNS (Domain Name Service) development for BIND.
328
329 You should install bind-devel if you want to develop bind DNS
330 applications. If you install bind-devel, you'll also need to install
331 bind-libs.
332
333 %description devel -l es.UTF-8
334 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
335 para el bind.
336
337 %description devel -l pl.UTF-8
338 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
339 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
340 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
341 pakiet.
342
343 %description devel -l pt_BR.UTF-8
344 Todos os arquivos de cabeçalho e bibliotecas necessários para o
345 desenvolvimento com o bind.
346
347 %description devel -l ru.UTF-8
348 Все хедеры и библиотеки, необходимые для написания программ с
349 использованием BIND 9.x.x.
350
351 %description devel -l uk.UTF-8
352 Всі хедери та бібліотеки, необхідні для розробки програм з
353 використанням BIND 9.x.x.
354
355 %package static
356 Summary:        DNS static libs
357 Summary(pl.UTF-8):      Biblioteki statyczne DNS
358 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
359 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
360 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
361 Group:          Development/Libraries
362 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
363
364 %description static
365 Static bind libraries.
366
367 %description static -l pl.UTF-8
368 Statyczne biblioteki binda.
369
370 %description static -l pt_BR.UTF-8
371 Bibliotecas estáticas para desenvolvimento DNS.
372
373 %description static -l ru.UTF-8
374 Статические библиотеки, необходимые для написания программ с
375 использованием BIND.
376
377 %description static -l uk.UTF-8
378 Статичні бібліотеки, необхідні для розробки програм з використанням
379 BIND.
380
381 %prep
382 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
383
384 %patch3 -p1
385 %patch4 -p1
386 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
387 %{?with_edns_cli:%patch5 -p0}
388
389 %build
390 %{__libtoolize}
391 %{__aclocal}
392 %{__autoconf}
393 %{__automake}
394 %configure \
395         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
396         LDFLAGS="%{rpmldflags}" \
397         %{?with_dnstap:--enable-dnstap} \
398         %{!?with_doh:--disable-doh} \
399         %{!?with_epoll:--disable-epoll --disable-devpoll} \
400         --enable-full-report \
401         --enable-largefile \
402         %{?with_static_libs:--enable-static} \
403         %{?with_kerberos5:--with-gssapi} \
404         --with-jemalloc=yes \
405         --with-libidn2 \
406         --with-libxml2 \
407         %{?with_ssl:--with-openssl} \
408         %{?with_geoip:--with-maxminddb} \
409         --with-lmdb%{!?with_lmdb:=no} \
410         --with-tuning \
411         --disable-silent-rules
412
413 %{__make}
414 %{__make} -C doc/arm html
415
416 %{?with_hip:%{__make} -C bind-hip}
417
418 %if %{with tests}
419 %if %{with system_tests}
420 %{__make} test-force
421 %else
422 sh unit/unittest.sh
423 %endif
424 %endif
425
426 %install
427 rm -rf $RPM_BUILD_ROOT
428 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
429         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
430         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
431         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
432
433 %{__make} install \
434         DESTDIR=$RPM_BUILD_ROOT
435
436 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
437 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
438 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
439 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
440
441 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
442 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
443 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
444 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
445 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
446 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
447 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
448 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
449
450 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
451 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
452 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
453 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
454
455 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
456
457 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
458 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
459
460 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
461
462 # we don't want Makefiles in documentation...
463 rm -rf _doc
464 cp -a doc _doc
465 %{__rm} _doc/misc/Makefile*
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %pre
471 if [ -f %{_sysconfdir}/named.boot ]; then
472         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
473         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
474         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
475 fi
476 %groupadd -g 58 named
477 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
478
479 %post
480 /sbin/chkconfig --add named
481 %service named restart
482 %systemd_post named.service
483
484 %preun
485 if [ "$1" = "0" ]; then
486         %service named stop
487         /sbin/chkconfig --del named
488 fi
489 %systemd_preun named.service
490
491 %postun
492 if [ "$1" = "0" ]; then
493         %userremove named
494         %groupremove named
495 fi
496 %systemd_reload
497
498 %post   libs -p /sbin/ldconfig
499 %postun libs -p /sbin/ldconfig
500
501 %triggerpostun -- %{name} < 7:9.9.2.P2-2
502 %systemd_trigger named.service
503
504 %files
505 %defattr(644,root,root,755)
506 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
507 %doc _doc/misc/* _doc/arm/_build/html/*.html
508
509 %{systemdunitdir}/named.service
510 %attr(754,root,root) /etc/rc.d/init.d/named
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
512 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
513 %{_sysconfdir}/named.conf
514 %{_sysconfdir}/bind.keys
515
516 %attr(755,root,root) %{_bindir}/dnssec-*
517 %attr(755,root,root) %{_bindir}/named-*
518 %attr(755,root,root) %{_bindir}/nsec3hash
519 %attr(755,root,root) %{_sbindir}/ddns-confgen
520 %attr(755,root,root) %{_sbindir}/named
521 %attr(755,root,root) %{_sbindir}/rndc
522 %attr(755,root,root) %{_sbindir}/rndc-confgen
523 %attr(755,root,root) %{_sbindir}/tsig-keygen
524
525 %{_mandir}/man1/dnssec-*.1*
526 %{_mandir}/man1/named-*.1*
527 %{_mandir}/man1/nsec3hash.1*
528 %{_mandir}/man5/named.conf.5*
529 %{_mandir}/man5/rndc.conf.5*
530 %{_mandir}/man8/ddns-confgen.8*
531 %{_mandir}/man8/named.8*
532 %{_mandir}/man8/rndc.8*
533 %{_mandir}/man8/rndc-confgen.8*
534 %{_mandir}/man8/tsig-keygen.8*
535 %lang(ja) %{_mandir}/ja/man8/named*
536
537 %{systemdtmpfilesdir}/%{name}.conf
538
539 %attr(770,root,named) %dir %{_var}/lib/named
540 %attr(770,root,named) %dir %{_var}/lib/named/D
541 %attr(770,root,named) %dir %{_var}/lib/named/M
542 %attr(770,root,named) %dir %{_var}/lib/named/S
543 %attr(770,root,named) %dir %{_var}/lib/named/dev
544 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
545 %attr(750,root,named) %dir %{_var}/lib/named/etc
546 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
547 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
548 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
549 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
550 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
551 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
552
553 %config(noreplace,missingok) %{_var}/log/named
554 %config(noreplace,missingok) %{_var}/log/named.stats
555
556 %attr(770,root,named) %dir %{_var}/run/named
557
558 %files plugins
559 %defattr(644,root,root,755)
560 %dir %{_libdir}/bind
561 %attr(755,root,root) %{_libdir}/bind/filter-a.so
562 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
563 %{_mandir}/man8/filter-a.8*
564 %{_mandir}/man8/filter-aaaa.8*
565
566 %files utils
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/arpaname
569 %attr(755,root,root) %{_bindir}/delv
570 %attr(755,root,root) %{_bindir}/dig
571 %attr(755,root,root) %{_bindir}/host
572 %attr(755,root,root) %{_bindir}/named-rrchecker
573 %attr(755,root,root) %{_bindir}/mdig
574 %attr(755,root,root) %{_bindir}/nslookup
575 %attr(755,root,root) %{_bindir}/nsupdate
576 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
577 %{_mandir}/man1/arpaname.1*
578 %{_mandir}/man1/delv.1*
579 %{_mandir}/man1/dig.1*
580 %{_mandir}/man1/host.1*
581 %{_mandir}/man1/mdig.1*
582 %{_mandir}/man1/named-rrchecker.1*
583 %{_mandir}/man1/nslookup.1*
584 %{_mandir}/man1/nsupdate.1*
585
586 %lang(fi) %{_mandir}/fi/man1/host.1*
587
588 %lang(fr) %{_mandir}/fr/man1/host.1*
589
590 %lang(hu) %{_mandir}/hu/man1/host.1*
591
592 %lang(ja) %{_mandir}/ja/man1/dig.1*
593 %lang(ja) %{_mandir}/ja/man1/host.1*
594 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
595 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
596
597 %lang(pl) %{_mandir}/pl/man1/host.1*
598
599 %files libs
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
602 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
603 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
604 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
605 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
606 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
607 %attr(755,root,root) %{_libdir}/libns-%{version}.so
608
609 %files devel
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/libbind9.so
612 %attr(755,root,root) %{_libdir}/libdns.so
613 %attr(755,root,root) %{_libdir}/libirs.so
614 %attr(755,root,root) %{_libdir}/libisc.so
615 %attr(755,root,root) %{_libdir}/libisccc.so
616 %attr(755,root,root) %{_libdir}/libisccfg.so
617 %attr(755,root,root) %{_libdir}/libns.so
618 %{_libdir}/libbind9.la
619 %{_libdir}/libdns.la
620 %{_libdir}/libirs.la
621 %{_libdir}/libisc.la
622 %{_libdir}/libisccc.la
623 %{_libdir}/libisccfg.la
624 %{_libdir}/libns.la
625 %{_includedir}/bind9
626 %{_includedir}/dns
627 %{_includedir}/dst
628 %{_includedir}/irs
629 %{_includedir}/isc
630 %{_includedir}/isccc
631 %{_includedir}/isccfg
632 %{_includedir}/ns
633
634 %if %{with static_libs}
635 %files static
636 %defattr(644,root,root,755)
637 %{_libdir}/libbind9.a
638 %{_libdir}/libdns.a
639 %{_libdir}/libirs.a
640 %{_libdir}/libisc.a
641 %{_libdir}/libisccc.a
642 %{_libdir}/libisccfg.a
643 %{_libdir}/libns.a
644 %endif
This page took 0.236452 seconds and 4 git commands to generate.