]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- separate subpackage for plugins
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_with     static_libs     # static libraries
11 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
12 %bcond_with     tests           # unit tests
13 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
14 %bcond_with     hip             # HIP RR support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.18.1
27 %if 0
28 %define         pverdot .P0
29 %define         pverdir -P0
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        1
47 Epoch:          7
48 License:        MPL 2.0
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
51 # Source0-md5:  d7072b2d774077f37bff51580b3a577b
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
58 Source5:        dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        https://www.internic.net/domain/named.root
63 # Source7-md5:  544504d19e2b71c259d2a09d231533aa
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69
70 Patch3:         jemalloc.patch
71 Patch4:         %{name}-ac-libs.patch
72 Patch5:         %{name}-edns-client-subnet.patch
73 URL:            https://www.isc.org/software/bind
74 BuildRequires:  autoconf >= 2.60
75 BuildRequires:  automake
76 BuildRequires:  bison
77 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
78 BuildRequires:  flex
79 %{?with_kerberos5:BuildRequires:        heimdal-devel}
80 BuildRequires:  jemalloc-devel
81 BuildRequires:  json-c-devel >= 0.11
82 BuildRequires:  libatomic-devel
83 BuildRequires:  libcap-devel
84 BuildRequires:  libidn2-devel
85 # note, there is no kyua in PLD yet (work in progress)
86 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
87 BuildRequires:  libtool
88 BuildRequires:  libuv-devel >= 1.37.0
89 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
90 BuildRequires:  libxml2-devel >= 1:2.6.0
91 %{?with_lmdb:BuildRequires:     lmdb-devel}
92 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
93 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
94 BuildRequires:  pkgconfig
95 BuildRequires:  python3-devel >= 1:3.2
96 BuildRequires:  python3-sphinx_rtd_theme
97 BuildRequires:  readline-devel
98 BuildRequires:  rpm >= 4.4.9-56
99 BuildRequires:  rpmbuild(macros) >= 1.647
100 BuildRequires:  sphinx-pdg
101 BuildRequires:  zlib-devel
102 %if %{with dnstap}
103 BuildRequires:  fstrm-devel
104 BuildRequires:  protobuf-c-devel
105 %endif
106 Requires(post,preun):   /sbin/chkconfig
107 Requires(postun):       /usr/sbin/groupdel
108 Requires(postun):       /usr/sbin/userdel
109 Requires(pre):  /bin/id
110 Requires(pre):  /usr/bin/getgid
111 Requires(pre):  /usr/sbin/groupadd
112 Requires(pre):  /usr/sbin/useradd
113 Requires(pre):  fileutils
114 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
115 Requires:       psmisc >= 20.1
116 Requires:       rc-scripts >= 0.2.0
117 Requires:       systemd-units >= 38
118 Requires:       uname(release) >= 2.2.18
119 Provides:       group(named)
120 Provides:       nameserver
121 Provides:       user(named)
122 Obsoletes:      caching-nameserver
123 Conflicts:      %{name}-chroot
124 Conflicts:      logrotate < 3.8.0
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %description
128 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
129 (Domain Name System) protocols. BIND includes a DNS server (named),
130 which resolves host names to IP addresses, and a resolver library
131 (routines for applications to use when interfacing with DNS). A DNS
132 server allows clients to name resources or objects and share the
133 information with other network machines. The named DNS server can be
134 used on workstations as a caching name server, but is generally only
135 needed on one machine for an entire network. Note that the
136 configuration files for making BIND act as a simple caching nameserver
137 are included in the caching-nameserver package.
138
139 Install the bind package if you need a DNS server for your network. If
140 you want bind to act a caching name server, you will also need to
141 install the caching-nameserver package.
142
143 %description -l de.UTF-8
144 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
145 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
146 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
147 Recher des Netzwerks erforderlich.
148
149 %description -l es.UTF-8
150 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
151 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
152 un servidor de nombres caché, pero generalmente sólo hace falta en una
153 máquina para toda la red.
154
155 %description -l fr.UTF-8
156 Contient le serveur de noms named, utilisé pour définir les
157 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
158 utilisé sur les stations de travail comme serveur de nom en cache mais
159 n'est souvent nécessaire que sur une machine pour un réseau entier.
160
161 %description -l pl.UTF-8
162 Pakiet ten zawiera demona named, który służy do zmieniania nazw
163 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
164 roboczych jako bufor odwołań do serwisu nazw (caching name server),
165 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
166 program na fragment sieci.
167
168 %description -l pt_BR.UTF-8
169 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
170 IP (e vice-versa). Pode ser usado em estações de trabalho como um
171 servidor de nomes cache, mas geralmente só é necessário em uma máquina
172 para toda a rede.
173
174 %description -l ru.UTF-8
175 BIND (Berkeley Internet Name Domain) является реализацией протоколов
176 DNS (Domain Name System). BIND включает DNS сервер (named) и
177 библиотеку "резолвера" (подпрограммы для приложений, через которые
178 происходят обращения к DNS). DNS сервер named может быть использован
179 на рабочих станциях как кеширующий сервер, но обычно запускается на
180 одной машине в локальной сети и используется остальными машинами (этим
181 достигается намного более эффективное кеширование).
182
183 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
184 кеширующего сервера, включены в пакет caching-nameserver.
185
186 %description -l tr.UTF-8
187 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
188 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
189 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
190 için sadece bir makina üzerinde kurulur.
191
192 %description -l uk.UTF-8
193 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
194 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
195 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
196 сервер named може бути використаний на робочих станціях як кешируючий
197 сервер, але звичайно запускається на одній машині в локальній мережі і
198 використовується іншими (цим досягається більша ефективність
199 використання кешу).
200
201 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
202 кешируючого серверу, включені в пакет caching-nameserver.
203
204 %package plugins
205 Summary:        Plugins for Bind DNS name server
206 Summary(pl.UTF-8):      Wtyczki dla serwera nazw DNS Bind
207 Group:          Networking/Utilities
208 Requires:       %{name} = %{epoch}:%{version}-%{release}
209
210 %description plugins
211 Plugins for extending of query processing functionality of Bind DNS name
212 server.
213
214 %description plugins -l pl.UTF-8
215 Wtyczki rozszerzające funkcjonalność przetwarzania zapytań przez serwer
216 nazw DNS Bind.
217
218 %package utils
219 Summary:        DNS utils - host, dig, dnsquery, nslookup
220 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
221 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
222 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
223 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
224 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
225 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
226 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
227 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
228 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
229 Group:          Networking/Utilities
230 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
231 Requires:       iconv
232
233 %description utils
234 Bind-utils contains a collection of utilities for querying DNS (Domain
235 Name Service) name servers to find out information about Internet
236 hosts. These tools will provide you with the IP addresses for given
237 host names, as well as other information about registered domains and
238 network addresses.
239
240 You should install bind-utils if you need to get information from DNS
241 name servers.
242
243 %description utils -l de.UTF-8
244 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
245 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
246 Informationen über registrierte Domains und Netzwerk-Adressen.
247
248 %description utils -l es.UTF-8
249 Conjunto de utilitarios para consulta a servidores de nombres. Estas
250 herramientas permiten la determinación de direcciones IP para nombres
251 de máquinas informados y busca información sobre dominios registrados
252 y direcciones de red.
253
254 %description utils -l fr.UTF-8
255 Ensemble d'utilitaires pour interroger les serveurs de noms et
256 rechercher des hôtes. Ces outils vous permettent de déterminer les
257 adresses IP pour des noms d'hôtes donnés, et trouver des informations
258 sur les noms de domaine déclarés et les adresses réseau.
259
260 %description utils -l pl.UTF-8
261 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
262 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
263 i ich adresach IP.
264
265 %description utils -l pt_BR.UTF-8
266 Conjunto de utilitários para consulta a servidores DNS. Estas
267 ferramentas permitem a determinação de endereços IP para nomes de
268 máquinas informados e busca informações sobre domínios registrados e
269 endereços de rede. Você deveria instalar este pacote se necessitar
270 obter informações de servidores DNS.
271
272 %description utils -l ru.UTF-8
273 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
274 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
275 доменному имени (и наоборот) и другую информацию о зарегистрированных
276 доменах и сетевых адресах.
277
278 %description utils -l tr.UTF-8
279 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
280 için kullanılan araçlar bulunmaktadır.
281
282 %description utils -l uk.UTF-8
283 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
284 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
285 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
286 домени та адреси.
287
288 %package libs
289 Summary:        DNS libraries
290 Summary(pl.UTF-8):      Biblioteki DNS
291 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
292 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
293 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
294 Group:          Libraries
295 Requires:       json-c >= 0.11
296 Requires:       libuv >= 1.37.0
297 Requires:       libxml2 >= 1:2.6.0
298
299 %description libs
300 The bind-libs package contains all libraries required for running BIND
301 and bind utils.
302
303 %description libs -l pl.UTF-8
304 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
305 lub programów z pakietu bind-utils.
306
307 %description libs -l ru.UTF-8
308 Библиотеки, необходимые для работы bind.
309
310 %description libs -l uk.UTF-8
311 Бібліотеки, необхідні для роботи bind.
312
313 %package devel
314 Summary:        DNS development includes
315 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
316 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
317 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
318 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
319 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
320 Group:          Development/Libraries
321 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
322
323 %description devel
324 The bind-devel package contains all the include files and symlinks
325 required for DNS (Domain Name Service) development for BIND.
326
327 You should install bind-devel if you want to develop bind DNS
328 applications. If you install bind-devel, you'll also need to install
329 bind-libs.
330
331 %description devel -l es.UTF-8
332 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
333 para el bind.
334
335 %description devel -l pl.UTF-8
336 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
337 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
338 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
339 pakiet.
340
341 %description devel -l pt_BR.UTF-8
342 Todos os arquivos de cabeçalho e bibliotecas necessários para o
343 desenvolvimento com o bind.
344
345 %description devel -l ru.UTF-8
346 Все хедеры и библиотеки, необходимые для написания программ с
347 использованием BIND 9.x.x.
348
349 %description devel -l uk.UTF-8
350 Всі хедери та бібліотеки, необхідні для розробки програм з
351 використанням BIND 9.x.x.
352
353 %package static
354 Summary:        DNS static libs
355 Summary(pl.UTF-8):      Biblioteki statyczne DNS
356 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
357 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
358 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
359 Group:          Development/Libraries
360 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
361
362 %description static
363 Static bind libraries.
364
365 %description static -l pl.UTF-8
366 Statyczne biblioteki binda.
367
368 %description static -l pt_BR.UTF-8
369 Bibliotecas estáticas para desenvolvimento DNS.
370
371 %description static -l ru.UTF-8
372 Статические библиотеки, необходимые для написания программ с
373 использованием BIND.
374
375 %description static -l uk.UTF-8
376 Статичні бібліотеки, необхідні для розробки програм з використанням
377 BIND.
378
379 %prep
380 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
381
382 %patch3 -p1
383 %patch4 -p1
384 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
385 %{?with_edns_cli:%patch5 -p0}
386
387 %build
388 %{__libtoolize}
389 %{__aclocal}
390 %{__autoconf}
391 %{__automake}
392 %configure \
393         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
394         LDFLAGS="%{rpmldflags}" \
395         %{?with_dnstap:--enable-dnstap} \
396         %{!?with_epoll:--disable-epoll --disable-devpoll} \
397         --enable-full-report \
398         --enable-largefile \
399         %{?with_static_libs:--enable-static} \
400         %{?with_kerberos5:--with-gssapi} \
401         --with-jemalloc=yes \
402         --with-libidn2 \
403         --with-libxml2 \
404         %{?with_ssl:--with-openssl} \
405         %{?with_geoip:--with-maxminddb} \
406         --with-lmdb%{!?with_lmdb:=no} \
407         --with-tuning \
408         --disable-silent-rules
409
410 %{__make}
411 %{__make} -C doc/arm html
412
413 %{?with_hip:%{__make} -C bind-hip}
414
415 %if %{with tests}
416 %if %{with system_tests}
417 %{__make} test-force
418 %else
419 sh unit/unittest.sh
420 %endif
421 %endif
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
426         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
427         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
428         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
429
430 %{__make} install \
431         DESTDIR=$RPM_BUILD_ROOT
432
433 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
434 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
435 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
436 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
437
438 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
439 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
440 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
441 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
442 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
443 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
444 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
445 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
446
447 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
448 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
449 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
450 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
451
452 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
453
454 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
455 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
456
457 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
458
459 # we don't want Makefiles in documentation...
460 rm -rf _doc
461 cp -a doc _doc
462 %{__rm} _doc/misc/Makefile*
463
464 %clean
465 rm -rf $RPM_BUILD_ROOT
466
467 %pre
468 if [ -f %{_sysconfdir}/named.boot ]; then
469         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
470         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
471         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
472 fi
473 %groupadd -g 58 named
474 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
475
476 %post
477 /sbin/chkconfig --add named
478 %service named restart
479 %systemd_post named.service
480
481 %preun
482 if [ "$1" = "0" ]; then
483         %service named stop
484         /sbin/chkconfig --del named
485 fi
486 %systemd_preun named.service
487
488 %postun
489 if [ "$1" = "0" ]; then
490         %userremove named
491         %groupremove named
492 fi
493 %systemd_reload
494
495 %post   libs -p /sbin/ldconfig
496 %postun libs -p /sbin/ldconfig
497
498 %triggerpostun -- %{name} < 7:9.9.2.P2-2
499 %systemd_trigger named.service
500
501 %files
502 %defattr(644,root,root,755)
503 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
504 %doc _doc/misc/* _doc/arm/_build/html/*.html
505
506 %{systemdunitdir}/named.service
507 %attr(754,root,root) /etc/rc.d/init.d/named
508 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
509 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
510 %{_sysconfdir}/named.conf
511 %{_sysconfdir}/bind.keys
512
513 %attr(755,root,root) %{_bindir}/dnssec-*
514 %attr(755,root,root) %{_bindir}/named-*
515 %attr(755,root,root) %{_bindir}/nsec3hash
516 %attr(755,root,root) %{_sbindir}/ddns-confgen
517 %attr(755,root,root) %{_sbindir}/named
518 %attr(755,root,root) %{_sbindir}/rndc
519 %attr(755,root,root) %{_sbindir}/rndc-confgen
520 %attr(755,root,root) %{_sbindir}/tsig-keygen
521
522 %{_mandir}/man1/dnssec-*.1*
523 %{_mandir}/man1/named-*.1*
524 %{_mandir}/man1/nsec3hash.1*
525 %{_mandir}/man5/named.conf.5*
526 %{_mandir}/man5/rndc.conf.5*
527 %{_mandir}/man8/ddns-confgen.8*
528 %{_mandir}/man8/named.8*
529 %{_mandir}/man8/rndc.8*
530 %{_mandir}/man8/rndc-confgen.8*
531 %{_mandir}/man8/tsig-keygen.8*
532 %lang(ja) %{_mandir}/ja/man8/named*
533
534 %{systemdtmpfilesdir}/%{name}.conf
535
536 %attr(770,root,named) %dir %{_var}/lib/named
537 %attr(770,root,named) %dir %{_var}/lib/named/D
538 %attr(770,root,named) %dir %{_var}/lib/named/M
539 %attr(770,root,named) %dir %{_var}/lib/named/S
540 %attr(770,root,named) %dir %{_var}/lib/named/dev
541 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
542 %attr(750,root,named) %dir %{_var}/lib/named/etc
543 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
544 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
545 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
546 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
547 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
548 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
549
550 %config(noreplace,missingok) %{_var}/log/named
551 %config(noreplace,missingok) %{_var}/log/named.stats
552
553 %attr(770,root,named) %dir %{_var}/run/named
554
555 %files plugins
556 %defattr(644,root,root,755)
557 %dir %{_libdir}/bind
558 %attr(755,root,root) %{_libdir}/bind/filter-a.so
559 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
560 %{_mandir}/man8/filter-a.8*
561 %{_mandir}/man8/filter-aaaa.8*
562
563 %files utils
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/arpaname
566 %attr(755,root,root) %{_bindir}/delv
567 %attr(755,root,root) %{_bindir}/dig
568 %attr(755,root,root) %{_bindir}/host
569 %attr(755,root,root) %{_bindir}/named-rrchecker
570 %attr(755,root,root) %{_bindir}/mdig
571 %attr(755,root,root) %{_bindir}/nslookup
572 %attr(755,root,root) %{_bindir}/nsupdate
573 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
574 %{_mandir}/man1/arpaname.1*
575 %{_mandir}/man1/delv.1*
576 %{_mandir}/man1/dig.1*
577 %{_mandir}/man1/host.1*
578 %{_mandir}/man1/mdig.1*
579 %{_mandir}/man1/named-rrchecker.1*
580 %{_mandir}/man1/nslookup.1*
581 %{_mandir}/man1/nsupdate.1*
582
583 %lang(fi) %{_mandir}/fi/man1/host.1*
584
585 %lang(fr) %{_mandir}/fr/man1/host.1*
586
587 %lang(hu) %{_mandir}/hu/man1/host.1*
588
589 %lang(ja) %{_mandir}/ja/man1/dig.1*
590 %lang(ja) %{_mandir}/ja/man1/host.1*
591 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
592 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
593
594 %lang(pl) %{_mandir}/pl/man1/host.1*
595
596 %files libs
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
599 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
600 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
601 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
602 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
603 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
604 %attr(755,root,root) %{_libdir}/libns-%{version}.so
605
606 %files devel
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/libbind9.so
609 %attr(755,root,root) %{_libdir}/libdns.so
610 %attr(755,root,root) %{_libdir}/libirs.so
611 %attr(755,root,root) %{_libdir}/libisc.so
612 %attr(755,root,root) %{_libdir}/libisccc.so
613 %attr(755,root,root) %{_libdir}/libisccfg.so
614 %attr(755,root,root) %{_libdir}/libns.so
615 %{_libdir}/libbind9.la
616 %{_libdir}/libdns.la
617 %{_libdir}/libirs.la
618 %{_libdir}/libisc.la
619 %{_libdir}/libisccc.la
620 %{_libdir}/libisccfg.la
621 %{_libdir}/libns.la
622 %{_includedir}/bind9
623 %{_includedir}/dns
624 %{_includedir}/dst
625 %{_includedir}/irs
626 %{_includedir}/isc
627 %{_includedir}/isccc
628 %{_includedir}/isccfg
629 %{_includedir}/ns
630
631 %if %{with static_libs}
632 %files static
633 %defattr(644,root,root,755)
634 %{_libdir}/libbind9.a
635 %{_libdir}/libdns.a
636 %{_libdir}/libirs.a
637 %{_libdir}/libisc.a
638 %{_libdir}/libisccc.a
639 %{_libdir}/libisccfg.a
640 %{_libdir}/libns.a
641 %endif
642
643 %if %{with ldap}
644 %files -n openldap-schema-bind
645 %defattr(644,root,root,755)
646 %{_datadir}/openldap/schema/dnszone.schema
647 %endif
This page took 0.120671 seconds and 4 git commands to generate.