]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
Up to 9.18.1 (fixes CVE-2022-0667, CVE-2022-0635, CVE-2022-0396, CVE-2021-25220)
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_with     dnstap          # dnstap replication support
6 %bcond_without  geoip           # GeoIP support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_without  lmdb            # LMDB storage support for addzone zones
10 %bcond_with     static_libs     # static libraries
11 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
12 %bcond_with     tests           # unit tests
13 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
14 %bcond_with     hip             # HIP RR support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.18.1
27 %if 0
28 %define         pverdot .P0
29 %define         pverdir -P0
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        1
47 Epoch:          7
48 License:        MPL 2.0
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.xz
51 # Source0-md5:  d7072b2d774077f37bff51580b3a577b
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 # formerly http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt (dead URL now)
58 Source5:        dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        https://www.internic.net/domain/named.root
63 # Source7-md5:  544504d19e2b71c259d2a09d231533aa
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69
70 Patch3:         jemalloc.patch
71 Patch4:         %{name}-ac-libs.patch
72 Patch5:         %{name}-edns-client-subnet.patch
73 URL:            https://www.isc.org/software/bind
74 BuildRequires:  autoconf >= 2.60
75 BuildRequires:  automake
76 BuildRequires:  bison
77 %{?with_tests:BuildRequires:    cmocka-devel >= 1.0.0}
78 BuildRequires:  flex
79 %{?with_kerberos5:BuildRequires:        heimdal-devel}
80 BuildRequires:  jemalloc-devel
81 BuildRequires:  json-c-devel >= 0.11
82 BuildRequires:  libatomic-devel
83 BuildRequires:  libcap-devel
84 BuildRequires:  libidn2-devel
85 # note, there is no kyua in PLD yet (work in progress)
86 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
87 BuildRequires:  libtool
88 BuildRequires:  libuv-devel >= 1.37.0
89 # any version for hi2dns (if with_hip), 2.6.0 for XML stats
90 BuildRequires:  libxml2-devel >= 1:2.6.0
91 %{?with_lmdb:BuildRequires:     lmdb-devel}
92 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
93 %{?with_ssl:BuildRequires:      openssl-devel >= 1.0.0}
94 BuildRequires:  pkgconfig
95 BuildRequires:  python3-devel >= 1:3.2
96 BuildRequires:  python3-sphinx_rtd_theme
97 BuildRequires:  readline-devel
98 BuildRequires:  rpm >= 4.4.9-56
99 BuildRequires:  rpmbuild(macros) >= 1.647
100 BuildRequires:  sphinx-pdg
101 BuildRequires:  zlib-devel
102 %if %{with dnstap}
103 BuildRequires:  fstrm-devel
104 BuildRequires:  protobuf-c-devel
105 %endif
106 Requires(post,preun):   /sbin/chkconfig
107 Requires(postun):       /usr/sbin/groupdel
108 Requires(postun):       /usr/sbin/userdel
109 Requires(pre):  /bin/id
110 Requires(pre):  /usr/bin/getgid
111 Requires(pre):  /usr/sbin/groupadd
112 Requires(pre):  /usr/sbin/useradd
113 Requires(pre):  fileutils
114 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
115 Requires:       psmisc >= 20.1
116 Requires:       rc-scripts >= 0.2.0
117 Requires:       systemd-units >= 38
118 Requires:       uname(release) >= 2.2.18
119 Provides:       group(named)
120 Provides:       nameserver
121 Provides:       user(named)
122 Obsoletes:      caching-nameserver
123 Conflicts:      %{name}-chroot
124 Conflicts:      logrotate < 3.8.0
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %description
128 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
129 (Domain Name System) protocols. BIND includes a DNS server (named),
130 which resolves host names to IP addresses, and a resolver library
131 (routines for applications to use when interfacing with DNS). A DNS
132 server allows clients to name resources or objects and share the
133 information with other network machines. The named DNS server can be
134 used on workstations as a caching name server, but is generally only
135 needed on one machine for an entire network. Note that the
136 configuration files for making BIND act as a simple caching nameserver
137 are included in the caching-nameserver package.
138
139 Install the bind package if you need a DNS server for your network. If
140 you want bind to act a caching name server, you will also need to
141 install the caching-nameserver package.
142
143 %description -l de.UTF-8
144 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
145 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
146 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
147 Recher des Netzwerks erforderlich.
148
149 %description -l es.UTF-8
150 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
151 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
152 un servidor de nombres caché, pero generalmente sólo hace falta en una
153 máquina para toda la red.
154
155 %description -l fr.UTF-8
156 Contient le serveur de noms named, utilisé pour définir les
157 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
158 utilisé sur les stations de travail comme serveur de nom en cache mais
159 n'est souvent nécessaire que sur une machine pour un réseau entier.
160
161 %description -l pl.UTF-8
162 Pakiet ten zawiera demona named, który służy do zmieniania nazw
163 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
164 roboczych jako bufor odwołań do serwisu nazw (caching name server),
165 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
166 program na fragment sieci.
167
168 %description -l pt_BR.UTF-8
169 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
170 IP (e vice-versa). Pode ser usado em estações de trabalho como um
171 servidor de nomes cache, mas geralmente só é necessário em uma máquina
172 para toda a rede.
173
174 %description -l ru.UTF-8
175 BIND (Berkeley Internet Name Domain) является реализацией протоколов
176 DNS (Domain Name System). BIND включает DNS сервер (named) и
177 библиотеку "резолвера" (подпрограммы для приложений, через которые
178 происходят обращения к DNS). DNS сервер named может быть использован
179 на рабочих станциях как кеширующий сервер, но обычно запускается на
180 одной машине в локальной сети и используется остальными машинами (этим
181 достигается намного более эффективное кеширование).
182
183 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
184 кеширующего сервера, включены в пакет caching-nameserver.
185
186 %description -l tr.UTF-8
187 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
188 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
189 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
190 için sadece bir makina üzerinde kurulur.
191
192 %description -l uk.UTF-8
193 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
194 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
195 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
196 сервер named може бути використаний на робочих станціях як кешируючий
197 сервер, але звичайно запускається на одній машині в локальній мережі і
198 використовується іншими (цим досягається більша ефективність
199 використання кешу).
200
201 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
202 кешируючого серверу, включені в пакет caching-nameserver.
203
204 %package utils
205 Summary:        DNS utils - host, dig, dnsquery, nslookup
206 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
207 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
208 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
209 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
210 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
211 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
212 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
213 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
214 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
215 Group:          Networking/Utilities
216 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
217 Requires:       iconv
218
219 %description utils
220 Bind-utils contains a collection of utilities for querying DNS (Domain
221 Name Service) name servers to find out information about Internet
222 hosts. These tools will provide you with the IP addresses for given
223 host names, as well as other information about registered domains and
224 network addresses.
225
226 You should install bind-utils if you need to get information from DNS
227 name servers.
228
229 %description utils -l de.UTF-8
230 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
231 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
232 Informationen über registrierte Domains und Netzwerk-Adressen.
233
234 %description utils -l es.UTF-8
235 Conjunto de utilitarios para consulta a servidores de nombres. Estas
236 herramientas permiten la determinación de direcciones IP para nombres
237 de máquinas informados y busca información sobre dominios registrados
238 y direcciones de red.
239
240 %description utils -l fr.UTF-8
241 Ensemble d'utilitaires pour interroger les serveurs de noms et
242 rechercher des hôtes. Ces outils vous permettent de déterminer les
243 adresses IP pour des noms d'hôtes donnés, et trouver des informations
244 sur les noms de domaine déclarés et les adresses réseau.
245
246 %description utils -l pl.UTF-8
247 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
248 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
249 i ich adresach IP.
250
251 %description utils -l pt_BR.UTF-8
252 Conjunto de utilitários para consulta a servidores DNS. Estas
253 ferramentas permitem a determinação de endereços IP para nomes de
254 máquinas informados e busca informações sobre domínios registrados e
255 endereços de rede. Você deveria instalar este pacote se necessitar
256 obter informações de servidores DNS.
257
258 %description utils -l ru.UTF-8
259 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
260 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
261 доменному имени (и наоборот) и другую информацию о зарегистрированных
262 доменах и сетевых адресах.
263
264 %description utils -l tr.UTF-8
265 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
266 için kullanılan araçlar bulunmaktadır.
267
268 %description utils -l uk.UTF-8
269 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
270 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
271 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
272 домени та адреси.
273
274 %package libs
275 Summary:        DNS libraries
276 Summary(pl.UTF-8):      Biblioteki DNS
277 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
278 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
279 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
280 Group:          Libraries
281 Requires:       json-c >= 0.11
282 Requires:       libuv >= 1.37.0
283 Requires:       libxml2 >= 1:2.6.0
284
285 %description libs
286 The bind-libs package contains all libraries required for running BIND
287 and bind utils.
288
289 %description libs -l pl.UTF-8
290 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
291 lub programów z pakietu bind-utils.
292
293 %description libs -l ru.UTF-8
294 Библиотеки, необходимые для работы bind.
295
296 %description libs -l uk.UTF-8
297 Бібліотеки, необхідні для роботи bind.
298
299 %package devel
300 Summary:        DNS development includes
301 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
302 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
303 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
304 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
305 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
306 Group:          Development/Libraries
307 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
308
309 %description devel
310 The bind-devel package contains all the include files and symlinks
311 required for DNS (Domain Name Service) development for BIND.
312
313 You should install bind-devel if you want to develop bind DNS
314 applications. If you install bind-devel, you'll also need to install
315 bind-libs.
316
317 %description devel -l es.UTF-8
318 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
319 para el bind.
320
321 %description devel -l pl.UTF-8
322 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
323 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
324 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
325 pakiet.
326
327 %description devel -l pt_BR.UTF-8
328 Todos os arquivos de cabeçalho e bibliotecas necessários para o
329 desenvolvimento com o bind.
330
331 %description devel -l ru.UTF-8
332 Все хедеры и библиотеки, необходимые для написания программ с
333 использованием BIND 9.x.x.
334
335 %description devel -l uk.UTF-8
336 Всі хедери та бібліотеки, необхідні для розробки програм з
337 використанням BIND 9.x.x.
338
339 %package static
340 Summary:        DNS static libs
341 Summary(pl.UTF-8):      Biblioteki statyczne DNS
342 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
343 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
344 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
345 Group:          Development/Libraries
346 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
347
348 %description static
349 Static bind libraries.
350
351 %description static -l pl.UTF-8
352 Statyczne biblioteki binda.
353
354 %description static -l pt_BR.UTF-8
355 Bibliotecas estáticas para desenvolvimento DNS.
356
357 %description static -l ru.UTF-8
358 Статические библиотеки, необходимые для написания программ с
359 использованием BIND.
360
361 %description static -l uk.UTF-8
362 Статичні бібліотеки, необхідні для розробки програм з використанням
363 BIND.
364
365 %prep
366 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
367
368 %patch3 -p1
369 %patch4 -p1
370 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
371 %{?with_edns_cli:%patch5 -p0}
372
373 %build
374 %{__libtoolize}
375 %{__aclocal}
376 %{__autoconf}
377 %{__automake}
378 %configure \
379         CFLAGS="-D_GNU_SOURCE=1 %{rpmcflags} %{rpmcppflags}" \
380         LDFLAGS="%{rpmldflags}" \
381         %{?with_dnstap:--enable-dnstap} \
382         %{!?with_epoll:--disable-epoll --disable-devpoll} \
383         --enable-full-report \
384         --enable-largefile \
385         %{?with_static_libs:--enable-static} \
386         %{?with_kerberos5:--with-gssapi} \
387         --with-jemalloc=yes \
388         --with-libidn2 \
389         --with-libxml2 \
390         %{?with_ssl:--with-openssl} \
391         %{?with_geoip:--with-maxminddb} \
392         --with-lmdb%{!?with_lmdb:=no} \
393         --with-tuning \
394         --disable-silent-rules
395
396 %{__make}
397 %{__make} -C doc/arm html
398
399 %{?with_hip:%{__make} -C bind-hip}
400
401 %if %{with tests}
402 %if %{with system_tests}
403 %{__make} test-force
404 %else
405 sh unit/unittest.sh
406 %endif
407 %endif
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
412         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
413         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
414         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
415
416 %{__make} install \
417         DESTDIR=$RPM_BUILD_ROOT
418
419 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
420 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
421 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
422 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
423
424 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
425 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
426 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
427 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
428 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
429 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
430 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
431 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
432
433 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
434 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
435 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.log    $RPM_BUILD_ROOT%{_var}/log/named
436 ln -sf --relative $RPM_BUILD_ROOT%{_var}/lib/named/named.stats  $RPM_BUILD_ROOT%{_var}/log/named.stats
437
438 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
439
440 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
441 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
442
443 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
444
445 # we don't want Makefiles in documentation...
446 rm -rf _doc
447 cp -a doc _doc
448 %{__rm} _doc/misc/Makefile*
449
450 %clean
451 rm -rf $RPM_BUILD_ROOT
452
453 %pre
454 if [ -f %{_sysconfdir}/named.boot ]; then
455         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
456         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
457         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
458 fi
459 %groupadd -g 58 named
460 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
461
462 %post
463 /sbin/chkconfig --add named
464 %service named restart
465 %systemd_post named.service
466
467 %preun
468 if [ "$1" = "0" ]; then
469         %service named stop
470         /sbin/chkconfig --del named
471 fi
472 %systemd_preun named.service
473
474 %postun
475 if [ "$1" = "0" ]; then
476         %userremove named
477         %groupremove named
478 fi
479 %systemd_reload
480
481 %post   libs -p /sbin/ldconfig
482 %postun libs -p /sbin/ldconfig
483
484 %triggerpostun -- %{name} < 7:9.9.2.P2-2
485 %systemd_trigger named.service
486
487 %files
488 %defattr(644,root,root,755)
489 %doc README.md %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
490 %doc _doc/misc/* _doc/arm/_build/html/*.html
491
492 %{systemdunitdir}/named.service
493 %attr(754,root,root) /etc/rc.d/init.d/named
494 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
495 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
496 %{_sysconfdir}/named.conf
497 %{_sysconfdir}/bind.keys
498
499 %attr(755,root,root) %{_bindir}/dnssec-*
500 %attr(755,root,root) %{_bindir}/named-*
501 %attr(755,root,root) %{_bindir}/nsec3hash
502 %attr(755,root,root) %{_sbindir}/ddns-confgen
503 %attr(755,root,root) %{_sbindir}/named
504 %attr(755,root,root) %{_sbindir}/rndc
505 %attr(755,root,root) %{_sbindir}/rndc-confgen
506 %attr(755,root,root) %{_sbindir}/tsig-keygen
507
508 %{_mandir}/man1/dnssec-*.1*
509 %{_mandir}/man1/named-*.1*
510 %{_mandir}/man1/nsec3hash.1*
511 %{_mandir}/man5/named.conf.5*
512 %{_mandir}/man5/rndc.conf.5*
513 %{_mandir}/man8/ddns-confgen.8*
514 %{_mandir}/man8/named.8*
515 %{_mandir}/man8/rndc.8*
516 %{_mandir}/man8/rndc-confgen.8*
517 %{_mandir}/man8/tsig-keygen.8*
518 %lang(ja) %{_mandir}/ja/man8/named*
519
520 %{systemdtmpfilesdir}/%{name}.conf
521
522 %attr(770,root,named) %dir %{_var}/lib/named
523 %attr(770,root,named) %dir %{_var}/lib/named/D
524 %attr(770,root,named) %dir %{_var}/lib/named/M
525 %attr(770,root,named) %dir %{_var}/lib/named/S
526 %attr(770,root,named) %dir %{_var}/lib/named/dev
527 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
528 %attr(750,root,named) %dir %{_var}/lib/named/etc
529 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
530 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
531 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
532 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
533 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
534 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
535
536 %config(noreplace,missingok) %{_var}/log/named
537 %config(noreplace,missingok) %{_var}/log/named.stats
538
539 %attr(770,root,named) %dir %{_var}/run/named
540
541 %dir %{_libdir}/bind
542 %attr(755,root,root) %{_libdir}/bind/filter-a.so
543 %attr(755,root,root) %{_libdir}/bind/filter-aaaa.so
544 %{_mandir}/man8/filter-a.8*
545 %{_mandir}/man8/filter-aaaa.8*
546
547 %files utils
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/arpaname
550 %attr(755,root,root) %{_bindir}/delv
551 %attr(755,root,root) %{_bindir}/dig
552 %attr(755,root,root) %{_bindir}/host
553 %attr(755,root,root) %{_bindir}/named-rrchecker
554 %attr(755,root,root) %{_bindir}/mdig
555 %attr(755,root,root) %{_bindir}/nslookup
556 %attr(755,root,root) %{_bindir}/nsupdate
557 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
558 %{_mandir}/man1/arpaname.1*
559 %{_mandir}/man1/delv.1*
560 %{_mandir}/man1/dig.1*
561 %{_mandir}/man1/host.1*
562 %{_mandir}/man1/mdig.1*
563 %{_mandir}/man1/named-rrchecker.1*
564 %{_mandir}/man1/nslookup.1*
565 %{_mandir}/man1/nsupdate.1*
566
567 %lang(fi) %{_mandir}/fi/man1/host.1*
568
569 %lang(fr) %{_mandir}/fr/man1/host.1*
570
571 %lang(hu) %{_mandir}/hu/man1/host.1*
572
573 %lang(ja) %{_mandir}/ja/man1/dig.1*
574 %lang(ja) %{_mandir}/ja/man1/host.1*
575 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
576 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
577
578 %lang(pl) %{_mandir}/pl/man1/host.1*
579
580 %files libs
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/libbind9-%{version}.so
583 %attr(755,root,root) %{_libdir}/libdns-%{version}.so
584 %attr(755,root,root) %{_libdir}/libirs-%{version}.so
585 %attr(755,root,root) %{_libdir}/libisc-%{version}.so
586 %attr(755,root,root) %{_libdir}/libisccc-%{version}.so
587 %attr(755,root,root) %{_libdir}/libisccfg-%{version}.so
588 %attr(755,root,root) %{_libdir}/libns-%{version}.so
589
590 %files devel
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_libdir}/libbind9.so
593 %attr(755,root,root) %{_libdir}/libdns.so
594 %attr(755,root,root) %{_libdir}/libirs.so
595 %attr(755,root,root) %{_libdir}/libisc.so
596 %attr(755,root,root) %{_libdir}/libisccc.so
597 %attr(755,root,root) %{_libdir}/libisccfg.so
598 %attr(755,root,root) %{_libdir}/libns.so
599 %{_libdir}/libbind9.la
600 %{_libdir}/libdns.la
601 %{_libdir}/libirs.la
602 %{_libdir}/libisc.la
603 %{_libdir}/libisccc.la
604 %{_libdir}/libisccfg.la
605 %{_libdir}/libns.la
606 %{_includedir}/bind9
607 %{_includedir}/dns
608 %{_includedir}/dst
609 %{_includedir}/irs
610 %{_includedir}/isc
611 %{_includedir}/isccc
612 %{_includedir}/isccfg
613 %{_includedir}/ns
614
615 %if %{with static_libs}
616 %files static
617 %defattr(644,root,root,755)
618 %{_libdir}/libbind9.a
619 %{_libdir}/libdns.a
620 %{_libdir}/libirs.a
621 %{_libdir}/libisc.a
622 %{_libdir}/libisccc.a
623 %{_libdir}/libisccfg.a
624 %{_libdir}/libns.a
625 %endif
626
627 %if %{with ldap}
628 %files -n openldap-schema-bind
629 %defattr(644,root,root,755)
630 %{_datadir}/openldap/schema/dnszone.schema
631 %endif
This page took 0.087747 seconds and 4 git commands to generate.