]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.14.10
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  geoip           # GeoIP support
6 %bcond_without  kerberos5       # GSS-API support
7 %bcond_without  ssl             # OpenSSL support
8 %bcond_with     ldap            # LDAP DLZ support
9 %bcond_with     odbc            # ODBC DLZ support
10 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
11 %bcond_without  lmdb            # LMDB storage support for addzone zones
12 %bcond_without  static_libs     # static libraries
13 %bcond_with     system_tests    # system tests (require root to configure localhost IPs)
14 %bcond_with     tests           # unit tests
15 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
16 %bcond_with     hip             # HIP RR support
17
18 %if "%{pld_release}" == "ac"
19 %bcond_with     epoll           # enable epoll support
20 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
21 %ifarch %{x8664}
22 %define         with_epoll      1
23 %endif
24 %else
25 %bcond_without  epoll           # disable epoll support
26 %endif
27
28 %define         ver     9.14.10
29 %if 0
30 %define         pverdot .P0
31 %define         pverdir -P0
32 %else
33 %define         pverdot %{nil}
34 %define         pverdir %{nil}
35 %endif
36 Summary:        BIND - DNS name server
37 Summary(de.UTF-8):      BIND - DNS-Namenserver
38 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
39 Summary(fr.UTF-8):      BIND - serveur de noms DNS
40 Summary(pl.UTF-8):      BIND - serwer nazw DNS
41 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
42 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
43 Summary(tr.UTF-8):      DNS alan adı sunucusu
44 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
45 Summary(zh_CN.UTF-8):   Internet 域名服务器
46 Name:           bind
47 Version:        %{ver}%{pverdot}
48 Release:        1
49 Epoch:          7
50 License:        MPL 2.0
51 Group:          Networking/Daemons
52 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
53 # Source0-md5:  c4b4e48ae6dc87da4cae333665c0b4e3
54 Source1:        named.init
55 Source2:        named.sysconfig
56 Source3:        named.logrotate
57 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
58 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
59 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
60 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
61 Source6:        %{name}-hip.tar.gz
62 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
63 Source7:        https://www.internic.net/domain/named.root
64 # Source7-md5:  1e4e7c3e1ce2c5442eed998046edf548
65 Source8:        %{name}-127.0.0.zone
66 Source9:        %{name}-localhost.zone
67 Source10:       %{name}-named.conf
68 Source11:       %{name}.tmpfiles
69 Source12:       named.service
70 Patch0:         %{name}-time.patch
71 Patch1:         %{name}-link.patch
72 Patch2:         %{name}-pmake.patch
73 Patch3:         %{name}-sdb-ldap.patch
74 Patch4:         %{name}-ac-libs.patch
75 Patch5:         %{name}-edns-client-subnet.patch
76 Patch6:         nsupdate_segfault.patch
77 URL:            https://www.isc.org/software/bind
78 BuildRequires:  autoconf >= 2.59
79 BuildRequires:  automake
80 BuildRequires:  bison
81 BuildRequires:  flex
82 %{?with_kerberos5:BuildRequires:        heimdal-devel}
83 BuildRequires:  json-c-devel
84 BuildRequires:  libidn2-devel
85 # note, there is no kyua in PLD yet (work in progress)
86 %{?with_tests:%{!?with_system_tests:BuildRequires:      kyua}}
87 BuildRequires:  libtool
88 %{?with_hip:BuildRequires:      libxml2-devel}
89 %{?with_lmdb:BuildRequires:     lmdb-devel}
90 %{?with_geoip:BuildRequires:    libmaxminddb-devel}
91 %{?with_sql:BuildRequires:      mysql-devel}
92 %{?with_ldap:BuildRequires:     openldap-devel}
93 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
94 %{?with_sql:BuildRequires:      postgresql-devel}
95 BuildRequires:  python3-devel
96 BuildRequires:  python3-ply
97 BuildRequires:  readline-devel
98 BuildRequires:  rpm >= 4.4.9-56
99 BuildRequires:  rpmbuild(macros) >= 1.647
100 %{?with_odbc:BuildRequires:     unixODBC-devel}
101 BuildRequires:  zlib-devel
102 Requires(post,preun):   /sbin/chkconfig
103 Requires(postun):       /usr/sbin/groupdel
104 Requires(postun):       /usr/sbin/userdel
105 Requires(pre):  /bin/id
106 Requires(pre):  /usr/bin/getgid
107 Requires(pre):  /usr/sbin/groupadd
108 Requires(pre):  /usr/sbin/useradd
109 Requires(pre):  fileutils
110 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
111 # for dnssec-{checkds,coverage,keymgr}
112 Requires:       python3-isc = %{epoch}:%{version}-%{release}
113 Requires:       psmisc >= 20.1
114 Requires:       rc-scripts >= 0.2.0
115 Requires:       systemd-units >= 38
116 Requires:       uname(release) >= 2.2.18
117 Provides:       group(named)
118 Provides:       nameserver
119 Provides:       user(named)
120 Obsoletes:      caching-nameserver
121 Conflicts:      %{name}-chroot
122 Conflicts:      logrotate < 3.8.0
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         schemadir       /usr/share/openldap/schema
126
127 %description
128 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
129 (Domain Name System) protocols. BIND includes a DNS server (named),
130 which resolves host names to IP addresses, and a resolver library
131 (routines for applications to use when interfacing with DNS). A DNS
132 server allows clients to name resources or objects and share the
133 information with other network machines. The named DNS server can be
134 used on workstations as a caching name server, but is generally only
135 needed on one machine for an entire network. Note that the
136 configuration files for making BIND act as a simple caching nameserver
137 are included in the caching-nameserver package.
138
139 Install the bind package if you need a DNS server for your network. If
140 you want bind to act a caching name server, you will also need to
141 install the caching-nameserver package.
142
143 %description -l de.UTF-8
144 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
145 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
146 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
147 Recher des Netzwerks erforderlich.
148
149 %description -l es.UTF-8
150 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
151 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
152 un servidor de nombres caché, pero generalmente sólo hace falta en una
153 máquina para toda la red.
154
155 %description -l fr.UTF-8
156 Contient le serveur de noms named, utilisé pour définir les
157 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
158 utilisé sur les stations de travail comme serveur de nom en cache mais
159 n'est souvent nécessaire que sur une machine pour un réseau entier.
160
161 %description -l pl.UTF-8
162 Pakiet ten zawiera demona named, który służy do zmieniania nazw
163 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
164 roboczych jako bufor odwołań do serwisu nazw (caching name server),
165 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
166 program na fragment sieci.
167
168 %description -l pt_BR.UTF-8
169 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
170 IP (e vice-versa). Pode ser usado em estações de trabalho como um
171 servidor de nomes cache, mas geralmente só é necessário em uma máquina
172 para toda a rede.
173
174 %description -l ru.UTF-8
175 BIND (Berkeley Internet Name Domain) является реализацией протоколов
176 DNS (Domain Name System). BIND включает DNS сервер (named) и
177 библиотеку "резолвера" (подпрограммы для приложений, через которые
178 происходят обращения к DNS). DNS сервер named может быть использован
179 на рабочих станциях как кеширующий сервер, но обычно запускается на
180 одной машине в локальной сети и используется остальными машинами (этим
181 достигается намного более эффективное кеширование).
182
183 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
184 кеширующего сервера, включены в пакет caching-nameserver.
185
186 %description -l tr.UTF-8
187 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
188 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
189 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
190 için sadece bir makina üzerinde kurulur.
191
192 %description -l uk.UTF-8
193 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
194 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
195 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
196 сервер named може бути використаний на робочих станціях як кешируючий
197 сервер, але звичайно запускається на одній машині в локальній мережі і
198 використовується іншими (цим досягається більша ефективність
199 використання кешу).
200
201 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
202 кешируючого серверу, включені в пакет caching-nameserver.
203
204 %package utils
205 Summary:        DNS utils - host, dig, dnsquery, nslookup
206 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
207 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
208 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
209 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
210 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
211 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
212 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
213 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
214 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
215 Group:          Networking/Utilities
216 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
217 Requires:       iconv
218
219 %description utils
220 Bind-utils contains a collection of utilities for querying DNS (Domain
221 Name Service) name servers to find out information about Internet
222 hosts. These tools will provide you with the IP addresses for given
223 host names, as well as other information about registered domains and
224 network addresses.
225
226 You should install bind-utils if you need to get information from DNS
227 name servers.
228
229 %description utils -l de.UTF-8
230 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
231 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
232 Informationen über registrierte Domains und Netzwerk-Adressen.
233
234 %description utils -l es.UTF-8
235 Conjunto de utilitarios para consulta a servidores de nombres. Estas
236 herramientas permiten la determinación de direcciones IP para nombres
237 de máquinas informados y busca información sobre dominios registrados
238 y direcciones de red.
239
240 %description utils -l fr.UTF-8
241 Ensemble d'utilitaires pour interroger les serveurs de noms et
242 rechercher des hôtes. Ces outils vous permettent de déterminer les
243 adresses IP pour des noms d'hôtes donnés, et trouver des informations
244 sur les noms de domaine déclarés et les adresses réseau.
245
246 %description utils -l pl.UTF-8
247 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
248 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
249 i ich adresach IP.
250
251 %description utils -l pt_BR.UTF-8
252 Conjunto de utilitários para consulta a servidores DNS. Estas
253 ferramentas permitem a determinação de endereços IP para nomes de
254 máquinas informados e busca informações sobre domínios registrados e
255 endereços de rede. Você deveria instalar este pacote se necessitar
256 obter informações de servidores DNS.
257
258 %description utils -l ru.UTF-8
259 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
260 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
261 доменному имени (и наоборот) и другую информацию о зарегистрированных
262 доменах и сетевых адресах.
263
264 %description utils -l tr.UTF-8
265 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
266 için kullanılan araçlar bulunmaktadır.
267
268 %description utils -l uk.UTF-8
269 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
270 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
271 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
272 домени та адреси.
273
274 %package libs
275 Summary:        DNS libraries
276 Summary(pl.UTF-8):      Biblioteki DNS
277 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
278 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
279 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
280 Group:          Libraries
281
282 %description libs
283 The bind-libs package contains all libraries required for running BIND
284 and bind utils.
285
286 %description libs -l pl.UTF-8
287 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
288 lub programów z pakietu bind-utils.
289
290 %description libs -l ru.UTF-8
291 Библиотеки, необходимые для работы bind.
292
293 %description libs -l uk.UTF-8
294 Бібліотеки, необхідні для роботи bind.
295
296 %package devel
297 Summary:        DNS development includes
298 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
299 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
300 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
301 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
302 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
303 Group:          Development/Libraries
304 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
305
306 %description devel
307 The bind-devel package contains all the include files and symlinks
308 required for DNS (Domain Name Service) development for BIND.
309
310 You should install bind-devel if you want to develop bind DNS
311 applications. If you install bind-devel, you'll also need to install
312 bind-libs.
313
314 %description devel -l es.UTF-8
315 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
316 para el bind.
317
318 %description devel -l pl.UTF-8
319 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
320 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
321 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
322 pakiet.
323
324 %description devel -l pt_BR.UTF-8
325 Todos os arquivos de cabeçalho e bibliotecas necessários para o
326 desenvolvimento com o bind.
327
328 %description devel -l ru.UTF-8
329 Все хедеры и библиотеки, необходимые для написания программ с
330 использованием BIND 9.x.x.
331
332 %description devel -l uk.UTF-8
333 Всі хедери та бібліотеки, необхідні для розробки програм з
334 використанням BIND 9.x.x.
335
336 %package static
337 Summary:        DNS static libs
338 Summary(pl.UTF-8):      Biblioteki statyczne DNS
339 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
340 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
341 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
342 Group:          Development/Libraries
343 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
344
345 %description static
346 Static bind libraries.
347
348 %description static -l pl.UTF-8
349 Statyczne biblioteki binda.
350
351 %description static -l pt_BR.UTF-8
352 Bibliotecas estáticas para desenvolvimento DNS.
353
354 %description static -l ru.UTF-8
355 Статические библиотеки, необходимые для написания программ с
356 использованием BIND.
357
358 %description static -l uk.UTF-8
359 Статичні бібліотеки, необхідні для розробки програм з використанням
360 BIND.
361
362 %package -n openldap-schema-bind
363 Summary:        BIND schema for openldap
364 Summary(pl.UTF-8):      Schemat BIND dla openldap
365 Group:          Development/Libraries
366 Requires(post,postun):  sed >= 4.0
367 Requires:       openldap-servers
368 Requires:       sed >= 4.0
369 %if "%{_rpmversion}" >= "5"
370 BuildArch:      noarch
371 %endif
372
373 %description -n openldap-schema-bind
374 BIND schema for openldap.
375
376 %description -n openldap-schema-bind -l pl.UTF-8
377 Schemat BIND dla openldap.
378
379 %package -n python3-isc
380 Summary:        Python 3 ISC module - functions to support BIND utilities
381 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
382 Group:          Libraries/Python
383 Requires:       python3-modules
384
385 %description -n python3-isc
386 Python 3 ISC module containing functions to support BIND utilities.
387
388 %description -n python3-isc -l pl.UTF-8
389 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
390 BIND-a.
391
392 %prep
393 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
394 %patch0 -p1
395 %patch1 -p1
396 %patch2 -p1
397 %{?with_ldap:%patch3 -p1}
398 %patch4 -p1
399 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
400 %{?with_edns_cli:%patch5 -p0}
401 %patch6 -p0
402
403 %build
404 %{__libtoolize}
405 %{__aclocal}
406 %{__autoconf}
407 cp -f /usr/share/automake/config.* .
408 %configure \
409         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
410         %{!?with_epoll:--disable-epoll --disable-devpoll} \
411         --enable-full-report \
412         --enable-largefile \
413         %{!?with_static_libs:--disable-static} \
414         %{?with_kerberos5:--with-gssapi} \
415         --with-libidn2 \
416         --with-libtool \
417         %{?with_ssl:--with-openssl} \
418         %{?with_sql:--with-dlz-postgres} \
419         %{?with_sql:--with-dlz-mysql} \
420         --without-dlz-bdb \
421         --with-dlz-filesystem \
422         %{?with_ldap:--with-dlz-ldap} \
423         --with-dlz-odbc%{!?with_odbc:=no} \
424         --with-dlz-stub \
425         %{?with_geoip:--with-geoip2} \
426         --with-lmdb%{!?with_lmdb:=no} \
427         --with-python=%{__python3}
428
429 %{__make}
430
431 %{?with_hip:%{__make} -C bind-hip}
432
433 %if %{with tests}
434 %if %{with system_tests}
435 %{__make} test-force
436 %else
437 sh unit/unittest.sh
438 %endif
439 %endif
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
444         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
445         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
446         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
447
448 %{__make} install \
449         DESTDIR=$RPM_BUILD_ROOT
450
451 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
452 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
453 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
454 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
455
456 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
457 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
458 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
459 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
460 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
461 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
462 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
463 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
464 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
465
466 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
467 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
468 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
469 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
470
471 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
472
473 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
474 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
475
476 %if %{with ldap}
477 install -d $RPM_BUILD_ROOT%{schemadir}
478 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
479 %endif
480
481 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
482
483 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
484 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
485
486 # let rpm generate deps (workaround -m644 used for libs installation)
487 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
488
489 # we don't want Makefiles in documentation...
490 rm -rf _doc
491 cp -a doc _doc
492 %{__rm} _doc/misc/Makefile*
493
494 %clean
495 rm -rf $RPM_BUILD_ROOT
496
497 %pre
498 if [ -f %{_sysconfdir}/named.boot ]; then
499         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
500         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
501         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
502 fi
503 %groupadd -g 58 named
504 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
505
506 %post
507 /sbin/chkconfig --add named
508 %service named restart
509 %systemd_post named.service
510
511 %preun
512 if [ "$1" = "0" ]; then
513         %service named stop
514         /sbin/chkconfig --del named
515 fi
516 %systemd_preun named.service
517
518 %postun
519 if [ "$1" = "0" ]; then
520         %userremove named
521         %groupremove named
522 fi
523 %systemd_reload
524
525 %post   libs -p /sbin/ldconfig
526 %postun libs -p /sbin/ldconfig
527
528 %post -n openldap-schema-bind
529 %openldap_schema_register %{schemadir}/dnszone.schema
530 %service -q ldap restart
531
532 %postun -n openldap-schema-bind
533 if [ "$1" = "0" ]; then
534         %openldap_schema_unregister %{schemadir}/dnszone.schema
535         %service -q ldap restart
536 fi
537
538 %triggerpostun -- %{name} < 7:9.4.2-2
539 /sbin/chkconfig named reset
540 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
541 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
542 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
543
544 %triggerpostun -- %{name} < 7:9.9.2.P2-2
545 %systemd_trigger named.service
546
547 %files
548 %defattr(644,root,root,755)
549 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
550 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
551
552 %{systemdunitdir}/named.service
553 %attr(754,root,root) /etc/rc.d/init.d/named
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
555 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
556 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
557 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
558
559 %attr(755,root,root) %{_sbindir}/ddns-confgen
560 %attr(755,root,root) %{_sbindir}/dnssec-*
561 %attr(755,root,root) %{_sbindir}/named
562 %attr(755,root,root) %{_sbindir}/named-*
563 %attr(755,root,root) %{_sbindir}/nsec3hash
564 %attr(755,root,root) %{_sbindir}/rndc
565 %attr(755,root,root) %{_sbindir}/rndc-confgen
566 %attr(755,root,root) %{_sbindir}/tsig-keygen
567
568 %{_mandir}/man5/named.conf.5*
569 %{_mandir}/man5/rndc.conf.5*
570 %{_mandir}/man8/ddns-confgen.8*
571 %{_mandir}/man8/dnssec-*.8*
572 %{_mandir}/man8/named.8*
573 %{_mandir}/man8/named-*.8*
574 %{_mandir}/man8/nsec3hash.8*
575 %{_mandir}/man8/rndc.8*
576 %{_mandir}/man8/rndc-confgen.8*
577 %{_mandir}/man8/tsig-keygen.8*
578 %lang(ja) %{_mandir}/ja/man8/named*
579
580 %{systemdtmpfilesdir}/%{name}.conf
581
582 %attr(770,root,named) %dir %{_var}/lib/named
583 %attr(770,root,named) %dir %{_var}/lib/named/D
584 %attr(770,root,named) %dir %{_var}/lib/named/M
585 %attr(770,root,named) %dir %{_var}/lib/named/S
586 %attr(770,root,named) %dir %{_var}/lib/named/dev
587 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
588 %attr(750,root,named) %dir %{_var}/lib/named/etc
589 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
590 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
591 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
592 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
593 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
594 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
595
596 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
597 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
598
599 %attr(770,root,named) %dir %{_var}/run/named
600
601 %dir %{_libdir}/named
602 %attr(755,root,root) %{_libdir}/named/filter-aaaa.so
603 %{_mandir}/man8/filter-aaaa.8*
604
605 %files utils
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_bindir}/arpaname
608 %attr(755,root,root) %{_bindir}/delv
609 %attr(755,root,root) %{_bindir}/dig
610 %attr(755,root,root) %{_bindir}/host
611 %attr(755,root,root) %{_bindir}/named-rrchecker
612 %attr(755,root,root) %{_bindir}/mdig
613 %attr(755,root,root) %{_bindir}/nslookup
614 %attr(755,root,root) %{_bindir}/nsupdate
615 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
616 %{_mandir}/man1/arpaname.1*
617 %{_mandir}/man1/delv.1*
618 %{_mandir}/man1/dig.1*
619 %{_mandir}/man1/host.1*
620 %{_mandir}/man1/mdig.1*
621 %{_mandir}/man1/named-rrchecker.1*
622 %{_mandir}/man1/nslookup.1*
623 %{_mandir}/man1/nsupdate.1*
624
625 %lang(fi) %{_mandir}/fi/man1/host.1*
626
627 %lang(fr) %{_mandir}/fr/man1/host.1*
628
629 %lang(hu) %{_mandir}/hu/man1/host.1*
630
631 %lang(ja) %{_mandir}/ja/man1/dig.1*
632 %lang(ja) %{_mandir}/ja/man1/host.1*
633 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
634 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
635
636 %lang(pl) %{_mandir}/pl/man1/host.1*
637
638 %files libs
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1302
642 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1312
644 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1301
646 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1310
648 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1302
650 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1302
652 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libns.so.1307
654
655 %files devel
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/bind9-config
658 %attr(755,root,root) %{_bindir}/isc-config.sh
659 %attr(755,root,root) %{_libdir}/libbind9.so
660 %attr(755,root,root) %{_libdir}/libdns.so
661 %attr(755,root,root) %{_libdir}/libirs.so
662 %attr(755,root,root) %{_libdir}/libisc.so
663 %attr(755,root,root) %{_libdir}/libisccc.so
664 %attr(755,root,root) %{_libdir}/libisccfg.so
665 %attr(755,root,root) %{_libdir}/libns.so
666 %{_libdir}/libbind9.la
667 %{_libdir}/libdns.la
668 %{_libdir}/libirs.la
669 %{_libdir}/libisc.la
670 %{_libdir}/libisccc.la
671 %{_libdir}/libisccfg.la
672 %{_libdir}/libns.la
673 %{_includedir}/bind9
674 %{_includedir}/dns
675 %{_includedir}/dst
676 %{_includedir}/irs
677 %{_includedir}/isc
678 %{_includedir}/isccc
679 %{_includedir}/isccfg
680 %{_includedir}/ns
681 %{_includedir}/pk11
682 %{_includedir}/pkcs11
683 %{_mandir}/man1/bind9-config.1*
684 %{_mandir}/man1/isc-config.sh.1*
685
686 %if %{with static_libs}
687 %files static
688 %defattr(644,root,root,755)
689 %{_libdir}/libbind9.a
690 %{_libdir}/libdns.a
691 %{_libdir}/libirs.a
692 %{_libdir}/libisc.a
693 %{_libdir}/libisccc.a
694 %{_libdir}/libisccfg.a
695 %{_libdir}/libns.a
696 %endif
697
698 %if %{with ldap}
699 %files -n openldap-schema-bind
700 %defattr(644,root,root,755)
701 %{_datadir}/openldap/schema/dnszone.schema
702 %endif
703
704 %files -n python3-isc
705 %defattr(644,root,root,755)
706 %{py3_sitedir}/isc
707 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.143578 seconds and 4 git commands to generate.