]> git.pld-linux.org Git - packages/bfilter.git/blob - bfilter.spec
- New spec.
[packages/bfilter.git] / bfilter.spec
1 %bcond_with gui         # Enable GTK+ UI (doesn't build)
2
3 Summary:        A filtering Web proxy
4 Summary(pl):    Filtruj±ce proxy WWW
5 Name:           bfilter
6 Version:        0.9.4
7 Release:        1
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
11 # Source0-md5:  72ca85565bd4c556b06e3a264c0c24f1
12 Source1:        %{name}.init
13 URL:            http://bfilter.sf.net
14 BuildRequires:  zlib-devel
15 BuildRequires:  popt-devel
16 BuildRequires:  libsigc++12-devel
17 Requires(post): /usr/sbin/groupadd
18 Requires(post): /usr/sbin/useradd
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description 
23 BFilter is a filtering web proxy. It was originally intended for
24 removing banner ads only, but at some point it has been extended to
25 remove popups and webbugs.  Its main advantage over the similar tools
26 is its heuristic ad detection algorithm. 
27
28 %description -l pl
29 BFilter jest filtruj±cym proxy WWW.  Pierwotnie mia³ on filtrowaæ
30 tylko bannery, jednak rozszerzono go o usuwanie popupów i innych
31 reklam.  G³ówn± jego przewag± nad innymi tego rodzaju narzêdziami jest
32 heurystyczny algorytm rozpoznawania reklam.
33
34 %prep
35 %setup -q
36
37 %build
38 %configure \
39         --with%{!?with_gui:out}-gui
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # create directories if necessary
45 #install -d $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49 %{__install} -d $RPM_BUILD_ROOT/etc/init.d
50 %{__install} -m 0755 %{SOURCE1} $RPM_BUILD_ROOT/etc/init.d/%{name}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %pre
56 groupadd -r -f %{name}
57 useradd -r -s /bin/false -d / -M -g %{name} -c 'BFilter filtering proxy' %{name} || :
58
59 %post
60 chkconfig --add %{name}
61 if [ -f /var/lock/subsys/%{name} ]; then
62         /etc/rc.d/init.d/%{name} restart 1>&2
63 else
64         echo "Type \"/etc/rc.d/init.d/%{name} start\" to start %{name}." 1>&2
65 fi
66
67 %preun
68 if [ "$1" = "0" ]; then
69         if [ -f /var/lock/subsys/%{name} ]; then
70                 /etc/rc.d/init.d/%{name} stop 1>&2
71         fi
72         /sbin/chkconfig --del %{name}
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS ChangeLog INSTALL NEWS README VERSION doc/*.html doc/*.png
78 %attr(755,root,root) %{_bindir}/%{name}
79 %attr(755,root,root) /etc/init.d/%{name}
80 %dir %{_sysconfdir}/%{name}
81 %config %{_sysconfdir}/%{name}/config
82 %config %{_sysconfdir}/%{name}/rules.local
83 %{_sysconfdir}/%{name}/config.default
84 %{_sysconfdir}/%{name}/rules
This page took 0.053378 seconds and 3 git commands to generate.