]> git.pld-linux.org Git - packages/beryl-core.git/blob - beryl-core.spec
- separated gconf settings backend
[packages/beryl-core.git] / beryl-core.spec
1 #
2 # Conditional build:
3 %bcond_without  beryl_mesa      # beryl-xgl statically linked with own libGL
4 #
5 Summary:        OpenGL window and compositing manager
6 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
7 Name:           beryl-core
8 Version:        0.1.3
9 Release:        1
10 Epoch:          1
11 License:        MIT
12 Group:          X11
13 Source0:        http://releases.beryl-project.org/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  24caed8a8cb50fd30823a9ee182f85f4
15 Source1:        http://releases.beryl-project.org/%{version}/beryl-mesa-%{version}.tar.bz2
16 # Source1-md5:  c22765c2637846907ee6154b548151e9
17 Patch0:         %{name}-link.patch
18 URL:            http://beryl-project.org/
19 BuildRequires:  GConf2-devel >= 2.0
20 BuildRequires:  OpenGL-GLX-devel
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  intltool >= 0.35.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  startup-notification-devel >= 0.7
30 BuildRequires:  xorg-lib-libSM-devel
31 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.3
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXinerama-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  xorg-proto-glproto-devel
36 BuildRequires:  xorg-util-makedepend
37 Provides:       compiz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Beryl is an OpenGL compositing manager that use
42 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
43 to texture objects. It has a flexible plug-in system and it is
44 designed to run well on most graphics hardware.
45
46 This is an enhanced version of compiz, developed mainly by Quinnstorm.
47 Some parts were optimized for speed and there were added few
48 additional plugins and patches, delivering even more eyecandy.
49
50 %description -l pl
51 Beryl jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
52 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
53 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
54 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
55
56 To jest udoskonalona wersja compiza, tworzona g³ównie przez
57 Quinnstorma. Niektóre czê¶ci zosta³y zoptymalizowane pod wzglêdem
58 prêdko¶ci oraz dodano kilka dodatkowych wtyczek i ³atek,
59 dostarczaj±cych jeszcze wiêcej ¶wiecide³ek.
60
61 %package devel
62 Summary:        Header files for beryl
63 Summary(pl):    Pliki nag³ówkowe dla beryla
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66 Requires:       OpenGL-GLX-devel
67 Requires:       glib2-devel >= 2.0
68 Requires:       libpng-devel
69 Requires:       startup-notification-devel >= 0.7
70 Requires:       xorg-lib-libSM-devel
71 Requires:       xorg-lib-libXcomposite-devel >= 0.3
72 Requires:       xorg-lib-libXdamage-devel
73 Requires:       xorg-lib-libXinerama-devel
74 Requires:       xorg-lib-libXrandr-devel
75 Requires:       xorg-proto-glproto-devel
76
77 %description devel
78 Header files for beryl.
79
80 %description devel -l pl
81 Pliki nag³ówkowe dla beryla.
82
83 %package gconf
84 Summary:        GConf settings plugin for beryl
85 Summary(pl):    Wtyczka ustawieñ GConf dla beryla
86 Group:          Libraries
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88
89 %description gconf
90 GConf settings plugin for beryl.
91
92 %description gconf -l pl
93 Wtyczka ustawieñ GConf dla beryla.
94
95 %prep
96 %setup -q %{?with_beryl_mesa: -a1}
97 %patch0 -p1
98
99 mv -f po/{ca_ES,ca}.po
100 mv -f po/{es_ES,es}.po
101 mv -f po/{fr_FR,fr}.po
102 mv -f po/{hu_HU,hu}.po
103 mv -f po/{it_IT,it}.po
104 mv -f po/{ja_JP,ja}.po
105 mv -f po/{ko_KR,ko}.po
106 mv -f po/{pt_PT,pt}.po
107 mv -f po/{sv_SE,sv}.po
108 # sv_FI is identical to sv_SE
109
110 # NOTE: check the list ofter any upgrade!
111 cat > po/LINGUAS <<EOF
112 ca
113 es
114 es_AR
115 fr
116 hu
117 it
118 ja
119 ko
120 pt_BR
121 pt
122 sv
123 zh_CN
124 zh_HK
125 zh_TW
126 EOF
127
128 %build
129 %{__glib_gettextize}
130 %{__intltoolize} --automake
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136
137 # bashisms inside
138 sed -i -e 's@^#! /bin/sh$@#!/bin/bash@' configure
139
140 %configure \
141         %{?with_beryl_mesa:--with-berylmesadir=beryl-mesa} \
142         --disable-static
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 rm -f $RPM_BUILD_ROOT%{_libdir}/beryl/backends/*.la
152
153 # program removed
154 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/beryl-settings-dump.1
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS README TODO
167 %attr(755,root,root) %{_bindir}/beryl
168 %attr(755,root,root) %{_libdir}/libberylsettings.so.*.*.*
169 %dir %{_libdir}/beryl
170 %dir %{_libdir}/beryl/backends
171 %attr(755,root,root) %{_libdir}/beryl/backends/libini.so
172 %{_datadir}/beryl
173 %{_mandir}/man1/beryl.1*
174 %if %{with beryl_mesa}
175 %attr(755,root,root) %{_bindir}/beryl-xgl
176 %{_mandir}/man1/beryl-xgl.1*
177 %endif
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libberylsettings.so
182 %{_libdir}/libberylsettings.la
183 %{_includedir}/beryl
184 %{_pkgconfigdir}/beryl.pc
185 %{_pkgconfigdir}/berylsettings.pc
186 %{_mandir}/man3/*.3*
187
188 %files gconf
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/beryl/backends/libgconf.so
This page took 0.064848 seconds and 4 git commands to generate.