]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- dbus stuff not required in any form, %%files fixes, more Rs
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 # - MOZILLA_HOME misdetected
4 #
5 # Conditional build:
6 %bcond_with     epiphany        # build epiphany extension
7                                 # (just a hack)
8 Summary:        Beagle - An indexing subsystem
9 Summary(pl):    Beagle - podsystem indeksuj±cy
10 Name:           beagle
11 Version:        0.0.12
12 Release:        0.1
13 License:        Various
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.0/%{name}-%{version}.tar.bz2
16 # Source0-md5:  27bfdc64982a471a7d9c2a86c620752d
17 URL:            http://beaglewiki.org/Main_Page
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  dotnet-evolution-sharp-devel >= 0.6
21 BuildRequires:  dotnet-gecko-sharp-devel = 0.6
22 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.15
23 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
24 #BuildRequires: dotnet-gst-sharp-devel
25 BuildRequires:  dotnet-gtk-sharp-gnome-devel
26 BuildRequires:  dotnet-gtk-sharp-devel
27 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.6}
28 BuildRequires:  gnome-vfs2-devel
29 BuildRequires:  gtk+2-devel >= 2:2.4.0
30 BuildRequires:  libexif-devel >= 0.5.0
31 BuildRequires:  libgnome-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libtool
34 BuildRequires:  libxml2-devel >= 2.6.0
35 BuildRequires:  mono-csharp >= 1.0.6
36 BuildRequires:  mozilla-devel
37 BuildRequires:  pkgconfig
38 BuildRequires:  sqlite-devel
39 BuildRequires:  wv-devel >= 1.0.0
40 BuildRequires:  zip
41 Requires:       dotnet-evolution-sharp >= 0.6
42 Requires:       dotnet-gecko-sharp = 0.6
43 Requires:       dotnet-gmime-sharp >= 2.1.15
44 #Requires:      dotnet-gsf-sharp-devel >= 0.2
45 #Requires:      dotnet-gst-sharp-devel
46 Requires:       dotnet-gtk-sharp-gnome
47 %{?with_epiphany:Requires:      epiphany-extensions}
48 Requires:       gtk+2 >= 2:2.4.0
49 Requires:       sqlite
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Beagle is an indexing sub-system and search aggregator built on top of
54 Lucene.Net.
55
56 %description -l pl
57 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
58 bazie Lucene.Net.
59
60 %package devel
61 Summary:        Beagle development files
62 Summary(pl):    Pliki programistyczne Beagle
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Beagle development files.
68
69 %description devel -l pl
70 Pliki programistyczne Beagle.
71
72 %package -n epiphany-extension-beagle
73 Summary:        Epiphany extension - beagle
74 Summary(pl):    Rozszerzenie dla Epiphany - beagle
75 Group:          X11/Applications/Networking
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       epiphany >= 1.2.1
78 Requires:       epiphany < 1.3.0
79
80 %description -n epiphany-extension-beagle
81 Epiphany extension that allows Beagle to index every page the user
82 views.
83
84 %description -n epiphany-extension-beagle -l pl
85 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
86 odwiedzan± stronê.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         --disable-static \
98 %if %{with epiphany}
99         --enable-epiphany-extension
100 %else
101         --disable-epiphany-extension
102 %endif
103
104 %{__make} \
105         MOZILLA_HOME=%{_libdir}/mozilla
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # Kill useless files
114 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/extensions/*.la \
115         $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.4.0/filesystems/*.la \
116         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
117         
118 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
119
120 %find_lang %{name}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS COPYING ChangeLog NEWS README
131 %attr(755,root,root)%{_bindir}/*
132 %dir %{_libdir}/%{name}
133 %{_libdir}/%{name}/Filters
134 %{_libdir}/%{name}/*.exe
135 %{_libdir}/%{name}/*.dll*
136 %attr(755,root,root) %{_libdir}/lib*.so*
137 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
138 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
139 %attr(755,root,root) %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.so*
140 %{_pixmapsdir}/*.png
141 %{_desktopdir}/*.desktop
142 %{_mandir}/man1/*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %{_includedir}/libbeagle
147 %{_libdir}/*.la
148 %{_libdir}/*.so
149 %{_pkgconfigdir}/*
150
151 %if %{with epiphany}
152 %files -n epiphany-extension-beagle
153 %defattr(644,root,root,755)
154 %doc epiphany-extension/README
155 %attr(755,root,root) %{_libdir}/epiphany/extensions/libbeagleextension.so*
156 %endif
This page took 0.25934 seconds and 4 git commands to generate.