]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- started work on 0.1.1, without evolution by default (evolution is handled
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 # - package 'crawl' files
4 # - check .desktop files
5 # - separate libs (future proof)
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  epiphany        # don't build epiphany extension
11 %bcond_with     evolution       # don't include evolution support
12 #
13 Summary:        Beagle - An indexing subsystem
14 Summary(pl):    Beagle - podsystem indeksuj±cy
15 Name:           beagle
16 Version:        0.1.1
17 Release:        0.1
18 License:        Various
19 Group:          Libraries
20 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
21 # Source0-md5:  e788ed11077e576797a0793631f2fe8b
22 URL:            http://beaglewiki.org/Main_Page
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.6}
26 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
27 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
28 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
29 #BuildRequires: dotnet-gst-sharp-devel
30 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
31 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
32 BuildRequires:  gnome-vfs2-devel
33 BuildRequires:  gtk+2-devel >= 2:2.4.0
34 BuildRequires:  gtk-doc
35 BuildRequires:  libexif-devel >= 0.5.0
36 BuildRequires:  libgnome-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2.6.0
40 BuildRequires:  mono-csharp >= 1.0.6
41 BuildRequires:  mozilla-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  sqlite-devel
44 BuildRequires:  wv-devel >= 1.0.0
45 BuildRequires:  zip
46 Requires:       dotnet-gmime-sharp >= 2.1.16-2
47 %{?with_epiphany:Requires:      epiphany-extensions}
48 Requires:       gtk+2 >= 2:2.4.0
49 Requires:       sqlite
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Beagle is an indexing sub-system and search aggregator built on top of
54 Lucene.Net.
55
56 %description -l pl
57 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
58 bazie Lucene.Net.
59
60 %package devel
61 Summary:        Beagle development files
62 Summary(pl):    Pliki programistyczne Beagle
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Beagle development files.
68
69 %description devel -l pl
70 Pliki programistyczne Beagle.
71
72 %package -n epiphany-extension-beagle
73 Summary:        Epiphany extension - beagle
74 Summary(pl):    Rozszerzenie dla Epiphany - beagle
75 Group:          X11/Applications/Networking
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       epiphany >= 1.2.1
78 Requires:       epiphany < 1.3.0
79
80 %description -n epiphany-extension-beagle
81 Epiphany extension that allows Beagle to index every page the user
82 views.
83
84 %description -n epiphany-extension-beagle -l pl
85 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
86 odwiedzan± stronê.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         --disable-static \
98         --enable-gtk-doc \
99         --with-html-dir=%{_gtkdocdir} \
100         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
101         --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
102         
103
104 %{__make} \
105         MOZILLA_HOME=%{_libdir}/mozilla
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # Kill useless files
114 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
115         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
116         
117 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
118
119 %find_lang %{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files -f %{name}.lang
128 %defattr(644,root,root,755)
129 %doc AUTHORS COPYING ChangeLog NEWS README
130 %attr(755,root,root) %{_bindir}/*
131 %attr(755,root,root) %{_sbindir}/*
132
133 %dir %{_libdir}/%{name}
134 %{_libdir}/%{name}/Filters
135 %{_libdir}/%{name}/*.exe
136 %{_libdir}/%{name}/*.dll*
137
138 # to be separtated
139 %attr(755,root,root) %{_libdir}/lib*.so*
140 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
141 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
142
143 %{_pixmapsdir}/*.png
144 %{_desktopdir}/*.desktop
145 %{_mandir}/man*/*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %{_includedir}/libbeagle
150 %{_libdir}/*.la
151 %{_libdir}/*.so
152 %{_gtkdocdir}/beagle
153 %{_pkgconfigdir}/*
154
155 %if %{with epiphany}
156 %files -n epiphany-extension-beagle
157 %defattr(644,root,root,755)
158 %doc epiphany-extension/README
159 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
160 %{_libdir}/epiphany/1.8/extensions/*.xml
161 %endif
This page took 0.084151 seconds and 4 git commands to generate.