]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- 0.2.4, added filtertiff patch (compilation fix for mono 1.1.14), updated
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # don't build API documentation
9 %bcond_without  evolution       # don't include evolution support
10 %bcond_without  galago          # build without galago support
11 %bcond_without  gsf             # build without libgsf support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     epiphany        # build epiphany extension
15 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
16 #
17 %if %{without gui}
18 %undefine       with_evolution
19 %endif
20 #
21 Summary:        Beagle - An indexing subsystem
22 Summary(pl):    Beagle - podsystem indeksuj±cy
23 Name:           beagle
24 Version:        0.2.4
25 Release:        1
26 License:        Various
27 Group:          Libraries
28 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
29 # Source0-md5:  bd915b5f7de56c91dae2c26121c586fa
30 Patch0:         %{name}-desktop.patch
31 Patch1:         %{name}-crawl.patch
32 Patch2:         %{name}-kill_exec_a.patch
33 Patch3:         %{name}-filtertiff.patch
34 URL:            http://beaglewiki.org/Main_Page
35 BuildRequires:  autoconf >= 2.52
36 BuildRequires:  automake
37 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
38 %{?with_galago:BuildRequires:   dotnet-galago-sharp-devel}
39 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
40 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
41 #BuildRequires: dotnet-gst-sharp-devel
42 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
43 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
44 BuildRequires:  gtk+2-devel >= 2:2.6.0
45 %{?with_apidocs:BuildRequires:  gtk-doc}
46 BuildRequires:  libexif-devel >= 0.5.0
47 BuildRequires:  librsvg-devel
48 BuildRequires:  libpng-devel
49 BuildRequires:  libtool
50 BuildRequires:  libxml2-devel >= 2.6.19
51 BuildRequires:  mono-csharp >= 1.1.13.4
52 # not used atm
53 #BuildRequires: mozilla-devel
54 %{?with_python:BuildRequires:   python-pygtk-devel}
55 BuildRequires:  pkgconfig
56 BuildRequires:  perl-XML-Parser
57 BuildRequires:  python-devel
58 %if %{with sqlite3}
59 BuildRequires:  sqlite3-devel >= 3.3.4
60 %else
61 BuildRequires:  sqlite-devel
62 %endif
63 BuildRequires:  wv-devel >= 1.2.1
64 BuildRequires:  zip
65 # GUI BRs
66 %if %{with gui}
67 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
68 BuildRequires:  gnome-vfs2-devel
69 BuildRequires:  libgnome-devel
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       dotnet-gmime-sharp >= 2.1.19
73 %if %{with sqlite3}
74 Requires:       sqlite3
75 %else
76 Requires:       sqlite
77 %endif
78 ExcludeArch:    alpha i386 sparc sparc64
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Beagle is an indexing sub-system and search aggregator built on top of
83 Lucene.Net.
84
85 %description -l pl
86 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
87 bazie Lucene.Net.
88
89 %package libs
90 Summary:        Beagle libraries
91 Summary(pl):    Bibiloteki Beagle
92 Group:          Libraries
93
94 %description libs
95 Beagle libraries.
96
97 %description libs -l pl
98 Bibiloteki Beagle.
99
100 %package devel
101 Summary:        Beagle development files
102 Summary(pl):    Pliki programistyczne Beagle
103 Group:          Development/Libraries
104 Requires:       %{name}-libs = %{version}-%{release}
105
106 %description devel
107 Beagle development files.
108
109 %description devel -l pl
110 Pliki programistyczne Beagle.
111
112 %package static
113 Summary:        Beagle static libraries
114 Summary(pl):    Statyczne biblioteki Beagle
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description static
119 Beagle static libraries.
120
121 %description static -l pl
122 Statyczne biblioteki Beagle.
123
124 %package crawl-system
125 Summary:        Beagle crawl system
126 Summary(pl):    System przeszukuj±cy beagle-crawl
127 Group:          Applications/System
128 Requires:       crondaemon
129 Provides:       group(beagleindex)
130 Provides:       user(beagleindex)
131
132 %description crawl-system
133 Beagle crawl system.
134
135 %description crawl-system -l pl
136 System przeszukuj±cy beagle-crawl.
137
138 %package evolution
139 Summary:        Beagle Evolution backend
140 Summary(pl):    Backend Beagle dla Evolution
141 Group:          X11/Applications/Networking
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       dotnet-evolution-sharp >= 0.10.2-4
144 Requires:       evolution
145
146 %description
147 Beagle Evolution backend.
148
149 %description evolution -l pl
150 Backend Beagle dla Evolution.
151
152 %package -n epiphany-extension-beagle
153 Summary:        Epiphany extension - beagle
154 Summary(pl):    Rozszerzenie dla Epiphany - beagle
155 Group:          X11/Applications/Networking
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       epiphany-extensions
158
159 %description -n epiphany-extension-beagle
160 Epiphany extension that allows Beagle to index every page the user
161 views.
162
163 %description -n epiphany-extension-beagle -l pl
164 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
165 odwiedzan± stronê.
166
167 %package -n python-%{name}
168 Summary:        Beagle Python bindings
169 Summary(pl):    Wi±zania jêzyka Python dla Beagle
170 Group:          Libraries/Python
171 Requires:       %{name} = %{version}-%{release}
172 %pyrequires_eq  python-libs
173
174 %description -n python-%{name}
175 Beagle Python bindings.
176
177 %description -n python-%{name} -l pl
178 Wi±zania jêzyka Python dla Beagle.
179
180 %package search-gui
181 Summary:        GNOME based Beagle GUI
182 Summary(pl):    Bazowane na GNOME GUI dla Beagle
183 Group:          Libraries/Python
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       gtk+2 >= 2:2.6.0
186
187 %description search-gui
188 GNOME based Beagle GUI.
189
190 %description search-gui -l pl
191 Bazowane na GNOME GUI dla Beagle.
192
193 %prep
194 %setup -q
195 %patch0 -p1
196 %patch1 -p1
197 %patch2 -p1
198 %patch3 -p0
199
200 %build
201 %{__libtoolize}
202 %{__aclocal}
203 %{__autoconf}
204 %{__automake}
205 %configure \
206         --enable-static \
207         %{?with_apidocs:--enable-gtk-doc} \
208         --with-html-dir=%{_gtkdocdir} \
209         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
210         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
211         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
212
213 %{__make} \
214         MOZILLA_HOME=%{_libdir}/mozilla \
215         pythondir=%{py_sitedir}
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
220
221 %{__make} install \
222         DESTDIR=$RPM_BUILD_ROOT \
223         pythondir=%{py_sitedir}
224
225 # Kill useless files
226 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
227         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
228
229 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
230 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
231
232 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
233
234 %find_lang %{name}
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %pre crawl-system
240 %groupadd -g 166 -r -f beagleindex
241 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
242
243 %postun crawl-system
244 if [ "$1" = "0" ]; then
245         %userremove beagleindex
246         %groupremove beagleindex
247 fi
248
249 %post   libs -p /sbin/ldconfig
250 %postun libs -p /sbin/ldconfig
251
252 %files -f %{name}.lang
253 %defattr(644,root,root,755)
254 %doc AUTHORS COPYING ChangeLog NEWS README
255 %attr(755,root,root) %{_bindir}/beagle-config
256 %attr(755,root,root) %{_bindir}/beagled
257 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
258 %attr(755,root,root) %{_bindir}/beagle-extract-content
259 %attr(755,root,root) %{_bindir}/beagle-index-info
260 %attr(755,root,root) %{_bindir}/beagle-index-url
261 %attr(755,root,root) %{_bindir}/beagle-info
262 %attr(755,root,root) %{_bindir}/beagle-ping
263 %attr(755,root,root) %{_bindir}/beagle-query
264 %attr(755,root,root) %{_bindir}/beagle-shutdown
265 %attr(755,root,root) %{_bindir}/beagle-status
266 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
267 %attr(755,root,root) %{_libdir}/%{name}/*.exe
268 %dir %{_libdir}/%{name}
269 %dir %{_libdir}/%{name}/Backends
270 %{_libdir}/%{name}/Filters
271 %{_libdir}/%{name}/*.dll*
272 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
273 %{_mandir}/man*/*
274
275 %files libs
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
278
279 %files devel
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/*.so
282 %{_includedir}/libbeagle
283 %{_libdir}/*.la
284 %{?with_apidocs:%{_gtkdocdir}/beagle}
285 %{_pkgconfigdir}/*
286
287 %files static
288 %defattr(644,root,root,755)
289 %{_libdir}/*.a
290
291 %files crawl-system
292 %defattr(644,root,root,755)
293 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
294 %dir %{_sysconfdir}/beagle
295 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
296 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
297 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
298 %attr(755,root,root) %{_sbindir}/*
299 %attr(755,root,root) %{_libdir}/beagle-crawl-system
300
301 %if %{with evolution}
302 %files evolution
303 %defattr(644,root,root,755)
304 %{_libdir}/%{name}/Backends/Evolution*
305 %endif
306
307 %if %{with epiphany}
308 %files -n epiphany-extension-beagle
309 %defattr(644,root,root,755)
310 %doc epiphany-extension/README
311 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
312 %{_libdir}/epiphany/1.8/extensions/*.xml
313 %endif
314
315 %if %{with python}
316 %files -n python-%{name}
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{py_sitedir}/*.so
319 %endif
320
321 %if %{with gui}
322 %files search-gui
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_bindir}/beagle-search
325 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
326 %attr(755,root,root) %{_bindir}/beagle-settings
327 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
328 %{_pixmapsdir}/*.png
329 %{_desktopdir}/*.desktop
330 %endif
This page took 0.063138 seconds and 4 git commands to generate.