]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- 0.2.1, fixed cut&paste typo, removed woraround for broken mono version
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - separtate CLI utilities
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.2.1
16 Release:        1
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
20 # Source0-md5:  325ed91dc66fb6be060d0a5f4c8f56dd
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
27 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
28 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
29 #BuildRequires: dotnet-gst-sharp-devel
30 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
31 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
32 BuildRequires:  gnome-vfs2-devel
33 BuildRequires:  gtk+2-devel >= 2:2.6.0
34 BuildRequires:  gtk-doc
35 BuildRequires:  libexif-devel >= 0.5.0
36 BuildRequires:  libgnome-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2.6.19
40 BuildRequires:  mono-csharp >= 1.1.10
41 BuildRequires:  mozilla-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  python-devel
44 BuildRequires:  sqlite-devel
45 BuildRequires:  wv-devel >= 1.0.0
46 BuildRequires:  zip
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       dotnet-gmime-sharp >= 2.1.19
49 %{?with_epiphany:Requires:      epiphany-extensions}
50 Requires:       gtk+2 >= 2:2.6.0
51 Requires:       sqlite
52 ExcludeArch:    alpha i386 sparc sparc64
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Beagle is an indexing sub-system and search aggregator built on top of
57 Lucene.Net.
58
59 %description -l pl
60 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
61 bazie Lucene.Net.
62
63 %package libs
64 Summary:        Beagle libraries
65 Summary(pl):    Bibiloteki Beagle
66 Group:          Libraries
67
68 %description libs
69 Beagle libraries.
70
71 %description libs -l pl
72 Bibiloteki Beagle.
73
74 %package devel
75 Summary:        Beagle development files
76 Summary(pl):    Pliki programistyczne Beagle
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79
80 %description devel
81 Beagle development files.
82
83 %description devel -l pl
84 Pliki programistyczne Beagle.
85
86 %package static
87 Summary:        Beagle static libraries
88 Summary(pl):    Statyczne biblioteki Beagle
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Beagle static libraries.
94
95 %description static -l pl
96 Statyczne biblioteki Beagle.
97
98 %package crawl-system
99 Summary:        Beagle crawl system
100 Summary(pl):    System przeszukuj±cy beagle-crawl
101 Group:          Applications/System
102 Requires:       crondaemon
103 Provides:       group(beagleindex)
104 Provides:       user(beagleindex)
105
106 %description crawl-system
107 Beagle crawl system.
108
109 %description crawl-system -l pl
110 System przeszukuj±cy beagle-crawl.
111
112 %package evolution
113 Summary:        Beagle Evolution backend
114 Summary(pl):    Backend Beagle dla Evolution
115 Group:          X11/Applications/Networking
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       evolution
118
119 %description
120 Beagle Evolution backend.
121
122 %description evolution -l pl
123 Backend Beagle dla Evolution.
124
125 %package -n epiphany-extension-beagle
126 Summary:        Epiphany extension - beagle
127 Summary(pl):    Rozszerzenie dla Epiphany - beagle
128 Group:          X11/Applications/Networking
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       epiphany >= 1.2.1
131
132 %description -n epiphany-extension-beagle
133 Epiphany extension that allows Beagle to index every page the user
134 views.
135
136 %description -n epiphany-extension-beagle -l pl
137 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
138 odwiedzan± stronê.
139
140 %package -n python-%{name}
141 Summary:        Beagle Python bindings
142 Summary(pl):    Wi±zania jêzyka Python dla Beagle
143 Group:          Libraries/Python
144 Requires:       %{name} = %{version}-%{release}
145 %pyrequires_eq  python-libs
146
147 %description -n python-%{name}
148 Beagle Python bindings.
149
150 %description -n python-%{name} -l pl
151 Wi±zania jêzyka Python dla Beagle.
152
153 %prep
154 %setup -q
155 %patch0 -p1
156 %patch1 -p1
157
158 %build
159 %{__libtoolize}
160 %{__aclocal}
161 %{__autoconf}
162 %{__automake}
163 %configure \
164         --enable-static \
165         --enable-gtk-doc \
166         --with-html-dir=%{_gtkdocdir} \
167         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
168         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp
169
170 %{__make} \
171         MOZILLA_HOME=%{_libdir}/mozilla \
172         pythondir=%{py_sitedir}
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT \
180         pythondir=%{py_sitedir}
181
182 # Kill useless files
183 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
184         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
185
186 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
187 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
188
189 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
190
191 %find_lang %{name}
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %pre crawl-system
197 %groupadd -g 166 -r -f beagleindex
198 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
199
200 %postun crawl-system
201 if [ "$1" = "0" ]; then
202         %userremove beagleindex
203         %groupremove beagleindex
204 fi
205
206 %post   libs -p /sbin/ldconfig
207 %postun libs -p /sbin/ldconfig
208
209 %files -f %{name}.lang
210 %defattr(644,root,root,755)
211 %doc AUTHORS COPYING ChangeLog NEWS README
212 %attr(755,root,root) %{_bindir}/*
213 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
214 %dir %{_libdir}/%{name}/Backends
215 %{_libdir}/%{name}/Filters
216 %attr(755,root,root) %{_libdir}/%{name}/*.exe
217 %{_libdir}/%{name}/*.dll*
218
219 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
220
221 %{_pixmapsdir}/*.png
222 %{_desktopdir}/*.desktop
223 %{_mandir}/man*/*
224
225 %files libs
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
228 %dir %{_libdir}/%{name}
229
230 %files devel
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/*.so
233 %{_includedir}/libbeagle
234 %{_libdir}/*.la
235 %{_gtkdocdir}/beagle
236 %{_pkgconfigdir}/*
237
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/*.a
241
242 %files crawl-system
243 %defattr(644,root,root,755)
244 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
245 %dir %{_sysconfdir}/beagle
246 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
247 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
248 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
249 %attr(755,root,root) %{_sbindir}/*
250 %{_libdir}/beagle-crawl-system
251
252 %files evolution
253 %defattr(644,root,root,755)
254 %{_libdir}/%{name}/Backends/Evolution*
255
256 %if %{with epiphany}
257 %files -n epiphany-extension-beagle
258 %defattr(644,root,root,755)
259 %doc epiphany-extension/README
260 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
261 %{_libdir}/epiphany/1.8/extensions/*.xml
262 %endif
263
264 %files -n python-%{name}
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.070722 seconds and 4 git commands to generate.