]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- fixed libs
[packages/beagle.git] / beagle.spec
1 #
2 # TODO: finish crawl system
3 #
4 %include        /usr/lib/rpm/macros.mono
5 #
6 # Conditional build:
7 %bcond_with     epiphany        # don't build epiphany extension
8 %bcond_with     evolution       # don't include evolution support
9 #
10 Summary:        Beagle - An indexing subsystem
11 Summary(pl):    Beagle - podsystem indeksuj±cy
12 Name:           beagle
13 Version:        0.1.1
14 Release:        0.9
15 License:        Various
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
18 # Source0-md5:  e788ed11077e576797a0793631f2fe8b
19 Patch0:         %{name}-desktop.patch
20 PAtch1:         %{name}-crawl.patch
21 URL:            http://beaglewiki.org/Main_Page
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.6}
25 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
26 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
27 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
28 #BuildRequires: dotnet-gst-sharp-devel
29 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
30 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
31 BuildRequires:  gnome-vfs2-devel
32 BuildRequires:  gtk+2-devel >= 2:2.4.0
33 BuildRequires:  gtk-doc
34 BuildRequires:  libexif-devel >= 0.5.0
35 BuildRequires:  libgnome-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2.6.0
39 BuildRequires:  mono-csharp >= 1.0.6
40 BuildRequires:  mozilla-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sqlite-devel
43 BuildRequires:  wv-devel >= 1.0.0
44 BuildRequires:  zip
45 Requires:       %{name}-libs = %{version}-%{release}
46 Requires:       dotnet-gmime-sharp >= 2.1.16-2
47 %{?with_epiphany:Requires:      epiphany-extensions}
48 Requires:       gtk+2 >= 2:2.4.0
49 Requires:       sqlite
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Beagle is an indexing sub-system and search aggregator built on top of
54 Lucene.Net.
55
56 %description -l pl
57 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
58 bazie Lucene.Net.
59
60 %package libs
61 Summary:        Beagle libraries
62 Summary(pl):    Bibiloteki Beagle
63 Group:          Libraries
64
65 %description libs
66 Beagle libraries.
67
68 %description libs -l pl
69 Bibiloteki Beagle.
70
71 %package devel
72 Summary:        Beagle development files
73 Summary(pl):    Pliki programistyczne Beagle
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{version}-%{release}
76
77 %description devel
78 Beagle development files.
79
80 %description devel -l pl
81 Pliki programistyczne Beagle.
82
83 %package static
84 Summary:        Beagle static libraries
85 Summary(pl):    Statyczne biblioteki Beagle
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Beagle static libraries.
91
92 %description static -l pl
93 Statyczne biblioteki Beagle.
94
95 %package crawl-system
96 Summary:        Beagle crawl system
97 #Summary(pl):   ???
98 Group:          Applications/System
99
100 %description crawl-system
101 Beagle crawl system.
102
103 #%description crawl-system -l pl
104 # ???
105
106 %package -n epiphany-extension-beagle
107 Summary:        Epiphany extension - beagle
108 Summary(pl):    Rozszerzenie dla Epiphany - beagle
109 Group:          X11/Applications/Networking
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       epiphany >= 1.2.1
112
113 %description -n epiphany-extension-beagle
114 Epiphany extension that allows Beagle to index every page the user
115 views.
116
117 %description -n epiphany-extension-beagle -l pl
118 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
119 odwiedzan± stronê.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125
126 %build
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoconf}
130 %{__automake}
131 %configure \
132         --enable-static \
133         --enable-gtk-doc \
134         --with-html-dir=%{_gtkdocdir} \
135         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
136         --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
137         
138 %{__make} \
139         MOZILLA_HOME=%{_libdir}/mozilla
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 # Kill useless files
148 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
149         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
150         
151 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS COPYING ChangeLog NEWS README
164 %attr(755,root,root) %{_bindir}/*
165
166 %dir %{_libdir}/%{name}
167 %{_libdir}/%{name}/Filters
168 %{_libdir}/%{name}/*.exe
169 %{_libdir}/%{name}/*.dll*
170
171 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
172
173 %{_pixmapsdir}/*.png
174 %{_desktopdir}/*.desktop
175 %{_mandir}/man*/*
176
177 %files libs
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
180 %attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
181
182 %files devel
183 %defattr(644,root,root,755)
184 %{_includedir}/libbeagle
185 %attr(755,root,root) %{_libdir}/*.so
186 %attr(755,root,root) %{_libdir}/%{name}/*.so
187 %{_libdir}/*.la
188 %{_gtkdocdir}/beagle
189 %{_pkgconfigdir}/*
190
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/*.a
194 %{_libdir}/%{name}/*.a
195
196 # not finished yet
197 %files crawl-system
198 %defattr(644,root,root,755)
199 %attr(750,root,root) %config(noreplace) %verify(not size mtime md5) /etc/cron.daily/*
200 %attr(750,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/beagle/*
201 %attr(755,root,root) %{_sbindir}/*
202 %{_libdir}/beagle-crawl-system
203
204 %if %{with epiphany}
205 %files -n epiphany-extension-beagle
206 %defattr(644,root,root,755)
207 %doc epiphany-extension/README
208 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
209 %{_libdir}/epiphany/1.8/extensions/*.xml
210 %endif
This page took 0.252446 seconds and 4 git commands to generate.