]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- 0.1.3, python bindings added
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - finish crawl system
4 #       - separtate CLI utilities
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_with     epiphany        # don't build epiphany extension
10 %bcond_with     evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.1.3
16 Release:        0.9
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
20 # Source0-md5:  d24c10650a5d39758da19a5d067dfee2
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.6}
27 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
28 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
29 BuildRequires:  dotnet-gsf-sharp-devel >= 0.7
30 #BuildRequires: dotnet-gst-sharp-devel
31 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
32 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
33 BuildRequires:  gnome-vfs2-devel
34 BuildRequires:  gtk+2-devel >= 2:2.4.0
35 BuildRequires:  gtk-doc
36 BuildRequires:  libexif-devel >= 0.5.0
37 BuildRequires:  libgnome-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 2.6.0
41 BuildRequires:  mono-csharp >= 1.1.10
42 BuildRequires:  mozilla-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-devel
45 BuildRequires:  sqlite-devel
46 BuildRequires:  wv-devel >= 1.0.0
47 BuildRequires:  zip
48 Requires:       %{name}-libs = %{version}-%{release}
49 Requires:       dotnet-gmime-sharp >= 2.1.16-2
50 %{?with_epiphany:Requires:      epiphany-extensions}
51 Requires:       gtk+2 >= 2:2.4.0
52 Requires:       sqlite
53
54 ExcludeArch:    alpha i386 sparc sparc64
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Beagle is an indexing sub-system and search aggregator built on top of
59 Lucene.Net.
60
61 %description -l pl
62 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
63 bazie Lucene.Net.
64
65 %package libs
66 Summary:        Beagle libraries
67 Summary(pl):    Bibiloteki Beagle
68 Group:          Libraries
69
70 %description libs
71 Beagle libraries.
72
73 %description libs -l pl
74 Bibiloteki Beagle.
75
76 %package devel
77 Summary:        Beagle development files
78 Summary(pl):    Pliki programistyczne Beagle
79 Group:          Development/Libraries
80 Requires:       %{name}-libs = %{version}-%{release}
81
82 %description devel
83 Beagle development files.
84
85 %description devel -l pl
86 Pliki programistyczne Beagle.
87
88 %package static
89 Summary:        Beagle static libraries
90 Summary(pl):    Statyczne biblioteki Beagle
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Beagle static libraries.
96
97 %description static -l pl
98 Statyczne biblioteki Beagle.
99
100 %package crawl-system
101 Summary:        Beagle crawl system
102 Summary(pl):    System przeszukuj±cy beagle-crawl
103 Group:          Applications/System
104
105 %description crawl-system
106 Beagle crawl system.
107
108 %description crawl-system -l pl
109 System przeszukuj±cy beagle-crawl.
110
111 %package -n epiphany-extension-beagle
112 Summary:        Epiphany extension - beagle
113 Summary(pl):    Rozszerzenie dla Epiphany - beagle
114 Group:          X11/Applications/Networking
115 Requires:       %{name} = %{version}-%{release}
116 Requires:       epiphany >= 1.2.1
117
118 %description -n epiphany-extension-beagle
119 Epiphany extension that allows Beagle to index every page the user
120 views.
121
122 %description -n epiphany-extension-beagle -l pl
123 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
124 odwiedzan± stronê.
125
126 %package -n python-%{name}
127 Summary:        Beagle Python bindings
128 Summary(pl):    Wi^Ezania j^Yzyka Python dla Beagle
129 Group:          Libraries/Python
130 Requires:       %{name} = %{version}-%{release}
131 %pyrequires_eq  python-libs
132
133 %description -n python-%{name}
134 Beagle Python bindings.
135
136 %description -n python-%{name} -l pl
137 Wi^Ezania j^Yzyka Python dla Beagle.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142 %patch1 -p1
143
144 %build
145 %{__libtoolize}
146 %{__aclocal}
147 %{__autoconf}
148 %{__automake}
149 %configure \
150         --enable-static \
151         --enable-gtk-doc \
152         --with-html-dir=%{_gtkdocdir} \
153         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
154         --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
155
156 %{__make} \
157         MOZILLA_HOME=%{_libdir}/mozilla \
158         pythondir=%{py_sitedir}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT \
165         pythondir=%{py_sitedir}
166
167 # Kill useless files
168 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
169         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
170
171 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
172
173 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
174
175 %find_lang %{name}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   libs -p /sbin/ldconfig
181 %postun libs -p /sbin/ldconfig
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS COPYING ChangeLog NEWS README
186 %attr(755,root,root) %{_bindir}/*
187
188 %{_libdir}/%{name}/Filters
189 %{_libdir}/%{name}/*.exe
190 %{_libdir}/%{name}/*.dll*
191
192 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
193
194 %{_pixmapsdir}/*.png
195 %{_desktopdir}/*.desktop
196 %{_mandir}/man*/*
197
198 %files libs
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
201 %dir %{_libdir}/%{name}
202 %attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/*.so
207 %attr(755,root,root) %{_libdir}/%{name}/*.so
208 %{_includedir}/libbeagle
209 %{_libdir}/*.la
210 %{_gtkdocdir}/beagle
211 %{_pkgconfigdir}/*
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/*.a
216 %{_libdir}/%{name}/*.a
217
218 # not finished yet
219 %files crawl-system
220 %defattr(644,root,root,755)
221 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
222 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
223 %attr(755,root,root) %{_sbindir}/*
224 %{_libdir}/beagle-crawl-system
225
226 %if %{with epiphany}
227 %files -n epiphany-extension-beagle
228 %defattr(644,root,root,755)
229 %doc epiphany-extension/README
230 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
231 %{_libdir}/epiphany/1.8/extensions/*.xml
232 %endif
233
234 %files -n python-%{name}
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.042149 seconds and 4 git commands to generate.