]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- more files
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_without  evolution       # don't include evolution support
12 %bcond_without  gui             # don't build GNOME based GUI
13 #
14 %if %{without gui}
15 %undefine       with_evolution
16 %endif
17 #
18 Summary:        Beagle - An indexing subsystem
19 Summary(pl):    Beagle - podsystem indeksuj±cy
20 Name:           beagle
21 Version:        0.2.1
22 Release:        2.1
23 License:        Various
24 Group:          Libraries
25 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
26 # Source0-md5:  325ed91dc66fb6be060d0a5f4c8f56dd
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-crawl.patch
29 URL:            http://beaglewiki.org/Main_Page
30 BuildRequires:  autoconf >= 2.52
31 BuildRequires:  automake
32 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
33 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
34 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
35 #BuildRequires: dotnet-gst-sharp-devel
36 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
37 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
38 BuildRequires:  gtk+2-devel >= 2:2.6.0
39 %{?with_apidocs:BuildRequires:  gtk-doc}
40 BuildRequires:  libexif-devel >= 0.5.0
41 BuildRequires:  libpng-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 2.6.19
44 BuildRequires:  mono-csharp >= 1.1.10
45 BuildRequires:  mozilla-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  python-devel
48 BuildRequires:  sqlite-devel
49 BuildRequires:  wv-devel >= 1.0.0
50 BuildRequires:  zip
51 # GUI BRs
52 %if %{with gui}
53 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
54 BuildRequires:  gnome-vfs2-devel
55 BuildRequires:  libgnome-devel
56 %endif
57 Requires:       %{name}-libs = %{version}-%{release}
58 Requires:       dotnet-gmime-sharp >= 2.1.19
59 %{?with_epiphany:Requires:      epiphany-extensions}
60 Requires:       gtk+2 >= 2:2.6.0
61 Requires:       sqlite
62 ExcludeArch:    alpha i386 sparc sparc64
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Beagle is an indexing sub-system and search aggregator built on top of
67 Lucene.Net.
68
69 %description -l pl
70 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
71 bazie Lucene.Net.
72
73 %package libs
74 Summary:        Beagle libraries
75 Summary(pl):    Bibiloteki Beagle
76 Group:          Libraries
77
78 %description libs
79 Beagle libraries.
80
81 %description libs -l pl
82 Bibiloteki Beagle.
83
84 %package devel
85 Summary:        Beagle development files
86 Summary(pl):    Pliki programistyczne Beagle
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89
90 %description devel
91 Beagle development files.
92
93 %description devel -l pl
94 Pliki programistyczne Beagle.
95
96 %package static
97 Summary:        Beagle static libraries
98 Summary(pl):    Statyczne biblioteki Beagle
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 Beagle static libraries.
104
105 %description static -l pl
106 Statyczne biblioteki Beagle.
107
108 %package crawl-system
109 Summary:        Beagle crawl system
110 Summary(pl):    System przeszukuj±cy beagle-crawl
111 Group:          Applications/System
112 Requires:       crondaemon
113 Provides:       group(beagleindex)
114 Provides:       user(beagleindex)
115
116 %description crawl-system
117 Beagle crawl system.
118
119 %description crawl-system -l pl
120 System przeszukuj±cy beagle-crawl.
121
122 %package evolution
123 Summary:        Beagle Evolution backend
124 Summary(pl):    Backend Beagle dla Evolution
125 Group:          X11/Applications/Networking
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       dotnet-evolution-sharp >= 0.10.2-4
128 Requires:       evolution
129
130 %description
131 Beagle Evolution backend.
132
133 %description evolution -l pl
134 Backend Beagle dla Evolution.
135
136 %package -n epiphany-extension-beagle
137 Summary:        Epiphany extension - beagle
138 Summary(pl):    Rozszerzenie dla Epiphany - beagle
139 Group:          X11/Applications/Networking
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       epiphany >= 1.2.1
142
143 %description -n epiphany-extension-beagle
144 Epiphany extension that allows Beagle to index every page the user
145 views.
146
147 %description -n epiphany-extension-beagle -l pl
148 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
149 odwiedzan± stronê.
150
151 %package -n python-%{name}
152 Summary:        Beagle Python bindings
153 Summary(pl):    Wi±zania jêzyka Python dla Beagle
154 Group:          Libraries/Python
155 Requires:       %{name} = %{version}-%{release}
156 %pyrequires_eq  python-libs
157
158 %description -n python-%{name}
159 Beagle Python bindings.
160
161 %description -n python-%{name} -l pl
162 Wi±zania jêzyka Python dla Beagle.
163
164 %package search-gui
165 Summary:        GNOME based Beagle GUI
166 Summary(pl):    Bazowane na GNOME GUI dla Beagle
167 Group:          Libraries/Python
168 Requires:       %{name} = %{version}-%{release}
169
170 %description search-gui
171 GNOME based Beagle GUI.
172
173 %description search-gui -l pl
174 Bazowane na GNOME GUI dla Beagle.
175
176 %prep
177 %setup -q
178 %patch0 -p1
179 %patch1 -p1
180
181 %build
182 %{__libtoolize}
183 %{__aclocal}
184 %{__autoconf}
185 %{__automake}
186 %configure \
187         --enable-static \
188         %{?with_apidocs:--enable-gtk-doc} \
189         --with-html-dir=%{_gtkdocdir} \
190         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
191         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
192         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
193
194 %{__make} \
195         MOZILLA_HOME=%{_libdir}/mozilla \
196         pythondir=%{py_sitedir}
197
198 %install
199 rm -rf $RPM_BUILD_ROOT
200 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
201
202 %{__make} install \
203         DESTDIR=$RPM_BUILD_ROOT \
204         pythondir=%{py_sitedir}
205
206 # Kill useless files
207 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
208         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
209
210 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
211 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
212
213 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
214
215 %find_lang %{name}
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %pre crawl-system
221 %groupadd -g 166 -r -f beagleindex
222 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
223
224 %postun crawl-system
225 if [ "$1" = "0" ]; then
226         %userremove beagleindex
227         %groupremove beagleindex
228 fi
229
230 %post   libs -p /sbin/ldconfig
231 %postun libs -p /sbin/ldconfig
232
233 %files -f %{name}.lang
234 %defattr(644,root,root,755)
235 %doc AUTHORS COPYING ChangeLog NEWS README
236 %attr(755,root,root) %{_bindir}/beagle-config
237 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
238 %attr(755,root,root) %{_bindir}/beagle-index-info
239 %attr(755,root,root) %{_bindir}/beagle-index-url
240 %attr(755,root,root) %{_bindir}/beagle-info
241 %attr(755,root,root) %{_bindir}/beagle-ping
242 %attr(755,root,root) %{_bindir}/beagle-query
243 %attr(755,root,root) %{_bindir}/beagle-shutdown
244 %attr(755,root,root) %{_bindir}/beagle-status
245 %attr(755,root,root) %{_bindir}/beagled
246 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
247 %dir %{_libdir}/%{name}/Backends
248 %{_libdir}/%{name}/Filters
249 %attr(755,root,root) %{_libdir}/%{name}/*.exe
250 %{_libdir}/%{name}/*.dll*
251
252 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
253
254 %{_mandir}/man*/*
255
256 %files libs
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
259 %dir %{_libdir}/%{name}
260
261 %files devel
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_libdir}/*.so
264 %{_includedir}/libbeagle
265 %{_libdir}/*.la
266 %{?with_apidocs:%{_gtkdocdir}/beagle}
267 %{_pkgconfigdir}/*
268
269 %files static
270 %defattr(644,root,root,755)
271 %{_libdir}/*.a
272
273 %files crawl-system
274 %defattr(644,root,root,755)
275 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
276 %dir %{_sysconfdir}/beagle
277 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
278 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
279 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
280 %attr(755,root,root) %{_sbindir}/*
281 %attr(755,root,root) %{_libdir}/beagle-crawl-system
282
283 %if %{with evolution}
284 %files evolution
285 %defattr(644,root,root,755)
286 %{_libdir}/%{name}/Backends/Evolution*
287 %endif
288
289 %if %{with epiphany}
290 %files -n epiphany-extension-beagle
291 %defattr(644,root,root,755)
292 %doc epiphany-extension/README
293 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
294 %{_libdir}/epiphany/1.8/extensions/*.xml
295 %endif
296
297 %files -n python-%{name}
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{py_sitedir}/*.so
300
301 %if %{with gui}
302 %files search-gui
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_bindir}/beagle-search
305 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
306 %attr(755,root,root) %{_bindir}/beagle-settings
307 %{_pixmapsdir}/*.png
308 %{_desktopdir}/*.desktop
309 %endif
This page took 0.088115 seconds and 4 git commands to generate.