]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- bash.patch change /bin/sh -> /bin/bash
[packages/beagle.git] / beagle.spec
1 #
2 # Conditional build:
3 %bcond_with     epiphany        # build epiphany extension (it requires
4                                 # epiphany-1.2.x)
5 #
6 # INFO: need dbus newer than 0.22. you can get it from DEVEL branch.
7 #
8
9 #%define        snap 20041214
10 #Release:       0.%{snap}.1
11
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.0.4
16 Release:        0.1
17 License:        Various
18 Group:          Libraries
19 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
20 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.0/%{name}-%{version}.tar.bz2
21 # Source0-md5:  db81d4d1bd0f841f0ae77829623d2a59
22 Patch0:         %{name}-Filters-dir.patch
23 Patch1:         %{name}-pc.patch
24 Patch2:         %{name}-bash.patch
25 URL:            http://www.gnome.com/
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake
28 BuildRequires:  dotnet-evolution-sharp-devel >= 0.3
29 BuildRequires:  dotnet-gtk-sharp-devel
30 BuildRequires:  dotnet-dbus-sharp-devel >= 0.22
31 BuildRequires:  dotnet-gmime-sharp-devel
32 BuildRequires:  dotnet-gecko-sharp-devel
33 %if %{with epiphany}
34 BuildRequires:  epiphany-devel >= 1.2.1
35 BuildRequires:  epiphany-devel < 1.3.0
36 %endif
37 BuildRequires:  gtk+2-devel >= 2:2.4.0
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2.6.0
40 BuildRequires:  mono-csharp
41 BuildRequires:  pkgconfig
42 Requires:       dotnet-evolution-sharp >= 0.3
43 Requires:       dotnet-gtk-sharp
44 Requires:       dotnet-dbus-sharp >= 0.22
45 Requires:       gtk+2 >= 2:2.4.0
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Beagle is an indexing sub-system and search aggregator built on top of
50 Lucene.Net.
51
52 %description -l pl
53 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
54 bazie Lucene.Net.
55
56 %package devel
57 Summary:        Beagle development files
58 Summary(pl):    Pliki programistyczne Beagle
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Beagle development files.
64
65 %description devel -l pl
66 Pliki programistyczne Beagle.
67
68 %package -n epiphany-extension-beagle
69 Summary:        Epiphany extension - beagle
70 Summary(pl):    Rozszerzenie dla Epiphany - beagle
71 Group:          X11/Applications/Networking
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       epiphany >= 1.2.1
74 Requires:       epiphany < 1.3.0
75
76 %description -n epiphany-extension-beagle
77 Epiphany extension that allows Beagle to index every page the user
78 views.
79
80 %description -n epiphany-extension-beagle -l pl
81 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
82 odwiedzan± stronê.
83
84 %prep
85 %setup -q
86 #%patch0 -p0
87 #%patch1 -p0
88 %patch2 -p0
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96 %if %{with epiphany}
97         --enable-epiphany-extension
98 %else
99         --disable-epiphany-extension
100 %endif
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # Kill useless files
111 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/extensions/*.{a,la}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING ChangeLog NEWS README
119 %attr(755,root,root)%{_bindir}/*
120 %dir %{_libdir}/%{name}
121 %{_libdir}/%{name}
122 %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.so.*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %{_pkgconfigdir}/*
127 %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.la
128
129 %if %{with epiphany}
130 %files -n epiphany-extension-beagle
131 %defattr(644,root,root,755)
132 %doc epiphany-extension/README
133 %attr(755,root,root)%{_libdir}/epiphany/extensions/libbeagleextension.so*
134 %endif
This page took 0.098804 seconds and 4 git commands to generate.