]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- move beagleuiglue to search-gui
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_without  evolution       # don't include evolution support
12 %bcond_without  gui             # don't build GNOME based GUI
13 #
14 %if %{without gui}
15 %undefine       with_evolution
16 %endif
17 #
18 Summary:        Beagle - An indexing subsystem
19 Summary(pl):    Beagle - podsystem indeksuj±cy
20 Name:           beagle
21 Version:        0.2.1
22 Release:        2.1
23 License:        Various
24 Group:          Libraries
25 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
26 # Source0-md5:  325ed91dc66fb6be060d0a5f4c8f56dd
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-crawl.patch
29 URL:            http://beaglewiki.org/Main_Page
30 BuildRequires:  autoconf >= 2.52
31 BuildRequires:  automake
32 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
33 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
34 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
35 #BuildRequires: dotnet-gst-sharp-devel
36 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
37 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
38 BuildRequires:  gtk+2-devel >= 2:2.6.0
39 %{?with_apidocs:BuildRequires:  gtk-doc}
40 BuildRequires:  libexif-devel >= 0.5.0
41 BuildRequires:  libpng-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 2.6.19
44 BuildRequires:  mono-csharp >= 1.1.10
45 BuildRequires:  mozilla-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  python-devel
48 BuildRequires:  sqlite-devel
49 BuildRequires:  wv-devel >= 1.0.0
50 BuildRequires:  zip
51 # GUI BRs
52 %if %{with gui}
53 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
54 BuildRequires:  gnome-vfs2-devel
55 BuildRequires:  libgnome-devel
56 %endif
57 Requires:       %{name}-libs = %{version}-%{release}
58 Requires:       dotnet-gmime-sharp >= 2.1.19
59 Requires:       sqlite
60 ExcludeArch:    alpha i386 sparc sparc64
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Beagle is an indexing sub-system and search aggregator built on top of
65 Lucene.Net.
66
67 %description -l pl
68 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
69 bazie Lucene.Net.
70
71 %package libs
72 Summary:        Beagle libraries
73 Summary(pl):    Bibiloteki Beagle
74 Group:          Libraries
75
76 %description libs
77 Beagle libraries.
78
79 %description libs -l pl
80 Bibiloteki Beagle.
81
82 %package devel
83 Summary:        Beagle development files
84 Summary(pl):    Pliki programistyczne Beagle
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87
88 %description devel
89 Beagle development files.
90
91 %description devel -l pl
92 Pliki programistyczne Beagle.
93
94 %package static
95 Summary:        Beagle static libraries
96 Summary(pl):    Statyczne biblioteki Beagle
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Beagle static libraries.
102
103 %description static -l pl
104 Statyczne biblioteki Beagle.
105
106 %package crawl-system
107 Summary:        Beagle crawl system
108 Summary(pl):    System przeszukuj±cy beagle-crawl
109 Group:          Applications/System
110 Requires:       crondaemon
111 Provides:       group(beagleindex)
112 Provides:       user(beagleindex)
113
114 %description crawl-system
115 Beagle crawl system.
116
117 %description crawl-system -l pl
118 System przeszukuj±cy beagle-crawl.
119
120 %package evolution
121 Summary:        Beagle Evolution backend
122 Summary(pl):    Backend Beagle dla Evolution
123 Group:          X11/Applications/Networking
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       dotnet-evolution-sharp >= 0.10.2-4
126 Requires:       evolution
127
128 %description
129 Beagle Evolution backend.
130
131 %description evolution -l pl
132 Backend Beagle dla Evolution.
133
134 %package -n epiphany-extension-beagle
135 Summary:        Epiphany extension - beagle
136 Summary(pl):    Rozszerzenie dla Epiphany - beagle
137 Group:          X11/Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       epiphany-extensions
140
141 %description -n epiphany-extension-beagle
142 Epiphany extension that allows Beagle to index every page the user
143 views.
144
145 %description -n epiphany-extension-beagle -l pl
146 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
147 odwiedzan± stronê.
148
149 %package -n python-%{name}
150 Summary:        Beagle Python bindings
151 Summary(pl):    Wi±zania jêzyka Python dla Beagle
152 Group:          Libraries/Python
153 Requires:       %{name} = %{version}-%{release}
154 %pyrequires_eq  python-libs
155
156 %description -n python-%{name}
157 Beagle Python bindings.
158
159 %description -n python-%{name} -l pl
160 Wi±zania jêzyka Python dla Beagle.
161
162 %package search-gui
163 Summary:        GNOME based Beagle GUI
164 Summary(pl):    Bazowane na GNOME GUI dla Beagle
165 Group:          Libraries/Python
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       gtk+2 >= 2:2.6.0
168
169 %description search-gui
170 GNOME based Beagle GUI.
171
172 %description search-gui -l pl
173 Bazowane na GNOME GUI dla Beagle.
174
175 %prep
176 %setup -q
177 %patch0 -p1
178 %patch1 -p1
179
180 %build
181 %{__libtoolize}
182 %{__aclocal}
183 %{__autoconf}
184 %{__automake}
185 %configure \
186         --enable-static \
187         %{?with_apidocs:--enable-gtk-doc} \
188         --with-html-dir=%{_gtkdocdir} \
189         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
190         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
191         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
192
193 %{__make} \
194         MOZILLA_HOME=%{_libdir}/mozilla \
195         pythondir=%{py_sitedir}
196
197 %install
198 rm -rf $RPM_BUILD_ROOT
199 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
200
201 %{__make} install \
202         DESTDIR=$RPM_BUILD_ROOT \
203         pythondir=%{py_sitedir}
204
205 # Kill useless files
206 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
207         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
208
209 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
210 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
211
212 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
213
214 %find_lang %{name}
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %pre crawl-system
220 %groupadd -g 166 -r -f beagleindex
221 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
222
223 %postun crawl-system
224 if [ "$1" = "0" ]; then
225         %userremove beagleindex
226         %groupremove beagleindex
227 fi
228
229 %post   libs -p /sbin/ldconfig
230 %postun libs -p /sbin/ldconfig
231
232 %files -f %{name}.lang
233 %defattr(644,root,root,755)
234 %doc AUTHORS COPYING ChangeLog NEWS README
235 %attr(755,root,root) %{_bindir}/beagle-config
236 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
237 %attr(755,root,root) %{_bindir}/beagle-index-info
238 %attr(755,root,root) %{_bindir}/beagle-index-url
239 %attr(755,root,root) %{_bindir}/beagle-info
240 %attr(755,root,root) %{_bindir}/beagle-ping
241 %attr(755,root,root) %{_bindir}/beagle-query
242 %attr(755,root,root) %{_bindir}/beagle-shutdown
243 %attr(755,root,root) %{_bindir}/beagle-status
244 %attr(755,root,root) %{_bindir}/beagled
245 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
246 %attr(755,root,root) %{_libdir}/%{name}/*.exe
247 %dir %{_libdir}/%{name}
248 %dir %{_libdir}/%{name}/Backends
249 %{_libdir}/%{name}/Filters
250 %{_libdir}/%{name}/*.dll*
251 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
252 %{_mandir}/man*/*
253
254 %files libs
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
257
258 %files devel
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_libdir}/*.so
261 %{_includedir}/libbeagle
262 %{_libdir}/*.la
263 %{?with_apidocs:%{_gtkdocdir}/beagle}
264 %{_pkgconfigdir}/*
265
266 %files static
267 %defattr(644,root,root,755)
268 %{_libdir}/*.a
269
270 %files crawl-system
271 %defattr(644,root,root,755)
272 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
273 %dir %{_sysconfdir}/beagle
274 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
275 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
276 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
277 %attr(755,root,root) %{_sbindir}/*
278 %attr(755,root,root) %{_libdir}/beagle-crawl-system
279
280 %if %{with evolution}
281 %files evolution
282 %defattr(644,root,root,755)
283 %{_libdir}/%{name}/Backends/Evolution*
284 %endif
285
286 %if %{with epiphany}
287 %files -n epiphany-extension-beagle
288 %defattr(644,root,root,755)
289 %doc epiphany-extension/README
290 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
291 %{_libdir}/epiphany/1.8/extensions/*.xml
292 %endif
293
294 %files -n python-%{name}
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{py_sitedir}/*.so
297
298 %if %{with gui}
299 %files search-gui
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_bindir}/beagle-search
302 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
303 %attr(755,root,root) %{_bindir}/beagle-settings
304 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
305 %{_pixmapsdir}/*.png
306 %{_desktopdir}/*.desktop
307 %endif
This page took 0.111 seconds and 4 git commands to generate.