]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- corrected permissions
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - finish crawl system
4 #       - separtate CLI utilities
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_with     epiphany        # build epiphany extension
10 %bcond_with     gsf             # build with libgsf support
11 %bcond_without  evolution       # don't include evolution support
12 #
13 Summary:        Beagle - An indexing subsystem
14 Summary(pl):    Beagle - podsystem indeksuj±cy
15 Name:           beagle
16 Version:        0.2.0
17 Release:        1
18 License:        Various
19 Group:          Libraries
20 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
21 # Source0-md5:  faa236b812db1a8ee72c58d2cb810010
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-crawl.patch
24 URL:            http://beaglewiki.org/Main_Page
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
28 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
29 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
30 #BuildRequires: dotnet-gst-sharp-devel
31 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
32 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
33 BuildRequires:  gnome-vfs2-devel
34 BuildRequires:  gtk+2-devel >= 2:2.6.0
35 BuildRequires:  gtk-doc
36 BuildRequires:  libexif-devel >= 0.5.0
37 BuildRequires:  libgnome-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 2.6.19
41 BuildRequires:  mono-csharp >= 1.1.10
42 BuildRequires:  mozilla-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-devel
45 BuildRequires:  sqlite-devel
46 BuildRequires:  wv-devel >= 1.0.0
47 BuildRequires:  zip
48 Requires:       %{name}-libs = %{version}-%{release}
49 Requires:       dotnet-gmime-sharp >= 2.1.19
50 %{?with_epiphany:Requires:      epiphany-extensions}
51 Requires:       gtk+2 >= 2:2.6.0
52 Requires:       sqlite
53 ExcludeArch:    alpha i386 sparc sparc64
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Beagle is an indexing sub-system and search aggregator built on top of
58 Lucene.Net.
59
60 %description -l pl
61 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
62 bazie Lucene.Net.
63
64 %package libs
65 Summary:        Beagle libraries
66 Summary(pl):    Bibiloteki Beagle
67 Group:          Libraries
68
69 %description libs
70 Beagle libraries.
71
72 %description libs -l pl
73 Bibiloteki Beagle.
74
75 %package devel
76 Summary:        Beagle development files
77 Summary(pl):    Pliki programistyczne Beagle
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80
81 %description devel
82 Beagle development files.
83
84 %description devel -l pl
85 Pliki programistyczne Beagle.
86
87 %package static
88 Summary:        Beagle static libraries
89 Summary(pl):    Statyczne biblioteki Beagle
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Beagle static libraries.
95
96 %description static -l pl
97 Statyczne biblioteki Beagle.
98
99 %package crawl-system
100 Summary:        Beagle crawl system
101 Summary(pl):    System przeszukuj±cy beagle-crawl
102 Group:          Applications/System
103 Requires:       crondaemon
104 Provides:       group(avahi)
105 Provides:       user(avahi)
106
107 %description crawl-system
108 Beagle crawl system.
109
110 %description crawl-system -l pl
111 System przeszukuj±cy beagle-crawl.
112
113 %package -n epiphany-extension-beagle
114 Summary:        Epiphany extension - beagle
115 Summary(pl):    Rozszerzenie dla Epiphany - beagle
116 Group:          X11/Applications/Networking
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       epiphany >= 1.2.1
119
120 %description -n epiphany-extension-beagle
121 Epiphany extension that allows Beagle to index every page the user
122 views.
123
124 %description -n epiphany-extension-beagle -l pl
125 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
126 odwiedzan± stronê.
127
128 %package -n python-%{name}
129 Summary:        Beagle Python bindings
130 Summary(pl):    Wi±zania jêzyka Python dla Beagle
131 Group:          Libraries/Python
132 Requires:       %{name} = %{version}-%{release}
133 %pyrequires_eq  python-libs
134
135 %description -n python-%{name}
136 Beagle Python bindings.
137
138 %description -n python-%{name} -l pl
139 Wi±zania jêzyka Python dla Beagle.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144 %patch1 -p1
145
146 %build
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 %configure \
152         --enable-static \
153         --enable-gtk-doc \
154         --with-html-dir=%{_gtkdocdir} \
155         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
156         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp
157
158 %{__make} \
159         MOZILLA_HOME=%{_libdir}/mozilla \
160         pythondir=%{py_sitedir}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT \
168         pythondir=%{py_sitedir}
169
170 # Kill useless files
171 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
172         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
173
174 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
175 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
176
177 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
178
179 %find_lang %{name}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %pre crawl-system
185 %groupadd -g 166 -r -f beagleindex
186 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
187
188 %postun crawl-system
189 if [ "$1" = "0" ]; then
190         %userremove beagleindex
191         %groupremove beagleindex
192 fi
193
194 %post   libs -p /sbin/ldconfig
195 %postun libs -p /sbin/ldconfig
196
197 %files -f %{name}.lang
198 %defattr(644,root,root,755)
199 %doc AUTHORS COPYING ChangeLog NEWS README
200 %attr(755,root,root) %{_bindir}/*
201 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
202 %{_libdir}/%{name}/Backends
203 %{_libdir}/%{name}/Filters
204 %attr(755,root,root) %{_libdir}/%{name}/*.exe
205 %{_libdir}/%{name}/*.dll*
206
207 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
208
209 %{_pixmapsdir}/*.png
210 %{_desktopdir}/*.desktop
211 %{_mandir}/man*/*
212
213 %files libs
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
216 %dir %{_libdir}/%{name}
217
218 %files devel
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/*.so
221 %{_includedir}/libbeagle
222 %{_libdir}/*.la
223 %{_gtkdocdir}/beagle
224 %{_pkgconfigdir}/*
225
226 %files static
227 %defattr(644,root,root,755)
228 %{_libdir}/*.a
229
230 %files crawl-system
231 %defattr(644,root,root,755)
232 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
233 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
234 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
235 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
236 %attr(755,root,root) %{_sbindir}/*
237 %{_libdir}/beagle-crawl-system
238
239 %if %{with epiphany}
240 %files -n epiphany-extension-beagle
241 %defattr(644,root,root,755)
242 %doc epiphany-extension/README
243 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
244 %{_libdir}/epiphany/1.8/extensions/*.xml
245 %endif
246
247 %files -n python-%{name}
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.106071 seconds and 4 git commands to generate.