]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- missing dir in -libs
[packages/beagle.git] / beagle.spec
1 #
2 # TODO: 
3 #       - finish crawl system
4 #       - separtate CLI utilities
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_with     epiphany        # don't build epiphany extension
10 %bcond_with     evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.1.1
16 Release:        0.9
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
20 # Source0-md5:  e788ed11077e576797a0793631f2fe8b
21 Patch0:         %{name}-desktop.patch
22 PAtch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.6}
27 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
28 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
29 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
30 #BuildRequires: dotnet-gst-sharp-devel
31 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
32 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
33 BuildRequires:  gnome-vfs2-devel
34 BuildRequires:  gtk+2-devel >= 2:2.4.0
35 BuildRequires:  gtk-doc
36 BuildRequires:  libexif-devel >= 0.5.0
37 BuildRequires:  libgnome-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 2.6.0
41 BuildRequires:  mono-csharp >= 1.0.6
42 BuildRequires:  mozilla-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  sqlite-devel
45 BuildRequires:  wv-devel >= 1.0.0
46 BuildRequires:  zip
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       dotnet-gmime-sharp >= 2.1.16-2
49 %{?with_epiphany:Requires:      epiphany-extensions}
50 Requires:       gtk+2 >= 2:2.4.0
51 Requires:       sqlite
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Beagle is an indexing sub-system and search aggregator built on top of
56 Lucene.Net.
57
58 %description -l pl
59 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
60 bazie Lucene.Net.
61
62 %package libs
63 Summary:        Beagle libraries
64 Summary(pl):    Bibiloteki Beagle
65 Group:          Libraries
66
67 %description libs
68 Beagle libraries.
69
70 %description libs -l pl
71 Bibiloteki Beagle.
72
73 %package devel
74 Summary:        Beagle development files
75 Summary(pl):    Pliki programistyczne Beagle
76 Group:          Development/Libraries
77 Requires:       %{name}-libs = %{version}-%{release}
78
79 %description devel
80 Beagle development files.
81
82 %description devel -l pl
83 Pliki programistyczne Beagle.
84
85 %package static
86 Summary:        Beagle static libraries
87 Summary(pl):    Statyczne biblioteki Beagle
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Beagle static libraries.
93
94 %description static -l pl
95 Statyczne biblioteki Beagle.
96
97 %package crawl-system
98 Summary:        Beagle crawl system
99 Summary(pl):    System przeszukuj±cy beagle-crawl 
100 Group:          Applications/System
101
102 %description crawl-system
103 Beagle crawl system.
104
105 %description crawl-system -l pl
106 System przeszukuj±cy beagle-crawl.
107
108 %package -n epiphany-extension-beagle
109 Summary:        Epiphany extension - beagle
110 Summary(pl):    Rozszerzenie dla Epiphany - beagle
111 Group:          X11/Applications/Networking
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       epiphany >= 1.2.1
114
115 %description -n epiphany-extension-beagle
116 Epiphany extension that allows Beagle to index every page the user
117 views.
118
119 %description -n epiphany-extension-beagle -l pl
120 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
121 odwiedzan± stronê.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         --enable-static \
135         --enable-gtk-doc \
136         --with-html-dir=%{_gtkdocdir} \
137         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
138         --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
139         
140 %{__make} \
141         MOZILLA_HOME=%{_libdir}/mozilla
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 # Kill useless files
150 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
151         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
152         
153 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
154
155 %find_lang %{name}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %doc AUTHORS COPYING ChangeLog NEWS README
166 %attr(755,root,root) %{_bindir}/*
167
168 %{_libdir}/%{name}/Filters
169 %{_libdir}/%{name}/*.exe
170 %{_libdir}/%{name}/*.dll*
171
172 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
173
174 %{_pixmapsdir}/*.png
175 %{_desktopdir}/*.desktop
176 %{_mandir}/man*/*
177
178 %files libs
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
181 %dir %{_libdir}/%{name}
182 %attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
183
184 %files devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/*.so
187 %attr(755,root,root) %{_libdir}/%{name}/*.so
188 %{_includedir}/libbeagle
189 %{_libdir}/*.la
190 %{_gtkdocdir}/beagle
191 %{_pkgconfigdir}/*
192
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/*.a
196 %{_libdir}/%{name}/*.a
197
198 # not finished yet
199 %files crawl-system
200 %defattr(644,root,root,755)
201 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
202 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
203 %attr(755,root,root) %{_sbindir}/*
204 %{_libdir}/beagle-crawl-system
205
206 %if %{with epiphany}
207 %files -n epiphany-extension-beagle
208 %defattr(644,root,root,755)
209 %doc epiphany-extension/README
210 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
211 %{_libdir}/epiphany/1.8/extensions/*.xml
212 %endif
This page took 0.106469 seconds and 4 git commands to generate.