]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- smashed some of mono Rs (autodeps included)
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 # - package 'crawl' files
4 # - check .desktop files
5 # - separate libs (future proof)
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  epiphany        # build epiphany extension
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.1.0
16 Release:        0.1
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
20 # Source0-md5:  79d43b6b3ff0de919b54b08844b5cea2
21 URL:            http://beaglewiki.org/Main_Page
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  dotnet-evolution-sharp-devel >= 0.6
25 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
26 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
27 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
28 #BuildRequires: dotnet-gst-sharp-devel
29 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
30 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
31 BuildRequires:  gnome-vfs2-devel
32 BuildRequires:  gtk+2-devel >= 2:2.4.0
33 BuildRequires:  gtk-doc
34 BuildRequires:  libexif-devel >= 0.5.0
35 BuildRequires:  libgnome-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2.6.0
39 BuildRequires:  mono-csharp >= 1.0.6
40 BuildRequires:  mozilla-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sqlite-devel
43 BuildRequires:  wv-devel >= 1.0.0
44 BuildRequires:  zip
45 Requires:       dotnet-gmime-sharp >= 2.1.16-2
46 %{?with_epiphany:Requires:      epiphany-extensions}
47 Requires:       gtk+2 >= 2:2.4.0
48 Requires:       sqlite
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Beagle is an indexing sub-system and search aggregator built on top of
53 Lucene.Net.
54
55 %description -l pl
56 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
57 bazie Lucene.Net.
58
59 %package devel
60 Summary:        Beagle development files
61 Summary(pl):    Pliki programistyczne Beagle
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Beagle development files.
67
68 %description devel -l pl
69 Pliki programistyczne Beagle.
70
71 %package -n epiphany-extension-beagle
72 Summary:        Epiphany extension - beagle
73 Summary(pl):    Rozszerzenie dla Epiphany - beagle
74 Group:          X11/Applications/Networking
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       epiphany >= 1.2.1
77 Requires:       epiphany < 1.3.0
78
79 %description -n epiphany-extension-beagle
80 Epiphany extension that allows Beagle to index every page the user
81 views.
82
83 %description -n epiphany-extension-beagle -l pl
84 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
85 odwiedzan± stronê.
86
87 %prep
88 %setup -q
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         --disable-static \
97         --enable-gtk-doc \
98         --with-html-dir=%{_gtkdocdir} \
99 %if %{with epiphany}
100         --enable-epiphany-extension
101 %else
102         --disable-epiphany-extension
103 %endif
104
105 %{__make} \
106         MOZILLA_HOME=%{_libdir}/mozilla
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # Kill useless files
115 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
116         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
117         
118 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
119
120 %find_lang %{name}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS COPYING ChangeLog NEWS README
131 %attr(755,root,root) %{_bindir}/*
132 %attr(755,root,root) %{_sbindir}/*
133
134 %dir %{_libdir}/%{name}
135 %{_libdir}/%{name}/Filters
136 %{_libdir}/%{name}/*.exe
137 %{_libdir}/%{name}/*.dll*
138
139 # to be separtated
140 %attr(755,root,root) %{_libdir}/lib*.so*
141 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
142 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
143
144 %{_pixmapsdir}/*.png
145 %{_desktopdir}/*.desktop
146 %{_mandir}/man*/*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %{_includedir}/libbeagle
151 %{_libdir}/*.la
152 %{_libdir}/*.so
153 %{_gtkdocdir}/beagle
154 %{_pkgconfigdir}/*
155
156 %if %{with epiphany}
157 %files -n epiphany-extension-beagle
158 %defattr(644,root,root,755)
159 %doc epiphany-extension/README
160 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
161 %{_libdir}/epiphany/1.8/extensions/*.xml
162 %endif
This page took 0.061403 seconds and 4 git commands to generate.