]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- build against mono 1.1.12
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - separtate CLI utilities
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.2.0
16 Release:        1
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
20 # Source0-md5:  faa236b812db1a8ee72c58d2cb810010
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 Patch2:         %{name}-mono-1.1.12-bludgeon.patch
24 URL:            http://beaglewiki.org/Main_Page
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
28 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
29 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
30 #BuildRequires: dotnet-gst-sharp-devel
31 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
32 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
33 BuildRequires:  gnome-vfs2-devel
34 BuildRequires:  gtk+2-devel >= 2:2.6.0
35 BuildRequires:  gtk-doc
36 BuildRequires:  libexif-devel >= 0.5.0
37 BuildRequires:  libgnome-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 2.6.19
41 BuildRequires:  mono-csharp >= 1.1.10
42 BuildRequires:  mozilla-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-devel
45 BuildRequires:  sqlite-devel
46 BuildRequires:  wv-devel >= 1.0.0
47 BuildRequires:  zip
48 Requires:       %{name}-libs = %{version}-%{release}
49 Requires:       dotnet-gmime-sharp >= 2.1.19
50 %{?with_epiphany:Requires:      epiphany-extensions}
51 Requires:       gtk+2 >= 2:2.6.0
52 Requires:       sqlite
53 ExcludeArch:    alpha i386 sparc sparc64
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Beagle is an indexing sub-system and search aggregator built on top of
58 Lucene.Net.
59
60 %description -l pl
61 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
62 bazie Lucene.Net.
63
64 %package libs
65 Summary:        Beagle libraries
66 Summary(pl):    Bibiloteki Beagle
67 Group:          Libraries
68
69 %description libs
70 Beagle libraries.
71
72 %description libs -l pl
73 Bibiloteki Beagle.
74
75 %package devel
76 Summary:        Beagle development files
77 Summary(pl):    Pliki programistyczne Beagle
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80
81 %description devel
82 Beagle development files.
83
84 %description devel -l pl
85 Pliki programistyczne Beagle.
86
87 %package static
88 Summary:        Beagle static libraries
89 Summary(pl):    Statyczne biblioteki Beagle
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Beagle static libraries.
95
96 %description static -l pl
97 Statyczne biblioteki Beagle.
98
99 %package crawl-system
100 Summary:        Beagle crawl system
101 Summary(pl):    System przeszukuj±cy beagle-crawl
102 Group:          Applications/System
103 Requires:       crondaemon
104 Provides:       group(avahi)
105 Provides:       user(avahi)
106
107 %description crawl-system
108 Beagle crawl system.
109
110 %description crawl-system -l pl
111 System przeszukuj±cy beagle-crawl.
112
113 %package evolution
114 Summary:        Beagle Evolution backend
115 Summary(pl):    Backend Beagle dla Evolution
116 Group:          X11/Applications/Networking
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       evolution
119
120 %description
121 Beagle Evolution backend.
122
123 %description evolution -l pl
124 Backend Beagle dla Evolution.
125
126 %package -n epiphany-extension-beagle
127 Summary:        Epiphany extension - beagle
128 Summary(pl):    Rozszerzenie dla Epiphany - beagle
129 Group:          X11/Applications/Networking
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       epiphany >= 1.2.1
132
133 %description -n epiphany-extension-beagle
134 Epiphany extension that allows Beagle to index every page the user
135 views.
136
137 %description -n epiphany-extension-beagle -l pl
138 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
139 odwiedzan± stronê.
140
141 %package -n python-%{name}
142 Summary:        Beagle Python bindings
143 Summary(pl):    Wi±zania jêzyka Python dla Beagle
144 Group:          Libraries/Python
145 Requires:       %{name} = %{version}-%{release}
146 %pyrequires_eq  python-libs
147
148 %description -n python-%{name}
149 Beagle Python bindings.
150
151 %description -n python-%{name} -l pl
152 Wi±zania jêzyka Python dla Beagle.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157 %patch1 -p1
158 %patch2 -p0
159
160 %build
161 %{__libtoolize}
162 %{__aclocal}
163 %{__autoconf}
164 %{__automake}
165 %configure \
166         --enable-static \
167         --enable-gtk-doc \
168         --with-html-dir=%{_gtkdocdir} \
169         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
170         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp
171
172 %{__make} \
173         MOZILLA_HOME=%{_libdir}/mozilla \
174         pythondir=%{py_sitedir}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT \
182         pythondir=%{py_sitedir}
183
184 # Kill useless files
185 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
186         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
187
188 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
189 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
190
191 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
192
193 %find_lang %{name}
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %pre crawl-system
199 %groupadd -g 166 -r -f beagleindex
200 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
201
202 %postun crawl-system
203 if [ "$1" = "0" ]; then
204         %userremove beagleindex
205         %groupremove beagleindex
206 fi
207
208 %post   libs -p /sbin/ldconfig
209 %postun libs -p /sbin/ldconfig
210
211 %files -f %{name}.lang
212 %defattr(644,root,root,755)
213 %doc AUTHORS COPYING ChangeLog NEWS README
214 %attr(755,root,root) %{_bindir}/*
215 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
216 %dir %{_libdir}/%{name}/Backends
217 %{_libdir}/%{name}/Filters
218 %attr(755,root,root) %{_libdir}/%{name}/*.exe
219 %{_libdir}/%{name}/*.dll*
220
221 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
222
223 %{_pixmapsdir}/*.png
224 %{_desktopdir}/*.desktop
225 %{_mandir}/man*/*
226
227 %files libs
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
230 %dir %{_libdir}/%{name}
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/*.so
235 %{_includedir}/libbeagle
236 %{_libdir}/*.la
237 %{_gtkdocdir}/beagle
238 %{_pkgconfigdir}/*
239
240 %files static
241 %defattr(644,root,root,755)
242 %{_libdir}/*.a
243
244 %files crawl-system
245 %defattr(644,root,root,755)
246 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
247 %dir %{_sysconfdir}/beagle
248 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
249 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
250 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
251 %attr(755,root,root) %{_sbindir}/*
252 %{_libdir}/beagle-crawl-system
253
254 %files evolution
255 %defattr(644,root,root,755)
256 %{_libdir}/%{name}/Backends/Evolution*
257
258 %if %{with epiphany}
259 %files -n epiphany-extension-beagle
260 %defattr(644,root,root,755)
261 %doc epiphany-extension/README
262 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
263 %{_libdir}/epiphany/1.8/extensions/*.xml
264 %endif
265
266 %files -n python-%{name}
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.167845 seconds and 4 git commands to generate.