]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- exclude alpha i386 sparc sparc64 from build, enable gsf-sharp
[packages/beagle.git] / beagle.spec
1 #
2 # TODO: 
3 #       - finish crawl system
4 #       - separtate CLI utilities
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_with     epiphany        # don't build epiphany extension
10 %bcond_with     evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.1.2
16 Release:        0.9
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
20 # Source0-md5:  944553979659ed21a68bba307126126a
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.6}
27 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
28 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
29 BuildRequires:  dotnet-gsf-sharp-devel >= 0.7
30 #BuildRequires: dotnet-gst-sharp-devel
31 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
32 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
33 BuildRequires:  gnome-vfs2-devel
34 BuildRequires:  gtk+2-devel >= 2:2.4.0
35 BuildRequires:  gtk-doc
36 BuildRequires:  libexif-devel >= 0.5.0
37 BuildRequires:  libgnome-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 2.6.0
41 BuildRequires:  mono-csharp >= 1.1.10
42 BuildRequires:  mozilla-devel
43 BuildRequires:  pkgconfig
44 BuildRequires:  sqlite-devel
45 BuildRequires:  wv-devel >= 1.0.0
46 BuildRequires:  zip
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       dotnet-gmime-sharp >= 2.1.16-2
49 %{?with_epiphany:Requires:      epiphany-extensions}
50 Requires:       gtk+2 >= 2:2.4.0
51 Requires:       sqlite
52 ExcludeArch:    alpha i386 sparc sparc64
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Beagle is an indexing sub-system and search aggregator built on top of
57 Lucene.Net.
58
59 %description -l pl
60 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
61 bazie Lucene.Net.
62
63 %package libs
64 Summary:        Beagle libraries
65 Summary(pl):    Bibiloteki Beagle
66 Group:          Libraries
67
68 %description libs
69 Beagle libraries.
70
71 %description libs -l pl
72 Bibiloteki Beagle.
73
74 %package devel
75 Summary:        Beagle development files
76 Summary(pl):    Pliki programistyczne Beagle
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79
80 %description devel
81 Beagle development files.
82
83 %description devel -l pl
84 Pliki programistyczne Beagle.
85
86 %package static
87 Summary:        Beagle static libraries
88 Summary(pl):    Statyczne biblioteki Beagle
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Beagle static libraries.
94
95 %description static -l pl
96 Statyczne biblioteki Beagle.
97
98 %package crawl-system
99 Summary:        Beagle crawl system
100 Summary(pl):    System przeszukuj±cy beagle-crawl 
101 Group:          Applications/System
102
103 %description crawl-system
104 Beagle crawl system.
105
106 %description crawl-system -l pl
107 System przeszukuj±cy beagle-crawl.
108
109 %package -n epiphany-extension-beagle
110 Summary:        Epiphany extension - beagle
111 Summary(pl):    Rozszerzenie dla Epiphany - beagle
112 Group:          X11/Applications/Networking
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       epiphany >= 1.2.1
115
116 %description -n epiphany-extension-beagle
117 Epiphany extension that allows Beagle to index every page the user
118 views.
119
120 %description -n epiphany-extension-beagle -l pl
121 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
122 odwiedzan± stronê.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %patch1 -p1
128
129 %build
130 %{__libtoolize}
131 %{__aclocal}
132 %{__autoconf}
133 %{__automake}
134 %configure \
135         --enable-static \
136         --enable-gtk-doc \
137         --with-html-dir=%{_gtkdocdir} \
138         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
139         --%{!?with_evoultion:dis}%{?with_evolution:en}able-evolution-sharp
140         
141 %{__make} \
142         MOZILLA_HOME=%{_libdir}/mozilla
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 # Kill useless files
151 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
152         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
153         
154 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS COPYING ChangeLog NEWS README
167 %attr(755,root,root) %{_bindir}/*
168
169 %{_libdir}/%{name}/Filters
170 %{_libdir}/%{name}/*.exe
171 %{_libdir}/%{name}/*.dll*
172
173 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
174
175 %{_pixmapsdir}/*.png
176 %{_desktopdir}/*.desktop
177 %{_mandir}/man*/*
178
179 %files libs
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
182 %dir %{_libdir}/%{name}
183 %attr(755,root,root) %{_libdir}/%{name}/lib*.so.*.*.*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/*.so
188 %attr(755,root,root) %{_libdir}/%{name}/*.so
189 %{_includedir}/libbeagle
190 %{_libdir}/*.la
191 %{_gtkdocdir}/beagle
192 %{_pkgconfigdir}/*
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/*.a
197 %{_libdir}/%{name}/*.a
198
199 # not finished yet
200 %files crawl-system
201 %defattr(644,root,root,755)
202 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
203 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
204 %attr(755,root,root) %{_sbindir}/*
205 %{_libdir}/beagle-crawl-system
206
207 %if %{with epiphany}
208 %files -n epiphany-extension-beagle
209 %defattr(644,root,root,755)
210 %doc epiphany-extension/README
211 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
212 %{_libdir}/epiphany/1.8/extensions/*.xml
213 %endif
This page took 0.04122 seconds and 4 git commands to generate.