]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- packaged more %%files, fixed BRs/Rs, build epiphany plugin by default,
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 # - package 'crawl' files
4 # - check .desktop files
5 # - separate libs (future proof)
6 #
7 %include        /usr/lib/rpm/macros.mono
8 #
9 # Conditional build:
10 %bcond_without  epiphany        # build epiphany extension
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.1.0
16 Release:        0.1
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
20 # Source0-md5:  79d43b6b3ff0de919b54b08844b5cea2
21 URL:            http://beaglewiki.org/Main_Page
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  dotnet-evolution-sharp-devel >= 0.6
25 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
26 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
27 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
28 #BuildRequires: dotnet-gst-sharp-devel
29 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
30 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
31 BuildRequires:  gnome-vfs2-devel
32 BuildRequires:  gtk+2-devel >= 2:2.4.0
33 BuildRequires:  gtk-doc
34 BuildRequires:  libexif-devel >= 0.5.0
35 BuildRequires:  libgnome-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2.6.0
39 BuildRequires:  mono-csharp >= 1.0.6
40 BuildRequires:  mozilla-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sqlite-devel
43 BuildRequires:  wv-devel >= 1.0.0
44 BuildRequires:  zip
45 Requires:       dotnet-evolution-sharp >= 0.6
46 Requires:       dotnet-gecko-sharp2 >= 0.11
47 Requires:       dotnet-gmime-sharp >= 2.1.16-2
48 #Requires:      dotnet-gsf-sharp-devel >= 0.2
49 #Requires:      dotnet-gst-sharp-devel
50 Requires:       dotnet-gtk-sharp2-gnome
51 %{?with_epiphany:Requires:      epiphany-extensions}
52 Requires:       gtk+2 >= 2:2.4.0
53 Requires:       sqlite
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Beagle is an indexing sub-system and search aggregator built on top of
58 Lucene.Net.
59
60 %description -l pl
61 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
62 bazie Lucene.Net.
63
64 %package devel
65 Summary:        Beagle development files
66 Summary(pl):    Pliki programistyczne Beagle
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Beagle development files.
72
73 %description devel -l pl
74 Pliki programistyczne Beagle.
75
76 %package -n epiphany-extension-beagle
77 Summary:        Epiphany extension - beagle
78 Summary(pl):    Rozszerzenie dla Epiphany - beagle
79 Group:          X11/Applications/Networking
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       epiphany >= 1.2.1
82 Requires:       epiphany < 1.3.0
83
84 %description -n epiphany-extension-beagle
85 Epiphany extension that allows Beagle to index every page the user
86 views.
87
88 %description -n epiphany-extension-beagle -l pl
89 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
90 odwiedzan± stronê.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__automake}
100 %configure \
101         --disable-static \
102         --enable-gtk-doc \
103         --with-html-dir=%{_gtkdocdir} \
104 %if %{with epiphany}
105         --enable-epiphany-extension
106 %else
107         --disable-epiphany-extension
108 %endif
109
110 %{__make} \
111         MOZILLA_HOME=%{_libdir}/mozilla
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 # Kill useless files
120 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
121         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
122         
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
124
125 %find_lang %{name}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS COPYING ChangeLog NEWS README
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_sbindir}/*
138
139 %dir %{_libdir}/%{name}
140 %{_libdir}/%{name}/Filters
141 %{_libdir}/%{name}/*.exe
142 %{_libdir}/%{name}/*.dll*
143
144 # to be separtated
145 %attr(755,root,root) %{_libdir}/lib*.so*
146 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
147 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
148
149 %{_pixmapsdir}/*.png
150 %{_desktopdir}/*.desktop
151 %{_mandir}/man*/*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %{_includedir}/libbeagle
156 %{_libdir}/*.la
157 %{_libdir}/*.so
158 %{_gtkdocdir}/beagle
159 %{_pkgconfigdir}/*
160
161 %if %{with epiphany}
162 %files -n epiphany-extension-beagle
163 %defattr(644,root,root,755)
164 %doc epiphany-extension/README
165 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
166 %{_libdir}/epiphany/1.8/extensions/*.xml
167 %endif
This page took 0.043847 seconds and 4 git commands to generate.