]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- bconds: python, sqlite3, updated BR's
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_without  evolution       # don't include evolution support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
15 #
16 %if %{without gui}
17 %undefine       with_evolution
18 %endif
19 #
20 Summary:        Beagle - An indexing subsystem
21 Summary(pl):    Beagle - podsystem indeksuj±cy
22 Name:           beagle
23 Version:        0.2.1
24 Release:        2.1
25 License:        Various
26 Group:          Libraries
27 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
28 # Source0-md5:  325ed91dc66fb6be060d0a5f4c8f56dd
29 Patch0:         %{name}-desktop.patch
30 Patch1:         %{name}-crawl.patch
31 URL:            http://beaglewiki.org/Main_Page
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
35 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
36 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
37 #BuildRequires: dotnet-gst-sharp-devel
38 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
39 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
40 BuildRequires:  gtk+2-devel >= 2:2.6.0
41 %{?with_apidocs:BuildRequires:  gtk-doc}
42 BuildRequires:  libexif-devel >= 0.5.0
43 BuildRequires:  librsvg-devel
44 BuildRequires:  libpng-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.19
47 BuildRequires:  mono-csharp >= 1.1.10
48 # not used atm
49 #BuildRequires: mozilla-devel
50 %{?with_python:BuildRequires:   python-pygtk-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  perl-XML-Parser
53 BuildRequires:  python-devel
54 %if %{with sqlite3}
55 BuildRequires:  sqlite3-devel >= 3.3.4
56 %else
57 BuildRequires:  sqlite-devel
58 %endif
59 BuildRequires:  wv-devel >= 1.0.0
60 BuildRequires:  zip
61 # GUI BRs
62 %if %{with gui}
63 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
64 BuildRequires:  gnome-vfs2-devel
65 BuildRequires:  libgnome-devel
66 %endif
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       dotnet-gmime-sharp >= 2.1.19
69 %if %{with sqlite3}
70 Requires:       sqlite3
71 %else
72 Requires:       sqlite
73 %endif
74 ExcludeArch:    alpha i386 sparc sparc64
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 Beagle is an indexing sub-system and search aggregator built on top of
79 Lucene.Net.
80
81 %description -l pl
82 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
83 bazie Lucene.Net.
84
85 %package libs
86 Summary:        Beagle libraries
87 Summary(pl):    Bibiloteki Beagle
88 Group:          Libraries
89
90 %description libs
91 Beagle libraries.
92
93 %description libs -l pl
94 Bibiloteki Beagle.
95
96 %package devel
97 Summary:        Beagle development files
98 Summary(pl):    Pliki programistyczne Beagle
99 Group:          Development/Libraries
100 Requires:       %{name}-libs = %{version}-%{release}
101
102 %description devel
103 Beagle development files.
104
105 %description devel -l pl
106 Pliki programistyczne Beagle.
107
108 %package static
109 Summary:        Beagle static libraries
110 Summary(pl):    Statyczne biblioteki Beagle
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Beagle static libraries.
116
117 %description static -l pl
118 Statyczne biblioteki Beagle.
119
120 %package crawl-system
121 Summary:        Beagle crawl system
122 Summary(pl):    System przeszukuj±cy beagle-crawl
123 Group:          Applications/System
124 Requires:       crondaemon
125 Provides:       group(beagleindex)
126 Provides:       user(beagleindex)
127
128 %description crawl-system
129 Beagle crawl system.
130
131 %description crawl-system -l pl
132 System przeszukuj±cy beagle-crawl.
133
134 %package evolution
135 Summary:        Beagle Evolution backend
136 Summary(pl):    Backend Beagle dla Evolution
137 Group:          X11/Applications/Networking
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       dotnet-evolution-sharp >= 0.10.2-4
140 Requires:       evolution
141
142 %description
143 Beagle Evolution backend.
144
145 %description evolution -l pl
146 Backend Beagle dla Evolution.
147
148 %package -n epiphany-extension-beagle
149 Summary:        Epiphany extension - beagle
150 Summary(pl):    Rozszerzenie dla Epiphany - beagle
151 Group:          X11/Applications/Networking
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       epiphany-extensions
154
155 %description -n epiphany-extension-beagle
156 Epiphany extension that allows Beagle to index every page the user
157 views.
158
159 %description -n epiphany-extension-beagle -l pl
160 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
161 odwiedzan± stronê.
162
163 %package -n python-%{name}
164 Summary:        Beagle Python bindings
165 Summary(pl):    Wi±zania jêzyka Python dla Beagle
166 Group:          Libraries/Python
167 Requires:       %{name} = %{version}-%{release}
168 %pyrequires_eq  python-libs
169
170 %description -n python-%{name}
171 Beagle Python bindings.
172
173 %description -n python-%{name} -l pl
174 Wi±zania jêzyka Python dla Beagle.
175
176 %package search-gui
177 Summary:        GNOME based Beagle GUI
178 Summary(pl):    Bazowane na GNOME GUI dla Beagle
179 Group:          Libraries/Python
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       gtk+2 >= 2:2.6.0
182
183 %description search-gui
184 GNOME based Beagle GUI.
185
186 %description search-gui -l pl
187 Bazowane na GNOME GUI dla Beagle.
188
189 %prep
190 %setup -q
191 %patch0 -p1
192 %patch1 -p1
193
194 %build
195 %{__libtoolize}
196 %{__aclocal}
197 %{__autoconf}
198 %{__automake}
199 %configure \
200         --enable-static \
201         %{?with_apidocs:--enable-gtk-doc} \
202         --with-html-dir=%{_gtkdocdir} \
203         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
204         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
205         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
206
207 %{__make} \
208         MOZILLA_HOME=%{_libdir}/mozilla \
209         pythondir=%{py_sitedir}
210
211 %install
212 rm -rf $RPM_BUILD_ROOT
213 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
214
215 %{__make} install \
216         DESTDIR=$RPM_BUILD_ROOT \
217         pythondir=%{py_sitedir}
218
219 # Kill useless files
220 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
221         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
222
223 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
224 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
225
226 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
227
228 %find_lang %{name}
229
230 %clean
231 rm -rf $RPM_BUILD_ROOT
232
233 %pre crawl-system
234 %groupadd -g 166 -r -f beagleindex
235 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
236
237 %postun crawl-system
238 if [ "$1" = "0" ]; then
239         %userremove beagleindex
240         %groupremove beagleindex
241 fi
242
243 %post   libs -p /sbin/ldconfig
244 %postun libs -p /sbin/ldconfig
245
246 %files -f %{name}.lang
247 %defattr(644,root,root,755)
248 %doc AUTHORS COPYING ChangeLog NEWS README
249 %attr(755,root,root) %{_bindir}/beagle-config
250 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
251 %attr(755,root,root) %{_bindir}/beagle-index-info
252 %attr(755,root,root) %{_bindir}/beagle-index-url
253 %attr(755,root,root) %{_bindir}/beagle-info
254 %attr(755,root,root) %{_bindir}/beagle-ping
255 %attr(755,root,root) %{_bindir}/beagle-query
256 %attr(755,root,root) %{_bindir}/beagle-shutdown
257 %attr(755,root,root) %{_bindir}/beagle-status
258 %attr(755,root,root) %{_bindir}/beagled
259 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
260 %attr(755,root,root) %{_libdir}/%{name}/*.exe
261 %dir %{_libdir}/%{name}
262 %dir %{_libdir}/%{name}/Backends
263 %{_libdir}/%{name}/Filters
264 %{_libdir}/%{name}/*.dll*
265 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
266 %{_mandir}/man*/*
267
268 %files libs
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
271
272 %files devel
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_libdir}/*.so
275 %{_includedir}/libbeagle
276 %{_libdir}/*.la
277 %{?with_apidocs:%{_gtkdocdir}/beagle}
278 %{_pkgconfigdir}/*
279
280 %files static
281 %defattr(644,root,root,755)
282 %{_libdir}/*.a
283
284 %files crawl-system
285 %defattr(644,root,root,755)
286 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
287 %dir %{_sysconfdir}/beagle
288 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
289 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
290 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
291 %attr(755,root,root) %{_sbindir}/*
292 %attr(755,root,root) %{_libdir}/beagle-crawl-system
293
294 %if %{with evolution}
295 %files evolution
296 %defattr(644,root,root,755)
297 %{_libdir}/%{name}/Backends/Evolution*
298 %endif
299
300 %if %{with epiphany}
301 %files -n epiphany-extension-beagle
302 %defattr(644,root,root,755)
303 %doc epiphany-extension/README
304 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
305 %{_libdir}/epiphany/1.8/extensions/*.xml
306 %endif
307
308 %if %{with python}
309 %files -n python-%{name}
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{py_sitedir}/*.so
312 %endif
313
314 %if %{with gui}
315 %files search-gui
316 %defattr(644,root,root,755)
317 %attr(755,root,root) %{_bindir}/beagle-search
318 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
319 %attr(755,root,root) %{_bindir}/beagle-settings
320 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
321 %{_pixmapsdir}/*.png
322 %{_desktopdir}/*.desktop
323 %endif
This page took 0.064395 seconds and 4 git commands to generate.