]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- started work on 0.2.0, updated BR, not finished yet
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - finish crawl system
4 #       - separtate CLI utilities
5 #
6 %include        /usr/lib/rpm/macros.mono
7 #
8 # Conditional build:
9 %bcond_with     epiphany        # don't build epiphany extension
10 %bcond_with     evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.2.0
16 Release:        0.9
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
20 # Source0-md5:  faa236b812db1a8ee72c58d2cb810010
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
27 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
28 BuildRequires:  dotnet-gsf-sharp-devel >= 0.7
29 #BuildRequires: dotnet-gst-sharp-devel
30 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
31 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
32 BuildRequires:  gnome-vfs2-devel
33 BuildRequires:  gtk+2-devel >= 2:2.6.0
34 BuildRequires:  gtk-doc
35 BuildRequires:  libexif-devel >= 0.5.0
36 BuildRequires:  libgnome-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2.6.19
40 BuildRequires:  mono-csharp >= 1.1.10
41 BuildRequires:  mozilla-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  python-devel
44 BuildRequires:  sqlite-devel
45 BuildRequires:  wv-devel >= 1.0.0
46 BuildRequires:  zip
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       dotnet-gmime-sharp >= 2.1.19
49 %{?with_epiphany:Requires:      epiphany-extensions}
50 Requires:       gtk+2 >= 2:2.6.0
51 Requires:       sqlite
52
53 ExcludeArch:    alpha i386 sparc sparc64
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 Beagle is an indexing sub-system and search aggregator built on top of
58 Lucene.Net.
59
60 %description -l pl
61 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
62 bazie Lucene.Net.
63
64 %package libs
65 Summary:        Beagle libraries
66 Summary(pl):    Bibiloteki Beagle
67 Group:          Libraries
68
69 %description libs
70 Beagle libraries.
71
72 %description libs -l pl
73 Bibiloteki Beagle.
74
75 %package devel
76 Summary:        Beagle development files
77 Summary(pl):    Pliki programistyczne Beagle
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80
81 %description devel
82 Beagle development files.
83
84 %description devel -l pl
85 Pliki programistyczne Beagle.
86
87 %package static
88 Summary:        Beagle static libraries
89 Summary(pl):    Statyczne biblioteki Beagle
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Beagle static libraries.
95
96 %description static -l pl
97 Statyczne biblioteki Beagle.
98
99 %package crawl-system
100 Summary:        Beagle crawl system
101 Summary(pl):    System przeszukuj±cy beagle-crawl
102 Group:          Applications/System
103
104 %description crawl-system
105 Beagle crawl system.
106
107 %description crawl-system -l pl
108 System przeszukuj±cy beagle-crawl.
109
110 %package -n epiphany-extension-beagle
111 Summary:        Epiphany extension - beagle
112 Summary(pl):    Rozszerzenie dla Epiphany - beagle
113 Group:          X11/Applications/Networking
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       epiphany >= 1.2.1
116
117 %description -n epiphany-extension-beagle
118 Epiphany extension that allows Beagle to index every page the user
119 views.
120
121 %description -n epiphany-extension-beagle -l pl
122 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
123 odwiedzan± stronê.
124
125 %package -n python-%{name}
126 Summary:        Beagle Python bindings
127 Summary(pl):    Wi±zania jêzyka Python dla Beagle
128 Group:          Libraries/Python
129 Requires:       %{name} = %{version}-%{release}
130 %pyrequires_eq  python-libs
131
132 %description -n python-%{name}
133 Beagle Python bindings.
134
135 %description -n python-%{name} -l pl
136 Wi±zania jêzyka Python dla Beagle.
137
138 %prep
139 %setup -q
140 #%patch0 -p1
141 #%patch1 -p1
142
143 %build
144 %{__libtoolize}
145 %{__aclocal}
146 %{__autoconf}
147 %{__automake}
148 %configure \
149         --enable-static \
150         --enable-gtk-doc \
151         --with-html-dir=%{_gtkdocdir} \
152         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
153         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp
154
155 %{__make} \
156         MOZILLA_HOME=%{_libdir}/mozilla \
157         pythondir=%{py_sitedir}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         pythondir=%{py_sitedir}
165
166 # Kill useless files
167 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
168         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
169
170 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
171 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
172
173 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
174
175 %find_lang %{name}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   libs -p /sbin/ldconfig
181 %postun libs -p /sbin/ldconfig
182
183 %files -f %{name}.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS COPYING ChangeLog NEWS README
186 %attr(755,root,root) %{_bindir}/*
187 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
188
189 %{_libdir}/%{name}/Filters
190 %attr(755,root,root) %{_libdir}/%{name}/*.exe
191 %{_libdir}/%{name}/*.dll*
192
193 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
194
195 %{_pixmapsdir}/*.png
196 %{_desktopdir}/*.desktop
197 %{_mandir}/man*/*
198
199 %files libs
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
202 %dir %{_libdir}/%{name}
203
204 %files devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/*.so
207 %{_includedir}/libbeagle
208 %{_libdir}/*.la
209 %{_gtkdocdir}/beagle
210 %{_pkgconfigdir}/*
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/*.a
215
216 # not finished yet
217 %files crawl-system
218 %defattr(644,root,root,755)
219 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
220 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
221 %attr(755,root,root) %{_sbindir}/*
222 %{_libdir}/beagle-crawl-system
223
224 %if %{with epiphany}
225 %files -n epiphany-extension-beagle
226 %defattr(644,root,root,755)
227 %doc epiphany-extension/README
228 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
229 %{_libdir}/epiphany/1.8/extensions/*.xml
230 %endif
231
232 %files -n python-%{name}
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.080315 seconds and 3 git commands to generate.