]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
a4f4f308de21c20f09ad3256e17124b229ee141e
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - kill bashisms in crawl stuff
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  apidocs         # don't build API documentation
11 %bcond_without  evolution       # don't include evolution support
12 %bcond_without  gui             # don't build GNOME based GUI
13 %bcond_without  python          # don't build python libraries
14 %bcond_with     sqlite3         # use sqlite3 instead of sqlite2
15 #
16 %if %{without gui}
17 %undefine       with_evolution
18 %endif
19 #
20 Summary:        Beagle - An indexing subsystem
21 Summary(pl):    Beagle - podsystem indeksuj±cy
22 Name:           beagle
23 Version:        0.2.2
24 Release:        1
25 License:        Various
26 Group:          Libraries
27 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
28 # Source0-md5:  d8c4765a30b9bf989a769f4337f35b3f
29 Patch0:         %{name}-desktop.patch
30 Patch1:         %{name}-crawl.patch
31 Patch2:         %{name}-kill_exec_a.patch
32 URL:            http://beaglewiki.org/Main_Page
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
36 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
37 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
38 #BuildRequires: dotnet-gst-sharp-devel
39 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.3.90
40 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
41 BuildRequires:  gtk+2-devel >= 2:2.6.0
42 %{?with_apidocs:BuildRequires:  gtk-doc}
43 BuildRequires:  libexif-devel >= 0.5.0
44 BuildRequires:  librsvg-devel
45 BuildRequires:  libpng-devel
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 2.6.19
48 BuildRequires:  mono-csharp >= 1.1.10
49 # not used atm
50 #BuildRequires: mozilla-devel
51 %{?with_python:BuildRequires:   python-pygtk-devel}
52 BuildRequires:  pkgconfig
53 BuildRequires:  perl-XML-Parser
54 BuildRequires:  python-devel
55 %if %{with sqlite3}
56 BuildRequires:  sqlite3-devel >= 3.3.4
57 %else
58 BuildRequires:  sqlite-devel
59 %endif
60 BuildRequires:  wv-devel >= 1.0.0
61 BuildRequires:  zip
62 # GUI BRs
63 %if %{with gui}
64 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
65 BuildRequires:  gnome-vfs2-devel
66 BuildRequires:  libgnome-devel
67 %endif
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       dotnet-gmime-sharp >= 2.1.19
70 %if %{with sqlite3}
71 Requires:       sqlite3
72 %else
73 Requires:       sqlite
74 %endif
75 ExcludeArch:    alpha i386 sparc sparc64
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 Beagle is an indexing sub-system and search aggregator built on top of
80 Lucene.Net.
81
82 %description -l pl
83 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
84 bazie Lucene.Net.
85
86 %package libs
87 Summary:        Beagle libraries
88 Summary(pl):    Bibiloteki Beagle
89 Group:          Libraries
90
91 %description libs
92 Beagle libraries.
93
94 %description libs -l pl
95 Bibiloteki Beagle.
96
97 %package devel
98 Summary:        Beagle development files
99 Summary(pl):    Pliki programistyczne Beagle
100 Group:          Development/Libraries
101 Requires:       %{name}-libs = %{version}-%{release}
102
103 %description devel
104 Beagle development files.
105
106 %description devel -l pl
107 Pliki programistyczne Beagle.
108
109 %package static
110 Summary:        Beagle static libraries
111 Summary(pl):    Statyczne biblioteki Beagle
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Beagle static libraries.
117
118 %description static -l pl
119 Statyczne biblioteki Beagle.
120
121 %package crawl-system
122 Summary:        Beagle crawl system
123 Summary(pl):    System przeszukuj±cy beagle-crawl
124 Group:          Applications/System
125 Requires:       crondaemon
126 Provides:       group(beagleindex)
127 Provides:       user(beagleindex)
128
129 %description crawl-system
130 Beagle crawl system.
131
132 %description crawl-system -l pl
133 System przeszukuj±cy beagle-crawl.
134
135 %package evolution
136 Summary:        Beagle Evolution backend
137 Summary(pl):    Backend Beagle dla Evolution
138 Group:          X11/Applications/Networking
139 Requires:       %{name} = %{version}-%{release}
140 Requires:       dotnet-evolution-sharp >= 0.10.2-4
141 Requires:       evolution
142
143 %description
144 Beagle Evolution backend.
145
146 %description evolution -l pl
147 Backend Beagle dla Evolution.
148
149 %package -n epiphany-extension-beagle
150 Summary:        Epiphany extension - beagle
151 Summary(pl):    Rozszerzenie dla Epiphany - beagle
152 Group:          X11/Applications/Networking
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       epiphany-extensions
155
156 %description -n epiphany-extension-beagle
157 Epiphany extension that allows Beagle to index every page the user
158 views.
159
160 %description -n epiphany-extension-beagle -l pl
161 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
162 odwiedzan± stronê.
163
164 %package -n python-%{name}
165 Summary:        Beagle Python bindings
166 Summary(pl):    Wi±zania jêzyka Python dla Beagle
167 Group:          Libraries/Python
168 Requires:       %{name} = %{version}-%{release}
169 %pyrequires_eq  python-libs
170
171 %description -n python-%{name}
172 Beagle Python bindings.
173
174 %description -n python-%{name} -l pl
175 Wi±zania jêzyka Python dla Beagle.
176
177 %package search-gui
178 Summary:        GNOME based Beagle GUI
179 Summary(pl):    Bazowane na GNOME GUI dla Beagle
180 Group:          Libraries/Python
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       gtk+2 >= 2:2.6.0
183
184 %description search-gui
185 GNOME based Beagle GUI.
186
187 %description search-gui -l pl
188 Bazowane na GNOME GUI dla Beagle.
189
190 %prep
191 %setup -q
192 %patch0 -p1
193 %patch1 -p1
194 %patch2 -p1
195
196 %build
197 %{__libtoolize}
198 %{__aclocal}
199 %{__autoconf}
200 %{__automake}
201 %configure \
202         --enable-static \
203         %{?with_apidocs:--enable-gtk-doc} \
204         --with-html-dir=%{_gtkdocdir} \
205         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
206         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
207         --%{!?with_gui:dis}%{?with_gui:en}able-gui \
208
209 %{__make} \
210         MOZILLA_HOME=%{_libdir}/mozilla \
211         pythondir=%{py_sitedir}
212
213 %install
214 rm -rf $RPM_BUILD_ROOT
215 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
216
217 %{__make} install \
218         DESTDIR=$RPM_BUILD_ROOT \
219         pythondir=%{py_sitedir}
220
221 # Kill useless files
222 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
223         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
224
225 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
226 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
227
228 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
229
230 %find_lang %{name}
231
232 %clean
233 rm -rf $RPM_BUILD_ROOT
234
235 %pre crawl-system
236 %groupadd -g 166 -r -f beagleindex
237 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
238
239 %postun crawl-system
240 if [ "$1" = "0" ]; then
241         %userremove beagleindex
242         %groupremove beagleindex
243 fi
244
245 %post   libs -p /sbin/ldconfig
246 %postun libs -p /sbin/ldconfig
247
248 %files -f %{name}.lang
249 %defattr(644,root,root,755)
250 %doc AUTHORS COPYING ChangeLog NEWS README
251 %attr(755,root,root) %{_bindir}/beagle-config
252 %attr(755,root,root) %{_bindir}/beagle-exercise-file-system
253 %attr(755,root,root) %{_bindir}/beagle-index-info
254 %attr(755,root,root) %{_bindir}/beagle-index-url
255 %attr(755,root,root) %{_bindir}/beagle-info
256 %attr(755,root,root) %{_bindir}/beagle-ping
257 %attr(755,root,root) %{_bindir}/beagle-query
258 %attr(755,root,root) %{_bindir}/beagle-shutdown
259 %attr(755,root,root) %{_bindir}/beagle-status
260 %attr(755,root,root) %{_bindir}/beagled
261 %attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
262 %attr(755,root,root) %{_libdir}/%{name}/*.exe
263 %dir %{_libdir}/%{name}
264 %dir %{_libdir}/%{name}/Backends
265 %{_libdir}/%{name}/Filters
266 %{_libdir}/%{name}/*.dll*
267 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
268 %{_mandir}/man*/*
269
270 %files libs
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
273
274 %files devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_libdir}/*.so
277 %{_includedir}/libbeagle
278 %{_libdir}/*.la
279 %{?with_apidocs:%{_gtkdocdir}/beagle}
280 %{_pkgconfigdir}/*
281
282 %files static
283 %defattr(644,root,root,755)
284 %{_libdir}/*.a
285
286 %files crawl-system
287 %defattr(644,root,root,755)
288 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
289 %dir %{_sysconfdir}/beagle
290 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
291 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
292 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
293 %attr(755,root,root) %{_sbindir}/*
294 %attr(755,root,root) %{_libdir}/beagle-crawl-system
295
296 %if %{with evolution}
297 %files evolution
298 %defattr(644,root,root,755)
299 %{_libdir}/%{name}/Backends/Evolution*
300 %endif
301
302 %if %{with epiphany}
303 %files -n epiphany-extension-beagle
304 %defattr(644,root,root,755)
305 %doc epiphany-extension/README
306 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
307 %{_libdir}/epiphany/1.8/extensions/*.xml
308 %endif
309
310 %if %{with python}
311 %files -n python-%{name}
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{py_sitedir}/*.so
314 %endif
315
316 %if %{with gui}
317 %files search-gui
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{_bindir}/beagle-search
320 %attr(755,root,root) %{_bindir}/beagle-imlogviewer
321 %attr(755,root,root) %{_bindir}/beagle-settings
322 %attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
323 %{_pixmapsdir}/*.png
324 %{_desktopdir}/*.desktop
325 %endif
This page took 0.04395 seconds and 3 git commands to generate.