]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- force unbroken evo dotnet version, fix rights for beagle-crawl-system
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 #       - separtate CLI utilities
4 #
5 %include        /usr/lib/rpm/macros.mono
6 #
7 # Conditional build:
8 %bcond_with     epiphany        # build epiphany extension
9 %bcond_with     gsf             # build with libgsf support
10 %bcond_without  evolution       # don't include evolution support
11 #
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.2.1
16 Release:        2
17 License:        Various
18 Group:          Libraries
19 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
20 # Source0-md5:  325ed91dc66fb6be060d0a5f4c8f56dd
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-crawl.patch
23 URL:            http://beaglewiki.org/Main_Page
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 %{?with_evolution:BuildRequires:        dotnet-evolution-sharp-devel >= 0.10.2}
27 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.19
28 %{?with_gsf:BuildRequires:      dotnet-gsf-sharp-devel >= 0.7}
29 #BuildRequires: dotnet-gst-sharp-devel
30 BuildRequires:  dotnet-gtk-sharp2-gnome-devel >= 2.3.90
31 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.8}
32 BuildRequires:  gnome-vfs2-devel
33 BuildRequires:  gtk+2-devel >= 2:2.6.0
34 BuildRequires:  gtk-doc
35 BuildRequires:  libexif-devel >= 0.5.0
36 BuildRequires:  libgnome-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 2.6.19
40 BuildRequires:  mono-csharp >= 1.1.10
41 BuildRequires:  mozilla-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  python-devel
44 BuildRequires:  sqlite-devel
45 BuildRequires:  wv-devel >= 1.0.0
46 BuildRequires:  zip
47 Requires:       %{name}-libs = %{version}-%{release}
48 Requires:       dotnet-gmime-sharp >= 2.1.19
49 %{?with_epiphany:Requires:      epiphany-extensions}
50 Requires:       gtk+2 >= 2:2.6.0
51 Requires:       sqlite
52 ExcludeArch:    alpha i386 sparc sparc64
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 Beagle is an indexing sub-system and search aggregator built on top of
57 Lucene.Net.
58
59 %description -l pl
60 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
61 bazie Lucene.Net.
62
63 %package libs
64 Summary:        Beagle libraries
65 Summary(pl):    Bibiloteki Beagle
66 Group:          Libraries
67
68 %description libs
69 Beagle libraries.
70
71 %description libs -l pl
72 Bibiloteki Beagle.
73
74 %package devel
75 Summary:        Beagle development files
76 Summary(pl):    Pliki programistyczne Beagle
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79
80 %description devel
81 Beagle development files.
82
83 %description devel -l pl
84 Pliki programistyczne Beagle.
85
86 %package static
87 Summary:        Beagle static libraries
88 Summary(pl):    Statyczne biblioteki Beagle
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Beagle static libraries.
94
95 %description static -l pl
96 Statyczne biblioteki Beagle.
97
98 %package crawl-system
99 Summary:        Beagle crawl system
100 Summary(pl):    System przeszukuj±cy beagle-crawl
101 Group:          Applications/System
102 Requires:       crondaemon
103 Provides:       group(beagleindex)
104 Provides:       user(beagleindex)
105
106 %description crawl-system
107 Beagle crawl system.
108
109 %description crawl-system -l pl
110 System przeszukuj±cy beagle-crawl.
111
112 %package evolution
113 Summary:        Beagle Evolution backend
114 Summary(pl):    Backend Beagle dla Evolution
115 Group:          X11/Applications/Networking
116 Requires:       %{name} = %{version}-%{release}
117 Requires:       dotnet-evolution-sharp >= 0.10.2-4
118 Requires:       evolution
119
120 %description
121 Beagle Evolution backend.
122
123 %description evolution -l pl
124 Backend Beagle dla Evolution.
125
126 %package -n epiphany-extension-beagle
127 Summary:        Epiphany extension - beagle
128 Summary(pl):    Rozszerzenie dla Epiphany - beagle
129 Group:          X11/Applications/Networking
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       epiphany >= 1.2.1
132
133 %description -n epiphany-extension-beagle
134 Epiphany extension that allows Beagle to index every page the user
135 views.
136
137 %description -n epiphany-extension-beagle -l pl
138 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
139 odwiedzan± stronê.
140
141 %package -n python-%{name}
142 Summary:        Beagle Python bindings
143 Summary(pl):    Wi±zania jêzyka Python dla Beagle
144 Group:          Libraries/Python
145 Requires:       %{name} = %{version}-%{release}
146 %pyrequires_eq  python-libs
147
148 %description -n python-%{name}
149 Beagle Python bindings.
150
151 %description -n python-%{name} -l pl
152 Wi±zania jêzyka Python dla Beagle.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157 %patch1 -p1
158
159 %build
160 %{__libtoolize}
161 %{__aclocal}
162 %{__autoconf}
163 %{__automake}
164 %configure \
165         --enable-static \
166         --enable-gtk-doc \
167         --with-html-dir=%{_gtkdocdir} \
168         --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
169         --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp
170
171 %{__make} \
172         MOZILLA_HOME=%{_libdir}/mozilla \
173         pythondir=%{py_sitedir}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/index
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT \
181         pythondir=%{py_sitedir}
182
183 # Kill useless files
184 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/1.8/extensions/*.la \
185         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
186
187 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
188 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
189
190 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
191
192 %find_lang %{name}
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %pre crawl-system
198 %groupadd -g 166 -r -f beagleindex
199 %useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
200
201 %postun crawl-system
202 if [ "$1" = "0" ]; then
203         %userremove beagleindex
204         %groupremove beagleindex
205 fi
206
207 %post   libs -p /sbin/ldconfig
208 %postun libs -p /sbin/ldconfig
209
210 %files -f %{name}.lang
211 %defattr(644,root,root,755)
212 %doc AUTHORS COPYING ChangeLog NEWS README
213 %attr(755,root,root) %{_bindir}/*
214 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
215 %dir %{_libdir}/%{name}/Backends
216 %{_libdir}/%{name}/Filters
217 %attr(755,root,root) %{_libdir}/%{name}/*.exe
218 %{_libdir}/%{name}/*.dll*
219
220 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
221
222 %{_pixmapsdir}/*.png
223 %{_desktopdir}/*.desktop
224 %{_mandir}/man*/*
225
226 %files libs
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
229 %dir %{_libdir}/%{name}
230
231 %files devel
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/*.so
234 %{_includedir}/libbeagle
235 %{_libdir}/*.la
236 %{_gtkdocdir}/beagle
237 %{_pkgconfigdir}/*
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/*.a
242
243 %files crawl-system
244 %defattr(644,root,root,755)
245 %attr(640,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/*.crontab
246 %dir %{_sysconfdir}/beagle
247 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
248 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
249 %dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/index
250 %attr(755,root,root) %{_sbindir}/*
251 %attr(755,root,root) %{_libdir}/beagle-crawl-system
252
253 %files evolution
254 %defattr(644,root,root,755)
255 %{_libdir}/%{name}/Backends/Evolution*
256
257 %if %{with epiphany}
258 %files -n epiphany-extension-beagle
259 %defattr(644,root,root,755)
260 %doc epiphany-extension/README
261 %attr(755,root,root) %{_libdir}/epiphany/1.8/extensions/libbeagleextension.so*
262 %{_libdir}/epiphany/1.8/extensions/*.xml
263 %endif
264
265 %files -n python-%{name}
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.078034 seconds and 3 git commands to generate.