]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
5ad58626e15ae81ee849ff8c2d4c20d25409d1f5
[packages/beagle.git] / beagle.spec
1 #
2 # TODO:
3 # - MOZILLA_HOME misdetected
4 #
5 # Conditional build:
6 %bcond_with     epiphany        # build epiphany extension
7                                 # (just a hack)
8 Summary:        Beagle - An indexing subsystem
9 Summary(pl):    Beagle - podsystem indeksuj±cy
10 Name:           beagle
11 Version:        0.1.0
12 Release:        0.1
13 License:        Various
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/beagle/0.1/%{name}-%{version}.tar.bz2
16 # Source0-md5:  79d43b6b3ff0de919b54b08844b5cea2
17 URL:            http://beaglewiki.org/Main_Page
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  dotnet-evolution-sharp-devel >= 0.6
21 BuildRequires:  dotnet-gecko-sharp2-devel = 0.11
22 BuildRequires:  dotnet-gmime-sharp-devel >= 2.1.16-2
23 #BuildRequires: dotnet-gsf-sharp-devel >= 0.2
24 #BuildRequires: dotnet-gst-sharp-devel
25 BuildRequires:  dotnet-gtk-sharp2-gnome-devel
26 %{?with_epiphany:BuildRequires: epiphany-devel >= 1.6}
27 BuildRequires:  gnome-vfs2-devel
28 BuildRequires:  gtk+2-devel >= 2:2.4.0
29 BuildRequires:  libexif-devel >= 0.5.0
30 BuildRequires:  libgnome-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libtool
33 BuildRequires:  libxml2-devel >= 2.6.0
34 BuildRequires:  mono-csharp >= 1.0.6
35 BuildRequires:  mozilla-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  sqlite-devel
38 BuildRequires:  wv-devel >= 1.0.0
39 BuildRequires:  zip
40 Requires:       dotnet-evolution-sharp >= 0.6
41 Requires:       dotnet-gecko-sharp >= 0.11
42 Requires:       dotnet-gmime-sharp >= 2.1.16-2
43 #Requires:      dotnet-gsf-sharp-devel >= 0.2
44 #Requires:      dotnet-gst-sharp-devel
45 Requires:       dotnet-gtk-sharp2-gnome
46 %{?with_epiphany:Requires:      epiphany-extensions}
47 Requires:       gtk+2 >= 2:2.4.0
48 Requires:       sqlite
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Beagle is an indexing sub-system and search aggregator built on top of
53 Lucene.Net.
54
55 %description -l pl
56 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
57 bazie Lucene.Net.
58
59 %package devel
60 Summary:        Beagle development files
61 Summary(pl):    Pliki programistyczne Beagle
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Beagle development files.
67
68 %description devel -l pl
69 Pliki programistyczne Beagle.
70
71 %package -n epiphany-extension-beagle
72 Summary:        Epiphany extension - beagle
73 Summary(pl):    Rozszerzenie dla Epiphany - beagle
74 Group:          X11/Applications/Networking
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       epiphany >= 1.2.1
77 Requires:       epiphany < 1.3.0
78
79 %description -n epiphany-extension-beagle
80 Epiphany extension that allows Beagle to index every page the user
81 views.
82
83 %description -n epiphany-extension-beagle -l pl
84 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
85 odwiedzan± stronê.
86
87 %prep
88 %setup -q
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         --disable-static \
97 %if %{with epiphany}
98         --enable-epiphany-extension
99 %else
100         --disable-epiphany-extension
101 %endif
102
103 %{__make} \
104         MOZILLA_HOME=%{_libdir}/mozilla
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # Kill useless files
113 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany-*/extensions/*.la \
114         $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
115         
116 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS COPYING ChangeLog NEWS README
129 %attr(755,root,root)%{_bindir}/*
130 %dir %{_libdir}/%{name}
131 %{_libdir}/%{name}/Filters
132 %{_libdir}/%{name}/*.exe
133 %{_libdir}/%{name}/*.dll*
134 %attr(755,root,root) %{_libdir}/lib*.so*
135 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
136 %attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
137 %{_pixmapsdir}/*.png
138 %{_desktopdir}/*.desktop
139 %{_mandir}/man1/*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %{_includedir}/libbeagle
144 %{_libdir}/*.la
145 %{_libdir}/*.so
146 %{_pkgconfigdir}/*
147
148 %if %{with epiphany}
149 %files -n epiphany-extension-beagle
150 %defattr(644,root,root,755)
151 %doc epiphany-extension/README
152 %attr(755,root,root) %{_libdir}/epiphany-*/extensions/libbeagleextension.so*
153 %{_libdir}/epiphany-*/extensions/*.xml
154 %endif
This page took 0.053714 seconds and 3 git commands to generate.