]> git.pld-linux.org Git - packages/beagle.git/blob - beagle.spec
- add INFO
[packages/beagle.git] / beagle.spec
1 #
2 # Conditional build:
3 %bcond_with     epiphany        # build epiphany extension (it requires
4                                 # epiphany-1.2.x)
5 #
6 # INFO: need dbus newer than 0.22. you can get it from DEVEL branch.
7 #
8
9 #%define        snap 20041214
10 #Release:       0.%{snap}.1
11
12 Summary:        Beagle - An indexing subsystem
13 Summary(pl):    Beagle - podsystem indeksuj±cy
14 Name:           beagle
15 Version:        0.0.4
16 Release:        0.1
17 License:        Various
18 Group:          Libraries
19 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
20 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.0/%{name}-%{version}.tar.bz2
21 # Source0-md5:  db81d4d1bd0f841f0ae77829623d2a59
22 Patch0:         %{name}-Filters-dir.patch
23 Patch1:         %{name}-pc.patch
24 URL:            http://www.gnome.com/
25 BuildRequires:  autoconf >= 2.52
26 BuildRequires:  automake
27 BuildRequires:  dotnet-evolution-sharp-devel >= 0.3
28 BuildRequires:  dotnet-gtk-sharp-devel
29 BuildRequires:  dotnet-dbus-sharp-devel >= 0.22
30 BuildRequires:  dotnet-gmime-sharp-devel
31 BuildRequires:  dotnet-gecko-sharp-devel
32 %if %{with epiphany}
33 BuildRequires:  epiphany-devel >= 1.2.1
34 BuildRequires:  epiphany-devel < 1.3.0
35 %endif
36 BuildRequires:  gtk+2-devel >= 2:2.4.0
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 2.6.0
39 BuildRequires:  mono-csharp
40 BuildRequires:  pkgconfig
41 Requires:       dotnet-evolution-sharp >= 0.3
42 Requires:       dotnet-gtk-sharp
43 Requires:       dotnet-dbus-sharp >= 0.22
44 Requires:       gtk+2 >= 2:2.4.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Beagle is an indexing sub-system and search aggregator built on top of
49 Lucene.Net.
50
51 %description -l pl
52 Beagle jest podsystemem indeksuj±cym i wyszukuj±cym zbudowanym na
53 bazie Lucene.Net.
54
55 %package devel
56 Summary:        Beagle development files
57 Summary(pl):    Pliki programistyczne Beagle
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description devel
62 Beagle development files.
63
64 %description devel -l pl
65 Pliki programistyczne Beagle.
66
67 %package -n epiphany-extension-beagle
68 Summary:        Epiphany extension - beagle
69 Summary(pl):    Rozszerzenie dla Epiphany - beagle
70 Group:          X11/Applications/Networking
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       epiphany >= 1.2.1
73 Requires:       epiphany < 1.3.0
74
75 %description -n epiphany-extension-beagle
76 Epiphany extension that allows Beagle to index every page the user
77 views.
78
79 %description -n epiphany-extension-beagle -l pl
80 Rozszerzenie dla Epiphany sprawiaj±ce, ¿e Beagle indeksuje ka¿d±
81 odwiedzan± stronê.
82
83 %prep
84 %setup -q
85 #%patch0 -p0
86 #%patch1 -p0
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94 %if %{with epiphany}
95         --enable-epiphany-extension
96 %else
97         --disable-epiphany-extension
98 %endif
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # Kill useless files
109 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/extensions/*.{a,la}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING ChangeLog NEWS README
117 %attr(755,root,root)%{_bindir}/*
118 %dir %{_libdir}/%{name}
119 %{_libdir}/%{name}
120 %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.so.*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{_pkgconfigdir}/*
125 %{_libdir}/gtk-2.0/2.4.0/filesystems/libbeaglechooserhack.la
126
127 %if %{with epiphany}
128 %files -n epiphany-extension-beagle
129 %defattr(644,root,root,755)
130 %doc epiphany-extension/README
131 %attr(755,root,root)%{_libdir}/epiphany/extensions/libbeagleextension.so*
132 %endif
This page took 0.031509 seconds and 3 git commands to generate.