]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- updated to 3.2
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 ##
6 %define         _ver            3.2
7 %define         _patchlevel     000
8 #
9 Summary:        GNU Bourne Again Shell (bash)
10 Summary(fr):    Le shell Bourne Again de GNU
11 Summary(pl):    Pow³oka GNU Bourne Again Shell (bash)
12 Name:           bash
13 Version:        %{_ver}
14 #.%{_patchlevel}
15 Release:        1%{?with_bash_history:inv}
16 License:        GPL
17 Group:          Applications/Shells
18 Source0:        ftp://ftp.gnu.org/gnu/bash/%{name}-%{_ver}.tar.gz
19 # Source0-md5:  00bfa16d58e034e3c2aa27f390390d30
20 Source1:        %{name}rc
21 Source2:        %{name}-skel-.%{name}_logout
22 Source3:        %{name}-skel-.%{name}_profile
23 Source4:        %{name}-skel-.%{name}rc
24 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
26 Patch0:         %{name}-paths.patch
27 Patch1:         %{name}-security.patch
28 Patch2:         %{name}-autoconf.patch
29 Patch3:         %{name}-info.patch
30 Patch4:         %{name}-profile.patch
31 Patch5:         %{name}-requires.patch
32 Patch6:         %{name}-compat.patch
33 Patch8:         %{name}-sighup.patch
34 Patch9:         %{name}-backup_history.patch
35 Patch10:        %{name}-po.patch
36 Patch11:        %{name}-act_like_sh.patch
37 URL:            http://www.gnu.org/software/bash/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  bison
41 BuildRequires:  ncurses-devel >= 5.2
42 BuildRequires:  readline-devel >= 5.2
43 BuildRequires:  texinfo
44 %if %{with static}
45 # Require static library only for static build
46 BuildRequires:  glibc-static >= 2.2
47 BuildRequires:  ncurses-static >= 5.2
48 BuildRequires:  readline-static >= 5.2
49 %endif
50 Requires(post,preun):   grep
51 Requires(preun):        fileutils
52 Requires:       grep
53 Requires:       readline >= 5.2
54 Requires:       setup >= 2.4.6-2
55 Obsoletes:      bash-doc
56 Obsoletes:      bash2
57 Obsoletes:      bash2-doc
58 Obsoletes:      etcskel
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Bash is a GNU project sh-compatible shell or command language
63 interpreter. Bash (Bourne Again shell) incorporates useful features
64 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
65 be run by bash without modification. Bash offers several improvements
66 over sh, including command line editing, unlimited size command
67 history, job control, shell functions and aliases, indexed arrays of
68 unlimited size and integer arithmetic in any base from two to 64. Bash
69 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
70 Shell and Tools standard. Bash is the default shell for Linux
71 Mandrake. You should install bash because of its popularity and power.
72 You'll probably end up using it.
73
74 %description -l es
75 Bash es un interpretador de comandos compatible con sh, que ejecuta
76 comandos leídos de la entrada padrón o de un archivo. Bash también
77 incorpora características útiles de las shells Korn y C (ksh y csh).
78 Bash ha sido desarrollado para ser una adición compatible con la
79 especificación IEEE Posix para shells y herramientas (IEEE Working
80 Group 1003.2).
81
82 %description -l de
83 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
84 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
85 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
86 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
87 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
88 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
89 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
90 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
91 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
92 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
93 Mandrake.
94
95 %description -l fr
96 Bash est un shell (interpréteur de commande) du projet GNU, compatible
97 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
98 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
99 plupart des scripts sh sont exécutables sans modifications. Bash
100 comprend nombre d'améliorations par rapport à sh : édition de la ligne
101 de commande, historique illimité, contrôle des processus
102 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
103 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
104 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
105 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
106 l'installer du fait de sa puissance et de sa popularité. Vous finirez
107 probablement par l'utiliser.
108
109 %description -l pl
110 Bash (Bourne Again SHell) jest projektem GNU pow³oki kompatybilnej z
111 sh oraz interpretera jêzyka poleceñ. Posiada u¿yteczne w³a¶ciwo¶ci
112 pow³ok Korn (ksh) i C (csh). Wiêkszo¶æ skryptów sh mo¿e byæ
113 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeñ w
114 stosunku do sh, w³±czaj±c edycjê linii poleceñ, nieograniczony rozmiar
115 historii poleceñ, funkcje i aliasy, indeksowane tablice
116 nieograniczonych rozmiarów oraz arytmetykê ca³kowitoliczbow± o
117 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma byæ zgodny
118 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
119
120 %description -l pt_BR
121 Bash é um interpretador de comandos compatível com sh, que executa
122 comandos lidos da entrada padrão ou de um arquivo. Bash também
123 incorpora características úteis das shells Korn e C (ksh e csh). Bash
124 tem sido desenvolvido para ser uma implementação compatível com a
125 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
126 1003.2).
127
128 %description -l ru
129 Bash - ÜÔÏ sh-ÓÏ×ÍÅÓÔÉÍÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎÏÇÏ ÑÚÙËÁ (shell),
130 ÉÓÐÏÌÎÑÀÝÉÊ ËÏÍÁÎÄÙ, ÐÏÓÔÕÐÁÀÝÉÅ ÓÏ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÁ ÉÌÉ ÉÚ ÆÁÊÌÁ.
131 Bash ×ËÌÀÞÁÅÔ ÐÏÌÅÚÎÙÅ ÒÁÓÛÉÒÅÎÉÑ ÉÚ ÉÎÔÅÒÐÒÅÔÁÔÏÒÏ× Korn É C shell
132 (ksh É csh).
133
134 Bash ÒÁÚÒÁÂÁÔÙ×ÁÅÔÓÑ ËÁË ÒÅÁÌÉÚÁÃÉÑ, ÏÔ×ÅÞÁÀÝÁÑ IEEE Posix Shell and
135 Tools specification (IEEE Working Group 1003.2).
136
137 %description -l tr
138 Bash standart giriþten ya da bir dosyadan komut okuyup çalýþtýran sh
139 uyumlu bir komut dili yorumlayýcýsýdýr. Ayný zamanda Korn ve C
140 kabuklarýnýn (ksh ve csh) kullanýþlý özelliklerini de kapsar. Bash,
141 IEEE Posix Kabuk ve Araç ayrýntýlarýna (IEEE Working Group 1003.2)
142 uyumlu bir uygulama olarak tasarlanmýþtýr.
143
144 %description -l uk
145 Bash - ÃÅ sh-ÓÕͦÓÔÎÉÊ ¦ÎÔÅÒÐÒÅÔÁÔÏÒ ËÏÍÁÎÄÎϧ ÍÏ×É (shell),
146 ×ÉËÏÎÕÀÞÉÊ ËÏÍÁÎÄÉ Ú¦ ÓÔÁÎÄÁÒÔÎÏÇÏ ××ÏÄÕ ÁÂÏ Ú ÆÁÊÌÁ. Bash Í¦ÓÔÉÔØ
147 ËÏÒÉÓÔΦ ÒÏÚÛÉÒÅÎÎÑ Ú ¦ÎÔÅÒÐÒÅÔÁÔÏҦנKorn ÔÁ C shell (ksh ÔÁ csh).
148
149 Bash ÒÏÚÒÏÂÌÑ×ÓÑ ÑË ÒÅÁ̦ÚÁæÑ, ÝϠצÄÐÏצÄÁ¤ IEEE Posix Shell and
150 Tools specification (IEEE Working Group 1003.2).
151
152 %package static
153 Summary:        Statically linked GNU Bourne Again Shell (bash)
154 Summary(pl):    Statycznie skonsolidowany GNU Bourne Again Shell (bash)
155 Group:          Applications/Shells
156 Requires(post,preun):   grep
157 Requires(preun):        fileutils
158 Requires:       %{name} = %{version}-%{release}
159
160 %description static
161 Bash is a GNU project sh-compatible shell or command language
162 interpreter. Bash (Bourne Again shell) incorporates useful features
163 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
164 be run by bash without modification. Bash offers several improvements
165 over sh, including command line editing, unlimited size command
166 history, job control, shell functions and aliases, indexed arrays of
167 unlimited size and integer arithmetic in any base from two to 64. Bash
168 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
169 Shell and Tools standard. Bash is the default shell for Linux
170 Mandrake. You should install bash because of its popularity and power.
171 You'll probably end up using it. This package contains statically
172 linked version of bash.
173
174 %description static -l pl
175 Bash jest zaawansowan± pow³ok±, która wykonuje komendy czytane ze
176 standardowego wej¶cia (stdin) lub z pliku. Posiada w³a¶ciwo¶ci pow³ok
177 Korn i C (ksh i csh). Bash jest równie¿ zaimplementowany IEEE Posix
178 Shell oraz jest zgodny ze specyfikacj± - IEEE Working Group 1003.2. W
179 tym pakiecie jest wersja basha skonsolidowana statycznie.
180
181 %prep
182 %setup -q -n %{name}-%{_ver} -a5
183 %patch0 -p1
184 %patch1 -p1
185 %patch2 -p1
186 %patch3 -p1
187 %patch4 -p1
188 %patch5 -p1
189 %patch6 -p1
190 %patch8 -p1
191 %{?with_bash_history:%patch9 -p1}
192 %patch10 -p1
193 %patch11 -p1
194
195 %build
196 cp -f /usr/share/automake/config.* support
197 %{__autoconf}
198 for mode in %{?with_static:static} shared; do
199 %configure \
200         --enable-alias \
201         --enable-help-builtin \
202         --enable-history \
203         --enable-job-control \
204         --enable-restricted \
205         --enable-readline \
206         --with-curses \
207         --enable-extended-glob \
208         --enable-dparen-arithmetic \
209         --enable-separate-helpfiles \
210         --without-bash-malloc \
211         `[ "$mode" = "static" ] && echo "--enable-static-link"` \
212         --with-installed-readline
213
214 %{__make} \
215         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
216
217 [ "$mode" = "static" ] && mv -f bash bash.static || :
218 done
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
223 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
224
225 %{__make} install \
226         DESTDIR=$RPM_BUILD_ROOT
227
228 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
229 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
230
231 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
232 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
233
234 for d in es fr it ja ko nl pl ; do
235         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
236         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
237         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
238 done
239
240 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
241
242 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
243 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
244 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
245 rm -f $RPM_BUILD_ROOT/usr/share/info/dir
246
247 %find_lang %{name}
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %post
253 umask 022
254 if [ ! -f /etc/shells ]; then
255         echo "/bin/bash" > /etc/shells
256         echo "/bin/rbash" >> /etc/shells
257 else
258         if ! grep -q '^/bin/bash$' /etc/shells; then
259                 echo "/bin/bash" >> /etc/shells
260         fi
261         if ! grep -q '^/bin/rbash$' /etc/shells; then
262                 echo "/bin/rbash" >> /etc/shells
263         fi
264 fi
265
266 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
267
268 %preun
269 if [ "$1" = "0" ]; then
270         umask 022
271         grep -v /bin/bash /etc/shells | grep -v /bin/rbash > /etc/shells.new
272         mv -f /etc/shells.new /etc/shells
273 fi
274
275 %post static
276 umask 022
277 if [ ! -f /etc/shells ]; then
278         echo "/bin/bash.static" > /etc/shells
279 else
280         if ! grep -q '^/bin/bash.static$' /etc/shells; then
281                 echo "/bin/bash.static" >> /etc/shells
282         fi
283 fi
284
285 %preun static
286 if [ "$1" = "0" ]; then
287         umask 022
288         grep -v /bin/bash.static /etc/shells > /etc/shells.new
289         mv -f /etc/shells.new /etc/shells
290 fi
291
292 %postun
293 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
294
295 %files -f %{name}.lang
296 %defattr(644,root,root,755)
297 %doc CHANGES NEWS README doc/{FAQ,INTRO}
298
299 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
300 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
301 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
302 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
303
304 %attr(755,root,root) /bin/bash
305 %attr(755,root,root) /bin/rbash
306 %attr(755,root,root) %{_bindir}/bashbug
307
308 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
309 %{_infodir}/bash.info*
310 %{_mandir}/man1/*
311 %lang(es) %{_mandir}/es/man1/*
312 %lang(fr) %{_mandir}/fr/man1/*
313 %lang(it) %{_mandir}/it/man1/*
314 %lang(ja) %{_mandir}/ja/man1/*
315 %lang(ko) %{_mandir}/ko/man1/*
316 %lang(nl) %{_mandir}/nl/man1/*
317 %lang(pl) %{_mandir}/pl/man1/*
318 %{_datadir}/%{name}
319
320 %if %{with static}
321 %files static
322 %defattr(644,root,root,755)
323 %attr(755,root,root) /bin/bash.static
324 %endif
This page took 0.088431 seconds and 4 git commands to generate.